JVB Authenitication problem

Hi, I am trying to connect the second JVB to Jitsi. I have two EC2 ubuntu instances with static IP addresses. One with the whole Jitsi stack, another with JVB2 only. Following the guide, I configured the second JVB To have the same user and password as the first JVB.

JVB2 /etc/jitsi/videobridge/sip-communicator.properties:

org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.3.68.22.244/.*
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=3.68.22.244
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=muc
org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.3.68.22.244
org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
org.jitsi.videobridge.xmpp.user.shard.PASSWORD=8bzwrPHp
org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@internal.auth.3.68.22.244
org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=c1f6f31b-ce1a-4887-bbdc-c0879c85a179
org.jitsi.videobridge.xmpp.user.shard.DISABLE_CERTIFICATE_VERIFICATION=true
org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=meet-jit-si-turnrelay.jitsi.net:443
org.jitsi.videobridge.DISABLE_TCP_HARVESTER=true

JVB1 /etc/jitsi/videobridge/sip-communicator.properties

org.ice4j.ice.harvest.DISABLE_AWS_HARVESTER=true
org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=meet-jit-si-turnrelay.jitsi.net:443
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=muc
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=localhost
org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.3.68.22.244
org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
org.jitsi.videobridge.xmpp.user.shard.PASSWORD=8bzwrPHp
org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@internal.auth.3.68.22.244
org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=6f95bb17-1b02-476f-9e82-5de36a12bd7f

I tried to add a new user, but I got

prosodyctl adduser jvb2@3.68.22.244
Enter new password: 
Retype new password: 
Account creation/modification not supported.

I also added

component_ports = { 5347 }
component_interface = { "3.68.22.244" }

in prosody.cfg.lua

Then I got prosody errors

|Jul 14 11:28:56 c2s5642fd623360|info|Client connected|
|---|---|---|
|Jul 14 11:28:56 c2s5642fd623360|info|Stream encrypted (TLSv1.3 with TLS_AES_256_GCM_SHA384)|
|Jul 14 11:28:56 c2s5642fd623360|info|Client disconnected: connection closed|
|Jul 14 11:29:01 c2s5642fd6eeb90|info|Client connected|
|Jul 14 11:29:01 c2s5642fd6eeb90|info|Stream encrypted (TLSv1.3 with TLS_AES_256_GCM_SHA384)|
|Jul 14 11:29:01 c2s5642fd6eeb90|info|Client disconnected: connection closed|

Then I tried setup admins in prosody, and subdomain, with component secrets as in How to Load Balance Jitsi Meet - YouTube . With no success.

I also tried setting up a second JVB and Jitsi stack in docker. Using second user added with prosodyctl --config $PROSODY_CFG register JVB2 $XMPP_AUTH_DOMAIN $JVB_AUTH_PASSWORD .
unfortunately, the result was the same.

I would be very grateful if you guys could help me.
Regards.
Mateusz Sokolowski

1 Like

You don’t need this.

This method is no longer used. Horizontal scaling is not done with components anymore.

I suggest doing a search here for how to loadbalance multiple JVBs.

Ok, Can you send me the guide that should work? I already tried many.