JVB 2 considered stable

FYI for the people trying to do a apt upgrade jitsi-meet but get the following error:

The following packages have unmet dependencies:
 jitsi-meet : Depends: jitsi-videobridge2 (= 2.1-157-g389b69ff-1) but it is not going to be installed
E: Broken packages

Just do a apt install jitsi-videobridge2 this will uninstall the older ones and upgrade all the other components alongside

On meet.jit.si? Yeah go for it.

1 Like

Installing jvb2 over a previous installation doesn’t remove the service file of jvb1 (which gets in the way when using autocompletion by pressing tab):

> systemctl status jitsi-videobridge
● jitsi-videobridge.service
   Loaded: masked (Reason: Unit jitsi-videobridge.service is masked.)
   Active: inactive (dead)

Purging it shows me an error:

> sudo apt purge jitsi-videobridge
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  jitsi-videobridge*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 115686 files and directories currently installed.)
Purging configuration files for jitsi-videobridge (1126-1) ...
Removing user `jvb' ...
Warning: group `jitsi' has no more members.
userdel: user jvb is currently used by process 683
/usr/sbin/deluser: `/sbin/userdel jvb' returned error code 8. Exiting.
dpkg: error processing package jitsi-videobridge (--purge):
 installed jitsi-videobridge package post-removal script subprocess returned error exit status 1
Errors were encountered while processing:
 jitsi-videobridge
E: Sub-process /usr/bin/dpkg returned an error code (1)

And where can I find informations about the core features of jvb2? Don’t want to skim thousands of lines of very specific changlelog.

Hi,
this didn’t worked for me.
Now i have not possibility to connect to anything.
After a second one joins, always “2020-04-02T07:17:02.947Z [conference.js] <X._onConferenceFailed>: CONFERENCE FAILED: conference.videobridgeNotAvailable” Reconnecting 20 secs …
Not possible to use it anymore. I also made Config fit to my needs again (yes with no syntax errors or something)

If you have this problem, try to manually restart jitsi-videobridge2.service and let me know, if this solve your problem. I must do this at every system (Debian 10) reboot. This is my “workaround”.

Petr

userdel: user jvb is currently used by process 683

The upgrade from v1 to v2 broke conferences here, too.
To at least get rid of videobridge v1, I did:

$ systemctl stop jitsi-videobridge2.service
$ apt purge jitsi-videobridge
$ apt install --reinstall jitsi-videobridge2
$ systemctl reset-failed

The last command is to get rid of v1 listed in “systemctl”:

$ systemctl
...
● jitsi-videobridge.service  not-found failed failed  jitsi-videobridge.service

The next problem was that the videobridge could not connect to the xmpp server. The log showed:

org.jivesoftware.smack.sasl.SASLErrorException: SASLError using SCRAM-SHA-1: not-authorized
    at org.jivesoftware.smack.SASLAuthentication.authenticationFailed(SASLAuthentication.java:292)
    at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1100)
    at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
    at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
    at java.lang.Thread.run(Thread.java:748)

The solution was to edit /etc/jitsi/videobridge/sip-communicator.properties and change the password to the one of the jvb user that is stored in the prosody user database (SQL in my installation). (Related: https://github.com/jitsi/jitsi-meet/issues/5557)

1 Like

look at this too

did reboots and restarts of services, at that point, nothing changed.

This actually caused my authentication problem - because it deleted the configuration file with the password.

could we use iframe?

That’s why in most cases apt remove should be used, which leaves conf files in tact.
Purge removes conf files, it’s standard apt behavior.

1 Like

All the issue we had seen the past week, including all those on Debian10 and those with wrong password for jvb, are considered fixed and are no in the unstable repo if anybody wants to try it out before we push them to stable. Thank you.

2 Likes

Can anyone who has successfully migrated to JVB2 fill us in on what benefits you’re seeing?

Just asking my self : does that mean that even if JVB2 is running on my LAMP , its not fully running ?

I think you could/should update (in the jitsi install readme) the prerequis of the last jitsi

  • Apache/nginx ?
  • Java8/Java11 ?
  • Distribution running or optimized for

Thx

Now it’s default on stable installation with:

apt install jitsi-meet

I didn’t tried to install from 0, but I think that doing:

apt purge jitsi-videobridge -y;apt update;apt install jitsi-videobridge2

would work flawless, just remember to make a backup copy of your configurations in case you did something more than setting up the hostname and the certificate, since you’ll need to reconfigure those stuff

Well, if you setup by just making an apt install jitsi-meet it will configure by itself nginx, Java8 (i think, I’m not sure)

The optimized distribution is Ubuntu 18.04 LTS

2 Likes

I did just that on April 30 because I was pulling my hair out trying to get ldap authentication working. I have to say that it worked and I got ldap authentication working on the first try.

@olivluca I’m really happy to be helpful :slight_smile:

Hi @olivluca,
can you please elaborate about LDAP authentication for Jitsi Meet? I’d be very interested, but I found only a howto for implementing LDAP address book into Jitsi Desktop App.
Many thanks in advance,
HP.

Look here https://github.com/jitsi/jitsi-meet/wiki/LDAP-Authentication

3 Likes

My jitsi server has following version
jitsi-videobridge2/stable,now 2.1-183-gdbddd169-1 all [installed,automatic].???