Joining multiple rooms in a single tab

In my use case, user joins multiple rooms in a single tab.
I use lib-jitsi-meet.
However, after 5~6 rooms are joined, the xmpp ping timeout error will be output and user will not be able to receive the remote stream.
Also, it will take a minute or two for the connection to succeed.

I set up http2 on nginx using this thread.

So far, it seems to be working well.

So I am wondering, is there any possible impact on the other features of jitsi by using http2?
thank you.

http/2 will only be used for getting the static files from nginx; there is no (widely supported) websocket in http/2 so the prosody and JVB websocket connections will be http/1.1. so there should not be any negative impact by configuring nginx for http/2 support.

2 Likes

Thank you for your quickly reply.
Currently, I use http-bind to connect to prosody.
Is there any impact in this case as well?

Shouldn’t be any problem. The old http-bind way is just long polling (client makes a request, server doesn’t respond until it has data to send). The client connection to nginx will be over http/2 or http/1.1 depending on what the client supports, http/2 gives a slight improvement here in terms of less header overhead. nginx connection to Prosody will be http/1.1 since Prosody does not support http/2.

As for your issue of slow connection and ping timeouts, does it also occur if you make the same number of connections but 1 per tab? If it doesn’t, then it’s certainly a client-side issue, maybe a bug in lib-jitsi-meet with multiple JitsiConnections, perhaps there is some global state which gets messed up when more than one connection is used in the same browser context?

Is this your own deployment or meet.jit.si?

Prosody does not support http/2?
Setting up http2 seems to have fixed the connection problem.
I wonder why?
I add setting to /etc/nginx/sites-enabled/mydomain.com

...
server {
    listen 443 ssl http2;
    listen [::]:443 ssl;
    server_name mydomain.com;
...

As for your issue of slow connection and ping timeouts, does it also occur if you make the same number of connections but 1 per tab?

I have not tried this pattern yet. I’ll try it. Thank you.

Prosody doesn’t speak http/2 but it doesn’t matter, nginx works as a (reverse) proxy here, so there is a separate HTTP connection prosody <-> nginx and nginx <-> user.

This is my deployment.

Oh, ​I see.
It seems that there was a problem between nginx and the user.

I have made 6 connections on 1 per tab.(sum 6 tabs).
Same problem occured.
Again, this was solved by setting http2.

Interesting. Most deployments are still using http/1.1 and don’t have such an issue. I guess it was some configuration problem which was worked around as a side-effect of enabling http/2.