JitsiMeetSDK - Empty security modal on iOS

On iOS (using JitsiMeetSDK), when meeting-password is disabled in JitsiMeetConferenceOptions using setFeatureFlag, users are presented with an empty dialog when the 'Security Option` menu item is tapped.

Code:

JitsiMeetConferenceOptions *options
          = [JitsiMeetConferenceOptions fromBuilder:^(JitsiMeetConferenceOptionsBuilder *builder) 
{
            builder.room = self.meetingName;
            [builder setFeatureFlag:@"meeting-password.enabled" withBoolean:NO];
...
}

Result:

My Question:

Is there a way to hide the “Security options” option all together on iOS? Also (fwiw) - I removed 'security' from TOOLBAR_BUTTONS in config.js (and the TOOLBAR_BUTTONS was removed entirely from interface_config.js)

I think you can comment out the function that launches the pop-up box. I’m too lazy right now to look through the code (ios), but if you search through, you can just comment it out to prevent the pop-up from showing up.

@Freddie, developers who are using the JitsiMeetSDK are abstracted (by design) from the lower-level code that actually displays this modal. I am using CocoaPods btw - I think it’s probably a bug.

Really? Hmm…mm… I’ve been able to disable functions in the mobile SDK. I recall disabling the Calendar prompt in the past, so I don’t expect that this would be any different… :thinking:

You could have been building from source. I am using the CocoaPods method.

No, I used CocoaPods too. Weird you’re experiencing abstraction…

See, now you’re going to make my OCD kick in and force me to go unpack this. But I must resist. Resist, Freddie. RESIST! :joy:

Actually, wait - I’m reading over your post again and I think I may have misunderstood the problem. :man_facepalming:t5: You’re saying when you disable meeting-password, clicking security brings up that empty pop-up box? What about Lobby and e2ee - did you disable those features as well?

Yeah. Seems like we need something new, like:

in jitsi-meet/react/features/base/flags/constants.js

export const ENABLE_SECURITY_OPTIONS = 'security-options.enabled';

and then in SecurityDialogButton.js

in jitsi-meet/react/features/security/components/security-dialog/SecurityDialogButton.js line

class SecurityDialogButton extends AbstractButton<Props, *> {
...

   function _mapStateToProps(state): Object 
   {
      const enabled = getFeatureFlag(state, ENABLE_SECURITY_OPTIONS, true);

      return {
         visible: enabled,
        _locked: locked || lobbyEnabled
      };
   ...
  }
}

Looks like a number of people are reporting issues with the ios SDK.

God catch. Yep something like would be valuable. Mind submitting a PR through GitHub?

Like which ones?

Quite a few posts in the past day or two mentioning build issues.

Thank you @saghul - I created a few issues in git: