Jitsi xcframework does not contain bitcode

Hello everyone :wave:
I can not put together a project for release on iOS.
I collect xcframework according to the instructions from jitsi (ENABLE_BITCODE = NO).
I put it in the project, everything works well on the simulator, but when archiving for release I get the error — :exclamation: JitsiMeetSDK does not contain bitcode. You must rebuild it with bitcode enabled (Xcode setting ENABLE_BITCODE), obtain an updated library from the vendor, or disable bitcode for this target. :exclamation:
Found a solution that the project must also set ENABLE_BITCODE = NO.
This is how the archiving is performed, but at the end of the Apple it does not allow publishing the application and gives an error — :exclamation: No architectures in the binary. Lipo failed to detect any architectures in the bundle executable. :exclamation:
Help please, I don’t know what to do anymore

macos Big Sur 11.2.3
xcode 12.4

Do you actually need bitcode? It’s only necessary if you have an apple watch target for example. Otherwise it’s ok not to have it.

I do not see any other solutions, the project is not going to be built due to the lack of jitsi bitcode. I tried to do xcframework with ENABLE_BITCODE = YES, but ARCHIVE FAILED for ios-device

BuildProductsPath/Release-iphoneos/JitsiMeetSDK.framework/JitsiMeetSDK’ does not contain bitcode. You must rebuild it with bitcode enabled (Xcode setting ENABLE_BITCODE), obtain an updated library from the vendor, or disable bitcode for this target. file Release-iphoneos/JitsiMeetSDK.framework/JitsiMeetSDK’ for architecture arm64

Do you need bitcode? You can disable it in your project as a whole.

if i disable it i get an error from apple ERROR ITMS-90085: “No architectures in the binary. Lipo failed to detect any architectures in the bundle executable.”

I removed in BuildPhase Embded Frameworks. but apple send error
Your delivery was successful, but you may wish to correct the following issues in your next delivery:

ITMS-90863: Apple silicon Macs support issue - The app links with libraries that are not present on Mac:

@rpath/JitsiMeetSDK.framework/JitsiMeetSDK
@rpath/WebRTC.framework/WebRTC
.
After you’ve corrected the issues, you can upload a new binary to App Store Connect.

What Xcode version are you using? Are you using any script to strip architectures when building in release mode? That used to be necessary, but with xcframeworks that is taken care of autoomagically.

macos Big Sur 11.2.3
xcode 12.4
I used to just use a framework, then I had to rebuild jitsi in xcframework and there were problems

Wait, I just noticed something I missed on your previous message. Are you publishing your app on macOS too?

no, the application is only for iPhones and iPads

I think the problem is in the updated xcode

This suggests your app is attempted to be released on macOS too. Note that Apple made changes to that recently, check in Apple Store Connect to make sure your app is not released on macOS.

I just archived the assembly on the previous xcode, turned off the bitcodes and the project was approved, it was definitely not released for the Mac

Go to Apple Store Connect, and the Pricing and Availability section of your app. Make sure that checkbox there is unchecked as in the screenshot.