Jitsi With No audio No video issue

After installed Jitsi on my ubunton 18.4 server with nginx

When the participate joined he is only seeing hemself!

We are going to need more information. Let’s start with the JS console logs, please.

undefind channel and no channel error

Please paste actual logs.

Logger.js:154 2020-10-14T07:41:45.613Z [modules/RTC/BridgeChannel.js] <RTCDataChannel.e.onerror>: Channel error: undefined
o @ Logger.js:154
e.onerror @ BridgeChannel.js:286
error (async)
_handleChannel @ BridgeChannel.js:282
l @ BridgeChannel.js:70
initializeBridgeChannel @ RTC.js:285
re._setBridgeChannel @ JitsiConference.js:2018
re._acceptJvbIncomingCall @ JitsiConference.js:1936
re.onIncomingCall @ JitsiConference.js:1887
a.emit @ events.js:152
onJingle @ strophe.jingle.js:171
run @ strophe.umd.js:1875
(anonymous) @ strophe.umd.js:3157
forEachChild @ strophe.umd.js:830
_dataRecv @ strophe.umd.js:3146
_onRequestStateChange @ strophe.umd.js:5012
XMLHttpRequest.send (async)
d @ strophe.umd.js:5123
_processRequest @ strophe.umd.js:5137
_throttledRequestHandler @ strophe.umd.js:5290
_onIdle @ strophe.umd.js:4901
_onIdle @ strophe.umd.js:3881
(anonymous) @ strophe.umd.js:3886
setTimeout (async)
_onIdle @ strophe.umd.js:3885
(anonymous) @ strophe.umd.js:3886
setTimeout (async)
_onIdle @ strophe.umd.js:3885
(anonymous) @ strophe.umd.js:3886
setTimeout (async)
_onIdle @ strophe.umd.js:3885
(anonymous) @ strophe.umd.js:3886
setTimeout (async)
_onIdle @ strophe.umd.js:3885
(anonymous) @ strophe.umd.js:3886
setTimeout (async)
_onIdle @ strophe.umd.js:3885
(anonymous) @ strophe.umd.js:5257
setTimeout (async)
_send @ strophe.umd.js:5256
send @ strophe.umd.js:2583
sendIQ @ strophe.umd.js:2740
sendIQ @ XmppConnection.js:435
terminate @ JingleSessionPC.js:1485
_actOnIceFailed @ IceFailedHandling.js:66
(anonymous) @ IceFailedHandling.js:102
setTimeout (async)
(anonymous) @ IceFailedHandling.js:100
Promise.then (async)
start @ IceFailedHandling.js:97
re._onIceConnectionFailed @ JitsiConference.js:2629
(anonymous) @ JitsiConferenceEventManager.js:196
a.emit @ events.js:157
peerconnection.oniceconnectionstatechange @ JingleSessionPC.js:555
A.peerconnection.oniceconnectionstatechange @ TraceablePeerConnection.js:364
Logger.js:154 2020-10-14T07:41:46.899Z [modules/RTC/BridgeChannel.js] <l._send>: Bridge Channel send: no opened channel.

How does your config.js look like? It seems the channel connection didn’t work. If you installed the latest stable you must be using WebSockets.

where is this file config.js?

In /etc/jitsi/meet/