Jitsi with JWT (jitsi-meet-tokens) puts every user into a separate room

I’ve just installed Jitsi with JWT on Ubuntu 20.04 by following this guide (with a few tweaks for commands that don’t work and for settings that have moved in the latest version).

The server seems to be up and running correctly, and I can join a meeting by going to https://my-jitsi-url.com/meeting-room?jwt=[my token]. However if someone else join the meeting with https://my-jitsi-url.com/meeting-room?jwt=[their token] then they end up in a meeting room all on their own. The URL in the address bar is the same for both of us, but we’re not connected.

The JWT is working as when I’m in the room I have the correct name and profile picture from the token.

I’m running on Ubuntu 20.04 with the following TCP ports open 80, 443, 4443, 5222, 5347 and 5349, and UDP 10000.

Where should I start?

browser js console logs from both participants

The browser console looks normal, no obvious errors apart from a 404 for some translation resources.

After setting up a working Jitsi server, all you have to do install the jitsi-meet-tokens package

You may also try jitsi-token-installer

Thanks, I wasn’t aware of that installer. I’ll try it.

Just tried the installer, same issue but now without camera or audio. Does anyone have any other guides for this?

Is the setup address the same as you typed the browser address bar?

Yes. Looks like the request to https://JITSI_URL/http-bind is getting 502. Then I get the “You have been disconnected” message, then it tries http-bind again and so on. Will check the server logs for the 502 tomorrow.

502 happens when nginx cannot connect to the upstream server which is prosody in this case. Does prosody run?

systemctl status prosody

Bad config was preventing Prosody from starting. I tweaked the install script (see Github). Camera and audio are working as expected, and the http-bind request is going correctly.

Unfortunately I’m still seeing the same issue as when I installed it manually: I can join a meeting by going to https://my-jitsi-url.com/meeting-room?jwt=[my token] but if someone else joins the meeting with https://my-jitsi-url.com/meeting-room?jwt=[their token] we can’t see each other. Both of us have the correct URLs so not sure what’s going on!

Can you see the other participants in the room even they have no video?

No. I’m on my own in the room. No other participants. I can see my own camera and that’s it. It’s the same for anyone else who joins.

  • What is your distro?
  • How do you install it?

Ubuntu 20.04. I’ve tried installing and configuring it manually, and by using your scripts both with the same result.

I just checked the installer on an Ubuntu 20.04 box and it works for me. Any idea what might be different in your case?

Do you update anything in the script?

I didn’t change anything apart from injecting my own secret and app ID. It’s a clean EC2 instance, with the correct ports open.

I can check this server if I can connect to it via ssh. I didn’t understand what went wrong in your case

Unfortunately I can’t let you on to the server but I can see if I can reproduce the issue in a sandbox. Any advice on logs/config to check in the meantime?

You may check the browser console log and prosody log while joining the meeting