Jitsi web page not working but service running

Jitsi web page not working but service running, its trying to open but something is blocking.

Anyone had this issue? any idea?

Check your js console logs in the browser and you will have a better idea of the error.

A frequent cause is a format error in the config.js file (missing comma)

how do i login to JS, do i need to use different port number?

Open developer tools in the browser and navigate to Console tab.

Another quick way is to use a keyboard shortcut:

  • F12
  • Ctrl+Shift+i

I am seeing the error as “Uncaught SyntaxError: Unexpected token ‘<’”

Note: I am running Amazon Linux 2 Distro and jitsi docker installation.

Just wonder, when I looked at the config of web docker-file , I see as below,

RUN apt-dpkg-wrap apt-get update &&
apt-dpkg-wrap apt-get install -y cron nginx-extras jitsi-meet-web socat &&
apt-dpkg-wrap apt-get -d install -y jitsi-meet-web-config &&
dpkg -x /var/cache/apt/archives/jitsi-meet-web-config*.deb /tmp/pkg &&
mv /tmp/pkg/usr/share/jitsi-meet-web-config/config.js /defaults &&
mv /usr/share/jitsi-meet/interface_config.js /defaults &&
rm -f /etc/nginx/conf.d/default.conf &&
apt-cleanup &&
rm -rf /tmp/pkg /var/cache/apt

I am trying to understand where is the actual Nginx config because I can seeing nginx.conf file in “/home/ec2-user/docker-jitsi-meet/web/rootfs/defaults” when I looked the config file it includes “/etc/nginx/modules-enabled/*.conf;” which does not exist.

finally, I am not seeing any Nginx service running, is it part of Jitsi-web?