(Jitsi voice calls only) (server admin) How do I turn off video option for all users

My company doesn’t need us to necessarily video chat and so I want a option that will allow users to only do voice calls. Looking for some setting on server-side configurations that would allow me to turn off videos.
Is there an option?

Yes you can configure jitsi to start with video muted.
/etc/jitsi/meet/*-config.js

@xranby
Thanks for pointing me the to the settings file. I set “startWithVideoMuted: true” and I still see the video option displayed in the meeting and I can unmute it to show my video. Correct me if I am wrong anywhere.
I was looking for something different where the video icon shouldn’t be available in any meetings started on our server.

Is there an option for this?

You can hide the camera button by changing interface_config.js located in
/usr/share/jitsi-meet/interface_config.js

users can still enable the camera by pressing V button on the keyboard.

preventing video from the users would require more deep modifications to the whole jitsi meets system to suite “one to many”
"one to many" conference configuration in server jvb component

2 Likes

Awesome. That worked for me.
Thanks @xranby

Is there any way I can control program this through api.
I want to provide start with video muted with checkbox. If checkbox is ticked the meeting will start with video muted.
and

Is there a way to turn off the notification ‘this file wants to use your (camera, mic)’? Using the startWithVideoMuted and startWithAudioMuted, but the browser still prompts to turn on.

    <script src="https://meet.jit.si/external_api.js"></script>
    <script>
        var domain = "meet.jit.si";
        var options = {
            roomName: "HOP6Room1",
			width:'100%',
   			height:500,
            parentNode: undefined,
            configOverwrite: {},
			startWithVideoMuted: true,
			startWithAudioMuted: true,
            
        }

Firstly, config overrides should go under configOverwrite and not at the root of options, e.g.:

var options = {
  roomName: "HOP6Room1",
  width: '100%',
  height: 500,
  parentNode: undefined,
  configOverwrite: {
    startWithVideoMuted: true,
    startWithAudioMuted: true,
  }
}

That said, startWithVideoMuted and startWithAudioMuted may not suppress the permission checks for media. Try disableInitialGUM: true instead.

For example:

var options = {
  roomName: "HOP6Room1",
  width: '100%',
  height: 500,
  parentNode: undefined,
  configOverwrite: {
    disableInitialGUM: true,
  }
}

Demo: JSFiddle