Jitsi-videobridge2 Failed to select initial bridge for participantRegion=null

Hi, I had a working install with stable version on Ubuntu 18.04. Now Im trying to install for testing Jitsi-videobridge2.
I did apt purge jitsi-meet jitsi-meet-web-config jitsi-meet-prosody jitsi-meet-web jicofo jitsi-videobridge
then removed stable and added the unstable repository. Then installed these packages:
apt install jitsi-videobridge2 jicofo jitsi-meet-web jitsi-meet-web-config jitsi-meet-prosody

now I can’t do a call with more than one participant. when second participant enters the room I get:

Jicofo 2020-03-21 16:31:48.261 ADVERTENCIA: [35] org.jitsi.jicofo.bridge.BridgeSelectionStrategy.log() Failed to select initial bridge for participantRegion=null
Jicofo 2020-03-21 16:31:48.261 GRAVE: [35] org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Can not invite participant – no bridge available.

Any ideas? thanks in advance

Maybe the following file is symlinked to the old videobridge? Did happen for me on Debian 10.

ls -l /etc/systemd/system/jvb.service

Removing jvb.service and reinstalling jitsi-videobridge2 worked for me.

I’m having the same problem (same error message) here but this is not an upgrade but a direct install of stable.

When >1 participant in the room:

WARNING: [27] org.jitsi.jicofo.bridge.BridgeSelectionStrategy.log() Failed to select initial bridge for participantRegion=null
SEVERE: [27] org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Can not invite participant -- no bridge available.
1 Like

Same here:

WARNING: [30] org.jitsi.jicofo.bridge.BridgeSelectionStrategy.log() Failed to select initial bridge for participantRegion=null
Jicofo 2020-03-30 14:56:20.580 SEVERE: [30] org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Can not invite participant – no bridge available.
Jicofo 2020-03-30 14:56:20.582 WARNING: [30] org.jitsi.jicofo.bridge.BridgeSelectionStrategy.log() Failed to select initial bridge for participantRegion=null
Jicofo 2020-03-30 14:56:20.582 SEVERE: [30] org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Can not invite participant – no bridge available.
Jicofo 2020-03-30 14:56:21.236 INFO: [30] org.jitsi.jicofo.ChatRoomRoleAndPresence.log() Chat room event ChatRoomMemberPresenceChangeEvent[type=MemberLeft sourceRoom=org.jitsi.impl.protocol.xmpp.ChatRoomImpl@3dbf8961 member=ChatMember[ttt-mp@conference.jitsi.mydomain.tld/b7029e7d, jid: null]@106578477]

same problem as me

I’ve solved it with SASLError using SCRAM-SHA-1: not-authorized - on Debian buster system with existing prosody try on your side.

I my case I had to go back to stable repo. Today it updated to videobridge2 from stable and all is working fine so far.