Jitsi-videobridge statistics running but show only 0

Dear community,
I´m wondering about the behavior that my statistics showing all the time “nothing”:

  • Connection #0 to host 127.0.0.1 left intact
    {
    “largest_conference”: 0,
    “conference_sizes”: “”,
    “used_memory”: 0,
    “threads”: 0,
    “videochannels”: 0,
    “loss_rate_upload”: 0,
    “bit_rate_download”: 0,
    “videostreams”: 0,
    “jitter_aggregate”: 0,
    “loss_rate_download”: 0,
    “rtp_loss”: 0,
    “total_memory”: 0,
    “bit_rate_upload”: 0,
    “current_timestamp”: “2020-03-27 11:03:42.189”,
    “rtt_aggregate”: 0,
    “cpu_usage”: 0,
    “audiochannels”: 0,
    “conferences”: 0,
    “participants”: 0
    }

Is there something is missed during the config, any ideas/hints?


/etc/jitsi/videobridge/sip-communicator.properties
org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.webconf.mydom.here.de/.*
org.jitsi.videobridge.rest.jetty.host=::
org.jitsi.videobridge.rest.jetty.port=443
org.jitsi.videobridge.rest.jetty.ProxyServlet.hostHeader=webconf.mydom.here.de
org.jitsi.videobridge.rest.jetty.ProxyServlet.pathSpec=/http-bind
org.jitsi.videobridge.rest.jetty.ProxyServlet.proxyTo=http://localhost:5280/http-bind
org.jitsi.videobridge.rest.jetty.ResourceHandler.resourceBase=/usr/share/jitsi-meet
org.jitsi.videobridge.rest.jetty.ResourceHandler.alias./config.js=/etc/jitsi/meet/webconf.mydom.here.de-config.js
org.jitsi.videobridge.rest.jetty.ResourceHandler.alias./interface_config.js=/usr/share/jitsi-meet/interface_config.js
org.jitsi.videobridge.rest.jetty.ResourceHandler.alias./logging_config.js=/usr/share/jitsi-meet/logging_config.js
org.jitsi.videobridge.rest.jetty.ResourceHandler.alias./external_api.js=/usr/share/jitsi-meet/libs/external_api.min.js
org.jitsi.videobridge.rest.jetty.RewriteHandler.regex=^/([a-zA-Z0-9]+)$
org.jitsi.videobridge.rest.jetty.RewriteHandler.replacement=/
org.jitsi.videobridge.rest.jetty.SSIResourceHandler.paths=/
org.jitsi.videobridge.rest.jetty.tls.port=443
org.jitsi.videobridge.TCP_HARVESTER_PORT=443
org.jitsi.videobridge.rest.jetty.sslContextFactory.keyStorePath=/etc/jitsi/videobridge/webconf.mydom.here.de.jks
org.jitsi.videobridge.rest.jetty.sslContextFactory.keyStorePassword=changeit
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.ENABLE_REST_COLIBRI=true
org.jitsi.videobridge.rest.private.jetty.port=8080
org.jitsi.videobridge.rest.private.jetty.host=127.0.0.1
org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri
org.jitsi.videobridge.STATISTICS_INTERVAL=1000


/etc/jitsi/videobridge/config
JVB_OPTS=–apis=rest,xmpp
JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=videobridge -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi -Djava.util.logging.config.file=/etc/jitsi/videobridge/logging.properties"
AUTHBIND=yes

Thx and best regards
Marc

Hi guys, fixed by my self:
in /etc/jitsi/videobridge/config I´ve added at the end of JAVA_SYS_PROPS=
–add-opens jdk.management/com.sun.management.internal=ALL-UNNAMED

I don´t know what is does, but now the stats are working.

System is debian 10
openjdk version “11.0.6” 2020-01-14
OpenJDK Runtime Environment (build 11.0.6+10-post-Debian-1deb10u1)
OpenJDK 64-Bit Server VM (build 11.0.6+10-post-Debian-1deb10u1, mixed mode, sharing)

Bests Marc