Jitsi-videobridge behind NAT using only TCP port 4443

meet
#1

Hello,

I have installed jitsi-meet with prosody on a server running apache2.
The server is behind a NAT, the port 4443 have been forwarded and no UDP port can ever be forwarded.

I can see that there is someone else in the room but no audio or video stream is being transmitted.

Looking at the logs the channels open then close, since I don’t know much more about how this is suppose to work I don’t know what kind of information you would need to help me.

I suppose it’s an ICE issue but I don’t know where to look now. I have been lurking at this community for days but nothing seems to work. I can’t upload the logs apparently so ask me anything since I’m not sure wich part of the logs is relevant.

Is the UDP ports very important? I see that there is STUN request made by the client on that port but as I say it can not reach videobridge but if I understood right there should be a fallback on TCP 4443.

Can anyone help me to find what we’re doing wrong ?

here is my config :

org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay= false
org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP= focus@auth.*
org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS= 10.39.167.***
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS= 193.23.**.
org.jitsi.videobridge.TCP_HARVESTER_PORT=4443
org.jitsi.videobridge.TCP_HARVESTER_SSLTCP=true
net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED= true
net.java.sip.communicator.packetlogging.PACKET_LOGGING_ARBITRARY_ENABLED= true
net.java.sip.communicator.packetlogging.PACKET_LOGGING_SIP_ENABLED= false
net.java.sip.communicator.packetlogging.PACKET_LOGGING_JABBER_ENABLED= false
net.java.sip.communicator.packetlogging.PACKET_LOGGING_RTP_ENABLED= false
net.java.sip.communicator.packetlogging.PACKET_LOGGING_ICE4j_ENABLED= true
net.java.sip.communicator.packetlogging.PACKET_LOGGING_FILE_COUNT= 1
net.java.sip.communicator.packetlogging.PACKET_LOGGING_FILE_SIZE= -1

#2

Hi @jPorsan and welcome to the Jitsi community!

Those are incorrect, see the correct ones here: https://github.com/jitsi/jitsi-videobridge/blob/master/doc/tcp.md#orgice4jiceharvestnat_harvester_local_address

I’d urge you to try to avoid TCP in general (just keep it as a last-resort kind of option) because the quality will be worse than with UDP due to the nature of react-time media transfer.

#3

Hi! Thanks for the answer.

I fixed those but I still have the same behavior. The ICE fails everytime. I just saw that I have this warning in my jvb.log.

AVERTISSEMENT: [374] org.jitsi.videobridge.IceUdpTransportManager.log() Cannot get transport type.

Is that something that will cause it not working ?

This I can’t do! I wish I could but we work in the Health Sector so i’ts very restricted.