Jitsi video do not working with more 2 participant

Hi guy!
I have a issue for jitsi video. When have more 2 participant, only display one video, the video of remote participant is disabled.

I using the docker for install jitsi-meet, and config DOCKER_HOST_ADDRESS is public IP(DOCKER_HOST_ADDRESS=x.x.x.x). In addtition, i allow access the port(10000) of jvb

Jitsi _video_question

The log in console of brower is: Figure out conn status for is video muted: false video track frozen: true p2p mode: false is in forwarded sources: true currentStatus => newStatus: active => restoring

Can you help me?

Check to make sure your host’s firewall is not blocking port 10000/UDP. Even though you’ve allowed it on your server, your host may have a firewall which you’ll need to open as well.

1 Like

@Freddie
I can access the port 10000/UDP from my host, This is command of me for test that.
nc -uvvl -s <IP> -p 10000

I think my host have been connected to 10000/UDP of server. What should I do next…

Please share your browser console logs.

You can visit the link below to know the reason:
https://<IP_REDACTED>/

Have you tried running unmodified jitsi-meet, does it work that way?

In addition, do you have valid certs?

I using domain for point to this IP.
@hasagi If using domain, should be change DOCKER_HOST_ADDRESS to domain?

The communication with the bridge is fine, as I was hearing audio in a 3 way call. It is just the video not working. I don’t see a reason for that, other than the modifications in the UI, but this can be proven by simply testing the vanilla jitsi-meet on your deployment.

@damencho yes, I modified the UI of jitsi-meet, and deploy it to server.
After modify the UI, i using command

make

for create libs folder, and copy the libs folder to docker container [web]

I’m saying to test it with unmodified version to check do you observe the same.

1 Like

Why you set these to false?

config.flags.sourceNameSignaling = false;
config.flags.sendMultipleVideoStreams = false;

You need:

config.flags = config.flags || {};
config.flags.sourceNameSignaling = true;
config.flags.sendMultipleVideoStreams = true;
config.flags.receiveMultipleVideoStreams = true;
1 Like

@damencho Thank you very much, this issue resolved. I added config ENABLE_MULTI_STREAM in the docker-compose.yml and rebuild docker, the video work OK for me.
In the guilde haven’t this config. https://jitsi.github.io/handbook/docs/devops-guide/devops-guide-docker . Therefore I missing it.


That option is gone because it’s deprecated. I’d suggest you use the latest stable release.

1 Like