[jitsi-users] XMPP URI error handling


#1

Hi,
I am trying to use XMPP URI to open chat with users in my contact list, I
managed to point xmpp uri to Jitsi, but each time when I try to open it a
get: Error handling URI. Error handling xmpp://user@openfire.domain

This exact same URI works perfect in other clients so I am wondering how it
need to be formated to be accepted by Jitsi. I also tried putting in just
xmpp:userr@openfire.domain but with same result.

Any idea what I am doing wrong?

Brano


#2

I am trying to use XMPP URI to open chat with users in my contact list, I
managed to point xmpp uri to Jitsi, but each time when I try to open it a
get: Error handling URI. Error handling xmpp://user@openfire.domain

This exact same URI works perfect in other clients so I am wondering how it
need to be formated to be accepted by Jitsi. I also tried putting in just
xmpp:userr@openfire.domain but with same result.

The variant without // is correct and works for me.

Any idea what I am doing wrong?

Can you send us your logs please?

Brano

Ingo


#3

Hi Ingo,
thanks for quick reply. Here are my logs.

log.zip (262 KB)

···

On 13 August 2015 at 08:04, Branislav Brna <branislav.brna@gmail.com> wrote:

Hi,
I am trying to use XMPP URI to open chat with users in my contact list, I
managed to point xmpp uri to Jitsi, but each time when I try to open it a
get: Error handling URI. Error handling xmpp://user@openfire.domain

This exact same URI works perfect in other clients so I am wondering how
it need to be formated to be accepted by Jitsi. I also tried putting in
just xmpp:userr@openfire.domain but with same result.

Any idea what I am doing wrong?

Brano


#4

thanks for quick reply. Here are my logs.

There was an error that slipped into the 2.8 release and has been fixed in the
nightlies in March.

Ingo


#5

Ok, I just installed nightly build and it works now with
xmpp:user@openfire.domain. Is there a way to make it work also with
xmpp://user@openfire.domain? I am asking because default client to
Openfire, Spark doesnt like just xmpp: and I need to get this working on
both clients.

···

On 13 August 2015 at 10:39, Branislav Brna <branislav.brna@gmail.com> wrote:

Hi Ingo,
thanks for quick reply. Here are my logs.

On 13 August 2015 at 08:04, Branislav Brna <branislav.brna@gmail.com> > wrote:

Hi,
I am trying to use XMPP URI to open chat with users in my contact list, I
managed to point xmpp uri to Jitsi, but each time when I try to open it a
get: Error handling URI. Error handling xmpp://user@openfire.domain

This exact same URI works perfect in other clients so I am wondering how
it need to be formated to be accepted by Jitsi. I also tried putting in
just xmpp:userr@openfire.domain but with same result.

Any idea what I am doing wrong?

Brano


#6

Ok, I just installed nightly build and it works now with
xmpp:user@openfire.domain. Is there a way to make it work also with
xmpp://user@openfire.domain? I am asking because default client to Openfire,
Spark doesnt like just xmpp: and I need to get this working on both clients.

Currently not. You can open an issue in our tracker so maybe someone will take
a look at it at some point and implement a workaround. It would be better
though if Spark gets fixed as the // makes no sense.

Ingo


#7

xmpp.org/extensions/xep-0147.html

Clearly defines xmpp: as identifier in the style oft mailto:. So this should be fixed in spark in my opinion.

Best regards,
Klaus

···

Am 13. August 2015 1:28:53 nachm. schrieb "Ingo Bauersachs" <ingo@jitsi.org>:

Ok, I just installed nightly build and it works now with
xmpp:user@openfire.domain. Is there a way to make it work also with
xmpp://user@openfire.domain? I am asking because default client to Openfire,
Spark doesnt like just xmpp: and I need to get this working on both clients.

Currently not. You can open an issue in our tracker so maybe someone will take
a look at it at some point and implement a workaround. It would be better
though if Spark gets fixed as the // makes no sense.

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users