[jitsi-users] XMPP Passwords with non-latin characters don't work with Jitsi


#1

I suspect this is in some way related to the issue I posted a long
time
  ago that noone cared about, or noone could reproduce (IMHO, noone
  tried).

  I observed that an @ character was stripped from the password. I
figured
  out that this was an issue with the implementation of the password
input
  box - manually entering the password containing the @ didn't work,
but
  typing it elsewhere and pasting it in did.

  Maybe you could try entering your password in notepad and
cut&pasting it
  into Jitsi, then report back?

  -nik

my reply was not attached to this thread so here is another try:

Hi nik,

in pidgin I have added the ü to the password of my jabber account. I worked
fine in pidgin afterwards.
Then I tried to login via Jitsi and it told me that my credentials were
wrong. So I entered my password in notepad and copy-pasted it to Jitsi like
you had proposed. Again it rejected my credentials.

So I logged in via pidgin and removed the ü from the password. Afterwards
Jitsi accepted the password. So the notepad trick did not work in my case.

Maybe one more hint: I remember that when I created my jabber account with
Jitsi I saved my password in Jitsi. With this initial setting I was able to
use my account even with the ü-password. The trouble started when I decided
to un-tick the “Remember my password” box and to enter the password
manually.

Marco