[jitsi-users] XMPP Passwords with non-latin characters don't work with Jitsi


#1

Hi,

I can confirm this issue with the German umlaut in the password.
I created an account at swissjabber.ch and used a password which contained
an “ü”. With Jitsi (version 2.2.4603.9615) on my Windows 7 machine I was
able to create the account but I was not able to login afterwards.
But I was able to use the account with the ChatSecure-App and with Pidgin.
As soon as I removed the “ü” character from the password I was also able to
login via Jitsi.

Best regards,
Marco


#2

I can confirm this issue with the German umlaut in the password.
I created an account at swissjabber.ch and used a password which contained
an “ü”. With Jitsi (version 2.2.4603.9615) on my Windows 7 machine I was
able to create the account but I was not able to login afterwards.
But I was able to use the account with the ChatSecure-App and with Pidgin.
As soon as I removed the “ü” character from the password I was also able to
login via Jitsi.

I suspect this is in some way related to the issue I posted a long time
ago that noone cared about, or noone could reproduce (IMHO, noone
tried).

I observed that an @ character was stripped from the password. I figured
out that this was an issue with the implementation of the password input
box - manually entering the password containing the @ didn't work, but
typing it elsewhere and pasting it in did.

Maybe you could try entering your password in notepad and cut&pasting it
into Jitsi, then report back?

-nik

···

--
<Natureshadow> Auf welchem Server liegt das denn jetzt…?
<mirabilos> Wenn es nicht übers Netz kommt bei Hetzner, wenn es nicht
            gelesen wird bei STRATO, wenn es klappt bei manitu.

PGP-Fingerprint: 3C9D 54A4 7575 C026 FB17 FD26 B79A 3C16 A0C4 F296


#3

I remember trying (and telling you about it :wink: ) and not being able to
repro. As Ingo mentioned, other similar threads have led us to hrlieve that
this is a swing porblem with X.

--sent from my mobile

···

On 29 Aug 2013 14:18, "Dominik George" <nik@naturalnet.de> wrote:

> I can confirm this issue with the German umlaut in the password.
> I created an account at swissjabber.ch and used a password which
contained
> an “ü”. With Jitsi (version 2.2.4603.9615) on my Windows 7 machine I was
> able to create the account but I was not able to login afterwards.
> But I was able to use the account with the ChatSecure-App and with
Pidgin.
> As soon as I removed the “ü” character from the password I was also able
to
> login via Jitsi.

I suspect this is in some way related to the issue I posted a long time
ago that noone cared about, or noone could reproduce (IMHO, noone
tried).

I observed that an @ character was stripped from the password. I figured
out that this was an issue with the implementation of the password input
box - manually entering the password containing the @ didn't work, but
typing it elsewhere and pasting it in did.

Maybe you could try entering your password in notepad and cut&pasting it
into Jitsi, then report back?

-nik

--
<Natureshadow> Auf welchem Server liegt das denn jetzt…?
<mirabilos> Wenn es nicht übers Netz kommt bei Hetzner, wenn es nicht
            gelesen wird bei STRATO, wenn es klappt bei manitu.

PGP-Fingerprint: 3C9D 54A4 7575 C026 FB17 FD26 B79A 3C16 A0C4 F296

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users