[jitsi-users] XMPP file transfer behid firewall


#1

Using Jitsi 1.1 on Ubuntu 12.04 with an internal XMPP server (ejabberd2). File transfer between 2 Jitsi client is very slow (4 K/s).

We had the same problem with pidgin until we specified manually a listen port (we choose 8010 and opened it in the workstation firewall) : now file transfer is a snap with Pidgin.

Could jitsi introduce a similar option of specifying manually listening port ?

Claude


#2

Hey Claude,

Using Jitsi 1.1 on Ubuntu 12.04 with an internal XMPP server
(ejabberd2). File transfer between 2 Jitsi client is very slow (4 K/s).

We had the same problem with pidgin until we specified manually a listen
port (we choose 8010 and opened it in the workstation firewall) : now
file transfer is a snap with Pidgin.

Could jitsi introduce a similar option of specifying manually listening
port ?

Unfortunately it's not just a matter of port. Currently Jitsi transfers
files within the XMPP connection. I suppose traffic there is limited by
your server.

I am also guessing that Pidgin was using the same mechanism until you
opened that port and it could switch to an alternative that we don't
support.

We are however shortly going to add support for Pseudo TCP file
transfers, so this should improve the situation (although it may also
require you to run a Jingle Nodes relay).

Cheers,
Emil

···

On 10.10.12, 18:24, Claude Durocher wrote:


#3

Hi Emil,

I checked the ejabberd configuration and indeed, I found that there’s a traffic shaper and by doing the following change in ejabberd.cfg, I now have acceptable file transfer rate :

{shaper, normal, {maxrate, 50000}}.

Thanks for the hint.

Claude