[jitsi-users] XMPP authentication issue on jitsi-videobridge


#1

I'm working on a collection of docker images to use for easier deployment
of Jitsi Meet. I've managed to get everything talking to each other up to
the point of actually getting two participants into a conference.

In the JS console, I see this:

[conference.js] <e.value>: CONFERENCE FAILED:
conference.videobridgeNotAvailable

I inspected the videobridge to see what was going on and I see some 401
responses being sent to requests from focus@auth.domain, like this:

jitsi-videobridge_1 | JVB 2017-06-22 13:19:44.900 FINE: [35]
org.jitsi.videobridge.xmpp.ComponentImpl.log() RECV: <iq type="get"
to="jitsi-videobridge.prosody" from="focus@auth.prosody/focus233101738271937"
id="Pxp0C-229"><healthcheck xmlns="http://jitsi.org/protocol/healthcheck
"/></iq>
jitsi-videobridge_1 | JVB 2017-06-22 13:19:44.901 FINE: [35]
org.jitsi.videobridge.xmpp.ComponentImpl.log() SENT: <iq id="Pxp0C-229"
to="focus@auth.prosody/focus233101738271937"
from="jitsi-videobridge.prosody" type="error"><healthcheck xmlns="
http://jitsi.org/protocol/healthcheck"></healthcheck><error code="401"
type="AUTH"><not-authorized
xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"></not-authorized></error></iq>

I have triple-checked and all the secrets are set up as per
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md so I
don't understand why jitsi-videobridge is responding with a 401 - does
anyone know?

Kind regards,
Rob


#2

Hi,

I'm working on a collection of docker images to use for easier deployment of
Jitsi Meet. I've managed to get everything talking to each other up to the
point of actually getting two participants into a conference.

In the JS console, I see this:

[conference.js] <e.value>: CONFERENCE FAILED:
conference.videobridgeNotAvailable

I inspected the videobridge to see what was going on and I see some 401
responses being sent to requests from focus@auth.domain, like this:

jitsi-videobridge_1 | JVB 2017-06-22 13:19:44.900 FINE: [35]
org.jitsi.videobridge.xmpp.ComponentImpl.log() RECV: <iq type=“get”
to=“jitsi-videobridge.prosody”
from=“focus@auth.prosody/focus233101738271937” id=“Pxp0C-229”><healthcheck
xmlns=“http://jitsi.org/protocol/healthcheck”/></iq>
jitsi-videobridge_1 | JVB 2017-06-22 13:19:44.901 FINE: [35]
org.jitsi.videobridge.xmpp.ComponentImpl.log() SENT: <iq id=“Pxp0C-229”
to=“focus@auth.prosody/focus233101738271937”
from=“jitsi-videobridge.prosody” type=“error”><healthcheck
xmlns=“http://jitsi.org/protocol/healthcheck”></healthcheck><error
code=“401” type=“AUTH”><not-authorized
xmlns=“urn:ietf:params:xml:ns:xmpp-stanzas”></not-authorized></error></iq>

I have triple-checked and all the secrets are set up as per
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md so I
don't understand why jitsi-videobridge is responding with a 401 - does
anyone know?

Jicofo is sending health checks to jvb and jvb reports unhealthy.
Seems jvb is not connected to the xmpp. Restarting jvb and checking
the logs after startup will reveal more.

Regards
damencho

···

On Thu, Jun 22, 2017 at 8:24 AM, Rob <robert.swain@gmail.com> wrote:

Kind regards,
Rob

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

I think I see the problem:

JVB 2017-06-22 18:40:25.199 INFO: [11]
org.jitsi.videobridge.Videobridge.log() Authorized source regexp:
focus@auth.localhost/.*

That should be focus@auth.prosody/.* in my current setup. It seems it's
something hardcoded into a default config file:

# grep -Ir org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP /etc/
/etc/jitsi/videobridge/sip-communicator.properties:org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.localhost
/.*

I've fixed that and no longer see the 401s on the health checks. Now I get
this in jicofo:

jicofo_1 | Jicofo 2017-06-22 18:58:18.104 SEVERE: [62]
org.jitsi.jicofo.ChannelAllocator.log() Failed to allocate channels for
modifiedfruitadvertisevanishingly@conference.prosody/2adf4f9d
jicofo_1 |
net.java.sip.communicator.service.protocol.OperationFailedException: Failed
to allocate channels - no bridge configured
jicofo_1 | at
org.jitsi.jicofo.ChannelAllocator.allocateChannels(ChannelAllocator.java:378)
jicofo_1 | at
org.jitsi.jicofo.ChannelAllocator.createOffer(ChannelAllocator.java:310)
jicofo_1 | at
org.jitsi.jicofo.ChannelAllocator.discoverFeaturesAndInvite(ChannelAllocator.java:166)
jicofo_1 | at
org.jitsi.jicofo.ChannelAllocator.run(ChannelAllocator.java:135)
jicofo_1 | at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
jicofo_1 | at
java.util.concurrent.FutureTask.run(FutureTask.java:266)
jicofo_1 | at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
jicofo_1 | at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
jicofo_1 | at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
jicofo_1 | at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
jicofo_1 | at java.lang.Thread.run(Thread.java:748)
jicofo_1 | Jicofo 2017-06-22 18:58:18.106 SEVERE: [62]
org.jitsi.impl.protocol.xmpp.colibri.ColibriConferenceImpl.checkIfDisposed().188
Not doing expireConference - bridge not initialized

Any ideas about this one?

···

On 22 June 2017 at 17:05, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

On Thu, Jun 22, 2017 at 8:24 AM, Rob <robert.swain@gmail.com> wrote:
> I’m working on a collection of docker images to use for easier
deployment of
> Jitsi Meet. I’ve managed to get everything talking to each other up to
the
> point of actually getting two participants into a conference.
>
> In the JS console, I see this:
>
> [conference.js] <e.value>: CONFERENCE FAILED:
> conference.videobridgeNotAvailable
>
> I inspected the videobridge to see what was going on and I see some 401
> responses being sent to requests from focus@auth.domain, like this:
>
> jitsi-videobridge_1 | JVB 2017-06-22 13:19:44.900 FINE: [35]
> org.jitsi.videobridge.xmpp.ComponentImpl.log() RECV: <iq type=“get”
> to=“jitsi-videobridge.prosody”
> from=“focus@auth.prosody/focus233101738271937”
id=“Pxp0C-229”><healthcheck
> xmlns=“http://jitsi.org/protocol/healthcheck”/></iq>
> jitsi-videobridge_1 | JVB 2017-06-22 13:19:44.901 FINE: [35]
> org.jitsi.videobridge.xmpp.ComponentImpl.log() SENT: <iq id=“Pxp0C-229”
> to=“focus@auth.prosody/focus233101738271937”
> from=“jitsi-videobridge.prosody” type=“error”><healthcheck
> xmlns=“http://jitsi.org/protocol/healthcheck”></healthcheck><error
> code=“401” type=“AUTH”><not-authorized
> xmlns=“urn:ietf:params:xml:ns:xmpp-stanzas”></not-
></error></iq>
>
> I have triple-checked and all the secrets are set up as per
> https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md
so I
> don’t understand why jitsi-videobridge is responding with a 401 - does
> anyone know?

Jicofo is sending health checks to jvb and jvb reports unhealthy.
Seems jvb is not connected to the xmpp. Restarting jvb and checking
the logs after startup will reveal more.

Regards
damencho

>
> Kind regards,
> Rob
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Yep,

There is no bridge found connected to the prosody. "Failed to allocate
channels - no bridge configured". Check jvb logs at the moment it was
started and you should see more details why.

Regards
damencho

···

On Thu, Jun 22, 2017 at 2:03 PM, Rob <robert.swain@gmail.com> wrote:

I think I see the problem:

JVB 2017-06-22 18:40:25.199 INFO: [11]
org.jitsi.videobridge.Videobridge.log() Authorized source regexp:
focus@auth.localhost/.*

That should be focus@auth.prosody/.* in my current setup. It seems it's
something hardcoded into a default config file:

# grep -Ir org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP /etc/
/etc/jitsi/videobridge/sip-communicator.properties:org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.localhost/.*

I've fixed that and no longer see the 401s on the health checks. Now I get
this in jicofo:

jicofo_1 | Jicofo 2017-06-22 18:58:18.104 SEVERE: [62]
org.jitsi.jicofo.ChannelAllocator.log() Failed to allocate channels for
modifiedfruitadvertisevanishingly@conference.prosody/2adf4f9d
jicofo_1 |
net.java.sip.communicator.service.protocol.OperationFailedException: Failed
to allocate channels - no bridge configured
jicofo_1 | at
org.jitsi.jicofo.ChannelAllocator.allocateChannels(ChannelAllocator.java:378)
jicofo_1 | at
org.jitsi.jicofo.ChannelAllocator.createOffer(ChannelAllocator.java:310)
jicofo_1 | at
org.jitsi.jicofo.ChannelAllocator.discoverFeaturesAndInvite(ChannelAllocator.java:166)
jicofo_1 | at
org.jitsi.jicofo.ChannelAllocator.run(ChannelAllocator.java:135)
jicofo_1 | at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
jicofo_1 | at
java.util.concurrent.FutureTask.run(FutureTask.java:266)
jicofo_1 | at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
jicofo_1 | at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
jicofo_1 | at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
jicofo_1 | at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
jicofo_1 | at java.lang.Thread.run(Thread.java:748)
jicofo_1 | Jicofo 2017-06-22 18:58:18.106 SEVERE: [62]
org.jitsi.impl.protocol.xmpp.colibri.ColibriConferenceImpl.checkIfDisposed().188
Not doing expireConference - bridge not initialized

Any ideas about this one?

On 22 June 2017 at 17:05, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

On Thu, Jun 22, 2017 at 8:24 AM, Rob <robert.swain@gmail.com> wrote:
> I’m working on a collection of docker images to use for easier
> deployment of
> Jitsi Meet. I’ve managed to get everything talking to each other up to
> the
> point of actually getting two participants into a conference.
>
> In the JS console, I see this:
>
> [conference.js] <e.value>: CONFERENCE FAILED:
> conference.videobridgeNotAvailable
>
> I inspected the videobridge to see what was going on and I see some 401
> responses being sent to requests from focus@auth.domain, like this:
>
> jitsi-videobridge_1 | JVB 2017-06-22 13:19:44.900 FINE: [35]
> org.jitsi.videobridge.xmpp.ComponentImpl.log() RECV: <iq type=“get”
> to=“jitsi-videobridge.prosody”
> from=“focus@auth.prosody/focus233101738271937”
> id=“Pxp0C-229”><healthcheck
> xmlns=“http://jitsi.org/protocol/healthcheck”/></iq>
> jitsi-videobridge_1 | JVB 2017-06-22 13:19:44.901 FINE: [35]
> org.jitsi.videobridge.xmpp.ComponentImpl.log() SENT: <iq id=“Pxp0C-229”
> to=“focus@auth.prosody/focus233101738271937”
> from=“jitsi-videobridge.prosody” type=“error”><healthcheck
> xmlns=“http://jitsi.org/protocol/healthcheck”></healthcheck><error
> code=“401” type=“AUTH”><not-authorized
>
> xmlns=“urn:ietf:params:xml:ns:xmpp-stanzas”></not-authorized></error></iq>
>
> I have triple-checked and all the secrets are set up as per
> https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md so
> I
> don’t understand why jitsi-videobridge is responding with a 401 - does
> anyone know?

Jicofo is sending health checks to jvb and jvb reports unhealthy.
Seems jvb is not connected to the xmpp. Restarting jvb and checking
the logs after startup will reveal more.

Regards
damencho

>
> Kind regards,
> Rob
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

I don't see anything untoward but maybe I'm missing it. :slight_smile: See attached.

Kind regards,
Rob

20170622-2121-jitsi-videobridge.log (30.8 KB)

···

On 22 June 2017 at 21:12, Damian Minkov <damencho@jitsi.org> wrote:

Yep,

There is no bridge found connected to the prosody. "Failed to allocate
channels - no bridge configured". Check jvb logs at the moment it was
started and you should see more details why.

Regards
damencho

On Thu, Jun 22, 2017 at 2:03 PM, Rob <robert.swain@gmail.com> wrote:
> I think I see the problem:
>
> JVB 2017-06-22 18:40:25.199 INFO: [11]
> org.jitsi.videobridge.Videobridge.log() Authorized source regexp:
> focus@auth.localhost/.*
>
> That should be focus@auth.prosody/.* in my current setup. It seems it’s
> something hardcoded into a default config file:
>
> # grep -Ir org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP /etc/
> /etc/jitsi/videobridge/sip-communicator.properties:org.
jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.localhost/.*
>
> I’ve fixed that and no longer see the 401s on the health checks. Now I
get
> this in jicofo:
>
> jicofo_1 | Jicofo 2017-06-22 18:58:18.104 SEVERE: [62]
> org.jitsi.jicofo.ChannelAllocator.log() Failed to allocate channels for
> modifiedfruitadvertisevanishingly@conference.prosody/2adf4f9d
> jicofo_1 |
> net.java.sip.communicator.service.protocol.OperationFailedException:
Failed
> to allocate channels - no bridge configured
> jicofo_1 | at
> org.jitsi.jicofo.ChannelAllocator.allocateChannels(
ChannelAllocator.java:378)
> jicofo_1 | at
> org.jitsi.jicofo.ChannelAllocator.createOffer(ChannelAllocator.java:310)
> jicofo_1 | at
> org.jitsi.jicofo.ChannelAllocator.discoverFeaturesAndInvite(
ChannelAllocator.java:166)
> jicofo_1 | at
> org.jitsi.jicofo.ChannelAllocator.run(ChannelAllocator.java:135)
> jicofo_1 | at
> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
> jicofo_1 | at
> java.util.concurrent.FutureTask.run(FutureTask.java:266)
> jicofo_1 | at
> java.util.concurrent.ScheduledThreadPoolExecutor$
ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
> jicofo_1 | at
> java.util.concurrent.ScheduledThreadPoolExecutor$
ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
> jicofo_1 | at
> java.util.concurrent.ThreadPoolExecutor.runWorker(
ThreadPoolExecutor.java:1142)
> jicofo_1 | at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(
ThreadPoolExecutor.java:617)
> jicofo_1 | at java.lang.Thread.run(Thread.java:748)
> jicofo_1 | Jicofo 2017-06-22 18:58:18.106 SEVERE: [62]
> org.jitsi.impl.protocol.xmpp.colibri.ColibriConferenceImpl.
checkIfDisposed().188
> Not doing expireConference - bridge not initialized
>
> Any ideas about this one?
>
>
> On 22 June 2017 at 17:05, Damian Minkov <damencho@jitsi.org> wrote:
>>
>> Hi,
>>
>> On Thu, Jun 22, 2017 at 8:24 AM, Rob <robert.swain@gmail.com> wrote:
>> > I’m working on a collection of docker images to use for easier
>> > deployment of
>> > Jitsi Meet. I’ve managed to get everything talking to each other up to
>> > the
>> > point of actually getting two participants into a conference.
>> >
>> > In the JS console, I see this:
>> >
>> > [conference.js] <e.value>: CONFERENCE FAILED:
>> > conference.videobridgeNotAvailable
>> >
>> > I inspected the videobridge to see what was going on and I see some
401
>> > responses being sent to requests from focus@auth.domain, like this:
>> >
>> > jitsi-videobridge_1 | JVB 2017-06-22 13:19:44.900 FINE: [35]
>> > org.jitsi.videobridge.xmpp.ComponentImpl.log() RECV: <iq type=“get”
>> > to=“jitsi-videobridge.prosody”
>> > from=“focus@auth.prosody/focus233101738271937”
>> > id=“Pxp0C-229”><healthcheck
>> > xmlns=“http://jitsi.org/protocol/healthcheck”/></iq>
>> > jitsi-videobridge_1 | JVB 2017-06-22 13:19:44.901 FINE: [35]
>> > org.jitsi.videobridge.xmpp.ComponentImpl.log() SENT: <iq
id=“Pxp0C-229”
>> > to=“focus@auth.prosody/focus233101738271937”
>> > from=“jitsi-videobridge.prosody” type=“error”><healthcheck
>> > xmlns=“http://jitsi.org/protocol/healthcheck”></healthcheck><error
>> > code=“401” type=“AUTH”><not-authorized
>> >
>> > xmlns=“urn:ietf:params:xml:ns:xmpp-stanzas”></not-
></error></iq>
>> >
>> > I have triple-checked and all the secrets are set up as per
>> > https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md
so
>> > I
>> > don’t understand why jitsi-videobridge is responding with a 401 - does
>> > anyone know?
>>
>> Jicofo is sending health checks to jvb and jvb reports unhealthy.
>> Seems jvb is not connected to the xmpp. Restarting jvb and checking
>> the logs after startup will reveal more.
>>
>> Regards
>> damencho
>>
>>
>> >
>> > Kind regards,
>> > Rob
>> >
>> > _______________________________________________
>> > users mailing list
>> > users@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/users
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

Err. I'm not entirely sure why but I cleaned up setting the property and
restarted everything and it suddenly started working. Problem solved...? :slight_smile:
Nice way to finish the week. Thanks for your help!

Kind regards,
Rob

···

On 22 June 2017 at 21:22, Rob <robert.swain@gmail.com> wrote:

I don't see anything untoward but maybe I'm missing it. :slight_smile: See attached.

Kind regards,
Rob

On 22 June 2017 at 21:12, Damian Minkov <damencho@jitsi.org> wrote:

Yep,

There is no bridge found connected to the prosody. "Failed to allocate
channels - no bridge configured". Check jvb logs at the moment it was
started and you should see more details why.

Regards
damencho

On Thu, Jun 22, 2017 at 2:03 PM, Rob <robert.swain@gmail.com> wrote:
> I think I see the problem:
>
> JVB 2017-06-22 18:40:25.199 INFO: [11]
> org.jitsi.videobridge.Videobridge.log() Authorized source regexp:
> focus@auth.localhost/.*
>
> That should be focus@auth.prosody/.* in my current setup. It seems it’s
> something hardcoded into a default config file:
>
> # grep -Ir org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP /etc/
> /etc/jitsi/videobridge/sip-communicator.properties:org.jitsi
.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.localhost/.*
>
> I’ve fixed that and no longer see the 401s on the health checks. Now I
get
> this in jicofo:
>
> jicofo_1 | Jicofo 2017-06-22 18:58:18.104 SEVERE: [62]
> org.jitsi.jicofo.ChannelAllocator.log() Failed to allocate channels for
> modifiedfruitadvertisevanishingly@conference.prosody/2adf4f9d
> jicofo_1 |
> net.java.sip.communicator.service.protocol.OperationFailedException:
Failed
> to allocate channels - no bridge configured
> jicofo_1 | at
> org.jitsi.jicofo.ChannelAllocator.allocateChannels(ChannelAl
locator.java:378)
> jicofo_1 | at
> org.jitsi.jicofo.ChannelAllocator.createOffer(ChannelAllocat
or.java:310)
> jicofo_1 | at
> org.jitsi.jicofo.ChannelAllocator.discoverFeaturesAndInvite(
ChannelAllocator.java:166)
> jicofo_1 | at
> org.jitsi.jicofo.ChannelAllocator.run(ChannelAllocator.java:135)
> jicofo_1 | at
> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
> jicofo_1 | at
> java.util.concurrent.FutureTask.run(FutureTask.java:266)
> jicofo_1 | at
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFu
tureTask.access$201(ScheduledThreadPoolExecutor.java:180)
> jicofo_1 | at
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFu
tureTask.run(ScheduledThreadPoolExecutor.java:293)
> jicofo_1 | at
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPool
Executor.java:1142)
> jicofo_1 | at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoo
lExecutor.java:617)
> jicofo_1 | at java.lang.Thread.run(Thread.java:748)
> jicofo_1 | Jicofo 2017-06-22 18:58:18.106 SEVERE: [62]
> org.jitsi.impl.protocol.xmpp.colibri.ColibriConferenceImpl.c
heckIfDisposed().188
> Not doing expireConference - bridge not initialized
>
> Any ideas about this one?
>
>
> On 22 June 2017 at 17:05, Damian Minkov <damencho@jitsi.org> wrote:
>>
>> Hi,
>>
>> On Thu, Jun 22, 2017 at 8:24 AM, Rob <robert.swain@gmail.com> wrote:
>> > I’m working on a collection of docker images to use for easier
>> > deployment of
>> > Jitsi Meet. I’ve managed to get everything talking to each other up
to
>> > the
>> > point of actually getting two participants into a conference.
>> >
>> > In the JS console, I see this:
>> >
>> > [conference.js] <e.value>: CONFERENCE FAILED:
>> > conference.videobridgeNotAvailable
>> >
>> > I inspected the videobridge to see what was going on and I see some
401
>> > responses being sent to requests from focus@auth.domain, like this:
>> >
>> > jitsi-videobridge_1 | JVB 2017-06-22 13:19:44.900 FINE: [35]
>> > org.jitsi.videobridge.xmpp.ComponentImpl.log() RECV: <iq type=“get”
>> > to=“jitsi-videobridge.prosody”
>> > from=“focus@auth.prosody/focus233101738271937”
>> > id=“Pxp0C-229”><healthcheck
>> > xmlns=“http://jitsi.org/protocol/healthcheck”/></iq>
>> > jitsi-videobridge_1 | JVB 2017-06-22 13:19:44.901 FINE: [35]
>> > org.jitsi.videobridge.xmpp.ComponentImpl.log() SENT: <iq
id=“Pxp0C-229”
>> > to=“focus@auth.prosody/focus233101738271937”
>> > from=“jitsi-videobridge.prosody” type=“error”><healthcheck
>> > xmlns=“http://jitsi.org/protocol/healthcheck”></healthcheck><error
>> > code=“401” type=“AUTH”><not-authorized
>> >
>> > xmlns=“urn:ietf:params:xml:ns:xmpp-stanzas”></not-authorized
></error></iq>
>> >
>> > I have triple-checked and all the secrets are set up as per
>> > https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-
install.md so
>> > I
>> > don’t understand why jitsi-videobridge is responding with a 401 -
does
>> > anyone know?
>>
>> Jicofo is sending health checks to jvb and jvb reports unhealthy.
>> Seems jvb is not connected to the xmpp. Restarting jvb and checking
>> the logs after startup will reveal more.
>>
>> Regards
>> damencho
>>
>>
>> >
>> > Kind regards,
>> > Rob
>> >
>> > _______________________________________________
>> > users mailing list
>> > users@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/users
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

So by default, jicofo checks on some interval for bridges when pubsub
discovery of bridges is not enabled, which is by default. So basically
if you restart your bridge you need to give jicofo 30 or 60 secs
before it discovers the bridge.

···

On Thu, Jun 22, 2017 at 2:38 PM, Rob <robert.swain@gmail.com> wrote:

Err. I'm not entirely sure why but I cleaned up setting the property and
restarted everything and it suddenly started working. Problem solved...? :slight_smile:
Nice way to finish the week. Thanks for your help!

Kind regards,
Rob

On 22 June 2017 at 21:22, Rob <robert.swain@gmail.com> wrote:

I don't see anything untoward but maybe I'm missing it. :slight_smile: See attached.

Kind regards,
Rob

On 22 June 2017 at 21:12, Damian Minkov <damencho@jitsi.org> wrote:

Yep,

There is no bridge found connected to the prosody. "Failed to allocate
channels - no bridge configured". Check jvb logs at the moment it was
started and you should see more details why.

Regards
damencho

On Thu, Jun 22, 2017 at 2:03 PM, Rob <robert.swain@gmail.com> wrote:
> I think I see the problem:
>
> JVB 2017-06-22 18:40:25.199 INFO: [11]
> org.jitsi.videobridge.Videobridge.log() Authorized source regexp:
> focus@auth.localhost/.*
>
> That should be focus@auth.prosody/.* in my current setup. It seems it’s
> something hardcoded into a default config file:
>
> # grep -Ir org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP /etc/
>
> /etc/jitsi/videobridge/sip-communicator.properties:org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.localhost/.*
>
> I’ve fixed that and no longer see the 401s on the health checks. Now I
> get
> this in jicofo:
>
> jicofo_1 | Jicofo 2017-06-22 18:58:18.104 SEVERE: [62]
> org.jitsi.jicofo.ChannelAllocator.log() Failed to allocate channels for
> modifiedfruitadvertisevanishingly@conference.prosody/2adf4f9d
> jicofo_1 |
> net.java.sip.communicator.service.protocol.OperationFailedException:
> Failed
> to allocate channels - no bridge configured
> jicofo_1 | at
>
> org.jitsi.jicofo.ChannelAllocator.allocateChannels(ChannelAllocator.java:378)
> jicofo_1 | at
>
> org.jitsi.jicofo.ChannelAllocator.createOffer(ChannelAllocator.java:310)
> jicofo_1 | at
>
> org.jitsi.jicofo.ChannelAllocator.discoverFeaturesAndInvite(ChannelAllocator.java:166)
> jicofo_1 | at
> org.jitsi.jicofo.ChannelAllocator.run(ChannelAllocator.java:135)
> jicofo_1 | at
> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
> jicofo_1 | at
> java.util.concurrent.FutureTask.run(FutureTask.java:266)
> jicofo_1 | at
>
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
> jicofo_1 | at
>
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
> jicofo_1 | at
>
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
> jicofo_1 | at
>
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
> jicofo_1 | at java.lang.Thread.run(Thread.java:748)
> jicofo_1 | Jicofo 2017-06-22 18:58:18.106 SEVERE: [62]
>
> org.jitsi.impl.protocol.xmpp.colibri.ColibriConferenceImpl.checkIfDisposed().188
> Not doing expireConference - bridge not initialized
>
> Any ideas about this one?
>
>
> On 22 June 2017 at 17:05, Damian Minkov <damencho@jitsi.org> wrote:
>>
>> Hi,
>>
>> On Thu, Jun 22, 2017 at 8:24 AM, Rob <robert.swain@gmail.com> wrote:
>> > I’m working on a collection of docker images to use for easier
>> > deployment of
>> > Jitsi Meet. I’ve managed to get everything talking to each other up
>> > to
>> > the
>> > point of actually getting two participants into a conference.
>> >
>> > In the JS console, I see this:
>> >
>> > [conference.js] <e.value>: CONFERENCE FAILED:
>> > conference.videobridgeNotAvailable
>> >
>> > I inspected the videobridge to see what was going on and I see some
>> > 401
>> > responses being sent to requests from focus@auth.domain, like this:
>> >
>> > jitsi-videobridge_1 | JVB 2017-06-22 13:19:44.900 FINE: [35]
>> > org.jitsi.videobridge.xmpp.ComponentImpl.log() RECV: <iq type=“get”
>> > to=“jitsi-videobridge.prosody”
>> > from=“focus@auth.prosody/focus233101738271937”
>> > id=“Pxp0C-229”><healthcheck
>> > xmlns=“http://jitsi.org/protocol/healthcheck”/></iq>
>> > jitsi-videobridge_1 | JVB 2017-06-22 13:19:44.901 FINE: [35]
>> > org.jitsi.videobridge.xmpp.ComponentImpl.log() SENT: <iq
>> > id=“Pxp0C-229”
>> > to=“focus@auth.prosody/focus233101738271937”
>> > from=“jitsi-videobridge.prosody” type=“error”><healthcheck
>> > xmlns=“http://jitsi.org/protocol/healthcheck”></healthcheck><error
>> > code=“401” type=“AUTH”><not-authorized
>> >
>> >
>> > xmlns=“urn:ietf:params:xml:ns:xmpp-stanzas”></not-authorized></error></iq>
>> >
>> > I have triple-checked and all the secrets are set up as per
>> >
>> > https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md so
>> > I
>> > don’t understand why jitsi-videobridge is responding with a 401 -
>> > does
>> > anyone know?
>>
>> Jicofo is sending health checks to jvb and jvb reports unhealthy.
>> Seems jvb is not connected to the xmpp. Restarting jvb and checking
>> the logs after startup will reveal more.
>>
>> Regards
>> damencho
>>
>>
>> >
>> > Kind regards,
>> > Rob
>> >
>> > _______________________________________________
>> > users mailing list
>> > users@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/users
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users