[jitsi-users] Wrong repo URL in nightly Debian package


#1

Hi,

the Debian packages automatically add an apt sources entry upon
installing. This is OK, but the 2.3 nightlies should add the nightly
build repository. I guess that on most systems, automaticaly adding the
stable repository only results in the package never being automatically
upgraded, but as I use explicit pinning for packages from non-Debian
repositories, the jitsi package is pinned high from the Jitsi repository
and the result is Jitsi automaticaly being downgraded on the next apt
run, because the source of the 2.3 builds is no longer known.

- REPOCONFIG="deb http://download.jitsi.org/deb unstable/"
+ REPOCONFIG="deb http://download.jitsi.org/nightly/deb unstable/"

-nik

···

--
Wer den Grünkohl nicht ehrt, ist der Mettwurst nicht wert!

PGP-Fingerprint: 3C9D 54A4 7575 C026 FB17 FD26 B79A 3C16 A0C4 F296


#2

Hi,

the repo is intentionally the stable one, cause the same packages are
used when releasing a package in the stable line. If you want to keep
up with the nightlies put another entry in your apt sources, but not
modify the one installed from jitsi to avoid overriding.

Regards
damencho

···

On Wed, Aug 7, 2013 at 2:24 AM, Dominik George <nik@naturalnet.de> wrote:

Hi,

the Debian packages automatically add an apt sources entry upon
installing. This is OK, but the 2.3 nightlies should add the nightly
build repository. I guess that on most systems, automaticaly adding the
stable repository only results in the package never being automatically
upgraded, but as I use explicit pinning for packages from non-Debian
repositories, the jitsi package is pinned high from the Jitsi repository
and the result is Jitsi automaticaly being downgraded on the next apt
run, because the source of the 2.3 builds is no longer known.

- REPOCONFIG="deb http://download.jitsi.org/deb unstable/"
+ REPOCONFIG="deb http://download.jitsi.org/nightly/deb unstable/"

-nik

--
Wer den Grünkohl nicht ehrt, ist der Mettwurst nicht wert!

PGP-Fingerprint: 3C9D 54A4 7575 C026 FB17 FD26 B79A 3C16 A0C4 F296

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hi,

I went with chattr +i for now to see how the script behaves then ;)...

-nik

Damian Minkov <damencho@jitsi.org> schrieb:

···

Hi,

the repo is intentionally the stable one, cause the same packages are
used when releasing a package in the stable line. If you want to keep
up with the nightlies put another entry in your apt sources, but not
modify the one installed from jitsi to avoid overriding.

Regards
damencho

On Wed, Aug 7, 2013 at 2:24 AM, Dominik George <nik@naturalnet.de> >wrote:

Hi,

the Debian packages automatically add an apt sources entry upon
installing. This is OK, but the 2.3 nightlies should add the nightly
build repository. I guess that on most systems, automaticaly adding

the

stable repository only results in the package never being

automatically

upgraded, but as I use explicit pinning for packages from non-Debian
repositories, the jitsi package is pinned high from the Jitsi

repository

and the result is Jitsi automaticaly being downgraded on the next apt
run, because the source of the 2.3 builds is no longer known.

- REPOCONFIG="deb http://download.jitsi.org/deb unstable/"
+ REPOCONFIG="deb http://download.jitsi.org/nightly/deb unstable/"

-nik

--
Wer den Grünkohl nicht ehrt, ist der Mettwurst nicht wert!

PGP-Fingerprint: 3C9D 54A4 7575 C026 FB17 FD26 B79A 3C16 A0C4 F296

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Diese Nachricht wurde von meinem Android-Mobiltelefon mit K-9 Mail gesendet.


#4

Hi,

the repo is intentionally the stable one, cause the same packages are
used when releasing a package in the stable line. If you want to keep
up with the nightlies put another entry in your apt sources, but not
modify the one installed from jitsi to avoid overriding.

the clean ("Debian") way would be to manage the file as a conffile,
which would fix the issue while still enabling you to use the same
packages for stable releases.

-nik

···

--
# apt-assassinate --help
Usage: apt-assassinate [upstream|maintainer] <package>

PGP-Fingerprint: 3C9D 54A4 7575 C026 FB17 FD26 B79A 3C16 A0C4 F296