[jitsi-users] Wrong ptime for OPUS codec


#1

Hi,

It seems that Jitsi-2.9.5515 sends malformed "ptime" in SDP in case if OPUS
codec is enabled:

m=audio 5000 UDP/TLS/RTP/SAVP 96 97 98 9 100 102 0 8 103 3 104 101
a=rtpmap:96 opus/48000/2
a=fmtp:96 usedtx=1
a=ptime:96 20

According to RFC4566, where "ptime" attribute was introduced, it's format
is:

a=ptime:<packet time>

So it should be single int, not payload type+int.

Should I create issue on github for this ?


#2

Hi,

It seems that Jitsi-2.9.5515 sends malformed "ptime" in SDP in case if OPUS
codec is enabled:

m=audio 5000 UDP/TLS/RTP/SAVP 96 97 98 9 100 102 0 8 103 3 104 101
a=rtpmap:96 opus/48000/2
a=fmtp:96 usedtx=1
a=ptime:96 20

According to RFC4566, where "ptime" attribute was introduced, it's format
is:

a=ptime:<packet time>

So it should be single int, not payload type+int.

Should I create issue on github for this ?