[jitsi-users] wrong port in Contact header in responses on registrar-less account?


#1

Hi everybody,

I’m trying to use jitsi without a registrar. I plan to send requests to it directly by ip/port, only for tests.
I’m using Mac OS 10.11; I tried both the latest snapshot build and latest release build of jitsi and they both seem to have the same issue or I’m missing some configuration somewhere.

When I start Jitsi I can see it’s listening on TCP port 5060, as configured.
However, when jitsi receives a call/INVITE and it rings or I answer the incoming call, the 180/200 OK provided back contain some apparently random port on the Contact header.
For example, sip:

Contact: "hmacias" <sip:hmacias@192.168.10.8:50270;transport=tcp>

this makes the ACK be sent to that port, but jitsi is not really listening on that port.
I tried changing the SIP/SIPS port on the SIP configuration under Advanced settings, but although jitsi starts listening on that port (instead of the previous default 5060), again the responses to INVITE messages contain another random port not being the configured one and not being correct apparently (since jitsi is not listening on the port it’s reporting back).

Has anybody seen the same issue? Am I missing some kind of configuration somewhere?

Thanks,

H


#2

Hi everybody,

I’m trying to use jitsi without a registrar. I plan to send requests to
it directly by ip/port, only for tests.
I’m using Mac OS 10.11; I tried both the latest snapshot build and
latest release build of jitsi and they both seem to have the same issue
or I’m missing some configuration somewhere.

When I start Jitsi I can see it’s listening on TCP port 5060, as configured.
However, when jitsi receives a call/INVITE and it rings or I answer the
incoming call, the 180/200 OK provided back contain some apparently
random port on the Contact header.

That's the port of the TCP connection that Jitsi sets up toward the SIP server and where it expects to hear back from it.

For example, sip:

Contact: "hmacias" <sip:hmacias@192.168.10.8:*50270*;transport=tcp>

this makes the ACK be sent to that port, but jitsi is not really
listening on that port.

Right ... it has an established connection there and it only accepts messages from the server.

I tried changing the SIP/SIPS port on the SIP configuration under
Advanced settings, but although jitsi starts listening on that port
(instead of the previous default 5060), again the responses to INVITE
messages contain another random port not being the configured one and
not being correct apparently (since jitsi is not listening on the port
it’s reporting back).

Has anybody seen the same issue? Am I missing some kind of configuration
somewhere?

No, not really. It's just that regular accounts are not meant to accept messages from anywhere.

You may want to try a registrarless one.

Hope this helps,
Emil

···

On 3.04.16 г. 5:26, Macias, Horaci (Horaci) wrote:

Thanks,

H

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
https://jitsi.org


#3

thanks for the reply Emil.
I’m using a registrar less account for these tests.
Jitsi is listening on the configured port, 5060.
The problem is that the Contact header reports a different port, a port on which Jitsi is not listening on, hence what I believe is an issue in Jitsi at least for registrar less accounts.

* I start jitsi. SIP is configured on port 5060.
* I can connect to Jitsi on port 5060. I can send OPTIONS or INVITE messages on port 5060 and Jitsi answers.
* The Contact header of the responses to OPTION or INVITE messages contain a random port, e.g. 49455.
* I try connecting on the random port returned by Jitsi (which I should do to send the ACK in case of an INVITE transaction). That port is not open, or Jitsi is refusing my connections to it if I try using that port.

is anybody using registrar less accounts successfully?
I’d imagine anybody talking directly to Jitsi configured registrar less would have the same issue; the ACK message will not reach Jitsi.

Thanks,

H

···

On 04 Apr 2016, at 04:58, Emil Ivov <emcho@jitsi.org> wrote:

On 3.04.16 г. 5:26, Macias, Horaci (Horaci) wrote:

Hi everybody,

I’m trying to use jitsi without a registrar. I plan to send requests to
it directly by ip/port, only for tests.
I’m using Mac OS 10.11; I tried both the latest snapshot build and
latest release build of jitsi and they both seem to have the same issue
or I’m missing some configuration somewhere.

When I start Jitsi I can see it’s listening on TCP port 5060, as configured.
However, when jitsi receives a call/INVITE and it rings or I answer the
incoming call, the 180/200 OK provided back contain some apparently
random port on the Contact header.

That's the port of the TCP connection that Jitsi sets up toward the SIP server and where it expects to hear back from it.

For example, sip:

Contact: "hmacias" <sip:hmacias@192.168.10.8:*50270*;transport=tcp>

this makes the ACK be sent to that port, but jitsi is not really
listening on that port.

Right ... it has an established connection there and it only accepts messages from the server.

I tried changing the SIP/SIPS port on the SIP configuration under
Advanced settings, but although jitsi starts listening on that port
(instead of the previous default 5060), again the responses to INVITE
messages contain another random port not being the configured one and
not being correct apparently (since jitsi is not listening on the port
it’s reporting back).

Has anybody seen the same issue? Am I missing some kind of configuration
somewhere?

No, not really. It's just that regular accounts are not meant to accept messages from anywhere.

You may want to try a registrarless one.

Hope this helps,
Emil

Thanks,

H

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.jitsi.org_mailman_listinfo_users&d=BQIGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=JOmHbwesUy6Lfq3CW-EzfNELsHrjaOUtxJV1dP3hZrI&m=d4XRRpF3BVc6SZDAl9Nm2AA8k_DwrcdvmNhnha4270s&s=wj4cENlQwA5iiR7Yuq--7GnmS1cxcYFbefUEg6jh7Hc&e=


https://urldefense.proofpoint.com/v2/url?u=https-3A__jitsi.org&d=BQIGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=JOmHbwesUy6Lfq3CW-EzfNELsHrjaOUtxJV1dP3hZrI&m=d4XRRpF3BVc6SZDAl9Nm2AA8k_DwrcdvmNhnha4270s&s=qyip8VPtRizijJUvx_CrOAUw30a0HyTu26lvMWEHxmo&e=
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.jitsi.org_mailman_listinfo_users&d=BQIGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=JOmHbwesUy6Lfq3CW-EzfNELsHrjaOUtxJV1dP3hZrI&m=d4XRRpF3BVc6SZDAl9Nm2AA8k_DwrcdvmNhnha4270s&s=wj4cENlQwA5iiR7Yuq--7GnmS1cxcYFbefUEg6jh7Hc&e=


#4

thanks for the reply Emil.
I’m using a registrar less account for these tests.
Jitsi is listening on the configured port, 5060.
The problem is that the Contact header reports a different port, a port on
which Jitsi is not listening on, hence what I believe is an issue in Jitsi
at least for registrar less accounts.

* I start jitsi. SIP is configured on port 5060.
* I can connect to Jitsi on port 5060. I can send OPTIONS or INVITE
messages on port 5060 and Jitsi answers.
* The Contact header of the responses to OPTION or INVITE messages contain
a random port, e.g. 49455.
* I try connecting on the random port returned by Jitsi (which I should do
to send the ACK in case of an INVITE transaction). That port is not open,
or Jitsi is refusing my connections to it if I try using that port.

is anybody using registrar less accounts successfully?

Unfortunately not that much. Probably not at all with TCP :frowning:

I’d imagine anybody talking directly to Jitsi configured registrar less
would have the same issue; the ACK message will not reach Jitsi.

The point is that the common case does not involve other endpoints sending
signalling directly to jitsi.

Emil

···

On Thursday, 7 April 2016, Macias, Horaci (Horaci) <hmacias@avaya.com> wrote:

Thanks,

H

> On 04 Apr 2016, at 04:58, Emil Ivov <emcho@jitsi.org <javascript:;>> > wrote:
>
>
>
> On 3.04.16 г. 5:26, Macias, Horaci (Horaci) wrote:
>> Hi everybody,
>>
>> I’m trying to use jitsi without a registrar. I plan to send requests to
>> it directly by ip/port, only for tests.
>> I’m using Mac OS 10.11; I tried both the latest snapshot build and
>> latest release build of jitsi and they both seem to have the same issue
>> or I’m missing some configuration somewhere.
>>
>> When I start Jitsi I can see it’s listening on TCP port 5060, as
configured.
>> However, when jitsi receives a call/INVITE and it rings or I answer the
>> incoming call, the 180/200 OK provided back contain some apparently
>> random port on the Contact header.
>
> That's the port of the TCP connection that Jitsi sets up toward the SIP
server and where it expects to hear back from it.
>
>> For example, sip:
>>
>> Contact: "hmacias" <sip:hmacias@192.168.10.8:*50270*;transport=tcp>
>>
>> this makes the ACK be sent to that port, but jitsi is not really
>> listening on that port.
>
> Right … it has an established connection there and it only accepts
messages from the server.
>
>> I tried changing the SIP/SIPS port on the SIP configuration under
>> Advanced settings, but although jitsi starts listening on that port
>> (instead of the previous default 5060), again the responses to INVITE
>> messages contain another random port not being the configured one and
>> not being correct apparently (since jitsi is not listening on the port
>> it’s reporting back).
>>
>> Has anybody seen the same issue? Am I missing some kind of configuration
>> somewhere?
>
> No, not really. It's just that regular accounts are not meant to accept
messages from anywhere.
>
> You may want to try a registrarless one.
>
> Hope this helps,
> Emil
>>
>> Thanks,
>>
>> H
>>
>>
>>
>>
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org <javascript:;>
>> Unsubscribe instructions and other list options:
>>
https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.jitsi.org_mailman_listinfo_users&d=BQIGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=JOmHbwesUy6Lfq3CW-EzfNELsHrjaOUtxJV1dP3hZrI&m=d4XRRpF3BVc6SZDAl9Nm2AA8k_DwrcdvmNhnha4270s&s=wj4cENlQwA5iiR7Yuq--7GnmS1cxcYFbefUEg6jh7Hc&e=
>
> –
>
https://urldefense.proofpoint.com/v2/url?u=https-3A__jitsi.org&d=BQIGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=JOmHbwesUy6Lfq3CW-EzfNELsHrjaOUtxJV1dP3hZrI&m=d4XRRpF3BVc6SZDAl9Nm2AA8k_DwrcdvmNhnha4270s&s=qyip8VPtRizijJUvx_CrOAUw30a0HyTu26lvMWEHxmo&e=
> _______________________________________________
> users mailing list
> users@jitsi.org <javascript:;>
> Unsubscribe instructions and other list options:
>
https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.jitsi.org_mailman_listinfo_users&d=BQIGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=JOmHbwesUy6Lfq3CW-EzfNELsHrjaOUtxJV1dP3hZrI&m=d4XRRpF3BVc6SZDAl9Nm2AA8k_DwrcdvmNhnha4270s&s=wj4cENlQwA5iiR7Yuq--7GnmS1cxcYFbefUEg6jh7Hc&e=

_______________________________________________
users mailing list
users@jitsi.org <javascript:;>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
sent from my mobile