[jitsi-users] websockets on meet.jit.si


#1

Hi Jitsi Users,

I heard Chris mention today on the community call that websockets were not working properly on meet.jit.si <http://meet.jit.si/> after the upgrade on Friday.

The websocket URL is https://meet.jit.si/xmpp-websocket and I am unable to reproduce the failure reported (I see the expected response from this URL).

I wanted to get some more detail about how websockets are being used against meet.jit.si <http://meet.jit.si/>. Can you send me any details on how websockets are implemented in your client?

Additionally I want encourage anyone using meet.jit.si to include the room name as a URL parameter when attempting to access ANY meet.jit.si <http://meet.jit.si/> URL. This will allow our load-balancing algorithm to properly route all requests to the assigned shard.

So the FULL websocket URL for conference https://meet.jit.si/MyConferenceRoom is: https://meet.jit.si/xmpp-websocket?room=MyConferenceRoom <https://meet.jit.si/xmpp-websocket?room=MyConferenceRoom>

Please let me know if there continues to be issues with websockets on meet.jit.si <http://meet.jit.si/> as well as any details of how the failure occurs.

I’d also love to get some more details on what steps I would need to take to install the iOS client, as I’d be happy to test new releases with it if I have the client installed.

Cheers,

-Aaron van Meerten


#2

Hi Aaron,

Hi Jitsi Users,

I heard Chris mention today on the community call that websockets were not working properly on meet.jit.si <http://meet.jit.si/> after the upgrade on Friday.

The websocket URL is https://meet.jit.si/xmpp-websocket and I am unable to reproduce the failure reported (I see the expected response from this URL).

We will double check and get back to you soon.

I wanted to get some more detail about how websockets are being used against meet.jit.si <http://meet.jit.si/>. Can you send me any details on how websockets are implemented in your client?

It’s just standard XMPP over websockets as implemented in strophe.js/Prosody, no special sauce.

Additionally I want encourage anyone using meet.jit.si <http://meet.jit.si/> to include the room name as a URL parameter when attempting to access ANY meet.jit.si <http://meet.jit.si/> URL. This will allow our load-balancing algorithm to properly route all requests to the assigned shard.

So the FULL websocket URL for conference https://meet.jit.si/MyConferenceRoom is: https://meet.jit.si/xmpp-websocket?room=MyConferenceRoom <https://meet.jit.si/xmpp-websocket?room=MyConferenceRoom>

Will double check on this too.

Please let me know if there continues to be issues with websockets on meet.jit.si <http://meet.jit.si/> as well as any details of how the failure occurs.

I’d also love to get some more details on what steps I would need to take to install the iOS client, as I’d be happy to test new releases with it if I have the client installed.

We can get you a build, will contact directly for that.

···

On Apr 25, 2016, at 2:54 PM, Aaron van Meerten <avanmeerten@atlassian.com> wrote:

Cheers,

-Aaron van Meerten

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

I was successfully able to use websockets against an instance of jitsi meet. I set the bosh: parameter in config.js to start with wss:// instead of just //, and then I changed the path from http-bind to xmpp-websocket

With this change, I was able to use conferences without any problems.

So, please let me know whether you can see the same behavior when using a non-javascript client.

Cheers,

-Aaron

···

On Apr 25, 2016, at 15:06, Chris Wendt <chris@chriswendt.net> wrote:

Hi Aaron,

On Apr 25, 2016, at 2:54 PM, Aaron van Meerten <avanmeerten@atlassian.com <mailto:avanmeerten@atlassian.com>> wrote:

Hi Jitsi Users,

I heard Chris mention today on the community call that websockets were not working properly on meet.jit.si <http://meet.jit.si/> after the upgrade on Friday.

The websocket URL is https://meet.jit.si/xmpp-websocket and I am unable to reproduce the failure reported (I see the expected response from this URL).

We will double check and get back to you soon.

I wanted to get some more detail about how websockets are being used against meet.jit.si <http://meet.jit.si/>. Can you send me any details on how websockets are implemented in your client?

It’s just standard XMPP over websockets as implemented in strophe.js/Prosody, no special sauce.

Additionally I want encourage anyone using meet.jit.si <http://meet.jit.si/> to include the room name as a URL parameter when attempting to access ANY meet.jit.si <http://meet.jit.si/> URL. This will allow our load-balancing algorithm to properly route all requests to the assigned shard.

So the FULL websocket URL for conference https://meet.jit.si/MyConferenceRoom is: https://meet.jit.si/xmpp-websocket?room=MyConferenceRoom <https://meet.jit.si/xmpp-websocket?room=MyConferenceRoom>

Will double check on this too.

Please let me know if there continues to be issues with websockets on meet.jit.si <http://meet.jit.si/> as well as any details of how the failure occurs.

I’d also love to get some more details on what steps I would need to take to install the iOS client, as I’d be happy to test new releases with it if I have the client installed.

We can get you a build, will contact directly for that.

Cheers,

-Aaron van Meerten

_______________________________________________
users mailing list
users@jitsi.org <mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users