[jitsi-users] WebRTC - sRTP


#1

Folks,

We have intalled Jitsi in order to do webconf between collegues.

Then, I installed Jitsi Meet / Nginx / Prosody / Jifoco and Jitsi VideoBridge.
It works well !! but the transport mode is in udp-raw instead of (our target) sRTP (or zRTP)....

I tried to change /etc/jitsi/videobridge/sip-communicator.properties with org.jitsi.videobridge.Videobridge.defaultTransportManager parameter, but it seems not working at all.

Any idea to configure jitsi for sRTP transport ?
Our goal is to force sRTP or zRTP transport mode for each communications.

Thanks !

Cédric


#2

Folks,

We have intalled Jitsi in order to do webconf between collegues.

Then, I installed Jitsi Meet / Nginx / Prosody / Jifoco and Jitsi
VideoBridge.
It works well !! but the transport mode is in udp-raw instead of (our
target) sRTP (or zRTP)....

I tried to change /etc/jitsi/videobridge/sip-communicator.properties
with org.jitsi.videobridge.Videobridge.defaultTransportManager
parameter, but it seems not working at all.

Any idea to configure jitsi for sRTP transport ?
Our goal is to force sRTP or zRTP transport mode for each communications.

WebRTC requires the use of SRTP (with keys setup with DTLS), so when using Jitsi-Meet SRTP is always used. ZRTP is not supported.

> http://booting-rpi.blogspot.fr/2015/09/using-ldap-authentication-with-jitsi.html

This refers to Jitsi, not Jitsi-Meet.

Regards,
Boris

···

On 17/12/15 08:29, cedm12@laposte.net wrote:


#3

Folks,

We have intalled Jitsi in order to do webconf between collegues.

Then, I installed Jitsi Meet / Nginx / Prosody / Jifoco and Jitsi VideoBridge.
It works well !!

Now, we tried to use our LDAP server, but without sucess.... And we found no errors into /var/log
We have follow this how-to :
http://booting-rpi.blogspot.fr/2015/09/using-ldap-authentication-with-jitsi.html

Any idea ?

For /etc/prosody/conf.avail/ldap.cfg.lua
authentication = 'ldap2'
ldap = {
hostname = 'Our LDAP Server',
use_tls = true,
bind_dn = 'cn=ldapreaderProxy,c=fr',
bind_password = 'XXX', -- Bind password (optional if anonymous bind is supported)

user = {
basedn = 'c=fr',
filter = '(&(objectClass=obmUser)(mail=$user))',
usernamefield = 'uid',
namefield = 'cn',
},
}

For /etc/prosody/conf.d/x.cfg.lua

VirtualHost "x"
authentication = "ldap2"
debug = true;

ssl configured

-- we need bosh
modules_enabled = {
"bosh";
"pubsub";
"ping"; -- Enable mod_ping
}

Thanks !

Cédric


#4

I tried to add LDAP authentification with WebRTC jitsi solution via CYRUS SASL

Then I provisionned
- prosody conf (/etc/conf.avail/myconf.lua)
authentication = "cyrus"
sasl_backend = "cyrus"
cyrus_service_name = "xmpp"

- SASL (seems working fine)
testsaslauthd -u xxx@yyy -p zzzzz
0: OK "Success."

I have a correct behaviour with my jitsi webrtc website (I mean I have a correct popup asking login ans password), but authentification is failing.
No failure logs in /var/log/auth.log

Is anybody has LDAP configured ? Or Any idea ?

Cédric

----- Mail original -----

···

De: cedm12@laposte.net
À: users@jitsi.org
Envoyé: Jeudi 17 Décembre 2015 15:39:35
Objet: WebRTC - LDAP

Folks,

We have intalled Jitsi in order to do webconf between collegues.

Then, I installed Jitsi Meet / Nginx / Prosody / Jifoco and Jitsi VideoBridge.
It works well !!

Now, we tried to use our LDAP server, but without sucess.... And we found no errors into /var/log
We have follow this how-to :
http://booting-rpi.blogspot.fr/2015/09/using-ldap-authentication-with-jitsi.html

Any idea ?

For /etc/prosody/conf.avail/ldap.cfg.lua
authentication = 'ldap2'
ldap = {
hostname = 'Our LDAP Server',
use_tls = true,
bind_dn = 'cn=ldapreaderProxy,c=fr',
bind_password = 'XXX', -- Bind password (optional if anonymous bind is supported)

user = {
basedn = 'c=fr',
filter = '(&(objectClass=obmUser)(mail=$user))',
usernamefield = 'uid',
namefield = 'cn',
},
}

For /etc/prosody/conf.d/x.cfg.lua

VirtualHost "x"
authentication = "ldap2"
debug = true;

ssl configured

-- we need bosh
modules_enabled = {
"bosh";
"pubsub";
"ping"; -- Enable mod_ping
}

Thanks !

Cédric


#5

Hi Cedric,

I'm author of this how-to, your basedn looks wrong, it should be "dc",
what openldap version do you use?

Best,
Stan

···

2016-01-08 17:01 GMT+01:00 <cedm12@laposte.net>:

I tried to add LDAP authentification with WebRTC jitsi solution via CYRUS
SASL

Then I provisionned
  - prosody conf (/etc/conf.avail/myconf.lua)
            authentication = "cyrus"
            sasl_backend = "cyrus"
            cyrus_service_name = "xmpp"

- SASL (seems working fine)
    testsaslauthd -u xxx@yyy -p zzzzz
    0: OK "Success."

I have a correct behaviour with my jitsi webrtc website (I mean I have a
correct popup asking login ans password), but authentification is failing.
No failure logs in /var/log/auth.log

Is anybody has LDAP configured ? Or Any idea ?

Cédric

________________________________
De: cedm12@laposte.net
À: users@jitsi.org
Envoyé: Jeudi 17 Décembre 2015 15:39:35
Objet: WebRTC - LDAP

Folks,

We have intalled Jitsi in order to do webconf between collegues.

Then, I installed Jitsi Meet / Nginx / Prosody / Jifoco and Jitsi
VideoBridge.
It works well !!

Now, we tried to use our LDAP server, but without sucess.... And we found
no errors into /var/log
We have follow this how-to :
http://booting-rpi.blogspot.fr/2015/09/using-ldap-authentication-with-jitsi.html

Any idea ?

For /etc/prosody/conf.avail/ldap.cfg.lua
authentication = 'ldap2'
ldap = {
    hostname = 'Our LDAP Server',
    use_tls = true,
    bind_dn = 'cn=ldapreaderProxy,c=fr',
    bind_password = 'XXX', -- Bind password (optional if anonymous bind is
supported)

    user = {
      basedn = 'c=fr',
      filter = '(&(objectClass=obmUser)(mail=$user))',
      usernamefield = 'uid',
      namefield = 'cn',
    },
}

For /etc/prosody/conf.d/x.cfg.lua

VirtualHost "x"
    authentication = "ldap2"
    debug = true;

   ssl configured

        -- we need bosh
        modules_enabled = {
            "bosh";
            "pubsub";
            "ping"; -- Enable mod_ping
        }

Thanks !

Cédric

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users