[jitsi-users] Videobridge looks ill and does not work... Where are all the prefs, by the way?


#1

Anyone? Come on.. I've broken all the head. It does not work even with clean Ubuntu installation. Nothing else: just ubuntu 14 server x86 from the cd and OpenFire. And a little bit of preferences:

root@abc:~# cat /etc/jitsi/videobridge/sip-communicator.properties
org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
org.jitsi.videobridge.TCP_HARVESTER_PORT=4443
org.ice4j.ipv6.DISABLED=true

root@abc:~# cat /etc/jitsi/videobridge/config
# Jitsi Videobridge settings
# sets the XMPP domain (default: none)
JVB_HOSTNAME=abc.temp
# sets the hostname of the XMPP server (default: domain if set, localhost otherwise)
JVB_HOST=
# sets the port of the XMPP server (default: 5275)
JVB_PORT=5275
# sets the shared secret used to authenticate to the XMPP server
JVB_SECRET=secret
# extra options to pass to the JVB daemon
JVB_OPTS=""
# adds java system props that are passed to jvb (default are for home and logging config file)
JAVA_SYS_PROPS="$JVB_EXTRA_JVM_PARAMS -Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=videobridge -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi -Djava.util.logging.config.file=/etc/jitsi/videobridge/logging.properties"

root@abc:~# cat /etc/hosts
127.0.0.1 localhost
127.0.0.1 abc.temp

# The following lines are desirable for IPv6 capable hosts
::1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

С уважением,
- -
ushastik-007@mail.ru


#2

Do you have any error messages in the log?

···

On Apr 6, 2017 7:54 AM, "- -" <ushastik-007@mail.ru> wrote:

Anyone? Come on.. I've broken all the head. It does not work even with
clean Ubuntu installation. Nothing else: just ubuntu 14 server x86 from the
cd and OpenFire. And a little bit of preferences:

root@abc:~# cat /etc/jitsi/videobridge/sip-communicator.properties
org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
org.jitsi.videobridge.TCP_HARVESTER_PORT=4443
org.ice4j.ipv6.DISABLED=true

root@abc:~# cat /etc/jitsi/videobridge/config
# Jitsi Videobridge settings
# sets the XMPP domain (default: none)
JVB_HOSTNAME=abc.temp
# sets the hostname of the XMPP server (default: domain if set, localhost
otherwise)
JVB_HOST=
# sets the port of the XMPP server (default: 5275)
JVB_PORT=5275
# sets the shared secret used to authenticate to the XMPP server
JVB_SECRET=secret
# extra options to pass to the JVB daemon
JVB_OPTS=""
# adds java system props that are passed to jvb (default are for home and
logging config file)
JAVA_SYS_PROPS="$JVB_EXTRA_JVM_PARAMS -Dnet.java.sip.communicator.
SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=videobridge
-Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi
-Djava.util.logging.config.file=/etc/jitsi/videobridge/logging.properties"

root@abc:~# cat /etc/hosts
127.0.0.1 localhost
127.0.0.1 abc.temp

# The following lines are desirable for IPv6 capable hosts
::1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

С уважением,
- -
ushastik-007@mail.ru

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

I would be happy to have errors! But there are no any...)

Videobridge talks with clients about port binding. Then clients start streaming to that ports (10002, 10003), I see two UDP streams coming in, but no one coming out. Sometimes bridge sends bind-keeping packets and collect responses, but nothing else.

I've attached a new log.

1.txt (40.1 KB)

···

Пятница, 7 апреля 2017, 4:12 +06:00 от Camilo <camilo@camilo.fm>:

Do you have any error messages in the log?

On Apr 6, 2017 7:54 AM, "- -" < ushastik-007@mail.ru > wrote:

Anyone? Come on.. I've broken all the head. It does not work even with clean Ubuntu installation. Nothing else: just ubuntu 14 server x86 from the cd and OpenFire. And a little bit of preferences:

root@abc:~# cat /etc/jitsi/videobridge/sip-communicator.properties
org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
org.jitsi.videobridge.TCP_HARVESTER_PORT=4443
org.ice4j.ipv6.DISABLED=true

root@abc:~# cat /etc/jitsi/videobridge/config
# Jitsi Videobridge settings
# sets the XMPP domain (default: none)
JVB_HOSTNAME=abc.temp
# sets the hostname of the XMPP server (default: domain if set, localhost otherwise)
JVB_HOST=
# sets the port of the XMPP server (default: 5275)
JVB_PORT=5275
# sets the shared secret used to authenticate to the XMPP server
JVB_SECRET=secret
# extra options to pass to the JVB daemon
JVB_OPTS=""
# adds java system props that are passed to jvb (default are for home and logging config file)
JAVA_SYS_PROPS="$JVB_EXTRA_JVM_PARAMS -Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=videobridge -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi -Djava.util.logging.config.file=/etc/jitsi/videobridge/logging.properties"

root@abc:~# cat /etc/hosts
127.0.0.1 localhost
127.0.0.1 abc.temp

# The following lines are desirable for IPv6 capable hosts
::1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

С уважением,
- -
ushastik-007@mail.ru

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

С уважением,
- -
ushastik-007@mail.ru