[jitsi-users] users Digest, Vol 31, Issue 6


#1

Still no luck. I changed my server and now I have no NAT. I have a basic
firewall and I have 5269, 5280 , 443, 80, 5280, 5222, 4443 opened up on the
firewall.

I still cannot get users to join. My new test site is
https://eu.circledisk.com

below is my netstat

root@myputputf1:~# netstat -tunlp

Active Internet connections (only servers)

Proto Recv-Q Send-Q Local Address Foreign Address State
    PID/Program name

tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN
    6169/nginx

tcp 0 0 0.0.0.0:5269 0.0.0.0:* LISTEN
    5952/lua5.1

tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN
    1836/sshd

tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN
    6169/nginx

tcp 0 0 0.0.0.0:5280 0.0.0.0:* LISTEN
    5952/lua5.1

tcp 0 0 127.0.0.1:5347 0.0.0.0:* LISTEN
    5952/lua5.1

tcp 0 0 0.0.0.0:5222 0.0.0.0:* LISTEN
    5952/lua5.1

tcp6 0 0 :::22 :::* LISTEN
    1836/sshd

tcp6 0 0 92.222.68.140:4443 :::* LISTEN
    5994/java

udp 0 0 0.0.0.0:4818 0.0.0.0:*
    1486/dhclient

udp 0 0 0.0.0.0:68 0.0.0.0:*
    1486/dhclient

udp6 0 0 92.222.68.140:10000 :::*
    5994/java

udp6 0 0 :::16261 :::*
    5994/java

udp6 0 0 :::21517 :::*
    6028/java

udp6 0 0 :::43087 :::*
    1486/dhclient

Help save paper! Do you really need to print this email?

···

------------------------------

On Sat, Oct 3, 2015 at 6:00 AM, <users-request@jitsi.org> wrote:

Send users mailing list submissions to
        users@jitsi.org

To subscribe or unsubscribe via the World Wide Web, visit
        http://lists.jitsi.org/mailman/listinfo/users
or, via email, send a message with subject or body 'help' to
        users-request@jitsi.org

You can reach the person managing the list at
        users-owner@jitsi.org

When replying, please edit your Subject line so it is more specific
than "Re: Contents of users digest..."

Today's Topics:

   1. New test site not working (using quick install) (Humphrey Davy)
   2. Re: New test site not working (using quick install) (Boris Grozev)

----------------------------------------------------------------------

Message: 1
Date: Fri, 2 Oct 2015 21:50:39 -0400
From: Humphrey Davy <hdavy2002@gmail.com>
To: users@jitsi.org
Subject: [jitsi-users] New test site not working (using quick install)
Message-ID:
        <
CAG_9CVE+p31hACTe0MQEH4in0x2okctrDrEWsO+GUR0wHNmRZA@mail.gmail.com>
Content-Type: text/plain; charset="utf-8"

Hello folks,

On a Google Virtual machine, I have a brand new install of Debian and I
used 'Quick Install' method. I have the correct ssl installed and the site
loads up fine, please see https://myputput.com. However, I am unable to
join as a guest. I used my cell phone and laptop to create two users.
Please could you guys also test it from your end. I have no idea where to
start looking for issues.

Many thanks in advance and a big thank you to the developers. This product
looks and feels AWESOME.

Cheers

Humphrey

Help save paper! Do you really need to print this email?
------------------------------
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <
http://lists.jitsi.org/pipermail/users/attachments/20151002/a1792c55/attachment-0001.html
>

------------------------------

Message: 2
Date: Fri, 2 Oct 2015 23:01:17 -0500
From: Boris Grozev <boris@jitsi.org>
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] New test site not working (using quick
        install)
Message-ID: <560F530D.4070608@jitsi.org>
Content-Type: text/plain; charset=utf-8; format=flowed

On 02/10/15 20:50, Humphrey Davy wrote:
> Hello folks,
>
> On a Google Virtual machine, I have a brand new install of Debian and I
> used 'Quick Install' method. I have the correct ssl installed and the
> site loads up fine, please see https://myputput.com. However, I am
> unable to join as a guest. I used my cell phone and laptop to create two
> users. Please could you guys also test it from your end. I have no idea
> where to start looking for issues.

It appears that your videobridge instance is running behind a NAT and is
not advertizing any publicly accessible addresses.
If you are doing port-forwarding, videobridge needs to be additionally
configured (see [1]).

Regards,
Boris

[1]

https://github.com/jitsi/jitsi-videobridge/blob/master/doc/tcp.md#orgjitsivideobridgenat_harvester_local_address

------------------------------

Subject: Digest Footer

_______________________________________________
users mailing list
users@jitsi.org
http://lists.jitsi.org/mailman/listinfo/users

------------------------------

End of users Digest, Vol 31, Issue 6
************************************


#2

Changed to another server same issue. check https://eu.circledisk.com

Something is not right here. This one has no NAT, simple firewall rules.
See attached photo.

The first browser, I use gives me https as green, the next browser I use
for testing gives me certificate failed.

Please if someone could try on two device. I am also attaching all my logs

Help save paper! Do you really need to print this email?

jicofo.log (55.4 KB)

jvb.log (160 KB)

prosody.err (135 Bytes)

prosody.log (2.67 KB)

···

------------------------------

On Sat, Oct 3, 2015 at 12:25 PM, Humphrey Davy <hdavy2002@gmail.com> wrote:

Still no luck. I changed my server and now I have no NAT. I have a basic
firewall and I have 5269, 5280 , 443, 80, 5280, 5222, 4443 opened up on the
firewall.

I still cannot get users to join. My new test site is
https://eu.circledisk.com

below is my netstat

root@myputputf1:~# netstat -tunlp

Active Internet connections (only servers)

Proto Recv-Q Send-Q Local Address Foreign Address State
      PID/Program name

tcp 0 0 0.0.0.0:80 0.0.0.0:*
LISTEN 6169/nginx

tcp 0 0 0.0.0.0:5269 0.0.0.0:*
LISTEN 5952/lua5.1

tcp 0 0 0.0.0.0:22 0.0.0.0:*
LISTEN 1836/sshd

tcp 0 0 0.0.0.0:443 0.0.0.0:*
LISTEN 6169/nginx

tcp 0 0 0.0.0.0:5280 0.0.0.0:*
LISTEN 5952/lua5.1

tcp 0 0 127.0.0.1:5347 0.0.0.0:*
LISTEN 5952/lua5.1

tcp 0 0 0.0.0.0:5222 0.0.0.0:*
LISTEN 5952/lua5.1

tcp6 0 0 :::22 :::*
LISTEN 1836/sshd

tcp6 0 0 92.222.68.140:4443 :::*
LISTEN 5994/java

udp 0 0 0.0.0.0:4818 0.0.0.0:*
      1486/dhclient

udp 0 0 0.0.0.0:68 0.0.0.0:*
      1486/dhclient

udp6 0 0 92.222.68.140:10000 :::*
      5994/java

udp6 0 0 :::16261 :::*
      5994/java

udp6 0 0 :::21517 :::*
      6028/java

udp6 0 0 :::43087 :::*
      1486/dhclient

Help save paper! Do you really need to print this email?
------------------------------

On Sat, Oct 3, 2015 at 6:00 AM, <users-request@jitsi.org> wrote:

Send users mailing list submissions to
        users@jitsi.org

To subscribe or unsubscribe via the World Wide Web, visit
        http://lists.jitsi.org/mailman/listinfo/users
or, via email, send a message with subject or body 'help' to
        users-request@jitsi.org

You can reach the person managing the list at
        users-owner@jitsi.org

When replying, please edit your Subject line so it is more specific
than "Re: Contents of users digest..."

Today's Topics:

   1. New test site not working (using quick install) (Humphrey Davy)
   2. Re: New test site not working (using quick install) (Boris Grozev)

----------------------------------------------------------------------

Message: 1
Date: Fri, 2 Oct 2015 21:50:39 -0400
From: Humphrey Davy <hdavy2002@gmail.com>
To: users@jitsi.org
Subject: [jitsi-users] New test site not working (using quick install)
Message-ID:
        <
CAG_9CVE+p31hACTe0MQEH4in0x2okctrDrEWsO+GUR0wHNmRZA@mail.gmail.com>
Content-Type: text/plain; charset="utf-8"

Hello folks,

On a Google Virtual machine, I have a brand new install of Debian and I
used 'Quick Install' method. I have the correct ssl installed and the site
loads up fine, please see https://myputput.com. However, I am unable to
join as a guest. I used my cell phone and laptop to create two users.
Please could you guys also test it from your end. I have no idea where to
start looking for issues.

Many thanks in advance and a big thank you to the developers. This product
looks and feels AWESOME.

Cheers

Humphrey

Help save paper! Do you really need to print this email?
------------------------------
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <
http://lists.jitsi.org/pipermail/users/attachments/20151002/a1792c55/attachment-0001.html
>

------------------------------

Message: 2
Date: Fri, 2 Oct 2015 23:01:17 -0500
From: Boris Grozev <boris@jitsi.org>
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] New test site not working (using quick
        install)
Message-ID: <560F530D.4070608@jitsi.org>
Content-Type: text/plain; charset=utf-8; format=flowed

On 02/10/15 20:50, Humphrey Davy wrote:
> Hello folks,
>
> On a Google Virtual machine, I have a brand new install of Debian and I
> used 'Quick Install' method. I have the correct ssl installed and the
> site loads up fine, please see https://myputput.com. However, I am
> unable to join as a guest. I used my cell phone and laptop to create two
> users. Please could you guys also test it from your end. I have no idea
> where to start looking for issues.

It appears that your videobridge instance is running behind a NAT and is
not advertizing any publicly accessible addresses.
If you are doing port-forwarding, videobridge needs to be additionally
configured (see [1]).

Regards,
Boris

[1]

https://github.com/jitsi/jitsi-videobridge/blob/master/doc/tcp.md#orgjitsivideobridgenat_harvester_local_address

------------------------------

Subject: Digest Footer

_______________________________________________
users mailing list
users@jitsi.org
http://lists.jitsi.org/mailman/listinfo/users

------------------------------

End of users Digest, Vol 31, Issue 6
************************************


#3

Hi,

from the screenshot I see you have rules to allow ssh, http, https.
You need to also allow udp traffic on 10000-20000 and tcp 4443.
And also you need to update your java, as 1.6 is too old, it may work
with it, but running with 1.7 or 1.8 is preferred.
Also your system has some old glibc or at least current sctp requires
new one, and you may be missing dominant speaker detection because of
that. There was recently a mail thread about this problem and a
solution for it.
Hope this helps.

Regards
damencho

···

On Sat, Oct 3, 2015 at 7:13 PM, Humphrey Davy <hdavy2002@gmail.com> wrote:

Changed to another server same issue. check https://eu.circledisk.com

Something is not right here. This one has no NAT, simple firewall rules. See
attached photo.

The first browser, I use gives me https as green, the next browser I use for
testing gives me certificate failed.

Please if someone could try on two device. I am also attaching all my logs

Help save paper! Do you really need to print this email?
________________________________

On Sat, Oct 3, 2015 at 12:25 PM, Humphrey Davy <hdavy2002@gmail.com> wrote:

Still no luck. I changed my server and now I have no NAT. I have a basic
firewall and I have 5269, 5280 , 443, 80, 5280, 5222, 4443 opened up on the
firewall.

I still cannot get users to join. My new test site is
https://eu.circledisk.com

below is my netstat

root@myputputf1:~# netstat -tunlp

Active Internet connections (only servers)

Proto Recv-Q Send-Q Local Address Foreign Address State
PID/Program name

tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN
6169/nginx

tcp 0 0 0.0.0.0:5269 0.0.0.0:* LISTEN
5952/lua5.1

tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN
1836/sshd

tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN
6169/nginx

tcp 0 0 0.0.0.0:5280 0.0.0.0:* LISTEN
5952/lua5.1

tcp 0 0 127.0.0.1:5347 0.0.0.0:* LISTEN
5952/lua5.1

tcp 0 0 0.0.0.0:5222 0.0.0.0:* LISTEN
5952/lua5.1

tcp6 0 0 :::22 :::* LISTEN
1836/sshd

tcp6 0 0 92.222.68.140:4443 :::* LISTEN
5994/java

udp 0 0 0.0.0.0:4818 0.0.0.0:*
1486/dhclient

udp 0 0 0.0.0.0:68 0.0.0.0:*
1486/dhclient

udp6 0 0 92.222.68.140:10000 :::*
5994/java

udp6 0 0 :::16261 :::*
5994/java

udp6 0 0 :::21517 :::*
6028/java

udp6 0 0 :::43087 :::*
1486/dhclient

Help save paper! Do you really need to print this email?
________________________________

On Sat, Oct 3, 2015 at 6:00 AM, <users-request@jitsi.org> wrote:

Send users mailing list submissions to
        users@jitsi.org

To subscribe or unsubscribe via the World Wide Web, visit
        http://lists.jitsi.org/mailman/listinfo/users
or, via email, send a message with subject or body 'help' to
        users-request@jitsi.org

You can reach the person managing the list at
        users-owner@jitsi.org

When replying, please edit your Subject line so it is more specific
than "Re: Contents of users digest..."

Today's Topics:

   1. New test site not working (using quick install) (Humphrey Davy)
   2. Re: New test site not working (using quick install) (Boris Grozev)

----------------------------------------------------------------------

Message: 1
Date: Fri, 2 Oct 2015 21:50:39 -0400
From: Humphrey Davy <hdavy2002@gmail.com>
To: users@jitsi.org
Subject: [jitsi-users] New test site not working (using quick install)
Message-ID:

<CAG_9CVE+p31hACTe0MQEH4in0x2okctrDrEWsO+GUR0wHNmRZA@mail.gmail.com>
Content-Type: text/plain; charset="utf-8"

Hello folks,

On a Google Virtual machine, I have a brand new install of Debian and I
used 'Quick Install' method. I have the correct ssl installed and the
site
loads up fine, please see https://myputput.com. However, I am unable to
join as a guest. I used my cell phone and laptop to create two users.
Please could you guys also test it from your end. I have no idea where to
start looking for issues.

Many thanks in advance and a big thank you to the developers. This
product
looks and feels AWESOME.

Cheers

Humphrey

Help save paper! Do you really need to print this email?
------------------------------
-------------- next part --------------
An HTML attachment was scrubbed...
URL:
<http://lists.jitsi.org/pipermail/users/attachments/20151002/a1792c55/attachment-0001.html>

------------------------------

Message: 2
Date: Fri, 2 Oct 2015 23:01:17 -0500
From: Boris Grozev <boris@jitsi.org>
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] New test site not working (using quick
        install)
Message-ID: <560F530D.4070608@jitsi.org>
Content-Type: text/plain; charset=utf-8; format=flowed

On 02/10/15 20:50, Humphrey Davy wrote:
> Hello folks,
>
> On a Google Virtual machine, I have a brand new install of Debian and I
> used 'Quick Install' method. I have the correct ssl installed and the
> site loads up fine, please see https://myputput.com. However, I am
> unable to join as a guest. I used my cell phone and laptop to create
> two
> users. Please could you guys also test it from your end. I have no idea
> where to start looking for issues.

It appears that your videobridge instance is running behind a NAT and is
not advertizing any publicly accessible addresses.
If you are doing port-forwarding, videobridge needs to be additionally
configured (see [1]).

Regards,
Boris

[1]

https://github.com/jitsi/jitsi-videobridge/blob/master/doc/tcp.md#orgjitsivideobridgenat_harvester_local_address

------------------------------

Subject: Digest Footer

_______________________________________________
users mailing list
users@jitsi.org
http://lists.jitsi.org/mailman/listinfo/users

------------------------------

End of users Digest, Vol 31, Issue 6
************************************

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users