[jitsi-users] users Digest, Vol 24, Issue 38


#1

I recreated focus user and used a new password. Now jicofo is starting without any error. But on browser side I still get “focus error”

Focus jid set to: focus@auth.studyboard.blazonlabs.com
app.bundle.js?v=41:15359 Session ID: null machine UID: 60f44836830d5e58f8425ad4dc69b62c
strophe.min.js?v=1:1 XHR finished loading: POST "https://studyboard.blazonlabs.com/http-bind".
app.bundle.js?v=41:15546 Focus error, retry after 1000
<iq xmlns="jabber:client" id="2:sendIQ" xml:lang="en" type="error" to="monu@studyboard.blazonlabs.com/11526226491426918693355895" from="focus.studyboard.blazonlabs.com"><conference xmlns="http://jitsi.org/protocol/focus" machine-uid="60f44836830d5e58f8425ad4dc69b62c" room="rapidbadgerscrawlnowhere@conference.studyboard.blazonlabs.com"><property value="jitsi-videobridge.studyboard.blazonlabs.com" name="bridge"/><property value="-1" name="channelLastN"/><property value="false" name="adaptiveLastN"/><property value="false" name="adaptiveSimulcast"/><property value="true" name="openSctp"/><property value="true" name="enableFirefoxHacks"/></conference><error type="cancel" code="503"><service-unavailable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></iq>

> Send users mailing list submissions to
> users@jitsi.org
>
> To subscribe or unsubscribe via the World Wide Web, visit
> http://lists.jitsi.org/mailman/listinfo/users
> or, via email, send a message with subject or body 'help' to
> users-request@jitsi.org
>
> You can reach the person managing the list at
> users-owner@jitsi.org
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of users digest..."
>
>
> Today's Topics:
>
> 1. Re: jicofo not starting up, focus error in jig-meet
> (John Lightfoot)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Thu, 19 Mar 2015 21:33:06 +0000
> From: John Lightfoot <john@vizhn.com>
> To: Jitsi Users <users@jitsi.org>
> Subject: Re: [jitsi-users] jicofo not starting up, focus error in
> jig-meet
> Message-ID:
> <DM2PR06MB912D90D966338E70798F2A4D5010@DM2PR06MB912.namprd06.prod.outlook.com>
>
> Content-Type: text/plain; charset="utf-8"
>
> It looks like the focus user password that jicofo is configured to connect with isn't consistent with the actual password set for that user. Get the value for JICOFO_AUTH_PASSWORD from /etc/Jitsi/jicofo/config then run this command:
>
> Sudo prosodyctl passwd focus@auth.jitsi.domain.com (obviously replace with your real domain)
>
> Enter the value for JICOFO_AUTH_PASSWORD. Restart jicofo and see if the log is clear of the connect errors.
>
>
> From: users [mailto:users-bounces@jitsi.org] On Behalf Of Sunil Nagi
> Sent: Thursday, March 19, 2015 1:29 PM
> To: users@jitsi.org; dev@jitsi.org
> Subject: [jitsi-users] jicofo not starting up, focus error in jig-meet
>
> I have installed latest jit-meet as per official documentation, which gave me focus related error on jitsi-meet. On debugging I figured jicofo is not starting up with some sasl error.
>
> 16:13:17.755 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() java.vendor=Oracle Corporation
> 16:13:17.755 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() file.separator=/
> 16:13:17.756 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() java.vendor.url.bug=http://bugreport.sun.com/bugreport/
> 16:13:17.756 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() sun.io.unicode.encoding=UnicodeLittle
> 16:13:17.756 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() sun.cpu.endian=little
> 16:13:17.757 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
> 16:13:17.757 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() sun.cpu.isalist=
> 16:13:17.758 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() Normal classloader
> 16:13:17.759 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() failed to find jitsi-defaults.properties with class loader, will continue without it.
> 16:13:17.760 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() Normal classloader
> 16:13:17.761 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() failed to find jitsi-default-overrides.properties with class loader, will continue without it.
> 16:13:17.894 INFO: [9] impl.netaddr.NetworkAddressManagerServiceImpl.start().81 Network Address Manager ...[ STARTED ]
> 16:13:17.894 INFO: [9] impl.netaddr.NetworkAddressManagerServiceImpl.start().87 Network Address Manager Service ...[REGISTERED]
> 16:13:17.924 INFO: [9] impl.netaddr.NetworkConfigurationWatcher.checkNetworkInterfaces().387 Currently Active eth0:[/128.199.185.133]
> 16:13:17.927 FINE: [9] plugin.reconnectplugin.ReconnectPluginActivator.start().238 Found 0 already installed providers.
> 16:13:18.274 SEVERE: [19] org.jitsi.jicofo.util.RegisterThread.run().42 net.java.sip.communicator.service.protocol.OperationFailedException: Failed to connect
> net.java.sip.communicator.service.protocol.OperationFailedException: Failed to connect
> at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:161)
> at org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:38)
> Caused by: service-unavailable(-1)
> at org.jivesoftware.smack.NonSASLAuthentication.authenticate(NonSASLAuthentication.java:77)
> at org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:217)
> at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:156)
> ... 1 more
>
> I have verified all configuration everything is ok. I have a production app which is broken since migrating to new version. Really hope to get some help here.
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users
>
> ------------------------------
>
> Subject: Digest Footer
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> http://lists.jitsi.org/mailman/listinfo/users
>
>
> ------------------------------
>
> End of users Digest, Vol 24, Issue 38
> *************************************

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

···

Can anyone help here?On Mar 21, 2015 2:24 AM, Sunil Nagi <sunilnagi@gmail.com> wrote:

> -----Original Message-----