[jitsi-users] Ukrainian keyboard layout freezes Jitsi


#1

Our staff in Ukraine installed Jitsi and they hit a stumbling block right away.
When they used Windows XP and 7 keyboard switcher, Jitsi froze and had to be killed via task manager.
I tested that here on Linux but did not have any issues.
Then I re-tested under Windows 7 and did could not reproduce it either.

Finally I found the difference: they were using older laptops with 32 bit OS, while all machines in our office were 64bit.

Those folks are now OK as we removed Jitsi from their machines and installed Gajim, so they can send the IMs, but the idea was to test a pilot project for voice calls using our London VOIP provider, whereas Gajim does not have voice under Windows.

Would anyone have a chance to look into the freezing due to layout switch?

I tried to collect the logs, but the latest entry was earlier than an attempt to switch the layouts, which indicates to me Jitsi was not able to flush the logs once it froze and was killed. So they logs will be of no use. We used 2.5.5065 for these pilots.


#2

Hello,

See here:
http://lists.jitsi.org/pipermail/users/2014-February/006586.html

Regards,
Boris


#3

That is sounding like they are having a different issue.
We are not observing any crashes yet and not even trying to type the
Russian characters.
It simply freezes once a keyboard layout is switched from EN-US to
Ukrainian, prior to typing anything.
Switching layout does not need to involve any keystrokes - it can be
performed via mouse click of the language bar icon and that would be it
- Jitsi freezes, UI hangs, can't access any menus, no response to the
buttons etc.

···

On Mon, 24 Feb 2014 15:36:37 +0100, Boris Grozev <boris@jitsi.org> wrote:

Hello,

See here:
http://lists.jitsi.org/pipermail/users/2014-February/006586.html

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Boris,

Setting non-unicode locale to Ukrainian does not solve the freeze.
Besides that, all non-unicode programs display their interfaces in
Ukrainian and that is not an acceptable solution even if it worked.

I played with the different languages and no matter what secondary
keyboard layout was, as long as there was one, Jitsi froze when
switched.

The cause of freeze is switching keyboard layout to no matter what
language.

···

On Mon, 24 Feb 2014 09:44:57 -0500, <dubrovic@mail.md> wrote:

That is sounding like they are having a different issue.
We are not observing any crashes yet and not even trying to type the
Russian characters.
It simply freezes once a keyboard layout is switched from EN-US to
Ukrainian, prior to typing anything.
Switching layout does not need to involve any keystrokes - it can be
performed via mouse click of the language bar icon and that would be it
- Jitsi freezes, UI hangs, can't access any menus, no response to the
buttons etc.

On Mon, 24 Feb 2014 15:36:37 +0100, Boris Grozev <boris@jitsi.org> > wrote:

Hello,

See here:
http://lists.jitsi.org/pipermail/users/2014-February/006586.html

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users