[jitsi-users] Trouble with jibri recording/streaming


#1

Hi All,

I have a jitsi installation working perfectly well https://vc.streaminglive.in <https://vc.streaminglive.in/>.
Needed to add recording to it, so installed jibri using the official guide (https://github.com/jitsi/jibri) on a separate AWS instance.
All went well with the installation, made the changes to my Jitsi installation also..
Got the streaming button on the conference rooms. But says “live streaming unavailable”..
Checking my prosody access log - info Authenticated as jibri@auth.vc.streaminglive <mailto:jibri@auth.vc.streaminglive>.in

Here is my config.json file content

{
    "jidserver_prefix":"auth.",
    "mucserver_prefix":"conference.",
    "boshdomain_prefix":"recorder.",
    "password":"jibripass",
    "jid_username":"jibri",
    "roomname":"TheBrewery",
    "xmpp_domain":"vc.streaminglive.in",
    "selenium_xmpp_prefix":"recorder.",
    "selenium_xmpp_username":"recorder",
    "selenium_xmpp_password":"jibripass",
    "servers":["13.126.127.204"],
    "environments":{
    }
}

I am able to use DISPLAY=:0 ./jibriselenium.py -u https://vc.streaminglive.in/jp to connect to the room jp and I see a second user with a youtube icon also in the room.
I am also able to use ./start-ffmpeg.sh filename.flv to record, but the video only has a connecting slide on it and no video from the conference.

Cant figure out what is wrong, would really appreciate any help

Regards,

Jaj


#2

Hi,

Are you sure that all services work correctly?

check out:
Sudo service jibri-xorg status
Sudo service jibri-icewm status
Sudo service jibri-xmpp status

Check the logs of each service, and check if everything is in order.
It appears that the XMPP service is not successfully connecting to prosody

Regards

···

2017-07-17 3:36 GMT-05:00 Jaj Padmakaran <jaj@synclinefilms.com>:

Hi All,

I have a jitsi installation working perfectly well
https://vc.streaminglive.in.
Needed to add recording to it, so installed jibri using the official guide
(https://github.com/jitsi/jibri) on a separate AWS instance.
All went well with the installation, made the changes to my Jitsi
installation also..
Got the streaming button on the conference rooms. But says “live streaming
unavailable”..
Checking my prosody access log - info Authenticated as
jibri@auth.vc.streaminglive.in

Here is my config.json file content

{
    "jidserver_prefix":"auth.",
    "mucserver_prefix":"conference.",
    "boshdomain_prefix":"recorder.",
    "password":"jibripass",
    "jid_username":"jibri",
    "roomname":"TheBrewery",
    "xmpp_domain":"vc.streaminglive.in",
    "selenium_xmpp_prefix":"recorder.",
    "selenium_xmpp_username":"recorder",
    "selenium_xmpp_password":"jibripass",
    "servers":["13.126.127.204"],
    "environments":{
    }
}

I am able to use DISPLAY=:0 ./jibriselenium.py -u
https://vc.streaminglive.in/jp to connect to the room jp and I see a
second user with a youtube icon also in the room.
I am also able to use ./start-ffmpeg.sh filename.flv to record, but the
video only has a connecting slide on it and no video from the conference.

Cant figure out what is wrong, would really appreciate any help

Regards,

Jaj

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users