[jitsi-users] The video quality isn't good with Chrome M62 and H.264


#1

Hi,

This mail is just for sharing information of jitsi-meet with H.264
codec on Chrome M62 which I found during testing Jitsi-meet. The
result is that much block noises happen on every clients; The quality
is so bad that I can't find who the client is.

- How to reproduce
  - Set up Jitsi-meet to use H.264 codec and not to use P2P but only SFU.
  - Deploy it on somewhere on the cloud. This time I used Ubuntu 14.04 LTS.
  - establish 3 connections, where each connection is from different
MBP to Jitsi-VideoBridge.
- Client environment
  - Mac OS 10.12.6
  - Chrome: Version 62.0.3202.62 (Official Build) (64-bit)

M62 isn't good although M61 seems to have good video quality.

···

--
Yoshimasa IWASE


#2

If you changed nothing other than the Chrome version it might be a problem with Chrome itself. This issue might be related: https://bugs.chromium.org/p/webrtc/issues/detail?id=8022

I suggest you try https://appr.tc (make sure you enable H264 with the URL params) and if you see changes between 61 and 62 report a bug on the Chrome / WebRTC bug tracker.

Cheers,

···

On Oct 24, 2017, at 10:30, Yoshimasa IWASE <iwase.yoshimasa@gmail.com> wrote:

Hi,

This mail is just for sharing information of jitsi-meet with H.264
codec on Chrome M62 which I found during testing Jitsi-meet. The
result is that much block noises happen on every clients; The quality
is so bad that I can't find who the client is.

- How to reproduce
- Set up Jitsi-meet to use H.264 codec and not to use P2P but only SFU.
- Deploy it on somewhere on the cloud. This time I used Ubuntu 14.04 LTS.
- establish 3 connections, where each connection is from different
MBP to Jitsi-VideoBridge.
- Client environment
- Mac OS 10.12.6
- Chrome: Version 62.0.3202.62 (Official Build) (64-bit)

M62 isn't good although M61 seems to have good video quality.

--
Saúl


#3

Hi Yoshimasa, thanks very much for reporting your experience here.

There may be a change in Chrome that the SFU needs to take into account but Saul’s answer has a couple of hidden questions :slight_smile:

Did you change anything else other than Chrome? Do you believe this is a “regression” in the SFU? Were you happy with the quality before you upgraded to version X? Or has it always been terrible for you?

Cheers,
George

···

On Oct 24, 2017, at 4:24 AM, Saúl Ibarra Corretgé <scorretge@atlassian.com> wrote:

On Oct 24, 2017, at 10:30, Yoshimasa IWASE <iwase.yoshimasa@gmail.com> wrote:

Hi,

This mail is just for sharing information of jitsi-meet with H.264
codec on Chrome M62 which I found during testing Jitsi-meet. The
result is that much block noises happen on every clients; The quality
is so bad that I can't find who the client is.

- How to reproduce
- Set up Jitsi-meet to use H.264 codec and not to use P2P but only SFU.
- Deploy it on somewhere on the cloud. This time I used Ubuntu 14.04 LTS.
- establish 3 connections, where each connection is from different
MBP to Jitsi-VideoBridge.
- Client environment
- Mac OS 10.12.6
- Chrome: Version 62.0.3202.62 (Official Build) (64-bit)

M62 isn't good although M61 seems to have good video quality.

If you changed nothing other than the Chrome version it might be a problem with Chrome itself. This issue might be related: https://bugs.chromium.org/p/webrtc/issues/detail?id=8022 <https://bugs.chromium.org/p/webrtc/issues/detail?id=8022>

I suggest you try https://appr.tc <https://appr.tc/> (make sure you enable H264 with the URL params) and if you see changes between 61 and 62 report a bug on the Chrome / WebRTC bug tracker.

Cheers,

--
Saúl

_______________________________________________
users mailing list
users@jitsi.org <mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users