[jitsi-users] Strophe.js removed from jitsi-meet ubuntu packages?


#1

Hi list,

I've been having some trouble with non-ASCII usernames not being able to
login in Jitsi-meet. This seemed to be caused by Strophe.js not being able
to handle UTF16 to UTF8 conversion in SASL plain authentication against
prosody.

Now that bug seems to be fixed, but to my surprise I do not find any
strophe.js.min file in the jitsi-meet package.

This is fixed in this commit
https://github.com/strophe/strophejs/commit/243f67752d8da03508bfca34443318e7c174845b

How could I test this? I'm not sure what happened to the strophe.js.min
file that used to be part of the jitsi-meet package?

Any enlightenment helps..

Kindest regards,
Mathias


#2

Hi,

···

On 03/12/15 02:19, Mathias Friman wrote:

Hi list,

I've been having some trouble with non-ASCII usernames not being able to
login in Jitsi-meet. This seemed to be caused by Strophe.js not being
able to handle UTF16 to UTF8 conversion in SASL plain authentication
against prosody.

Now that bug seems to be fixed, but to my surprise I do not find any
strophe.js.min file in the jitsi-meet package.

This is fixed in this commit
https://github.com/strophe/strophejs/commit/243f67752d8da03508bfca34443318e7c174845b

How could I test this? I'm not sure what happened to the strophe.js.min
file that used to be part of the jitsi-meet package?

Strophe is now used via npm. You should be able to get the commit by bumping the version in package.json and running make.

Regards,
Boris


#3

Hi Boris,

Not sure how I should interpret that. I have 1042 package.json files on
that system and seemingly none in the jitsi-meet-package (Ubuntu 14.04
LTS). Can't find any related to strophe either with my poor grep-fu ..

So which package.json-file should I edit? :slight_smile:

Kindest regards,
Mathias

···

2015-12-03 17:02 GMT+01:00 Boris Grozev <boris@jitsi.org>:

Hi,

On 03/12/15 02:19, Mathias Friman wrote:

Hi list,

I've been having some trouble with non-ASCII usernames not being able to
login in Jitsi-meet. This seemed to be caused by Strophe.js not being
able to handle UTF16 to UTF8 conversion in SASL plain authentication
against prosody.

Now that bug seems to be fixed, but to my surprise I do not find any
strophe.js.min file in the jitsi-meet package.

This is fixed in this commit

https://github.com/strophe/strophejs/commit/243f67752d8da03508bfca34443318e7c174845b

How could I test this? I'm not sure what happened to the strophe.js.min
file that used to be part of the jitsi-meet package?

Strophe is now used via npm. You should be able to get the commit by
bumping the version in package.json and running make.

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

You need to rebuild jitsi-meet if you want to change the strophe version (and the package.json you need to change is the one that resides in the jitsi-meet sources).

Regards,
Boris

···

On 07/12/15 04:18, Mathias Friman wrote:

Hi Boris,

Not sure how I should interpret that. I have 1042 package.json files on
that system and seemingly none in the jitsi-meet-package (Ubuntu 14.04
LTS). Can't find any related to strophe either with my poor grep-fu ..

So which package.json-file should I edit? :slight_smile: