[jitsi-users] SIP/SIMPLE and status change


#1

Hi,

In my first basic SIP presence tests with Jitsi (1.1-nightly.build.4037
on Ubuntu 12.04) I experienced that the client doesn't send a PUBLISH
when I change my account status (e.g. to "away"). The
~/.jitsi/log/jitsi0.log.0 doesn't say anything if I do this change, and
the pcap is also showing no SIP message leaving the host.

Any hints where I could start looking for the issue?

Andreas


#2

By the way, the same happens with Jitsi 1.1 nightly on Windows, whereas
it works fine with Bria, so it doesn't seem to be a platform or server
issue.

Andreas

···

On 05/31/2012 03:00 PM, Andreas Granig wrote:

In my first basic SIP presence tests with Jitsi (1.1-nightly.build.4037
on Ubuntu 12.04) I experienced that the client doesn't send a PUBLISH
when I change my account status (e.g. to "away"). The
~/.jitsi/log/jitsi0.log.0 doesn't say anything if I do this change, and
the pcap is also showing no SIP message leaving the host.

Any hints where I could start looking for the issue?


#3

Hey Andreas,

In my first basic SIP presence tests with Jitsi (1.1-nightly.build.4037
on Ubuntu 12.04) I experienced that the client doesn't send a PUBLISH
when I change my account status (e.g. to "away"). The
~/.jitsi/log/jitsi0.log.0 doesn't say anything if I do this change, and
the pcap is also showing no SIP message leaving the host.

Any hints where I could start looking for the issue?

By the way, the same happens with Jitsi 1.1 nightly on Windows, whereas
it works fine with Bria, so it doesn't seem to be a platform or server
issue.

Just checked on several different servers and I can't reproduce your
problem. PUBLISH requests are being sent every time I change my status.

Could you please check your account settings and make sure that:

* your account is not a RegistrarLess one
* the "Enable presence" option in the "Presence" tab is checked
* the "Force peer-to-peer presence mode" option is NOT checked.

Hope this helps,
Emil

···

On 01.06.12 13:49, Andreas Granig wrote:

On 05/31/2012 03:00 PM, Andreas Granig wrote:

--
http://jitsi.org


#4

Hi Emil,

Thanks for having a look at that, see comments below:

Just checked on several different servers and I can't reproduce your
problem. PUBLISH requests are being sent every time I change my status.

Could you please check your account settings and make sure that:

* your account is not a RegistrarLess one
* the "Enable presence" option in the "Presence" tab is checked
* the "Force peer-to-peer presence mode" option is NOT checked.

The account is registered, presence is enabled and peer-to-peer presence
is off.

Here are the screenshots of the settings I have:

http://linguin.org/tmp/jitsi-account.png
http://linguin.org/tmp/jitsi-connection.png
http://linguin.org/tmp/jitsi-presence.png

It doesn't make a difference when I use Local storage instead of XCAP.

Andreas

···

On 06/01/2012 02:21 PM, Emil Ivov wrote:


#5

One more thing, maybe that's important as well:

When I set my global status to Away, then go to
Tools->Options->Accounts, then uncheck and re-check the account, it does
send a PUBLISH, but the status in the content is "open"/"Online",
although the icon next to the Account shows "Away".

Apart from that, there doesn't seem to be another PUBLISH, no matter
what I do. So to sum it up, it sends an initial PUBLISH with status
"Online" when it registers, but not in any other case.

Andreas

···

On 06/01/2012 02:40 PM, Andreas Granig wrote:

Hi Emil,

Thanks for having a look at that, see comments below:

On 06/01/2012 02:21 PM, Emil Ivov wrote:

Just checked on several different servers and I can't reproduce your
problem. PUBLISH requests are being sent every time I change my status.

Could you please check your account settings and make sure that:

* your account is not a RegistrarLess one
* the "Enable presence" option in the "Presence" tab is checked
* the "Force peer-to-peer presence mode" option is NOT checked.

The account is registered, presence is enabled and peer-to-peer presence
is off.

Here are the screenshots of the settings I have:

http://linguin.org/tmp/jitsi-account.png
http://linguin.org/tmp/jitsi-connection.png
http://linguin.org/tmp/jitsi-presence.png

It doesn't make a difference when I use Local storage instead of XCAP.

Andreas


#6

One correction (this is getting messy, but I think I can describe the
behavior now :slight_smile: )

When I set my global status to Away, then go to
Tools->Options->Accounts, then uncheck and re-check the account, it does
send a PUBLISH, but the status in the content is "open"/"Online",
although the icon next to the Account shows "Away".

Looks like the way to trigger a PUBLISH (with correct status, so it's
not always Online as stated above) is really to unregister the user via
the checkbox, then register again. In this case, it publishes its
current status correctly.

The issue with not sending a PUBLISH on changing the status via the GUI
still is there.

Andreas

···

On 06/01/2012 02:48 PM, Andreas Granig wrote:


#7

Alright, after digging a bit into the source, it turns out that when
Jitsi registers and then calls
OperationSetPresenceSipImpl::publishPresenceStatus(),
"this.useDistantPA" is true and a PUBLISH is sent. However, when I
change the status manually via the GUI element, "this.useDistantPA" is
false. Any idea how this could happen?

Dummy question, as I'm not really that much into java/ant: How can I
enable debug logging when I run "ant run"?

Andreas

···

On 06/01/2012 03:41 PM, Andreas Granig wrote:

One correction (this is getting messy, but I think I can describe the
behavior now :slight_smile: )

On 06/01/2012 02:48 PM, Andreas Granig wrote:

When I set my global status to Away, then go to
Tools->Options->Accounts, then uncheck and re-check the account, it does
send a PUBLISH, but the status in the content is "open"/"Online",
although the icon next to the Account shows "Away".

Looks like the way to trigger a PUBLISH (with correct status, so it's
not always Online as stated above) is really to unregister the user via
the checkbox, then register again. In this case, it publishes its
current status correctly.

The issue with not sending a PUBLISH on changing the status via the GUI
still is there.

Andreas


#8

Could we please see some logs?

Emil

···

On 01.06.12 19:07, Andreas Granig wrote:

Alright, after digging a bit into the source, it turns out that when
Jitsi registers and then calls
OperationSetPresenceSipImpl::publishPresenceStatus(),
"this.useDistantPA" is true and a PUBLISH is sent. However, when I
change the status manually via the GUI element, "this.useDistantPA" is
false. Any idea how this could happen?

Dummy question, as I'm not really that much into java/ant: How can I
enable debug logging when I run "ant run"?

Andreas

On 06/01/2012 03:41 PM, Andreas Granig wrote:

One correction (this is getting messy, but I think I can describe the
behavior now :slight_smile: )

On 06/01/2012 02:48 PM, Andreas Granig wrote:

When I set my global status to Away, then go to
Tools->Options->Accounts, then uncheck and re-check the account, it does
send a PUBLISH, but the status in the content is "open"/"Online",
although the icon next to the Account shows "Away".

Looks like the way to trigger a PUBLISH (with correct status, so it's
not always Online as stated above) is really to unregister the user via
the checkbox, then register again. In this case, it publishes its
current status correctly.

The issue with not sending a PUBLISH on changing the status via the GUI
still is there.

Andreas

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#9

Ha, got it. Jitsi enters peer-to-peer presence mode when it gets a 1xx
reply (e.g. 100-Trying) for the PUBLISH! Adding this in the PUBLISH
handling of OperationSetPresenceSipImpl::processResponse() fixes the
issue, and then publishing the status works like charm:

else if (response.getStatusCode() < 200)
{
  // silently ignore provisional responses
}
else
{
  // usual p2p fallback code goes here
}

Could you please apply a fix for that?

Andreas

···

On 06/01/2012 07:07 PM, Andreas Granig wrote:

Alright, after digging a bit into the source, it turns out that when
Jitsi registers and then calls
OperationSetPresenceSipImpl::publishPresenceStatus(),
"this.useDistantPA" is true and a PUBLISH is sent. However, when I
change the status manually via the GUI element, "this.useDistantPA" is
false. Any idea how this could happen?

Dummy question, as I'm not really that much into java/ant: How can I
enable debug logging when I run "ant run"?

Andreas

On 06/01/2012 03:41 PM, Andreas Granig wrote:

One correction (this is getting messy, but I think I can describe the
behavior now :slight_smile: )

On 06/01/2012 02:48 PM, Andreas Granig wrote:

When I set my global status to Away, then go to
Tools->Options->Accounts, then uncheck and re-check the account, it does
send a PUBLISH, but the status in the content is "open"/"Online",
although the icon next to the Account shows "Away".

Looks like the way to trigger a PUBLISH (with correct status, so it's
not always Online as stated above) is really to unregister the user via
the checkbox, then register again. In this case, it publishes its
current status correctly.

The issue with not sending a PUBLISH on changing the status via the GUI
still is there.

Andreas


#10

Hey that's a great catch, Andreas!

We'll push this through on Monday. Thanks a lot for digging into it!

Emil

···

On 01.06.12 20:35, Andreas Granig wrote:

Ha, got it. Jitsi enters peer-to-peer presence mode when it gets a 1xx
reply (e.g. 100-Trying) for the PUBLISH! Adding this in the PUBLISH
handling of OperationSetPresenceSipImpl::processResponse() fixes the
issue, and then publishing the status works like charm:

else if (response.getStatusCode() < 200)
{
  // silently ignore provisional responses
}
else
{
  // usual p2p fallback code goes here
}

Could you please apply a fix for that?

Andreas

On 06/01/2012 07:07 PM, Andreas Granig wrote:

Alright, after digging a bit into the source, it turns out that when
Jitsi registers and then calls
OperationSetPresenceSipImpl::publishPresenceStatus(),
"this.useDistantPA" is true and a PUBLISH is sent. However, when I
change the status manually via the GUI element, "this.useDistantPA" is
false. Any idea how this could happen?

Dummy question, as I'm not really that much into java/ant: How can I
enable debug logging when I run "ant run"?

Andreas

On 06/01/2012 03:41 PM, Andreas Granig wrote:

One correction (this is getting messy, but I think I can describe the
behavior now :slight_smile: )

On 06/01/2012 02:48 PM, Andreas Granig wrote:

When I set my global status to Away, then go to
Tools->Options->Accounts, then uncheck and re-check the account, it does
send a PUBLISH, but the status in the content is "open"/"Online",
although the icon next to the Account shows "Away".

Looks like the way to trigger a PUBLISH (with correct status, so it's
not always Online as stated above) is really to unregister the user via
the checkbox, then register again. In this case, it publishes its
current status correctly.

The issue with not sending a PUBLISH on changing the status via the GUI
still is there.

Andreas

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#11

Hello Andreas,

I am unable to reproduce this kind of behavior: I do not have access to a server which answers to a PUBLISH with a 1xx response.

Consequently:
- Could you tells us which public service you are using, or provide us a temporary account to your server in order to test this behavior (you can send me the account details in a private mail)?
- Could you send us the corresponding log [0]?

Regards,
Vincent

[0] https://jitsi.org/index.php/Documentation/FAQ#logs

···

On 06/01/2012 08:38 PM, Emil Ivov wrote:

Hey that's a great catch, Andreas!

We'll push this through on Monday. Thanks a lot for digging into it!

Emil

On 01.06.12 20:35, Andreas Granig wrote:

Ha, got it. Jitsi enters peer-to-peer presence mode when it gets a 1xx
reply (e.g. 100-Trying) for the PUBLISH! Adding this in the PUBLISH
handling of OperationSetPresenceSipImpl::processResponse() fixes the
issue, and then publishing the status works like charm:

else if (response.getStatusCode()< 200)
{
   // silently ignore provisional responses
}
else
{
   // usual p2p fallback code goes here
}

Could you please apply a fix for that?

Andreas

On 06/01/2012 07:07 PM, Andreas Granig wrote:

Alright, after digging a bit into the source, it turns out that when
Jitsi registers and then calls
OperationSetPresenceSipImpl::publishPresenceStatus(),
"this.useDistantPA" is true and a PUBLISH is sent. However, when I
change the status manually via the GUI element, "this.useDistantPA" is
false. Any idea how this could happen?

Dummy question, as I'm not really that much into java/ant: How can I
enable debug logging when I run "ant run"?

Andreas

On 06/01/2012 03:41 PM, Andreas Granig wrote:

One correction (this is getting messy, but I think I can describe the
behavior now :slight_smile: )

On 06/01/2012 02:48 PM, Andreas Granig wrote:

When I set my global status to Away, then go to
Tools->Options->Accounts, then uncheck and re-check the account, it does
send a PUBLISH, but the status in the content is "open"/"Online",
although the icon next to the Account shows "Away".

Looks like the way to trigger a PUBLISH (with correct status, so it's
not always Online as stated above) is really to unregister the user via
the checkbox, then register again. In this case, it publishes its
current status correctly.

The issue with not sending a PUBLISH on changing the status via the GUI
still is there.

Andreas

--
Vincent Lucas, Ph.D. Jitsi developer
chenzo@jitsi.org http://jitsi.org


#12

Hello Andreas,

I have tried to include your proposition to skip provisional response for presence. Can you try build #4051 and tell us if it resolves this issue?

Once again, thank you for the report.

Regards,
Vincent

···

On 06/04/2012 04:25 PM, Vincent Lucas wrote:

Hello Andreas,

I am unable to reproduce this kind of behavior: I do not have access to
a server which answers to a PUBLISH with a 1xx response.

Consequently:
- Could you tells us which public service you are using, or provide us a
temporary account to your server in order to test this behavior (you can
send me the account details in a private mail)?
- Could you send us the corresponding log [0]?

Regards,
Vincent

[0] https://jitsi.org/index.php/Documentation/FAQ#logs

On 06/01/2012 08:38 PM, Emil Ivov wrote:

Hey that's a great catch, Andreas!

We'll push this through on Monday. Thanks a lot for digging into it!

Emil

On 01.06.12 20:35, Andreas Granig wrote:

Ha, got it. Jitsi enters peer-to-peer presence mode when it gets a 1xx
reply (e.g. 100-Trying) for the PUBLISH! Adding this in the PUBLISH
handling of OperationSetPresenceSipImpl::processResponse() fixes the
issue, and then publishing the status works like charm:

else if (response.getStatusCode()< 200)
{
// silently ignore provisional responses
}
else
{
// usual p2p fallback code goes here
}

Could you please apply a fix for that?

Andreas

On 06/01/2012 07:07 PM, Andreas Granig wrote:

Alright, after digging a bit into the source, it turns out that when
Jitsi registers and then calls
OperationSetPresenceSipImpl::publishPresenceStatus(),
"this.useDistantPA" is true and a PUBLISH is sent. However, when I
change the status manually via the GUI element, "this.useDistantPA" is
false. Any idea how this could happen?

Dummy question, as I'm not really that much into java/ant: How can I
enable debug logging when I run "ant run"?

Andreas

On 06/01/2012 03:41 PM, Andreas Granig wrote:

One correction (this is getting messy, but I think I can describe the
behavior now :slight_smile: )

On 06/01/2012 02:48 PM, Andreas Granig wrote:

When I set my global status to Away, then go to
Tools->Options->Accounts, then uncheck and re-check the account,
it does
send a PUBLISH, but the status in the content is "open"/"Online",
although the icon next to the Account shows "Away".

Looks like the way to trigger a PUBLISH (with correct status, so it's
not always Online as stated above) is really to unregister the user
via
the checkbox, then register again. In this case, it publishes its
current status correctly.

The issue with not sending a PUBLISH on changing the status via the
GUI
still is there.

Andreas

--
Vincent Lucas, Ph.D. Jitsi developer
chenzo@jitsi.org http://jitsi.org


#13

Hi Vincent,

···

On 06/05/2012 11:55 AM, Vincent Lucas wrote:

I have tried to include your proposition to skip provisional response
for presence. Can you try build #4051 and tell us if it resolves this
issue?

Alright, thanks for picking this up.

I'm currently in the process of setting up a test deployment with public
IP for you as well and send you the credentials in a couple of minutes.

I'll also check the 4051 built in parallel.

Andreas


#14

Hi Vincent,

I have tried to include your proposition to skip provisional response
for presence. Can you try build #4051 and tell us if it resolves this
issue?

That version works like charm, thanks!

You can double-check it with the following account:

user: testuser2@ce.dev.sipwise.com
pass: testuser2

The system is still rough around the edges (no auth for
subscribe/publish etc) and is a proof-of-concept as of now, but it'll be
refined and integrated into our open-source soft-switch
http://www.sipwise.com/products/spce/, and once it's done sip/simple
should gain more attraction because of a complete reference
implementation on top of kamailio, and we'd like to promote Jitsi as a
fully integrated client to our users.

Andreas

···

On 06/05/2012 11:55 AM, Vincent Lucas wrote:


#15

Hi Andreas,

Thank you very much for setting the test account: I can confirm the correction too.

Hence, feel free to delete this account (or at least change the password).

Best regards,
Vincent

···

On 06/05/2012 03:05 PM, Andreas Granig wrote:

Hi Vincent,

On 06/05/2012 11:55 AM, Vincent Lucas wrote:

I have tried to include your proposition to skip provisional response
for presence. Can you try build #4051 and tell us if it resolves this
issue?

That version works like charm, thanks!

You can double-check it with the following account:

user: testuser2@ce.dev.sipwise.com
pass: testuser2

The system is still rough around the edges (no auth for
subscribe/publish etc) and is a proof-of-concept as of now, but it'll be
refined and integrated into our open-source soft-switch
http://www.sipwise.com/products/spce/, and once it's done sip/simple
should gain more attraction because of a complete reference
implementation on top of kamailio, and we'd like to promote Jitsi as a
fully integrated client to our users.

Andreas

--
Vincent Lucas, Ph.D. Jitsi developer
chenzo@jitsi.org http://jitsi.org


#16

Hi Andreas,

Your report is acknowledged on the contributor web page.

Thank you once again,
Vincent

···

On 06/05/2012 03:05 PM, Andreas Granig wrote:

Hi Vincent,

On 06/05/2012 11:55 AM, Vincent Lucas wrote:

I have tried to include your proposition to skip provisional response
for presence. Can you try build #4051 and tell us if it resolves this
issue?

That version works like charm, thanks!

You can double-check it with the following account:

user: testuser2@ce.dev.sipwise.com
pass: testuser2

The system is still rough around the edges (no auth for
subscribe/publish etc) and is a proof-of-concept as of now, but it'll be
refined and integrated into our open-source soft-switch
http://www.sipwise.com/products/spce/, and once it's done sip/simple
should gain more attraction because of a complete reference
implementation on top of kamailio, and we'd like to promote Jitsi as a
fully integrated client to our users.

Andreas

--
Vincent Lucas, Ph.D. Jitsi developer
chenzo@jitsi.org http://jitsi.org


#17

Hi,

I'm new to jitsi and its users mail list so I'm not sure how this work. How does the below email help me with the pop error message that I keep getting, picture below:

I have three separate accounts and to all I'm getting the same error and will not connect online. Please advise.

[cid:image003.jpg@01CD43FD.86EA2090]

Thank you,

Anita Hagerty

···

-----Original Message-----

From: Vincent Lucas [mailto:chenzo@jitsi.org]

Sent: Wednesday, June 06, 2012 2:54 PM
To: users@jitsi.java.net
Subject: [jitsi-users] Re: SIP/SIMPLE and status change [solved]

Hi Andreas,

Your report is acknowledged on the contributor web page.

Thank you once again,

Vincent

On 06/05/2012 03:05 PM, Andreas Granig wrote:

Hi Vincent,

On 06/05/2012 11:55 AM, Vincent Lucas wrote:

I have tried to include your proposition to skip provisional response

for presence. Can you try build #4051 and tell us if it resolves this

issue?

That version works like charm, thanks!

You can double-check it with the following account:

user: testuser2@ce.dev.sipwise.com<mailto:testuser2@ce.dev.sipwise.com>

pass: testuser2

The system is still rough around the edges (no auth for

subscribe/publish etc) and is a proof-of-concept as of now, but it'll be

refined and integrated into our open-source soft-switch

http://www.sipwise.com/products/spce/, and once it's done sip/simple

should gain more attraction because of a complete reference

implementation on top of kamailio, and we'd like to promote Jitsi as a

fully integrated client to our users.

Andreas

--

Vincent Lucas, Ph.D. Jitsi developer

chenzo@jitsi.org<mailto:chenzo@jitsi.org> http://jitsi.org

This e-mail message is intended only for individual(s) to whom it is addressed and may contain information that is privileged, confidential, proprietary, or otherwise exempt from disclosure under applicable law. If you believe you have received this message in error, please advise the sender by return e-mail and delete it from your mailbox. Thank you.