[jitsi-users] SIP RTP Port Range


#1

I have two Windows clients. I'm running Jitsi version 2.5.5332. I have two accounts setup on each client. Jabber connection to my Openfire Server, and a SIP connection to my Asterisk server. The Jabber account works fine. The SIP account does not(No Audio) How do I change the RTP port range for my SIP account from within Jitsi? Also what is the default port range for SIP account for Jitsi.

Thanks in advance

BobS

···

#2

Hi,

by default the rtp port range is 5000-6000. But normally you do not
need to know that.

A common problem with asterisk is that Jitsi is behind nat and this is
not setup for that in asterisk. Do you have nat=yes for your sip
account.

Port range can be controlled by configuration properties no UI setting
currently for that. The properties with their default values are:
net.java.sip.communicator.service.media.MAX_PORT_NUMBER=6000
net.java.sip.communicator.service.media.MIN_PORT_NUMBER=5000

Regards
damencho

···

On Mon, Nov 3, 2014 at 1:31 PM, Robert Seaton <bobs@itproscorp.net> wrote:

I have two Windows clients. I'm running Jitsi version 2.5.5332. I have two
accounts setup on each client. Jabber connection to my Openfire Server, and
a SIP connection to my Asterisk server. The Jabber account works fine. The
SIP account does not(No Audio) How do I change the RTP port range for my SIP
account from within Jitsi? Also what is the default port range for SIP
account for Jitsi.

Thanks in advance

BobS

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Yes, The SIP acounts in Asterisk are set to NAT. I'm testing with Jitsi, and 3CX SIP phone loaded on each computer. Once I get this config working I'll remove the 3CX phone, and just use Jitsi for both. The 3CX-to-3CX phone works fine. JitsiSIP-to-JitsiSIP does not. I also know that my RTP port range in Asterisk is set to 10000-20000. The settings you've provided? Do they need to be added to the (sip-communicator.properties) file manually? Sorry, I'm a Newbee.

Thanks for the lightning fast response!

···

-----Original Message-----
From: users-bounces@jitsi.org [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: Monday, November 03, 2014 6:44 AM
To: Jitsi Users
Subject: [PossibleSpam] Re: [jitsi-users] SIP RTP Port Range

Hi,

by default the rtp port range is 5000-6000. But normally you do not need to know that.

A common problem with asterisk is that Jitsi is behind nat and this is not setup for that in asterisk. Do you have nat=yes for your sip account.

Port range can be controlled by configuration properties no UI setting currently for that. The properties with their default values are:
net.java.sip.communicator.service.media.MAX_PORT_NUMBER=6000
net.java.sip.communicator.service.media.MIN_PORT_NUMBER=5000

Regards
damencho

On Mon, Nov 3, 2014 at 1:31 PM, Robert Seaton <bobs@itproscorp.net> wrote:

I have two Windows clients. I'm running Jitsi version 2.5.5332. I have
two accounts setup on each client. Jabber connection to my Openfire
Server, and a SIP connection to my Asterisk server. The Jabber account
works fine. The SIP account does not(No Audio) How do I change the RTP
port range for my SIP account from within Jitsi? Also what is the
default port range for SIP account for Jitsi.

Thanks in advance

BobS

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

I did find out where to edit the configuration to add the settings. Thanks.

···

-----Original Message-----
From: users-bounces@jitsi.org [mailto:users-bounces@jitsi.org] On Behalf Of Robert Seaton
Sent: Monday, November 03, 2014 7:10 AM
To: Jitsi Users
Subject: Re: [jitsi-users] [PossibleSpam] Re: SIP RTP Port Range

Yes, The SIP acounts in Asterisk are set to NAT. I'm testing with Jitsi, and 3CX SIP phone loaded on each computer. Once I get this config working I'll remove the 3CX phone, and just use Jitsi for both. The 3CX-to-3CX phone works fine. JitsiSIP-to-JitsiSIP does not. I also know that my RTP port range in Asterisk is set to 10000-20000. The settings you've provided? Do they need to be added to the (sip-communicator.properties) file manually? Sorry, I'm a Newbee.

Thanks for the lightning fast response!

-----Original Message-----
From: users-bounces@jitsi.org [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: Monday, November 03, 2014 6:44 AM
To: Jitsi Users
Subject: [PossibleSpam] Re: [jitsi-users] SIP RTP Port Range

Hi,

by default the rtp port range is 5000-6000. But normally you do not need to know that.

A common problem with asterisk is that Jitsi is behind nat and this is not setup for that in asterisk. Do you have nat=yes for your sip account.

Port range can be controlled by configuration properties no UI setting currently for that. The properties with their default values are:
net.java.sip.communicator.service.media.MAX_PORT_NUMBER=6000
net.java.sip.communicator.service.media.MIN_PORT_NUMBER=5000

Regards
damencho

On Mon, Nov 3, 2014 at 1:31 PM, Robert Seaton <bobs@itproscorp.net> wrote:

I have two Windows clients. I'm running Jitsi version 2.5.5332. I have
two accounts setup on each client. Jabber connection to my Openfire
Server, and a SIP connection to my Asterisk server. The Jabber account
works fine. The SIP account does not(No Audio) How do I change the RTP
port range for my SIP account from within Jitsi? Also what is the
default port range for SIP account for Jitsi.

Thanks in advance

BobS

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hi,

if you edit the file by hand, you need to stop Jitsi before that. The
local media ports has nothing to do with the ports that asterisk uses,
both are for local use only. The ports used in the call are negotiated
and can be in different ranges without affecting the call.

Regards
damencho

···

On Mon, Nov 3, 2014 at 2:49 PM, Robert Seaton <bobs@itproscorp.net> wrote:

I did find out where to edit the configuration to add the settings. Thanks.

-----Original Message-----
From: users-bounces@jitsi.org [mailto:users-bounces@jitsi.org] On Behalf Of Robert Seaton
Sent: Monday, November 03, 2014 7:10 AM
To: Jitsi Users
Subject: Re: [jitsi-users] [PossibleSpam] Re: SIP RTP Port Range

Yes, The SIP acounts in Asterisk are set to NAT. I'm testing with Jitsi, and 3CX SIP phone loaded on each computer. Once I get this config working I'll remove the 3CX phone, and just use Jitsi for both. The 3CX-to-3CX phone works fine. JitsiSIP-to-JitsiSIP does not. I also know that my RTP port range in Asterisk is set to 10000-20000. The settings you've provided? Do they need to be added to the (sip-communicator.properties) file manually? Sorry, I'm a Newbee.

Thanks for the lightning fast response!

-----Original Message-----
From: users-bounces@jitsi.org [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: Monday, November 03, 2014 6:44 AM
To: Jitsi Users
Subject: [PossibleSpam] Re: [jitsi-users] SIP RTP Port Range

Hi,

by default the rtp port range is 5000-6000. But normally you do not need to know that.

A common problem with asterisk is that Jitsi is behind nat and this is not setup for that in asterisk. Do you have nat=yes for your sip account.

Port range can be controlled by configuration properties no UI setting currently for that. The properties with their default values are:
net.java.sip.communicator.service.media.MAX_PORT_NUMBER=6000
net.java.sip.communicator.service.media.MIN_PORT_NUMBER=5000

Regards
damencho

On Mon, Nov 3, 2014 at 1:31 PM, Robert Seaton <bobs@itproscorp.net> wrote:

I have two Windows clients. I'm running Jitsi version 2.5.5332. I have
two accounts setup on each client. Jabber connection to my Openfire
Server, and a SIP connection to my Asterisk server. The Jabber account
works fine. The SIP account does not(No Audio) How do I change the RTP
port range for my SIP account from within Jitsi? Also what is the
default port range for SIP account for Jitsi.

Thanks in advance

BobS

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users