[jitsi-users] SIP port bug


#1

Hi,

I was trying out the latest stable version when I encountered a problem with get an alternate port configured. Because of some issues, our asterisk is configured to listen on 5070 instead of 5060. When I tell jitsi to use port 5070 it still sends the data to 5060. When I configure the client side of things it does start to send FROM 5070. I tried a nightly version but the bug is there aswell.

···

--
Met vriendelijke groet,
Minze Zwerver


#2

Hi,

are you configuring the proxy manually and setting the port there?
(Unchecking "Configure proxy automatically").
Most probably you are changing the registrar port which is only used to
construct the request URI, which is used by the proxy to correctly route
your request to the registrar, which is not your case when using asterisk.
The destination of the packets are to the proxy which is auto-discovered by
dns entries or manually specified. http://tools.ietf.org/html/rfc3263

Regards
damencho

···

On Tue, Jan 7, 2014 at 3:52 PM, Minze Zwerver <minze@ovost.nl> wrote:

Hi,

I was trying out the latest stable version when I encountered a problem
with get an alternate port configured. Because of some issues, our asterisk
is configured to listen on 5070 instead of 5060. When I tell jitsi to use
port 5070 it still sends the data to 5060. When I configure the client side
of things it does start to send FROM 5070. I tried a nightly version but
the bug is there aswell.

--
Met vriendelijke groet,
Minze Zwerver

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hi Damian,

Thanks for the quick reply ! Your solution worked, I guess this is what happens if you try to do something too quickly and dont read up on the subject first.

Met vriendelijke groet,
Minze Zwerver

···

On 01/07/2014 04:42 PM, Damian Minkov wrote:

Hi,

are you configuring the proxy manually and setting the port there? (Unchecking "Configure proxy automatically").
Most probably you are changing the registrar port which is only used to construct the request URI, which is used by the proxy to correctly route your request to the registrar, which is not your case when using asterisk.
The destination of the packets are to the proxy which is auto-discovered by dns entries or manually specified. http://tools.ietf.org/html/rfc3263

Regards
damencho

On Tue, Jan 7, 2014 at 3:52 PM, Minze Zwerver <minze@ovost.nl > <mailto:minze@ovost.nl>> wrote:

    Hi,

    I was trying out the latest stable version when I encountered a
    problem with get an alternate port configured. Because of some
    issues, our asterisk is configured to listen on 5070 instead of
    5060. When I tell jitsi to use port 5070 it still sends the data
    to 5060. When I configure the client side of things it does start
    to send FROM 5070. I tried a nightly version but the bug is there
    aswell.

    -- Met vriendelijke groet,
    Minze Zwerver

    _______________________________________________
    users mailing list
    users@jitsi.org <mailto:users@jitsi.org>
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users