[jitsi-users] SIP-phonecall disconnects after connection


#1

I might have sent this message last night, but I'm not sure if it got
through so here's a second try.

Here goes:

If I make a SIP-phonecall with Jitsi the phonecall disconnects
immediately after it has been connected and I get the following error
message: "Call failed. Temporarily not available."

However if I make the same SIP-phonecall (same server, username and
recipient) with another softphone (Twinkle on Ubuntu or CSipSimple on my
Android phone) everything works perfectly.

I'm using Ubuntu Linux 11.04.


#2

Have got Jitsi running on U10.10. Installed it after reading it handled the
zrtp prtocol. But I can't seem to find in the security tab the ZRTP option.
Do I have to download it seperately, and if not, how do I configure security
with ZRTP?

1.0-beta1-nightly.build.3464

I started with google but could'nt find any info on configuration options.

Thank you for the project, you are right in time to take over many who do
not like what going on right now!
RB


#3

Hey Tommi,

На 19.05.11 19:58, Tommi Ahonen написа:

I might have sent this message last night, but I'm not sure if it got
through so here's a second try.

Here goes:

If I make a SIP-phonecall with Jitsi the phonecall disconnects
immediately after it has been connected and I get the following error
message: "Call failed. Temporarily not available."

Sounds like the server has a problem with either the message or the
destination. Could you send us the zip log [0]?

If capturing wireshark dumps is something your are comfortable with,
then dumps from a successful session may also come in handy.

Cheers,
Emil

[0] http://jitsi.org/faq/logs

···

However if I make the same SIP-phonecall (same server, username and
recipient) with another softphone (Twinkle on Ubuntu or CSipSimple on my
Android phone) everything works perfectly.

I'm using Ubuntu Linux 11.04.


#4

Hey there,

На 19.05.11 21:38, R B написа:

Have got Jitsi running on U10.10. Installed it after reading it handled
the zrtp prtocol. But I can't seem to find in the security tab the ZRTP
option. Do I have to download it seperately, and if not, how do I
configure security with ZRTP?

ZRTP is enabled by default and as long there's no one in the middle
preventing packet flow it would automatically kick in and you would see
a padlock in the call window.

Hope this helps,
Emil

···

1.0-beta1-nightly.build.3464

I started with google but could'nt find any info on configuration options.

Thank you for the project, you are right in time to take over many who
do not like what going on right now!
RB


#5

Emil,

    ZRTP is enabled by default and as long there's no one in the middle
    preventing packet flow it would automatically kick in and you would

see

    a padlock in the call window.

This means no security tab has to be activated(checked) in order to have
zrtp?
By default nothing is activated in security tab!
So, it is automatic, unless the other end is not compatible(protocol),
right?

If so, cool!
Thanks for your time
Rene

···

On Fri, May 20, 2011 at 3:38 PM, Emil Ivov <emcho@jitsi.org> wrote:

Hey Rene,

На 20.05.11 20:50, R B написа:
> Thank you Emil!
>
> A follow-up question, if I may.
>
> This means nothing has to be checked in security tab in order for ZRTP
> to work?
>
> Unless the padlock is not locked, due to non compatible protocol, if I
> understand.
>
> Not sure If I can send this directly to you, just give me a warning for
> next time.

I certainly don't mind it but other people may also like to follow the
thread (personally, I've already had to answer the same question
offlist) so it would be nice if you could respond to the list and I'll
reply immediately.

Thanks!

Emil
>
> Rene
>
> On Fri, May 20, 2011 at 1:18 PM, Emil Ivov <emcho@jitsi.org > > <mailto:emcho@jitsi.org>> wrote:
>
> Hey there,
>
> На 19.05.11 21:38, R B написа:
>
> > Have got Jitsi running on U10.10. Installed it after reading it
> handled
> > the zrtp prtocol. But I can't seem to find in the security tab the
> ZRTP
> > option. Do I have to download it seperately, and if not, how do I
> > configure security with ZRTP?
>
> ZRTP is enabled by default and as long there's no one in the middle
> preventing packet flow it would automatically kick in and you would
see
> a padlock in the call window.
>
> Hope this helps,
> Emil
> >
> > 1.0-beta1-nightly.build.3464
> >
> > I started with google but could'nt find any info on configuration
> options.
> >
> > Thank you for the project, you are right in time to take over many
who
> > do not like what going on right now!
> > RB
>
>

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#6

На 20.05.11 21:50, R B написа:

Emil,

    ZRTP is enabled by default and as long there's no one in the middle
    preventing packet flow it would automatically kick in and you

would see

    a padlock in the call window.

This means no security tab has to be activated(checked) in order to have
zrtp?
By default nothing is activated in security tab!
So, it is automatic, unless the other end is not compatible(protocol),
right?

Yes, absolutely. ZRTP settings are best left untouched. We'll probably
push them in an "Expert Settings" panel one of these days.

Emil

···

If so, cool!
Thanks for your time
Rene

On Fri, May 20, 2011 at 3:38 PM, Emil Ivov <emcho@jitsi.org > <mailto:emcho@jitsi.org>> wrote:

    Hey Rene,

    На 20.05.11 20:50, R B написа:
    > Thank you Emil!
    >
    > A follow-up question, if I may.
    >
    > This means nothing has to be checked in security tab in order for ZRTP
    > to work?
    >
    > Unless the padlock is not locked, due to non compatible protocol, if I
    > understand.
    >
    > Not sure If I can send this directly to you, just give me a
    warning for
    > next time.

    I certainly don't mind it but other people may also like to follow the
    thread (personally, I've already had to answer the same question
    offlist) so it would be nice if you could respond to the list and I'll
    reply immediately.

    Thanks!

    Emil
    >
    > Rene
    >
    > On Fri, May 20, 2011 at 1:18 PM, Emil Ivov <emcho@jitsi.org > <mailto:emcho@jitsi.org> > > <mailto:emcho@jitsi.org <mailto:emcho@jitsi.org>>> wrote:
    >
    > Hey there,
    >
    > На 19.05.11 21:38, R B написа:
    >
    > > Have got Jitsi running on U10.10. Installed it after reading it
    > handled
    > > the zrtp prtocol. But I can't seem to find in the security
    tab the
    > ZRTP
    > > option. Do I have to download it seperately, and if not, how
    do I
    > > configure security with ZRTP?
    >
    > ZRTP is enabled by default and as long there's no one in the
    middle
    > preventing packet flow it would automatically kick in and you
    would see
    > a padlock in the call window.
    >
    > Hope this helps,
    > Emil
    > >
    > > 1.0-beta1-nightly.build.3464
    > >
    > > I started with google but could'nt find any info on
    configuration
    > options.
    > >
    > > Thank you for the project, you are right in time to take
    over many who
    > > do not like what going on right now!
    > > RB
    >
    >

    --
    Emil Ivov, Ph.D. 67000 Strasbourg,
    Project Lead France
    Jitsi
    emcho@jitsi.org <mailto:emcho@jitsi.org>
     PHONE: +33.1.77.62.43.30 <tel:%2B33.1.77.62.43.30>
    http://jitsi.org FAX: +33.1.77.62.47.31
    <tel:%2B33.1.77.62.47.31>


#7

Hello,

I have another ZRTP related question:

Is there a description somewhere of the security options? What they each mean?

···

--
O zi buna,

Kertesz Laszlo


#8

Hi Emil

I've attached a wireshark capture of the disconnected SIP-phonecall and
I've also attached the Jitsi log-files.

20.05.2011 20:16, Emil Ivov kirjoitti:

2011-05-21@01.47.53-logs.zip (41.3 KB)

SIP_traffic_wireshark (11.4 KB)

···

Hey Tommi,

If I make a SIP-phonecall with Jitsi the phonecall disconnects
immediately after it has been connected and I get the following error
message: "Call failed. Temporarily not available."

Sounds like the server has a problem with either the message or the
destination. Could you send us the zip log [0]?

If capturing wireshark dumps is something your are comfortable with,
then dumps from a successful session may also come in handy.

Cheers,
Emil

[0] http://jitsi.org/faq/logs

However if I make the same SIP-phonecall (same server, username and
recipient) with another softphone (Twinkle on Ubuntu or CSipSimple on my
Android phone) everything works perfectly.

I'm using Ubuntu Linux 11.04.


#9

See the subject


#10

На 20.05.11 21:56, Kertesz Laszlo написа:

Hello,

I have another ZRTP related question:

Is there a description somewhere of the security options? What they each mean?

Werner prepared a ZRTP FAQ list and sent it to me ages ago. I'll try to
process it this weekend.

Emil


#11

I just set up Jitsi on another computer and did a few audio/video/screen sharing tests.

OS: Debian Testing and Debian Stable, both 32-bi, both using ALSA only.
Setup: 2 gmail accounts used, ilbc codec for sound, h264 for camera/shared desktop.

After i set up the zrtp options on the other computer (were all inactive by default) it went very well - using the ilbc codec + screen sharing with h264 (1280x1024 original size) the total bandwidth used was at ~17-30 KB/sec and good sound quality. Voice only was 7-9 KB/sec, mostly 7. Impressive.

There is an initial few seconds period during which the encryption is negotiated and in that timeframe you may not hear the other side, but in my case after the keys (4 characters and padlock) appeared, the sound was ok in both directions so no complaints here.

Likewise, after the screen sharing was activated i had to wait 10-15 seconds until the grey overlay was cleared and i was able to see the other desktop fully. Something similar was with the camera, only a bit faster.
Maybe this should be looked at because this was a bit long time to look ad a garbled greyish screen until it is "wiped" from left to right. But after these it worked well.
I also noticed that this time the shared desktop's aspect ratio seemed to be correct (5/4)?

In conclusion: the screen sharing needs some stability work, especially the remote control tends to be unstable at the moment and some disruption at initializing or cancelling of the sharing, but if stabilized, it will be a killer feature very useful for quick remote support.

All in all i was impressed. Good sound quality, low bandwidth screen sharing/webcam, remote control. All done over google talk. Nice.

···

--
O zi buna,

Kertesz Laszlo


#12

Hey Tommi,

Well, unfortunately, neither of the two reason headers in the response
your server returns helped me grasp what it is it doesn't like in the
INVITE.

One notable difference from the INVITE that Twinkle sends in your
successful session seems to be the absence of a video stream in their
message.

You may therefore want to try and disable video in Jitsi in case that's
what's freaking your server.

The best way to do this is to open the video configuration form and
disable all codecs (by default you should only have h.264 enabled).

Let me know if this helps,

Emil

На 21.05.11 01:01, Tommi Ahonen написа:

···

Hi Emil

I've attached a wireshark capture of the disconnected SIP-phonecall and
I've also attached the Jitsi log-files.

20.05.2011 20:16, Emil Ivov kirjoitti:

Hey Tommi,

If I make a SIP-phonecall with Jitsi the phonecall disconnects
immediately after it has been connected and I get the following error
message: "Call failed. Temporarily not available."

Sounds like the server has a problem with either the message or the
destination. Could you send us the zip log [0]?

If capturing wireshark dumps is something your are comfortable with,
then dumps from a successful session may also come in handy.

Cheers,
Emil

[0] http://jitsi.org/faq/logs

However if I make the same SIP-phonecall (same server, username and
recipient) with another softphone (Twinkle on Ubuntu or CSipSimple on my
Android phone) everything works perfectly.

I'm using Ubuntu Linux 11.04.


#13

jitsi.org -> development -> Mailing Lists

here's a shortcut link:

http://jitsi.org/mailinglists

I've also just removed you from this list.

Emil

На 21.05.11 02:08, Jian Yuan Peng написа:

···

See the subject


#14

When I disbale all the video codecs like you suggested (there was only
one: h.264) and make the same SIP-phonecall with Jitsi another thing
happens: when the receiver answers the call on his phone nothing happens
and the the calling party still hears the ringing of the connection tone
as if the receiveing party had not answered the call at all.

I have attached a new wireshark capture of the call.

22.05.2011 21:23, Emil Ivov kirjoitti:

SIP Wireshark - Call not answering at all (16.4 KB)

···

Hey Tommi,

Well, unfortunately, neither of the two reason headers in the response
your server returns helped me grasp what it is it doesn't like in the
INVITE.

One notable difference from the INVITE that Twinkle sends in your
successful session seems to be the absence of a video stream in their
message.

You may therefore want to try and disable video in Jitsi in case that's
what's freaking your server.

The best way to do this is to open the video configuration form and
disable all codecs (by default you should only have h.264 enabled).

Let me know if this helps,

Emil

На 21.05.11 01:01, Tommi Ahonen написа:

Hi Emil

I've attached a wireshark capture of the disconnected SIP-phonecall and
I've also attached the Jitsi log-files.

20.05.2011 20:16, Emil Ivov kirjoitti:

Hey Tommi,

If I make a SIP-phonecall with Jitsi the phonecall disconnects
immediately after it has been connected and I get the following error
message: "Call failed. Temporarily not available."

Sounds like the server has a problem with either the message or the
destination. Could you send us the zip log [0]?

If capturing wireshark dumps is something your are comfortable with,
then dumps from a successful session may also come in handy.

Cheers,
Emil

[0] http://jitsi.org/faq/logs

However if I make the same SIP-phonecall (same server, username and
recipient) with another softphone (Twinkle on Ubuntu or CSipSimple on my
Android phone) everything works perfectly.

I'm using Ubuntu Linux 11.04.


#15

Why did you remove me from the list? I just joined.

···

Sent from my iPhone

On May 21, 2011, at 5:05 PM, Emil Ivov <emcho@jitsi.org> wrote:

jitsi.org -> development -> Mailing Lists

here's a shortcut link:

http://jitsi.org/mailinglists

I've also just removed you from this list.

Emil

На 21.05.11 02:08, Jian Yuan Peng написа:

See the subject


#16

But I don´t want to be exactly in the same place, all the time!.

(JOKE, JOKE!!, sorry, couldn´t resist).

FC

···

On Sat, May 21, 2011 at 19:41, Emil Ivov <emcho@sip-communicator.org> wrote:

:slight_smile: .... My message was directed to Jian Yuan Peng who requested removal. Everyone else is exactly where they were before :slight_smile:


#17

Hey Tommi,

На 23.05.11 15:23, Tommi Ahonen написа:

When I disbale all the video codecs like you suggested (there was only
one: h.264) and make the same SIP-phonecall with Jitsi another thing
happens: when the receiver answers the call on his phone nothing happens
and the the calling party still hears the ringing of the connection tone
as if the receiveing party had not answered the call at all.

I have attached a new wireshark capture of the call.

It seems like Jitsi is getting no responses after the 180 Ringing. This
would explain why it keeps ringing. There must be a problem on the other
side or at the proxy.

Hope this helps,
Emil

···

22.05.2011 21:23, Emil Ivov kirjoitti:

Hey Tommi,

Well, unfortunately, neither of the two reason headers in the response
your server returns helped me grasp what it is it doesn't like in the
INVITE.

One notable difference from the INVITE that Twinkle sends in your
successful session seems to be the absence of a video stream in their
message.

You may therefore want to try and disable video in Jitsi in case that's
what's freaking your server.

The best way to do this is to open the video configuration form and
disable all codecs (by default you should only have h.264 enabled).

Let me know if this helps,

Emil

На 21.05.11 01:01, Tommi Ahonen написа:

Hi Emil

I've attached a wireshark capture of the disconnected SIP-phonecall and
I've also attached the Jitsi log-files.

20.05.2011 20:16, Emil Ivov kirjoitti:

Hey Tommi,

If I make a SIP-phonecall with Jitsi the phonecall disconnects
immediately after it has been connected and I get the following error
message: "Call failed. Temporarily not available."

Sounds like the server has a problem with either the message or the
destination. Could you send us the zip log [0]?

If capturing wireshark dumps is something your are comfortable with,
then dumps from a successful session may also come in handy.

Cheers,
Emil

[0] http://jitsi.org/faq/logs

However if I make the same SIP-phonecall (same server, username and
recipient) with another softphone (Twinkle on Ubuntu or CSipSimple on my
Android phone) everything works perfectly.

I'm using Ubuntu Linux 11.04.


#18

26.05.2011 16:42, Emil Ivov kirjoitti:

Hey Tommi,

На 23.05.11 15:23, Tommi Ahonen написа:

When I disbale all the video codecs like you suggested (there was only
one: h.264) and make the same SIP-phonecall with Jitsi another thing
happens: when the receiver answers the call on his phone nothing happens
and the the calling party still hears the ringing of the connection tone
as if the receiveing party had not answered the call at all.

I have attached a new wireshark capture of the call.

It seems like Jitsi is getting no responses after the 180 Ringing. This
would explain why it keeps ringing. There must be a problem on the other
side or at the proxy.

Hope this helps,
Emil

OK thanks.

Is there a way to figure out what software the SIP-server is running? In
case I want to file a bug report to the server developers so they can
correct the way in which the SIP-protocol is implemented on the server side.