[jitsi-users] SIP ALLOW MESSAGE - Asterisk


#1

I'm trying to get SIP messaging working using MessageSend on Asterisk 10. My preferred softphone is Jitsi (by far! :)), but I can't seem to get Jitsi to send messages. It will receive them, however, if sent by a different user agent, but it won't allow replies as it says that the protocol does now allow it. Looking at the SIP debug output, there is no "MESSAGE" in the ALLOW line from the server (Asterisk) although there is in the allow line from the user agent (Jitsi), not that I really know what I'm looking for. Some SIP debug output below.

It does work with Ekiga and X-Lite, so I can only assume they are less fussy about the ALLOW.

Does anyone have any ideas, please? Thanks!

SIP/2.0 200 OK
Via: SIP/2.0/UDP 192.168.232.102:5060;branch=z9hG4bK-353936-2e30437837fee7d3e62572728ab750e2;received=192.168.232.102;rport=5060

From: "836" <sip:836@10.168.252.135>;tag=89dff676

Call-ID: e3e0269708c97e5717428308a8d15d31@0:0:0:0:0:0:0:0
CSeq: 26 REGISTER
Server: Asterisk PBX 10.7.0-rc1
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH
Supported: replaces, timer
Expires: 60
Contact: <sip:836@192.168.232.102:5060;transport=udp;registering_acc=10_168_252_135>;expires=60
Content-Length: 0

<--- SIP read from UDP:192.168.232.102:5060 --->
OPTIONS sip:10.168.252.135 SIP/2.0
Call-ID: 6ccb1cd2c02ef1ffb18c3baade45feea@0:0:0:0:0:0:0:0
CSeq: 29 OPTIONS

From: "836" <sip:836@10.168.252.135>;tag=a98e047b

Via: SIP/2.0/UDP 192.168.232.102:5060;branch=z9hG4bK-353936-99c01d6e333abca29a176755367e8a81
Max-Forwards: 70
Contact: "836" <sip:836@192.168.232.102:5060;transport=udp;registering_acc=10_168_252_135>
User-Agent: Jitsi1.0-build.3967Windows 7
Allow: INFO,OPTIONS,MESSAGE,BYE,REFER,SUBSCRIBE,ACK,CANCEL,PUBLISH,NOTIFY,INVITE
Allow-Events: refer
Content-Length: 0

···

To: "836" <sip:836@10.168.252.135>;tag=as6f84296c
Date: Thu, 26 Jul 2012 19:00:06 GMT
To: "836" <sip:836@10.168.252.135>


#2

Hi,

while we were testing this some months ago we discovered the same, and
we added MESSAGE to the Allow header, in order asterisk to report the
support for message. I have put in my todo list to report this issue
but haven't done it till now.
We use the allow header to detect the server capabilities and missing
message there, we assume that this is not supported.
But after adding this to allow, asterisk always adds a contact header
something like asterisk@<ip_or_domain> and actually you cannot send
the message to the participant you want and then I stopped testing :slight_smile:
Hope this clear things.

Regards
damencho

···

On Fri, Jul 27, 2012 at 1:08 PM, Alistair Mackenzie <Alistair.Mackenzie@ntsols.com> wrote:

es as it says that the protocol does now allow it. Looking at the SIP debug
output, there is no "MESSAGE" in the ALLOW line from the server (Asterisk)
although there is in the allow line from the user agent (Jitsi), not that I
really know what I'm looking for. Some SIP debug output below.

It does work with Ekiga and X-Lite, so I can only assume they are less fussy
about the ALLOW.

Does anyone have any ideas, please? Thanks!

.


#3

Thanks for the reply.

Am I correct in understanding that you consider this to be effectively two bugs in Asterisk:

1. Asterisk incorrectly does not include MESSAGE in the ALLOW line
2. Asterisk incorrectly presents the contact header so that replies to a message would not get through anyway ( I agree that is appears a bit scruffy, but I did find that two way message conversations were possible with both Ekiga and X-Lite)

And as such, at this time, it is not possible to use SIP messages with Asterisk & Jitsi?

Thanks again for your assistance!

···

-----Original Message-----

From: damencho@damencho.com [mailto:damencho@damencho.com] On Behalf Of Damian Minkov

Sent: 27 July 2012 11:19
To: users@jitsi.java.net
Subject: [jitsi-users] Re: SIP ALLOW MESSAGE - Asterisk

Hi,

while we were testing this some months ago we discovered the same, and we added MESSAGE to the Allow header, in order asterisk to report the support for message. I have put in my todo list to report this issue but haven't done it till now.
We use the allow header to detect the server capabilities and missing message there, we assume that this is not supported.
But after adding this to allow, asterisk always adds a contact header something like asterisk@<ip_or_domain> and actually you cannot send the message to the participant you want and then I stopped testing :slight_smile: Hope this clear things.

Regards
damencho

On Fri, Jul 27, 2012 at 1:08 PM, Alistair Mackenzie <Alistair.Mackenzie@ntsols.com> wrote:

es as it says that the protocol does now allow it. Looking at the SIP
debug output, there is no "MESSAGE" in the ALLOW line from the server
(Asterisk) although there is in the allow line from the user agent
(Jitsi), not that I really know what I'm looking for. Some SIP debug output below.

It does work with Ekiga and X-Lite, so I can only assume they are less
fussy about the ALLOW.

Does anyone have any ideas, please? Thanks!

______________________________________________________________________
This email has been scanned by the Symantec Email Security.cloud service.
For more information please visit http://www.symanteccloud.com ______________________________________________________________________
.


#4

Hi,

Thanks for the reply.

Am I correct in understanding that you consider this to be effectively two bugs in Asterisk:

1. Asterisk incorrectly does not include MESSAGE in the ALLOW line

I think yes.

2. Asterisk incorrectly presents the contact header so that replies to a message would not get through anyway ( I agree that is appears a bit scruffy, but I did find that two way message conversations were possible with both Ekiga and X-Lite)

And as such, at this time, it is not possible to use SIP messages with Asterisk & Jitsi?

About this, I'm not sure right now, cause I haven't continue testing.
But as I remember the changed contact header caused a problem of the
communication, but what exactly it was, I'm not sure.
If you continue testing, we can discuss the problems you find and how
we can fix it.
For the time when testing we had some problems with asterisk and tls
and we returned to 1.8 version and didn't made more tests with their
messaging, as with sip proxies it is working fine.

Regards
damencho

···

On Fri, Jul 27, 2012 at 1:36 PM, Alistair Mackenzie <Alistair.Mackenzie@ntsols.com> wrote:

Thanks again for your assistance!

-----Original Message-----
From: damencho@damencho.com [mailto:damencho@damencho.com] On Behalf Of Damian Minkov
Sent: 27 July 2012 11:19
To: users@jitsi.java.net
Subject: [jitsi-users] Re: SIP ALLOW MESSAGE - Asterisk

Hi,

while we were testing this some months ago we discovered the same, and we added MESSAGE to the Allow header, in order asterisk to report the support for message. I have put in my todo list to report this issue but haven't done it till now.
We use the allow header to detect the server capabilities and missing message there, we assume that this is not supported.
But after adding this to allow, asterisk always adds a contact header something like asterisk@<ip_or_domain> and actually you cannot send the message to the participant you want and then I stopped testing :slight_smile: Hope this clear things.

Regards
damencho

On Fri, Jul 27, 2012 at 1:08 PM, Alistair Mackenzie <Alistair.Mackenzie@ntsols.com> wrote:

es as it says that the protocol does now allow it. Looking at the SIP
debug output, there is no "MESSAGE" in the ALLOW line from the server
(Asterisk) although there is in the allow line from the user agent
(Jitsi), not that I really know what I'm looking for. Some SIP debug output below.

It does work with Ekiga and X-Lite, so I can only assume they are less
fussy about the ALLOW.

Does anyone have any ideas, please? Thanks!

______________________________________________________________________
This email has been scanned by the Symantec Email Security.cloud service.
For more information please visit http://www.symanteccloud.com ______________________________________________________________________


#5

I know it's more of an Asterisk question, but please would you point me in the direction of how to " adding MESSAGE to the Allow header"? I'm keen to get this working as far you did if possible. Thanks!

···

-----Original Message-----

From: damencho@damencho.com [mailto:damencho@damencho.com] On Behalf Of Damian Minkov

Sent: 27 July 2012 11:52
To: users@jitsi.java.net
Subject: [jitsi-users] Re: SIP ALLOW MESSAGE - Asterisk

Hi,

On Fri, Jul 27, 2012 at 1:36 PM, Alistair Mackenzie <Alistair.Mackenzie@ntsols.com> wrote:

Thanks for the reply.

Am I correct in understanding that you consider this to be effectively two bugs in Asterisk:

1. Asterisk incorrectly does not include MESSAGE in the ALLOW line

I think yes.

2. Asterisk incorrectly presents the contact header so that replies to
a message would not get through anyway ( I agree that is appears a bit
scruffy, but I did find that two way message conversations were
possible with both Ekiga and X-Lite)

And as such, at this time, it is not possible to use SIP messages with Asterisk & Jitsi?

About this, I'm not sure right now, cause I haven't continue testing.
But as I remember the changed contact header caused a problem of the communication, but what exactly it was, I'm not sure.
If you continue testing, we can discuss the problems you find and how we can fix it.
For the time when testing we had some problems with asterisk and tls and we returned to 1.8 version and didn't made more tests with their messaging, as with sip proxies it is working fine.

Regards
damencho

Thanks again for your assistance!

-----Original Message-----
From: damencho@damencho.com [mailto:damencho@damencho.com] On Behalf
Of Damian Minkov
Sent: 27 July 2012 11:19
To: users@jitsi.java.net
Subject: [jitsi-users] Re: SIP ALLOW MESSAGE - Asterisk

Hi,

while we were testing this some months ago we discovered the same, and we added MESSAGE to the Allow header, in order asterisk to report the support for message. I have put in my todo list to report this issue but haven't done it till now.
We use the allow header to detect the server capabilities and missing message there, we assume that this is not supported.
But after adding this to allow, asterisk always adds a contact header something like asterisk@<ip_or_domain> and actually you cannot send the message to the participant you want and then I stopped testing :slight_smile: Hope this clear things.

Regards
damencho

On Fri, Jul 27, 2012 at 1:08 PM, Alistair Mackenzie <Alistair.Mackenzie@ntsols.com> wrote:

es as it says that the protocol does now allow it. Looking at the SIP
debug output, there is no "MESSAGE" in the ALLOW line from the server
(Asterisk) although there is in the allow line from the user agent
(Jitsi), not that I really know what I'm looking for. Some SIP debug output below.

It does work with Ekiga and X-Lite, so I can only assume they are
less fussy about the ALLOW.

Does anyone have any ideas, please? Thanks!

______________________________________________________________________
This email has been scanned by the Symantec Email Security.cloud service.
For more information please visit http://www.symanteccloud.com
______________________________________________________________________

______________________________________________________________________
This email has been scanned by the Symantec Email Security.cloud service.
For more information please visit http://www.symanteccloud.com ______________________________________________________________________


#6

Hi,

what I've did is just changed a line in:
channels/sip/include/sip.h

#define ALLOWED_METHODS "INVITE, ACK, CANCEL, OPTIONS, BYE, REFER,
SUBSCRIBE, NOTIFY, INFO, PUBLISH"

To become:

#define ALLOWED_METHODS "INVITE, ACK, CANCEL, OPTIONS, BYE, REFER,
SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE"

Regards
damencho

···

On Mon, Aug 6, 2012 at 8:53 PM, Alistair Mackenzie <Alistair.Mackenzie@ntsols.com> wrote:

I know it's more of an Asterisk question, but please would you point me in the direction of how to " adding MESSAGE to the Allow header"? I'm keen to get this working as far you did if possible. Thanks!

-----Original Message-----
From: damencho@damencho.com [mailto:damencho@damencho.com] On Behalf Of Damian Minkov
Sent: 27 July 2012 11:52
To: users@jitsi.java.net
Subject: [jitsi-users] Re: SIP ALLOW MESSAGE - Asterisk

Hi,

On Fri, Jul 27, 2012 at 1:36 PM, Alistair Mackenzie <Alistair.Mackenzie@ntsols.com> wrote:

Thanks for the reply.

Am I correct in understanding that you consider this to be effectively two bugs in Asterisk:

1. Asterisk incorrectly does not include MESSAGE in the ALLOW line

I think yes.

2. Asterisk incorrectly presents the contact header so that replies to
a message would not get through anyway ( I agree that is appears a bit
scruffy, but I did find that two way message conversations were
possible with both Ekiga and X-Lite)

And as such, at this time, it is not possible to use SIP messages with Asterisk & Jitsi?

About this, I'm not sure right now, cause I haven't continue testing.
But as I remember the changed contact header caused a problem of the communication, but what exactly it was, I'm not sure.
If you continue testing, we can discuss the problems you find and how we can fix it.
For the time when testing we had some problems with asterisk and tls and we returned to 1.8 version and didn't made more tests with their messaging, as with sip proxies it is working fine.

Regards
damencho

Thanks again for your assistance!

-----Original Message-----
From: damencho@damencho.com [mailto:damencho@damencho.com] On Behalf
Of Damian Minkov
Sent: 27 July 2012 11:19
To: users@jitsi.java.net
Subject: [jitsi-users] Re: SIP ALLOW MESSAGE - Asterisk

Hi,

while we were testing this some months ago we discovered the same, and we added MESSAGE to the Allow header, in order asterisk to report the support for message. I have put in my todo list to report this issue but haven't done it till now.
We use the allow header to detect the server capabilities and missing message there, we assume that this is not supported.
But after adding this to allow, asterisk always adds a contact header something like asterisk@<ip_or_domain> and actually you cannot send the message to the participant you want and then I stopped testing :slight_smile: Hope this clear things.

Regards
damencho

On Fri, Jul 27, 2012 at 1:08 PM, Alistair Mackenzie <Alistair.Mackenzie@ntsols.com> wrote:

es as it says that the protocol does now allow it. Looking at the SIP
debug output, there is no "MESSAGE" in the ALLOW line from the server
(Asterisk) although there is in the allow line from the user agent
(Jitsi), not that I really know what I'm looking for. Some SIP debug output below.

It does work with Ekiga and X-Lite, so I can only assume they are
less fussy about the ALLOW.

Does anyone have any ideas, please? Thanks!

______________________________________________________________________
This email has been scanned by the Symantec Email Security.cloud service.
For more information please visit http://www.symanteccloud.com
______________________________________________________________________

______________________________________________________________________
This email has been scanned by the Symantec Email Security.cloud service.
For more information please visit http://www.symanteccloud.com ______________________________________________________________________