[jitsi-users] show name from google-contacs in income calls

Hello,
I use jiti with one SIP-account. As address book use google.

That work very well, but if a call are coming, jitsi only display the
number and not the name from address book.
It is possible to implement it?

Regards,
Isaac Puch

Hi,

did you test the nightly build as this was recently added there?

Cheers
damencho

···

On Mon, May 12, 2014 at 6:45 PM, Isaac <pr@feder-software.de> wrote:

Hello,
I use jiti with one SIP-account. As address book use google.

That work very well, but if a call are coming, jitsi only display the number
and not the name from address book.
It is possible to implement it?

Regards,
Isaac Puch

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

Hi Damencho,
thanks for the quickly answer. On Windows always install the latest
night version, but on my computer I use the distribution packages
(Ubuntu). Now I install the latest night version and as you say, the
function are implemented there.

But I find a little bug. In Germany and other European countries have a
historic problem with the numbers:

So the number 030-1234567 sould lost the 0 if you call from a foreign
land or with the international code.
I use to use this norm to save my contacs:
+49-30-1234567 Uniform Resource Identifier
<http://de.wikipedia.org/wiki/Uniform_Resource_Identifier> nach RFC 3966
<http://tools.ietf.org/html/rfc3966>; wie E.123
<http://de.wikipedia.org/wiki/E.123>, jedoch mit Bindestrich statt
Leerzeichen

This has the advantage, that you can call from any land and with the -
the browser plugins recognise it as a number, so you can call it with SIP.

Unfortunately jitsi get from the SIP provider the number in the form
030-1234567 (with the 0 at the beginning) and don't find it in google
with the form +49-30-1234567

I don't want to give up this notation. It will be possible that the
function translate the number:
If the number begin with a 0, try to find in google contacs with
*number-without-0 or maybe:
Number=030-1234567
Number-without-0=30-1234567
+???$Number-without-0 or +??$Number-without-0 # the international code
are 2-3 lang.

Another approach would be ton make a private table with the translation
of the numbers
column google number -- column jitsi form
+49-30-1234567 -- 030-1234567
...

I think the first one would be better.

Regards,
Isaac

···

Am 12.05.2014 17:57, schrieb Damian Minkov:

Hi,

did you test the nightly build as this was recently added there?

Cheers
damencho

On Mon, May 12, 2014 at 6:45 PM, Isaac <pr@feder-software.de> wrote:

Hello,
I use jiti with one SIP-account. As address book use google.

That work very well, but if a call are coming, jitsi only display the number
and not the name from address book.
It is possible to implement it?

Regards,
Isaac Puch

Hi,

for the phone number matching, we are already using the google
libphonenumber lib which handles all this stuff. And locally when testing
with it I receive a match for the following:
phoneUtil.isNumberMatch("030-1234567", "+49-30-1234567"))
Maybe the problem is somewhere else and needs more debugging. Can you
report what is your country and locale setting. You can get this from the
logs:
user.country=US
user.language=en

Regards
damencho

···

On Mon, May 12, 2014 at 9:43 PM, Isaac <pr@feder-software.de> wrote:

Hi Damencho,
thanks for the quickly answer. On Windows always install the latest night
version, but on my computer I use the distribution packages (Ubuntu). Now I
install the latest night version and as you say, the function are
implemented there.

But I find a little bug. In Germany and other European countries have a
historic problem with the numbers:

So the number 030-1234567 sould lost the 0 if you call from a foreign land
or with the international code.
I use to use this norm to save my contacs:
  +49-30-1234567 Uniform Resource Identifier<http://de.wikipedia.org/wiki/Uniform_Resource_Identifier>
nach RFC 3966 <http://tools.ietf.org/html/rfc3966>; wie E.123<http://de.wikipedia.org/wiki/E.123>,
jedoch mit Bindestrich statt Leerzeichen This has the advantage, that
you can call from any land and with the - the browser plugins recognise it
as a number, so you can call it with SIP.

Unfortunately jitsi get from the SIP provider the number in the form
030-1234567 (with the 0 at the beginning) and don't find it in google with
the form +49-30-1234567

I don't want to give up this notation. It will be possible that the
function translate the number:
If the number begin with a 0, try to find in google contacs with
*number-without-0 or maybe:
Number=030-1234567
Number-without-0=30-1234567
+???$Number-without-0 or +??$Number-without-0 # the international code
are 2-3 lang.

Another approach would be ton make a private table with the translation of
the numbers
column google number -- column jitsi form
+49-30-1234567 -- 030-1234567
...

I think the first one would be better.

Regards,
Isaac

Am 12.05.2014 17:57, schrieb Damian Minkov:

Hi,

did you test the nightly build as this was recently added there?

Cheers
damencho

On Mon, May 12, 2014 at 6:45 PM, Isaac <pr@feder-software.de> <pr@feder-software.de> wrote:

Hello,
I use jiti with one SIP-account. As address book use google.

That work very well, but if a call are coming, jitsi only display the number
and not the name from address book.
It is possible to implement it?

Regards,
Isaac Puch

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

Hi Damencho,
user.country=DE
user.language=de

I call the number +49 421 40889670 from my mobile phone (Android). In my
google address-book I have the number "+49-421-40889670" on my
contact. But jitsi only show the number.

Regards,
Isaac Puch

···

Am 14.05.2014 13:03, schrieb Damian Minkov:

Hi,

for the phone number matching, we are already using the google
libphonenumber lib which handles all this stuff. And locally when
testing with it I receive a match for the following:
phoneUtil.isNumberMatch("030-1234567", "+49-30-1234567"))
Maybe the problem is somewhere else and needs more debugging. Can you
report what is your country and locale setting. You can get this from
the logs:
user.country=US
user.language=en

Regards
damencho

On Mon, May 12, 2014 at 9:43 PM, Isaac <pr@feder-software.de > <mailto:pr@feder-software.de>> wrote:

    Hi Damencho,
    thanks for the quickly answer. On Windows always install the
    latest night version, but on my computer I use the distribution
    packages (Ubuntu). Now I install the latest night version and as
    you say, the function are implemented there.

    But I find a little bug. In Germany and other European countries
    have a historic problem with the numbers:

    So the number 030-1234567 sould lost the 0 if you call from a
    foreign land or with the international code.
    I use to use this norm to save my contacs:
    +49-30-1234567 <tel:%2B49-30-1234567> Uniform Resource Identifier
    <http://de.wikipedia.org/wiki/Uniform_Resource_Identifier> nach RFC 3966
    <http://tools.ietf.org/html/rfc3966>; wie E.123
    <http://de.wikipedia.org/wiki/E.123>, jedoch mit Bindestrich statt
    Leerzeichen

    This has the advantage, that you can call from any land and with
    the - the browser plugins recognise it as a number, so you can
    call it with SIP.

    Unfortunately jitsi get from the SIP provider the number in the
    form 030-1234567 (with the 0 at the beginning) and don't find it
    in google with the form +49-30-1234567 <tel:%2B49-30-1234567>

    I don't want to give up this notation. It will be possible that
    the function translate the number:
    If the number begin with a 0, try to find in google contacs with
    *number-without-0 or maybe:
    Number=030-1234567
    Number-without-0=30-1234567
    +???$Number-without-0 or +??$Number-without-0 # the
    international code are 2-3 lang.

    Another approach would be ton make a private table with the
    translation of the numbers
    column google number -- column jitsi form
    +49-30-1234567 <tel:%2B49-30-1234567> -- 030-1234567
    ...

    I think the first one would be better.

    Regards,
    Isaac

    Am 12.05.2014 17:57, schrieb Damian Minkov:

    Hi,

    did you test the nightly build as this was recently added there?

    Cheers
    damencho

    On Mon, May 12, 2014 at 6:45 PM, Isaac <pr@feder-software.de> <mailto:pr@feder-software.de> wrote:

    Hello,
    I use jiti with one SIP-account. As address book use google.

    That work very well, but if a call are coming, jitsi only display the number
    and not the name from address book.
    It is possible to implement it?

    Regards,
    Isaac Puch