[jitsi-users] Shibboleth support


#1

I would like to use Shibboleth to control access to my Jitsi Meet installation.
It was possible while Jitsi was running on nginx. Is there any description how
to do that on the recent Jetty based release?

Best Regards
Istvan


#2

Hi,

you can always use the nginx deployment. When installing jitsi-meet it
detects whether nginx is installed and if it is, configures to use it
and skip the jetty configuration. The drawback is that you will lose
port 443 for tcp media as it will be used by nginx, but this can be
fixed by second public ip on the server used by the videobridge only.

Regards
damencho

···

On Wed, Jul 13, 2016 at 12:04 PM, Istvan Bernath <isbe@adm.dtu.dk> wrote:

I would like to use Shibboleth to control access to my Jitsi Meet
installation.
It was possible while Jitsi was running on nginx. Is there any description
how
to do that on the recent Jetty based release?

Best Regards
Istvan

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Dear Damian,

In the last couple of months I've tried many times to reinstall
my Jitsi setup, in a lot of combinations, but I can not any more
get Shibboleth authentication working.
As mentioned, I had a running setup but it is now history...
I always get the error message:

HTTP ERROR: 500

Problem accessing /login/. Reason:

    Attribute 'mail' not provided - check server configuration
Powered by Jetty://

Even though Shbboleth gives the right attribute:

Miscellaneous
Session Expiration (barring inactivity): 473 minute(s)
Client Address: 86.50.55.150
SSO Protocol: urn:oasis:names:tc:SAML:2.0:protocol
Identity Provider: https://wayf.wayf.dk
Authentication Time: 2016-09-21T06:45:52Z
Authentication Context Class: urn:oasis:names:tc:SAML:2.0:ac:classes:Password
Authentication Context Decl: (none)

Attributes
mail: isbe@dtu.dk

I've reinstalled from scratch a Debian Jessie, first nginx and
Shibboleth, and afterward the OLD jitsi software from august 2015
to return back to the working setup, but no luck.

root@meet:~# dpkg -l | grep ji
ii jicofo 1.0-148-1 amd64 JItsi Meet COnference FOcus
ii jitsi-meet 1.0.628-1 all WebRTC JavaScript video conferences
ii jitsi-meet-prosody 1.0.628-1 all Prosody configuration for Jitsi Meet
ii jitsi-videobridge 499-1 amd64 WebRTC compatible Selective Forwarding Unit (SFU)

Can you give me a hint what to do? Without federated login
I can not give Jitsi services to my community.

Best Regards
Istvan

···

________________________________________
Fra: users [users-bounces@jitsi.org] p&#229; vegne af Damian Minkov [damencho@jitsi.org]
Sendt: 15. juli 2016 16:13
Til: Jitsi Users
Emne: Re: [jitsi-users] Shibboleth support

Hi,

you can always use the nginx deployment. When installing jitsi-meet it
detects whether nginx is installed and if it is, configures to use it
and skip the jetty configuration. The drawback is that you will lose
port 443 for tcp media as it will be used by nginx, but this can be
fixed by second public ip on the server used by the videobridge only.

Regards
damencho

On Wed, Jul 13, 2016 at 12:04 PM, Istvan Bernath <isbe@adm.dtu.dk> wrote:

I would like to use Shibboleth to control access to my Jitsi Meet
installation.
It was possible while Jitsi was running on nginx. Is there any description
how
to do that on the recent Jetty based release?

Best Regards
Istvan

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users