[jitsi-users] Setting Opus bitrate


#1

Hi.

I'm new to Jitsi/SIP/WebRTC and trying to make high-quality audio
connections. I'm wanting to force a minimum bitrate for audio - say
100-200kbps. I'm currently only getting 40-50kbps max even between PCs
sitting on the same LAN. Can someone shed light on that?

Thanks,
Jeremy


#2

Hi Jeremy,

getting a high quality audio connection using Jitsi or Linphone seems to be a great challenge by now because they don’t support a STEREO input. I have submitted the task in both mailing lists but obtained no response from a single user or developer by now (I hope that someone hears me now!)

However, if stereo calls are not your priority, you can just open up Jitsi and go to TOOLS-->OPTIONS-->ADVANCED-->OPUS. (see attachment) Set sampling rate to Fullband (48KHz), choose your bitrate and, the higher encoder complexity you choose, the higher audio quality you should get. However something tells me that this particular setting doesn’t work – if I choose, let’s say, 10, and then save the settings and open them again, the number is gone. Every time. (Another Jitsi problem)

Then, if you want to be 100% sure that Jitsi will use only OPUS to encode you calls, go to TOOLS-->OPTIONS-->AUDIO-->ENCODINGS and leave only OPUS selected. This could however cause problems if the other side should use an encoder different from OPUS, so keep your eye on that – I haven’t tested it so far.

Have a nice time.

Michele

···

Da: users [mailto:users-bounces@jitsi.org] Per conto di Jeremy Morris
Inviato: sabato 5 dicembre 2015 22:08
A: users@jitsi.org
Oggetto: [jitsi-users] Setting Opus bitrate

Hi.

I'm new to Jitsi/SIP/WebRTC and trying to make high-quality audio connections. I'm wanting to force a minimum bitrate for audio - say 100-200kbps. I'm currently only getting 40-50kbps max even between PCs sitting on the same LAN. Can someone shed light on that?

Thanks,

Jeremy


#3

Hi,

Assuming that this is regarding the Jitsi client and not Jitsi-Meet: it's a known issue, but unfortunately no one has looked into it so far:
https://github.com/jitsi/libjitsi/issues/41

Regards,
Boris

···

On 05/12/15 15:07, Jeremy Morris wrote:

Hi.

I'm new to Jitsi/SIP/WebRTC and trying to make high-quality audio
connections. I'm wanting to force a minimum bitrate for audio - say
100-200kbps. I'm currently only getting 40-50kbps max even between PCs
sitting on the same LAN. Can someone shed light on that?


#4

I'm not much of a Java programmer unfortunately. Bummer.

Thanks for the guidance.

···

On Sun, Dec 6, 2015 at 6:36 PM, Boris Grozev <boris@jitsi.org> wrote:

On 05/12/15 15:07, Jeremy Morris wrote:

Hi.

I'm new to Jitsi/SIP/WebRTC and trying to make high-quality audio
connections. I'm wanting to force a minimum bitrate for audio - say
100-200kbps. I'm currently only getting 40-50kbps max even between PCs
sitting on the same LAN. Can someone shed light on that?

Hi,

Assuming that this is regarding the Jitsi client and not Jitsi-Meet: it's
a known issue, but unfortunately no one has looked into it so far:
https://github.com/jitsi/libjitsi/issues/41

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users