[jitsi-users] Self-hosted jitsi: no A/V stream and disconnection after 20 seconds


#1

Hi,

My system is running ubuntu 17.10 on an intel NUC. I followed the manual
installation instructions here
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md because
I seem to be having problems with the quick install.

Everything ran and compiled just fine and I can even open "
jitsi.mydomain.com" with my camera turned on. However, there is nothing on
the video part of the screen and the system gives me a disconnect error
every two seconds or so. I was wondering if I could get some help debugging
this issue?

Cheers!


#2

Hi,

You need to provide js console logs from the browser and also jvb and
jicofo logs when they are started.

Regards
damencho

···

On Mar 7, 2018 07:36, "Yang" <lzy7071@gmail.com> wrote:

Hi,

My system is running ubuntu 17.10 on an intel NUC. I followed the manual
installation instructions here https://github.com/jitsi/
jitsi-meet/blob/master/doc/manual-install.md because I seem to be having
problems with the quick install.

Everything ran and compiled just fine and I can even open "
jitsi.mydomain.com" with my camera turned on. However, there is nothing on
the video part of the screen and the system gives me a disconnect error
every two seconds or so. I was wondering if I could get some help debugging
this issue?

Cheers!

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hi,

As requested, the log files

js console logs: https://pastebin.com/DeS0B6e1
jicofo:
https://drive.google.com/file/d/1kfdjJn6XQCSk1ycU8Xk_vmu3SAPizONg/view?usp=sharing
jvb:
https://drive.google.com/file/d/1JmMhj4y3274kIsnA7OlbGrOfY0Acvn0t/view?usp=sharing

Let me know if these help.

Cheers!

···

On Wed, Mar 7, 2018 at 8:43 AM Damian Minkov <damencho@damencho.com> wrote:

Hi,

You need to provide js console logs from the browser and also jvb and
jicofo logs when they are started.

Regards
damencho

On Mar 7, 2018 07:36, "Yang" <lzy7071@gmail.com> wrote:

Hi,

My system is running ubuntu 17.10 on an intel NUC. I followed the manual
installation instructions here
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md because
I seem to be having problems with the quick install.

Everything ran and compiled just fine and I can even open "
jitsi.mydomain.com" with my camera turned on. However, there is nothing
on the video part of the screen and the system gives me a disconnect error
every two seconds or so. I was wondering if I could get some help debugging
this issue?

Cheers!

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Hi,

There are few errors I see in your logs.
1. OPTIONS https://jitsi.example.com/http-bind?room=babycreatureseatfrighteningly
net::ERR_NAME_NOT_RESOLVED
l @ lib-jitsi-meet.min.js:2
Your bosh connection is not working, the url for the bosh that is
configured in config.js is not resolvable.
2. In jicofo logs:
java.net.SocketTimeoutException: connect timed out,
host:jitsi.familian.life, port:5347
Mar 05 12:50:18 ubuntu-Server-NUC bash[17103]:
org.xmpp.component.ComponentException:
java.net.SocketTimeoutException: connect timed out
Jicofo cannot connect to prosody using address jitsi.familian.life.
3. Jvb logs also has errors coming from prosody, it connects to
prosody but receives a response service-unavailable, which I'm not
sure how to interpret, but you need to revisit your jvb and prosody
configurations.

Using manual install can easily lead to all sorts of these problems.
What didn't work for the quick install method? A few days ago I tested
installing everything with the quick install instructions on fresh
17.10 and everything is working fine.

Regards
damencho

···

On Wed, Mar 7, 2018 at 8:23 AM, Yang <lzy7071@gmail.com> wrote:

Hi,

As requested, the log files

js console logs: https://pastebin.com/DeS0B6e1
jicofo:
https://drive.google.com/file/d/1kfdjJn6XQCSk1ycU8Xk_vmu3SAPizONg/view?usp=sharing
jvb:
https://drive.google.com/file/d/1JmMhj4y3274kIsnA7OlbGrOfY0Acvn0t/view?usp=sharing

Let me know if these help.

Cheers!

On Wed, Mar 7, 2018 at 8:43 AM Damian Minkov <damencho@damencho.com> wrote:

Hi,

You need to provide js console logs from the browser and also jvb and
jicofo logs when they are started.

Regards
damencho

On Mar 7, 2018 07:36, "Yang" <lzy7071@gmail.com> wrote:

Hi,

My system is running ubuntu 17.10 on an intel NUC. I followed the manual
installation instructions here
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md
because I seem to be having problems with the quick install.

Everything ran and compiled just fine and I can even open
"jitsi.mydomain.com" with my camera turned on. However, there is nothing on
the video part of the screen and the system gives me a disconnect error
every two seconds or so. I was wondering if I could get some help debugging
this issue?

Cheers!

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hi,

Thank you so much for the help. I think I see the root of the problem for
me now:

In the config.js file for jitsi-meet there a line "bosh: '//
jitsi.example.com/http-bind', // FIXME: use xep-0156 for that". I think I
had the format wrong because when I typed "https://mydomain/http-bind" in
the browser, I was returned with "It works! Now point your BOSH client to
this URL to connect to Prosody. For more information see Prosody: Setting
up BOSH."

So I'm just wondering what the correct format for that line should be?
Maybe "bosh: '//mydomain/http-bind',"? When I tried that, the
"net::ERR_NAME_NOT_RESOLVED"
msg disappears but the disconnection happens right away. The console
message is as such: https://pastebin.com/LAz4t4B0

I suspect "Error: Strophe: Server did not offer a supported authentication
mechanism" is the main issue but I'm not sure how to solve that.

Cheers!

···

On Wed, Mar 7, 2018 at 10:53 AM Damian Minkov <damencho@jitsi.org> wrote:

Hi,

There are few errors I see in your logs.
1. OPTIONS
https://jitsi.example.com/http-bind?room=babycreatureseatfrighteningly
net::ERR_NAME_NOT_RESOLVED
l @ lib-jitsi-meet.min.js:2
Your bosh connection is not working, the url for the bosh that is
configured in config.js is not resolvable.
2. In jicofo logs:
java.net.SocketTimeoutException: connect timed out,
host:jitsi.familian.life, port:5347
Mar 05 12:50:18 ubuntu-Server-NUC bash[17103]:
org.xmpp.component.ComponentException:
java.net.SocketTimeoutException: connect timed out
Jicofo cannot connect to prosody using address jitsi.familian.life.
3. Jvb logs also has errors coming from prosody, it connects to
prosody but receives a response service-unavailable, which I'm not
sure how to interpret, but you need to revisit your jvb and prosody
configurations.

Using manual install can easily lead to all sorts of these problems.
What didn't work for the quick install method? A few days ago I tested
installing everything with the quick install instructions on fresh
17.10 and everything is working fine.

Regards
damencho

On Wed, Mar 7, 2018 at 8:23 AM, Yang <lzy7071@gmail.com> wrote:
> Hi,
>
> As requested, the log files
>
> js console logs: https://pastebin.com/DeS0B6e1
> jicofo:
>
https://drive.google.com/file/d/1kfdjJn6XQCSk1ycU8Xk_vmu3SAPizONg/view?usp=sharing
> jvb:
>
https://drive.google.com/file/d/1JmMhj4y3274kIsnA7OlbGrOfY0Acvn0t/view?usp=sharing
>
> Let me know if these help.
>
> Cheers!
>
>
>
> On Wed, Mar 7, 2018 at 8:43 AM Damian Minkov <damencho@damencho.com> > wrote:
>>
>> Hi,
>>
>> You need to provide js console logs from the browser and also jvb and
>> jicofo logs when they are started.
>>
>> Regards
>> damencho
>>
>>
>> On Mar 7, 2018 07:36, "Yang" <lzy7071@gmail.com> wrote:
>>
>> Hi,
>>
>> My system is running ubuntu 17.10 on an intel NUC. I followed the manual
>> installation instructions here
>> https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md
>> because I seem to be having problems with the quick install.
>>
>> Everything ran and compiled just fine and I can even open
>> "jitsi.mydomain.com" with my camera turned on. However, there is
nothing on
>> the video part of the screen and the system gives me a disconnect error
>> every two seconds or so. I was wondering if I could get some help
debugging
>> this issue?
>>
>> Cheers!
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>>
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

Check your prosody config, the error is that prosody doesn't return the
correct stuff for your requests. You need to fix jicofo and jvb, which also
can end up prosody config errors.

···

On Mar 7, 2018 13:31, "Yang" <lzy7071@gmail.com> wrote:

Hi,

Thank you so much for the help. I think I see the root of the problem for
me now:

In the config.js file for jitsi-meet there a line "bosh: '//
jitsi.example.com/http-bind', // FIXME: use xep-0156 for that". I think I
had the format wrong because when I typed "https://mydomain/http-bind" in
the browser, I was returned with "It works! Now point your BOSH client to
this URL to connect to Prosody. For more information see Prosody: Setting
up BOSH."

So I'm just wondering what the correct format for that line should be?
Maybe "bosh: '//mydomain/http-bind',"? When I tried that, the "net::ERR_NAME_NOT_RESOLVED"
msg disappears but the disconnection happens right away. The console
message is as such: https://pastebin.com/LAz4t4B0

I suspect "Error: Strophe: Server did not offer a supported
authentication mechanism" is the main issue but I'm not sure how to solve
that.

Cheers!

On Wed, Mar 7, 2018 at 10:53 AM Damian Minkov <damencho@jitsi.org> wrote:

Hi,

There are few errors I see in your logs.
1. OPTIONS https://jitsi.example.com/http-bind?room=
babycreatureseatfrighteningly
net::ERR_NAME_NOT_RESOLVED
l @ lib-jitsi-meet.min.js:2
Your bosh connection is not working, the url for the bosh that is
configured in config.js is not resolvable.
2. In jicofo logs:
java.net.SocketTimeoutException: connect timed out,
host:jitsi.familian.life, port:5347
Mar 05 12:50:18 ubuntu-Server-NUC bash[17103]:
org.xmpp.component.ComponentException:
java.net.SocketTimeoutException: connect timed out
Jicofo cannot connect to prosody using address jitsi.familian.life.
3. Jvb logs also has errors coming from prosody, it connects to
prosody but receives a response service-unavailable, which I'm not
sure how to interpret, but you need to revisit your jvb and prosody
configurations.

Using manual install can easily lead to all sorts of these problems.
What didn't work for the quick install method? A few days ago I tested
installing everything with the quick install instructions on fresh
17.10 and everything is working fine.

Regards
damencho

On Wed, Mar 7, 2018 at 8:23 AM, Yang <lzy7071@gmail.com> wrote:
> Hi,
>
> As requested, the log files
>
> js console logs: https://pastebin.com/DeS0B6e1
> jicofo:
> https://drive.google.com/file/d/1kfdjJn6XQCSk1ycU8Xk_
vmu3SAPizONg/view?usp=sharing
> jvb:
> https://drive.google.com/file/d/1JmMhj4y3274kIsnA7OlbGrOfY0Acv
n0t/view?usp=sharing
>
> Let me know if these help.
>
> Cheers!
>
>
>
> On Wed, Mar 7, 2018 at 8:43 AM Damian Minkov <damencho@damencho.com> >> wrote:
>>
>> Hi,
>>
>> You need to provide js console logs from the browser and also jvb and
>> jicofo logs when they are started.
>>
>> Regards
>> damencho
>>
>>
>> On Mar 7, 2018 07:36, "Yang" <lzy7071@gmail.com> wrote:
>>
>> Hi,
>>
>> My system is running ubuntu 17.10 on an intel NUC. I followed the
manual
>> installation instructions here
>> https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md
>> because I seem to be having problems with the quick install.
>>
>> Everything ran and compiled just fine and I can even open
>> "jitsi.mydomain.com" with my camera turned on. However, there is
nothing on
>> the video part of the screen and the system gives me a disconnect error
>> every two seconds or so. I was wondering if I could get some help
debugging
>> this issue?
>>
>> Cheers!
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>>
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

Hi,

Thank you for the help. I'm attaching my various configuration files and
the corresponding logs here

Prosody -
config: https://pastebin.com/sCep8qFR
started with command "sudo /etc/init.d/prosody start"
most recent log: https://pastebin.com/PuVpyxcT

jicofo -
started with a simple systemd file: https://pastebin.com/6crvDSL0
most recent log: https://pastebin.com/eaUztBLU

jvb -
sip-communicator.properties: https://pastebin.com/UecRyyvH
started with a simple systemd file: https://pastebin.com/DcN4XkSn
most recent log: https://pastebin.com/b47PBpmP

Again, thank you for the help!

Cheer!

···

On Wed, Mar 7, 2018 at 2:44 PM Damian Minkov <damencho@damencho.com> wrote:

Check your prosody config, the error is that prosody doesn't return the
correct stuff for your requests. You need to fix jicofo and jvb, which also
can end up prosody config errors.

On Mar 7, 2018 13:31, "Yang" <lzy7071@gmail.com> wrote:

Hi,

Thank you so much for the help. I think I see the root of the problem for
me now:

In the config.js file for jitsi-meet there a line "bosh: '//
jitsi.example.com/http-bind', // FIXME: use xep-0156 for that". I think
I had the format wrong because when I typed "https://mydomain/http-bind"
in the browser, I was returned with "It works! Now point your BOSH client
to this URL to connect to Prosody. For more information see Prosody:
Setting up BOSH."

So I'm just wondering what the correct format for that line should be?
Maybe "bosh: '//mydomain/http-bind',"? When I tried that, the "net::ERR_NAME_NOT_RESOLVED"
msg disappears but the disconnection happens right away. The console
message is as such: https://pastebin.com/LAz4t4B0

I suspect "Error: Strophe: Server did not offer a supported
authentication mechanism" is the main issue but I'm not sure how to
solve that.

Cheers!

On Wed, Mar 7, 2018 at 10:53 AM Damian Minkov <damencho@jitsi.org> wrote:

Hi,

There are few errors I see in your logs.
1. OPTIONS
https://jitsi.example.com/http-bind?room=babycreatureseatfrighteningly
net::ERR_NAME_NOT_RESOLVED
l @ lib-jitsi-meet.min.js:2
Your bosh connection is not working, the url for the bosh that is
configured in config.js is not resolvable.
2. In jicofo logs:
java.net.SocketTimeoutException: connect timed out,
host:jitsi.familian.life, port:5347
Mar 05 12:50:18 ubuntu-Server-NUC bash[17103]:
org.xmpp.component.ComponentException:
java.net.SocketTimeoutException: connect timed out
Jicofo cannot connect to prosody using address jitsi.familian.life.
3. Jvb logs also has errors coming from prosody, it connects to
prosody but receives a response service-unavailable, which I'm not
sure how to interpret, but you need to revisit your jvb and prosody
configurations.

Using manual install can easily lead to all sorts of these problems.
What didn't work for the quick install method? A few days ago I tested
installing everything with the quick install instructions on fresh
17.10 and everything is working fine.

Regards
damencho

On Wed, Mar 7, 2018 at 8:23 AM, Yang <lzy7071@gmail.com> wrote:
> Hi,
>
> As requested, the log files
>
> js console logs: https://pastebin.com/DeS0B6e1
> jicofo:
>
https://drive.google.com/file/d/1kfdjJn6XQCSk1ycU8Xk_vmu3SAPizONg/view?usp=sharing
> jvb:
>
https://drive.google.com/file/d/1JmMhj4y3274kIsnA7OlbGrOfY0Acvn0t/view?usp=sharing
>
> Let me know if these help.
>
> Cheers!
>
>
>
> On Wed, Mar 7, 2018 at 8:43 AM Damian Minkov <damencho@damencho.com> >>> wrote:
>>
>> Hi,
>>
>> You need to provide js console logs from the browser and also jvb and
>> jicofo logs when they are started.
>>
>> Regards
>> damencho
>>
>>
>> On Mar 7, 2018 07:36, "Yang" <lzy7071@gmail.com> wrote:
>>
>> Hi,
>>
>> My system is running ubuntu 17.10 on an intel NUC. I followed the
manual
>> installation instructions here
>> https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md
>> because I seem to be having problems with the quick install.
>>
>> Everything ran and compiled just fine and I can even open
>> "jitsi.mydomain.com" with my camera turned on. However, there is
nothing on
>> the video part of the screen and the system gives me a disconnect
error
>> every two seconds or so. I was wondering if I could get some help
debugging
>> this issue?
>>
>> Cheers!
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>>
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Hi again,

I just see a lot of errors and I cannot see anything wrong in the config.

Is this the main prosody config (/etc/prosody/prosody.cfg.lua) or you
include this. By default, the Debian packages create the config in
conf.d folder and which is included in the main config (Include
"conf.d/*.cfg.lua"). Make sure if you are including it you have the
include clause in the main prosody config.

What java version are you using?

Please, clean jicofo and jvb logs and restart them and then attach them.

Regards
damencho

···

On Wed, Mar 7, 2018 at 7:17 PM, Yang <lzy7071@gmail.com> wrote:

Hi,

Thank you for the help. I'm attaching my various configuration files and the
corresponding logs here

Prosody -
config: https://pastebin.com/sCep8qFR
started with command "sudo /etc/init.d/prosody start"
most recent log: https://pastebin.com/PuVpyxcT

jicofo -
started with a simple systemd file: https://pastebin.com/6crvDSL0
most recent log: https://pastebin.com/eaUztBLU

jvb -
sip-communicator.properties: https://pastebin.com/UecRyyvH
started with a simple systemd file: https://pastebin.com/DcN4XkSn
most recent log: https://pastebin.com/b47PBpmP

Again, thank you for the help!

Cheer!

On Wed, Mar 7, 2018 at 2:44 PM Damian Minkov <damencho@damencho.com> wrote:

Check your prosody config, the error is that prosody doesn't return the
correct stuff for your requests. You need to fix jicofo and jvb, which also
can end up prosody config errors.

On Mar 7, 2018 13:31, "Yang" <lzy7071@gmail.com> wrote:

Hi,

Thank you so much for the help. I think I see the root of the problem for
me now:

In the config.js file for jitsi-meet there a line "bosh:
'//jitsi.example.com/http-bind', // FIXME: use xep-0156 for that". I think I
had the format wrong because when I typed "https://mydomain/http-bind" in
the browser, I was returned with "It works! Now point your BOSH client to
this URL to connect to Prosody. For more information see Prosody: Setting up
BOSH."

So I'm just wondering what the correct format for that line should be?
Maybe "bosh: '//mydomain/http-bind',"? When I tried that, the
"net::ERR_NAME_NOT_RESOLVED" msg disappears but the disconnection happens
right away. The console message is as such: https://pastebin.com/LAz4t4B0

I suspect "Error: Strophe: Server did not offer a supported
authentication mechanism" is the main issue but I'm not sure how to solve
that.

Cheers!

On Wed, Mar 7, 2018 at 10:53 AM Damian Minkov <damencho@jitsi.org> wrote:

Hi,

There are few errors I see in your logs.
1. OPTIONS
https://jitsi.example.com/http-bind?room=babycreatureseatfrighteningly
net::ERR_NAME_NOT_RESOLVED
l @ lib-jitsi-meet.min.js:2
Your bosh connection is not working, the url for the bosh that is
configured in config.js is not resolvable.
2. In jicofo logs:
java.net.SocketTimeoutException: connect timed out,
host:jitsi.familian.life, port:5347
Mar 05 12:50:18 ubuntu-Server-NUC bash[17103]:
org.xmpp.component.ComponentException:
java.net.SocketTimeoutException: connect timed out
Jicofo cannot connect to prosody using address jitsi.familian.life.
3. Jvb logs also has errors coming from prosody, it connects to
prosody but receives a response service-unavailable, which I'm not
sure how to interpret, but you need to revisit your jvb and prosody
configurations.

Using manual install can easily lead to all sorts of these problems.
What didn't work for the quick install method? A few days ago I tested
installing everything with the quick install instructions on fresh
17.10 and everything is working fine.

Regards
damencho

On Wed, Mar 7, 2018 at 8:23 AM, Yang <lzy7071@gmail.com> wrote:
> Hi,
>
> As requested, the log files
>
> js console logs: https://pastebin.com/DeS0B6e1
> jicofo:
>
> https://drive.google.com/file/d/1kfdjJn6XQCSk1ycU8Xk_vmu3SAPizONg/view?usp=sharing
> jvb:
>
> https://drive.google.com/file/d/1JmMhj4y3274kIsnA7OlbGrOfY0Acvn0t/view?usp=sharing
>
> Let me know if these help.
>
> Cheers!
>
>
>
> On Wed, Mar 7, 2018 at 8:43 AM Damian Minkov <damencho@damencho.com> >>>> > wrote:
>>
>> Hi,
>>
>> You need to provide js console logs from the browser and also jvb and
>> jicofo logs when they are started.
>>
>> Regards
>> damencho
>>
>>
>> On Mar 7, 2018 07:36, "Yang" <lzy7071@gmail.com> wrote:
>>
>> Hi,
>>
>> My system is running ubuntu 17.10 on an intel NUC. I followed the
>> manual
>> installation instructions here
>> https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md
>> because I seem to be having problems with the quick install.
>>
>> Everything ran and compiled just fine and I can even open
>> "jitsi.mydomain.com" with my camera turned on. However, there is
>> nothing on
>> the video part of the screen and the system gives me a disconnect
>> error
>> every two seconds or so. I was wondering if I could get some help
>> debugging
>> this issue?
>>
>> Cheers!
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>>
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#9

Hi,

I eventually got the installation working. However, there were some issues
with the quick install methods that I was able to discover after fiddling
with manual installation for so long. For me, with ubuntu 17.10 and prosody
0.10.0+, the following are what I could remember:

1. I have to first apt install prosody and create 'certs', 'conf.d',
'conf.avail' directories under '/etc/prosody'
2. The various component secrets generated in the config files under
subdirectories in '/etc/jitsi' do not match with the component secrets
generated in '/etc/prosody/conf.avail/domain.cfg.lua' so one has to
manually match them.

Thank you for all the help!

Cheers!

···

On Thu, Mar 8, 2018 at 1:59 PM Damian Minkov <damencho@jitsi.org> wrote:

Hi again,

I just see a lot of errors and I cannot see anything wrong in the config.

Is this the main prosody config (/etc/prosody/prosody.cfg.lua) or you
include this. By default, the Debian packages create the config in
conf.d folder and which is included in the main config (Include
"conf.d/*.cfg.lua"). Make sure if you are including it you have the
include clause in the main prosody config.

What java version are you using?

Please, clean jicofo and jvb logs and restart them and then attach them.

Regards
damencho

On Wed, Mar 7, 2018 at 7:17 PM, Yang <lzy7071@gmail.com> wrote:
> Hi,
>
> Thank you for the help. I'm attaching my various configuration files and
the
> corresponding logs here
>
> Prosody -
> config: https://pastebin.com/sCep8qFR
> started with command "sudo /etc/init.d/prosody start"
> most recent log: https://pastebin.com/PuVpyxcT
>
> jicofo -
> started with a simple systemd file: https://pastebin.com/6crvDSL0
> most recent log: https://pastebin.com/eaUztBLU
>
> jvb -
> sip-communicator.properties: https://pastebin.com/UecRyyvH
> started with a simple systemd file: https://pastebin.com/DcN4XkSn
> most recent log: https://pastebin.com/b47PBpmP
>
> Again, thank you for the help!
>
> Cheer!
>
>
> On Wed, Mar 7, 2018 at 2:44 PM Damian Minkov <damencho@damencho.com> > wrote:
>>
>> Check your prosody config, the error is that prosody doesn't return the
>> correct stuff for your requests. You need to fix jicofo and jvb, which
also
>> can end up prosody config errors.
>>
>> On Mar 7, 2018 13:31, "Yang" <lzy7071@gmail.com> wrote:
>>>
>>> Hi,
>>>
>>> Thank you so much for the help. I think I see the root of the problem
for
>>> me now:
>>>
>>> In the config.js file for jitsi-meet there a line "bosh:
>>> '//jitsi.example.com/http-bind', // FIXME: use xep-0156 for that". I
think I
>>> had the format wrong because when I typed "https://mydomain/http-bind"
in
>>> the browser, I was returned with "It works! Now point your BOSH client
to
>>> this URL to connect to Prosody. For more information see Prosody:
Setting up
>>> BOSH."
>>>
>>> So I'm just wondering what the correct format for that line should be?
>>> Maybe "bosh: '//mydomain/http-bind',"? When I tried that, the
>>> "net::ERR_NAME_NOT_RESOLVED" msg disappears but the disconnection
happens
>>> right away. The console message is as such:
https://pastebin.com/LAz4t4B0
>>>
>>> I suspect "Error: Strophe: Server did not offer a supported
>>> authentication mechanism" is the main issue but I'm not sure how to
solve
>>> that.
>>>
>>> Cheers!
>>>
>>> On Wed, Mar 7, 2018 at 10:53 AM Damian Minkov <damencho@jitsi.org> > wrote:
>>>>
>>>> Hi,
>>>>
>>>> There are few errors I see in your logs.
>>>> 1. OPTIONS
>>>>
https://jitsi.example.com/http-bind?room=babycreatureseatfrighteningly
>>>> net::ERR_NAME_NOT_RESOLVED
>>>> l @ lib-jitsi-meet.min.js:2
>>>> Your bosh connection is not working, the url for the bosh that is
>>>> configured in config.js is not resolvable.
>>>> 2. In jicofo logs:
>>>> java.net.SocketTimeoutException: connect timed out,
>>>> host:jitsi.familian.life, port:5347
>>>> Mar 05 12:50:18 ubuntu-Server-NUC bash[17103]:
>>>> org.xmpp.component.ComponentException:
>>>> java.net.SocketTimeoutException: connect timed out
>>>> Jicofo cannot connect to prosody using address jitsi.familian.life.
>>>> 3. Jvb logs also has errors coming from prosody, it connects to
>>>> prosody but receives a response service-unavailable, which I'm not
>>>> sure how to interpret, but you need to revisit your jvb and prosody
>>>> configurations.
>>>>
>>>> Using manual install can easily lead to all sorts of these problems.
>>>> What didn't work for the quick install method? A few days ago I tested
>>>> installing everything with the quick install instructions on fresh
>>>> 17.10 and everything is working fine.
>>>>
>>>> Regards
>>>> damencho
>>>>
>>>>
>>>> On Wed, Mar 7, 2018 at 8:23 AM, Yang <lzy7071@gmail.com> wrote:
>>>> > Hi,
>>>> >
>>>> > As requested, the log files
>>>> >
>>>> > js console logs: https://pastebin.com/DeS0B6e1
>>>> > jicofo:
>>>> >
>>>> >
https://drive.google.com/file/d/1kfdjJn6XQCSk1ycU8Xk_vmu3SAPizONg/view?usp=sharing
>>>> > jvb:
>>>> >
>>>> >
https://drive.google.com/file/d/1JmMhj4y3274kIsnA7OlbGrOfY0Acvn0t/view?usp=sharing
>>>> >
>>>> > Let me know if these help.
>>>> >
>>>> > Cheers!
>>>> >
>>>> >
>>>> >
>>>> > On Wed, Mar 7, 2018 at 8:43 AM Damian Minkov <damencho@damencho.com > > > >>>> > wrote:
>>>> >>
>>>> >> Hi,
>>>> >>
>>>> >> You need to provide js console logs from the browser and also jvb
and
>>>> >> jicofo logs when they are started.
>>>> >>
>>>> >> Regards
>>>> >> damencho
>>>> >>
>>>> >>
>>>> >> On Mar 7, 2018 07:36, "Yang" <lzy7071@gmail.com> wrote:
>>>> >>
>>>> >> Hi,
>>>> >>
>>>> >> My system is running ubuntu 17.10 on an intel NUC. I followed the
>>>> >> manual
>>>> >> installation instructions here
>>>> >>
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md
>>>> >> because I seem to be having problems with the quick install.
>>>> >>
>>>> >> Everything ran and compiled just fine and I can even open
>>>> >> "jitsi.mydomain.com" with my camera turned on. However, there is
>>>> >> nothing on
>>>> >> the video part of the screen and the system gives me a disconnect
>>>> >> error
>>>> >> every two seconds or so. I was wondering if I could get some help
>>>> >> debugging
>>>> >> this issue?
>>>> >>
>>>> >> Cheers!
>>>> >>
>>>> >> _______________________________________________
>>>> >> users mailing list
>>>> >> users@jitsi.org
>>>> >> Unsubscribe instructions and other list options:
>>>> >> http://lists.jitsi.org/mailman/listinfo/users
>>>> >>
>>>> >>
>>>> >> _______________________________________________
>>>> >> users mailing list
>>>> >> users@jitsi.org
>>>> >> Unsubscribe instructions and other list options:
>>>> >> http://lists.jitsi.org/mailman/listinfo/users
>>>> >
>>>> >
>>>> > _______________________________________________
>>>> > users mailing list
>>>> > users@jitsi.org
>>>> > Unsubscribe instructions and other list options:
>>>> > http://lists.jitsi.org/mailman/listinfo/users
>>>>
>>>> _______________________________________________
>>>> users mailing list
>>>> users@jitsi.org
>>>> Unsubscribe instructions and other list options:
>>>> http://lists.jitsi.org/mailman/listinfo/users
>>>
>>>
>>> _______________________________________________
>>> users mailing list
>>> users@jitsi.org
>>> Unsubscribe instructions and other list options:
>>> http://lists.jitsi.org/mailman/listinfo/users
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#10

Hi,

Yep, I have seen these problems and will soon look at it.
With prosody 0.9 everything works as expected.

Regards
damencho

Hi,

I eventually got the installation working. However, there were some issues
with the quick install methods that I was able to discover after fiddling
with manual installation for so long. For me, with ubuntu 17.10 and prosody
0.10.0+, the following are what I could remember:

1. I have to first apt install prosody and create 'certs', 'conf.d',
'conf.avail' directories under '/etc/prosody'
2. The various component secrets generated in the config files under
subdirectories in '/etc/jitsi' do not match with the component secrets
generated in '/etc/prosody/conf.avail/domain.cfg.lua' so one has to
manually match them.

Thank you for all the help!

Cheers!

···

On Mar 8, 2018 15:27, "Yang" <lzy7071@gmail.com> wrote:

On Thu, Mar 8, 2018 at 1:59 PM Damian Minkov <damencho@jitsi.org> wrote:

Hi again,

I just see a lot of errors and I cannot see anything wrong in the config.

Is this the main prosody config (/etc/prosody/prosody.cfg.lua) or you
include this. By default, the Debian packages create the config in
conf.d folder and which is included in the main config (Include
"conf.d/*.cfg.lua"). Make sure if you are including it you have the
include clause in the main prosody config.

What java version are you using?

Please, clean jicofo and jvb logs and restart them and then attach them.

Regards
damencho

On Wed, Mar 7, 2018 at 7:17 PM, Yang <lzy7071@gmail.com> wrote:
> Hi,
>
> Thank you for the help. I'm attaching my various configuration files and
the
> corresponding logs here
>
> Prosody -
> config: https://pastebin.com/sCep8qFR
> started with command "sudo /etc/init.d/prosody start"
> most recent log: https://pastebin.com/PuVpyxcT
>
> jicofo -
> started with a simple systemd file: https://pastebin.com/6crvDSL0
> most recent log: https://pastebin.com/eaUztBLU
>
> jvb -
> sip-communicator.properties: https://pastebin.com/UecRyyvH
> started with a simple systemd file: https://pastebin.com/DcN4XkSn
> most recent log: https://pastebin.com/b47PBpmP
>
> Again, thank you for the help!
>
> Cheer!
>
>
> On Wed, Mar 7, 2018 at 2:44 PM Damian Minkov <damencho@damencho.com> > wrote:
>>
>> Check your prosody config, the error is that prosody doesn't return the
>> correct stuff for your requests. You need to fix jicofo and jvb, which
also
>> can end up prosody config errors.
>>
>> On Mar 7, 2018 13:31, "Yang" <lzy7071@gmail.com> wrote:
>>>
>>> Hi,
>>>
>>> Thank you so much for the help. I think I see the root of the problem
for
>>> me now:
>>>
>>> In the config.js file for jitsi-meet there a line "bosh:
>>> '//jitsi.example.com/http-bind', // FIXME: use xep-0156 for that". I
think I
>>> had the format wrong because when I typed "https://mydomain/http-bind"
in
>>> the browser, I was returned with "It works! Now point your BOSH client
to
>>> this URL to connect to Prosody. For more information see Prosody:
Setting up
>>> BOSH."
>>>
>>> So I'm just wondering what the correct format for that line should be?
>>> Maybe "bosh: '//mydomain/http-bind',"? When I tried that, the
>>> "net::ERR_NAME_NOT_RESOLVED" msg disappears but the disconnection
happens
>>> right away. The console message is as such:
https://pastebin.com/LAz4t4B0
>>>
>>> I suspect "Error: Strophe: Server did not offer a supported
>>> authentication mechanism" is the main issue but I'm not sure how to
solve
>>> that.
>>>
>>> Cheers!
>>>
>>> On Wed, Mar 7, 2018 at 10:53 AM Damian Minkov <damencho@jitsi.org> > wrote:
>>>>
>>>> Hi,
>>>>
>>>> There are few errors I see in your logs.
>>>> 1. OPTIONS
>>>> https://jitsi.example.com/http-bind?room=
babycreatureseatfrighteningly
>>>> net::ERR_NAME_NOT_RESOLVED
>>>> l @ lib-jitsi-meet.min.js:2
>>>> Your bosh connection is not working, the url for the bosh that is
>>>> configured in config.js is not resolvable.
>>>> 2. In jicofo logs:
>>>> java.net.SocketTimeoutException: connect timed out,
>>>> host:jitsi.familian.life, port:5347
>>>> Mar 05 12:50:18 ubuntu-Server-NUC bash[17103]:
>>>> org.xmpp.component.ComponentException:
>>>> java.net.SocketTimeoutException: connect timed out
>>>> Jicofo cannot connect to prosody using address jitsi.familian.life.
>>>> 3. Jvb logs also has errors coming from prosody, it connects to
>>>> prosody but receives a response service-unavailable, which I'm not
>>>> sure how to interpret, but you need to revisit your jvb and prosody
>>>> configurations.
>>>>
>>>> Using manual install can easily lead to all sorts of these problems.
>>>> What didn't work for the quick install method? A few days ago I tested
>>>> installing everything with the quick install instructions on fresh
>>>> 17.10 and everything is working fine.
>>>>
>>>> Regards
>>>> damencho
>>>>
>>>>
>>>> On Wed, Mar 7, 2018 at 8:23 AM, Yang <lzy7071@gmail.com> wrote:
>>>> > Hi,
>>>> >
>>>> > As requested, the log files
>>>> >
>>>> > js console logs: https://pastebin.com/DeS0B6e1
>>>> > jicofo:
>>>> >
>>>> > https://drive.google.com/file/d/1kfdjJn6XQCSk1ycU8Xk_
vmu3SAPizONg/view?usp=sharing
>>>> > jvb:
>>>> >
>>>> > https://drive.google.com/file/d/1JmMhj4y3274kIsnA7OlbGrOfY0Acv
n0t/view?usp=sharing
>>>> >
>>>> > Let me know if these help.
>>>> >
>>>> > Cheers!
>>>> >
>>>> >
>>>> >
>>>> > On Wed, Mar 7, 2018 at 8:43 AM Damian Minkov <damencho@damencho.com > > > >>>> > wrote:
>>>> >>
>>>> >> Hi,
>>>> >>
>>>> >> You need to provide js console logs from the browser and also jvb
and
>>>> >> jicofo logs when they are started.
>>>> >>
>>>> >> Regards
>>>> >> damencho
>>>> >>
>>>> >>
>>>> >> On Mar 7, 2018 07:36, "Yang" <lzy7071@gmail.com> wrote:
>>>> >>
>>>> >> Hi,
>>>> >>
>>>> >> My system is running ubuntu 17.10 on an intel NUC. I followed the
>>>> >> manual
>>>> >> installation instructions here
>>>> >> https://github.com/jitsi/jitsi-meet/blob/master/doc/
manual-install.md
>>>> >> because I seem to be having problems with the quick install.
>>>> >>
>>>> >> Everything ran and compiled just fine and I can even open
>>>> >> "jitsi.mydomain.com" with my camera turned on. However, there is
>>>> >> nothing on
>>>> >> the video part of the screen and the system gives me a disconnect
>>>> >> error
>>>> >> every two seconds or so. I was wondering if I could get some help
>>>> >> debugging
>>>> >> this issue?
>>>> >>
>>>> >> Cheers!
>>>> >>
>>>> >> _______________________________________________
>>>> >> users mailing list
>>>> >> users@jitsi.org
>>>> >> Unsubscribe instructions and other list options:
>>>> >> http://lists.jitsi.org/mailman/listinfo/users
>>>> >>
>>>> >>
>>>> >> _______________________________________________
>>>> >> users mailing list
>>>> >> users@jitsi.org
>>>> >> Unsubscribe instructions and other list options:
>>>> >> http://lists.jitsi.org/mailman/listinfo/users
>>>> >
>>>> >
>>>> > _______________________________________________
>>>> > users mailing list
>>>> > users@jitsi.org
>>>> > Unsubscribe instructions and other list options:
>>>> > http://lists.jitsi.org/mailman/listinfo/users
>>>>
>>>> _______________________________________________
>>>> users mailing list
>>>> users@jitsi.org
>>>> Unsubscribe instructions and other list options:
>>>> http://lists.jitsi.org/mailman/listinfo/users
>>>
>>>
>>> _______________________________________________
>>> users mailing list
>>> users@jitsi.org
>>> Unsubscribe instructions and other list options:
>>> http://lists.jitsi.org/mailman/listinfo/users
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users