[jitsi-users] Securing jitsi-meet creates error


#1

Hello all

I am new to Jitsi and have set up a server to host jitsi meetings. I set it up using packages from Linux Mint 18.1. Upon install it worked fine but when I tried to make it secure so that not anyone can create meetings on my server then I can no longer create meetings. Upon creating a room I get the following message "Error, Oops! Something went wrong and we couldn't connect to the conference: connection.otherError". Looking at logs I see in /var/log/jitsi/jigasi.log the following error: SEVERE: [40] org.jitsi.meet.ComponentMain.call().278 host-unknown, host:localhost, port:5347 org.xmpp.component.ComponentException: host-unknown

Now I am very new with Jitsi and don't know how all these components work together and was wondering where I should start to look for what is wrong with my configuration.

To make the server secure I followed the instructions on https://github.com/jitsi/jicofo#secure-domain.

Best regards, Olafur


#2

Hi,

The error you have pasted is from jigasi, which is responsible for
dialin/dialout.
You need to orovide browser js console log and jicofo logs, (restart
jicofo, make a test, and provide the logs from the restart).

Regards
damencho

···

On Mar 9, 2018 07:33, "Ólafur Jens Sigurðsson" <ojs@sraf.is> wrote:

Hello all

I am new to Jitsi and have set up a server to host jitsi meetings. I set it
up using packages from Linux Mint 18.1. Upon install it worked fine but
when I tried to make it secure so that not anyone can create meetings on my
server then I can no longer create meetings. Upon creating a room I get the
following message "Error, Oops! Something went wrong and we couldn't
connect to the conference: connection.otherError". Looking at logs I see in
/var/log/jitsi/jigasi.log the following error: SEVERE: [40]
org.jitsi.meet.ComponentMain.call().278 host-unknown, host:localhost,
port:5347 org.xmpp.component.ComponentException: host-unknown

Now I am very new with Jitsi and don't know how all these components work
together and was wondering where I should start to look for what is wrong
with my configuration.

To make the server secure I followed the instructions on
https://github.com/jitsi/jicofo#secure-domain.

Best regards, Olafur

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

When you added the anonymousdomain in the config file of meet under the
folder /etc/jitsi/meet/, did you put a comma at the end of the line above
it: "muc: 'conference.domain' *, *" ?

···

On Fri, Mar 9, 2018 at 9:01 AM Damian Minkov <damencho@damencho.com> wrote:

Hi,

The error you have pasted is from jigasi, which is responsible for
dialin/dialout.
You need to orovide browser js console log and jicofo logs, (restart
jicofo, make a test, and provide the logs from the restart).

Regards
damencho

On Mar 9, 2018 07:33, "Ólafur Jens Sigurðsson" <ojs@sraf.is> wrote:

Hello all

I am new to Jitsi and have set up a server to host jitsi meetings. I set
it up using packages from Linux Mint 18.1. Upon install it worked fine but
when I tried to make it secure so that not anyone can create meetings on my
server then I can no longer create meetings. Upon creating a room I get the
following message "Error, Oops! Something went wrong and we couldn't
connect to the conference: connection.otherError". Looking at logs I see in
/var/log/jitsi/jigasi.log the following error: SEVERE: [40]
org.jitsi.meet.ComponentMain.call().278 host-unknown, host:localhost,
port:5347 org.xmpp.component.ComponentException: host-unknown

Now I am very new with Jitsi and don't know how all these components work
together and was wondering where I should start to look for what is wrong
with my configuration.

To make the server secure I followed the instructions on
https://github.com/jitsi/jicofo#secure-domain.

Best regards, Olafur

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Hi and thanks for the reply. I restarted jicofo and tried to create a room (now actually I get the original error for a second and then it disappears and is replaced by "Jitsi Meet needs to use your microphone and camera. Select Share Selected Device when your browser asks for permissions". I selected allow on both microphone and camera but the message does not go away).

The js console is here:

(TIME) index.html loaded: 145.94 shyyora:9:9
[modules/RTC/RTCBrowserType.js] <o>: This appears to be Firefox, ver: 58 Logger.js:124:12
DEPRECATED JS - Cookie has been deprecated since 5.8.0 and will be removed in a future release. Use cookie instead. t.default@https://ishaf.uw.is /libs/app.bundle.min.js?v=2301:2:61138 app.bundle.min.js:2:227454
[react/index.web.js] <>: (TIME) document ready: 1359.6200000000001 Logger.js:124
[modules/URL/ConferenceUrl.js] <e>: Stored original conference URL: https://ishaf.uw.is/shyyora Logger.js:124
[modules/URL/ConferenceUrl.js] <e>: Conference URL for invites: https://ishaf.uw.is/shyyora Logger.js:124
[modules/RTC/RTCUtils.js] <value>: Get media constraints Object { audio: true, video: false } Logger.js:124:12
[modules/xmpp/strophe.jingle.js] <t>: Configured STUN servers: Array [ {…}, {…}, {…} ] Logger.js:124:12
[modules/xmpp/xmpp.js] <value>: (TIME) Strophe connecting: 1780.4 Logger.js:124:12
Blocked loading mixed active content “http://fonts.gstatic.com/s/roboto/v18/KFOjCnqEu92Fr1Mu51S7ACc6CsQ.woff2”
[Learn More] shyyora
Blocked loading mixed active content “http://www.bb.is/wp-content/themes/Newspaper/images/icons/newspaper.woff?9”
[Learn More] shyyora
Blocked loading mixed active content “http://fonts.gstatic.com/s/roboto/v18/KFOmCnqEu92Fr1Mu4mxK.woff2”
[Learn More] shyyora
Blocked loading mixed active content “http://fonts.gstatic.com/s/opensans/v15/mem8YaGs126MiZpBA-UFVZ0b.woff2”
[Learn More] shyyora
Blocked loading mixed active content “http://fonts.gstatic.com/s/roboto/v18/KFOkCnqEu92Fr1Mu51xIIzI.woff2”
[Learn More] shyyora
Blocked loading mixed active content “http://fonts.gstatic.com/s/roboto/v18/KFOlCnqEu92Fr1MmWUlfBBc4.woff2”
[Learn More] shyyora
navigator.mozGetUserMedia has been replaced by navigator.mediaDevices.getUserMedia RTCUtils.js:496:12
[JitsiMeetJS.js] <getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace:
Error: Strophe: BOSH-Connection failed: host-unknown Stack trace:
t.a/Strophe.log@https://ishaf.uw.is/libs/lib-jitsi-meet.min.js?v=2301:2:615191
error@https://ishaf.uw.is/libs/app.bundle.min.js?v=2301:2:2291896
_connect_cb@https://ishaf.uw.is/libs/app.bundle.min.js?v=2301:2:2316897
_connect_cb@https://ishaf.uw.is/libs/app.bundle.min.js?v=2301:2:2303131
_onRequestStateChange@https://ishaf.uw.is/libs/app.bundle.min.js?v=2301:2:2320103
Logger.js:124:12
[modules/xmpp/strophe.util.js] <t.a/Strophe.log>: Strophe: BOSH-Connection failed: host-unknown
Logger.js:124:12
[modules/xmpp/xmpp.js] <value>: (TIME) Strophe connfail[host-unknown]: 2146.12
Logger.js:124:12
[modules/xmpp/xmpp.js] <value>: (TIME) Strophe disconnected[host-unknown]: 2147.36
Logger.js:124:12
[connection.js] <p>: CONNECTION FAILED: connection.otherError
Logger.js:124
[react/features/overlay/reducer.js] <r>: FATAL XMPP connection error: host-unknown
Logger.js:124
[react/features/base/connection/actions.web.js] <i/</<>: connection.otherError
Logger.js:124
[modules/RTC/RTCUtils.js] <value/<>: onUserMediaSuccess
Logger.js:124:12
[modules/RTC/RTCUtils.js] <value>: Get media constraints
Object { audio: false, video: {…} }
Logger.js:124:12
[modules/RTC/RTCUtils.js] <value/<>: Failed to get access to local media. Error
MediaStreamError { name: "NotFoundError", message: "The object can not be found here.", constraint: "", stack: "" }

Object { audio: false, video: {…} }
Logger.js:124:12
[modules/RTC/RTCUtils.js] <_/<>: failed to obtain video stream - stop
Object { gum: {…}, name: "gum.not_found", message: "Requested device(s) was/were not found: video", stack: "r@https://ishaf.uw.is/libs/lib-jitsi-meet.min.js?v=2301:2:23989\nvalue/<@https://ishaf.uw.is/libs/lib-jitsi-meet.min.js?v=2301:2:144653\nh@https://ishaf.uw.is/libs/lib-jitsi-meet.min.js?v=2301:2:137273\nv/</<@https://ishaf.uw.is/libs/lib-jitsi-meet.min.js?v=2301:2:137528\n" }
Logger.js:124:12
[react/features/base/tracks/functions.js] <i/<>: Failed to create local tracks
Array [ "audio", "video" ]

Object { gum: {…}, name: "gum.not_found", message: "Requested device(s) was/were not found: video", stack: "r@https://ishaf.uw.is/libs/lib-jitsi-meet.min.js?v=2301:2:23989\nvalue/<@https://ishaf.uw.is/libs/lib-jitsi-meet.min.js?v=2301:2:144653\nh@https://ishaf.uw.is/libs/lib-jitsi-meet.min.js?v=2301:2:137273\nv/</<@https://ishaf.uw.is/libs/lib-jitsi-meet.min.js?v=2301:2:137528\n" }
Logger.js:124
[modules/RTC/RTCUtils.js] <value>: Get media constraints
Object { audio: true, video: false }
Logger.js:124:12
MediaStream.stop() is deprecated and will soon be removed. Use MediaStreamTrack.stop() instead.
RTCUtils.js:1299:12
[modules/RTC/RTCUtils.js] <value/<>: onUserMediaSuccess
Logger.js:124:12
[modules/RTC/JitsiLocalTrack.js] <value>: Setting new MSID: {bf639d0f-4137-439f-802a-a1ff73e45e36} {e3275832-04b1-43b0-80e3-5b52fb9c7700} on LocalTrack[undefined,audio]
Logger.js:124:12
[modules/RTC/RTCUtils.js] <f>: list of media devices has changed:
Array [ MediaDeviceInfo, MediaDeviceInfo, MediaDeviceInfo ]
Logger.js:124:12

Here is the /var/log/jitsi/jicofo.log (from the time the room was created).

Jicofo 2018-03-09 14:32:16.588 INFO: [11] org.jitsi.service.libjitsi.LibJitsi.log() Successfully started LibJitsi using as imp
lementation: org.jitsi.impl.libjitsi.LibJitsiOSGiImpl
Jicofo 2018-03-09 14:32:16.614 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jicofo.HOSTNAM
E=localhost
Jicofo 2018-03-09 14:32:16.614 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.runtime.name=OpenJD
K Runtime Environment
Jicofo 2018-03-09 14:32:16.615 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() sun.boot.library.path=/u
sr/lib/jvm/java-8-openjdk-amd64/jre/lib/amd64
Jicofo 2018-03-09 14:32:16.615 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.vm.version=25.131-b
11
Jicofo 2018-03-09 14:32:16.615 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.vm.vendor=Oracle Co
rporation
Jicofo 2018-03-09 14:32:16.615 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.vendor.url=http://j
ava.oracle.com/
Jicofo 2018-03-09 14:32:16.615 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() path.separator=:
Jicofo 2018-03-09 14:32:16.616 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.util.logging.config
.file=/etc/jitsi/jicofo/logging.properties
Jicofo 2018-03-09 14:32:16.616 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.vm.name=OpenJDK 64-Bit Server VM
Jicofo 2018-03-09 14:32:16.616 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() file.encoding.pkg=sun.io
Jicofo 2018-03-09 14:32:16.616 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() user.country=US
Jicofo 2018-03-09 14:32:16.616 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() sun.java.launcher=SUN_STANDARD
Jicofo 2018-03-09 14:32:16.616 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() sun.os.patch.level=unknown
Jicofo 2018-03-09 14:32:16.617 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() net.java.sip.communicator.service.media.DISABLE_AUDIO_SUPPORT=true
Jicofo 2018-03-09 14:32:16.617 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.vm.specification.name=Java Virtual Machine Specification
Jicofo 2018-03-09 14:32:16.617 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() user.dir=/usr/share/jicofo
Jicofo 2018-03-09 14:32:16.617 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jicofo.FOCUS_USER_PASSWORD=**********
Jicofo 2018-03-09 14:32:16.617 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.runtime.version=1.8.0_131-8u131-b11-0ubuntu1.16.04.2-b11
Jicofo 2018-03-09 14:32:16.617 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.awt.graphicsenv=sun.awt.X11GraphicsEnvironment
Jicofo 2018-03-09 14:32:16.618 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.endorsed.dirs=/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/endorsed
Jicofo 2018-03-09 14:32:16.618 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() os.arch=amd64
Jicofo 2018-03-09 14:32:16.618 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.io.tmpdir=/tmp
Jicofo 2018-03-09 14:32:16.618 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() line.separator=

Jicofo 2018-03-09 14:32:16.618 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.vm.specification.vendor=Oracle Corporation
Jicofo 2018-03-09 14:32:16.618 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() os.name=Linux
Jicofo 2018-03-09 14:32:16.619 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() sun.jnu.encoding=UTF-8
Jicofo 2018-03-09 14:32:16.619 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() net.java.sip.communicator.CONFIGURATION_FILE_IS_READ_ONLY=true
Jicofo 2018-03-09 14:32:16.619 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jicofo.FOCUS_USER_DOMAIN=auth.ishaf.uw.is
Jicofo 2018-03-09 14:32:16.619 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.library.path=/usr/share/jicofo/lib/native/linux-64
Jicofo 2018-03-09 14:32:16.619 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.specification.name=Java Platform API Specification
Jicofo 2018-03-09 14:32:16.619 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.class.version=52.0
Jicofo 2018-03-09 14:32:16.620 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.service.audionotifier.AudioNotifierService=org.jitsi.impl.neomedia.notify.AudioNotifierServiceImpl
Jicofo 2018-03-09 14:32:16.620 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() sun.management.compiler=HotSpot 64-Bit Tiered Compilers
Jicofo 2018-03-09 14:32:16.620 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() os.version=4.4.0-53-generic
Jicofo 2018-03-09 14:32:16.620 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() user.home=/usr/share/jicofo
Jicofo 2018-03-09 14:32:16.620 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() user.timezone=Atlantic/Reykjavik
Jicofo 2018-03-09 14:32:16.620 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.awt.printerjob=sun.print.PSPrinterJob
Jicofo 2018-03-09 14:32:16.621 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jicofo.FOCUS_USER_NAME=focus
Jicofo 2018-03-09 14:32:16.621 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() file.encoding=UTF-8
Jicofo 2018-03-09 14:32:16.621 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.specification.versi
on=1.8
Jicofo 2018-03-09 14:32:16.621 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() net.java.sip.communicator.service.media.DISABLE_VIDEO_SUPPORT=true
Jicofo 2018-03-09 14:32:16.621 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jicofo.XMPP_DOMAIN=ishaf.uw.is
Jicofo 2018-03-09 14:32:16.621 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.class.path=/usr/share/jicofo/jicofo.jar:/usr/share/jicofo/lib/agafua-syslog-0.4.jar:/usr/share/jicofo/lib/bccontrib-1.0.jar:/usr/share/jicofo/lib/bcpkix-jdk15on-1.54.jar:/usr/share/jicofo/lib/bcprov-jdk15on-1.54.jar:/usr/share/jicofo/lib/commons-codec-1.6.jar:/usr/share/jicofo/lib/commons-lang-2.4.jar:/usr/share/jicofo/lib/commons-lang3-3.1.jar:/usr/share/jicofo/lib/commons-logging-1.2.jar:/usr/share/jicofo/lib/concurrentlinkedhashmap-lru-1.0_jdk5.jar:/usr/share/jicofo/lib/core-2.0.0.jar:/usr/share/jicofo/lib/dnsjava-2.1.7.jar:/usr/share/jicofo/lib/dom4j-1.6.1.jar:/usr/share/jicofo/lib/fmj-1.0-20160121.172939-10.jar:/usr/share/jicofo/lib/guava-15.0.jar:/usr/share/jicofo/lib/httpclient-4.4.jar:/usr/share/jicofo/lib/httpcore-4.4.jar:/usr/share/jicofo/lib/ice4j-2.0-20170420.153542-14.jar:/usr/share/jicofo/lib/jain-sip-ri-ossonly-1.2.98c7f8c-jitsi-oss1.jar:/usr/share/jicofo/lib/java-sdp-nist-bridge-1.1.jar:/usr/share/jicofo/lib/javax.servlet-3.0.0.v201112011016.jar:/usr/share/jicofo/lib/javax.servlet-api-3.1.0.jar:/usr/share/jicofo/lib/jcip-annotations-1.0.jar:/usr/share/jicofo/lib/jetty-ajp-8.1.16.v20140903.jar:/usr/share/jicofo/lib/jetty-client-9.2.10.v20150310.jar:/usr/share/jicofo/lib/jetty-continuation-8.1.16.v20140903.jar:/usr/share/jicofo/lib/jetty-http-8.1.16.v20140903.jar:/usr/share/jicofo/lib/jetty-io-8.1.16.v20140903.jar:/usr/share/jicofo/lib/jetty-proxy-9.2.10.v20150310.jar:/usr/share/jicofo/lib/jetty-security-8.1.16.v20140903.jar:/usr/share/jicofo/lib/jetty-server-8.1.16.v20140903.jar:/usr/share/jicofo/lib/jetty-servlet-8.1.16.v20140903.jar:/usr/share/jicofo/lib/jetty-util-8.1.16.v20140903.jar:/usr/share/jicofo/lib/jetty-webapp-7.0.1.v20091125.jar:/usr/share/jicofo/lib/jetty-xml-7.0.1.v20091125.jar:/usr/share/jicofo/lib/jicoco-1.0-20161122.205032-37.jar:/usr/share/jicofo/lib/jitsi-android-osgi-1.0-20150723.002702-1.jar:/usr/share/jicofo/lib/jitsi-configuration-2.9-20150723.181638-1.jar:/usr/share/jicofo/lib/jitsi-credentialsstorage-2.9-20150723.181643-1.jar:/usr/share/jicofo/lib/jitsi-dnsservice-2.9-20150723.181644-1.jar:/usr/share/jicofo/lib/jitsi-netaddr-2.9-20150723.181645-1.jar:/usr/share/jicofo/lib/jitsi-protocol-2.9-20160823.174711-4.jar:/usr/share/jicofo/lib/jitsi-protocol-jabber-2.11-20170911.110205-14.jar:/usr/share/jicofo/lib/jitsi-protocol-media-2.9-20150723.181646-1.jar:/usr/share/jicofo/lib/jitsi-ui-service-2.9-20150723.181654-1.jar:/usr/share/jicofo/lib/jitsi-util-2.9-20160203.194039-2.jar:/usr/share/jicofo/lib/jna-4.1.0.jar:/usr/share/jicofo/lib/jnsapi-0.0.3-jitsi-1-20151013.145326-2.jar:/usr/share/jicofo/lib/json-simple-1.1.1.jar:/usr/share/jicofo/lib/jzlib-1.1.3.jar:/usr/share/jicofo/lib/libidn-1.15.jar:/usr/share/jicofo/lib/libjitsi-1.0-20170901.140206-311.jar:/usr/share/jicofo/lib/log4j-1.2.14.jar:/usr/share/jicofo/lib/orange-extensions-1.3.0.jar:/usr/share/jicofo/lib/org.apache.felix.framework-4.4.0.jar:/usr/share/jicofo/lib/org.apache.felix.main-4.4.0.jar:/usr/share/jicofo/lib/org.osgi.core-4.3.1.jar:/usr/share/jicofo/lib/sdes4j-1.1.3.jar:/usr/share/jicofo/lib/sdp-api-1.0.jar:/usr/share/jicofo/lib/slf4j-api-1.7.7.jar:/usr/share/jicofo/lib/slf4j-jdk14-1.7.7.jar:/usr/share/jicofo/lib/smack-3.2.2-jitsi-1-20151215.185921-3.jar:/usr/share/jicofo/lib/smackx-3.2.2-jitsi-1-20151215.185922-3.jar:/usr/share/jicofo/lib/tinder-1.2.3.jar:/usr/share/jicofo/lib/weupnp-0.1.4.jar:/usr/share/jicofo/lib/xml-apis-1.0.b2.jar:/usr/share/jicofo/lib/xmlpull-1.1.3.4a.jar:/usr/share/jicofo/lib/xpp3-1.1.4c.jar:/usr/share/jicofo/lib/zrtp4j-light-3.2.0-jitsi-1-20150723.002345-1.jar

Jicofo 2018-03-09 14:32:16.622 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() user.name=jicofo
Jicofo 2018-03-09 14:32:16.622 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.vm.specification.version=1.8
Jicofo 2018-03-09 14:32:16.622 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() sun.java.command=org.jitsi.jicofo.Main --host=localhost --domain=ishaf.uw.is --port=5347 --secret=X --user_name=focus --user_domain=auth.ishaf.uw.is --user_password=X
Jicofo 2018-03-09 14:32:16.623 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.home=/usr/lib/jvm/java-8-openjdk-amd64/jre
Jicofo 2018-03-09 14:32:16.623 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() sun.arch.data.model=64
Jicofo 2018-03-09 14:32:16.623 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() user.language=en
Jicofo 2018-03-09 14:32:16.623 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.specification.vendor=Oracle Corporation
Jicofo 2018-03-09 14:32:16.623 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() awt.toolkit=sun.awt.X11.XToolkit
Jicofo 2018-03-09 14:32:16.623 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.vm.info=mixed mode
Jicofo 2018-03-09 14:32:16.624 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.version=1.8.0_131
Jicofo 2018-03-09 14:32:16.624 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.ext.dirs=/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/ext:/usr/java/packages/lib/ext
Jicofo 2018-03-09 14:32:16.624 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() sun.boot.class.path=/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/resources.jar:/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/rt.jar:/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/sunrsasign.jar:/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/jsse.jar:/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/jce.jar:/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/charsets.jar:/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/jfr.jar:/usr/lib/jvm/java-8-openjdk-amd64/jre/classes
Jicofo 2018-03-09 14:32:16.624 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() net.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi
Jicofo 2018-03-09 14:32:16.624 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.vendor=Oracle Corporation
Jicofo 2018-03-09 14:32:16.624 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() file.separator=/
Jicofo 2018-03-09 14:32:16.624 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() net.java.sip.communicator.SC_HOME_DIR_NAME=jicofo
Jicofo 2018-03-09 14:32:16.625 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() java.vendor.url.bug=http://bugreport.sun.com/bugreport/
Jicofo 2018-03-09 14:32:16.625 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() sun.io.unicode.encoding=UnicodeLittle
Jicofo 2018-03-09 14:32:16.625 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() sun.cpu.endian=little
Jicofo 2018-03-09 14:32:16.625 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() net.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi
Jicofo 2018-03-09 14:32:16.625 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() sun.cpu.isalist=
Jicofo 2018-03-09 14:32:16.626 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() Normal classloader
Jicofo 2018-03-09 14:32:16.627 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() failed to find jitsi-defaults.properties with class loader, will continue without it.
Jicofo 2018-03-09 14:32:16.627 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() Normal classloader
Jicofo 2018-03-09 14:32:16.628 INFO: [11] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() failed to find jitsi-default-overrides.properties with class loader, will continue without it.
Jicofo 2018-03-09 14:32:16.707 INFO: [11] impl.netaddr.NetworkAddressManagerServiceImpl.start().92 Network Address Manager ...[ STARTED ]
Jicofo 2018-03-09 14:32:16.707 INFO: [11] impl.netaddr.NetworkAddressManagerServiceImpl.start().98 Network Address Manager Service ...[REGISTERED]
Jicofo 2018-03-09 14:32:16.711 INFO: [11] org.jitsi.version.AbstractVersionActivator.start().119 JiCoFo Version: JiCoFo 1.0.1.0-371
Jicofo 2018-03-09 14:32:16.833 INFO: [11] org.jitsi.jicofo.JitsiMeetGlobalConfig.init().170 Automatically grant 'owner' role:
true
Jicofo 2018-03-09 14:32:16.834 INFO: [11] org.jitsi.jicofo.JitsiMeetGlobalConfig.init().183 Jibri requests in PENDING state wi
ll be timed out after: 90 seconds
Jicofo 2018-03-09 14:32:16.834 INFO: [11] org.jitsi.jicofo.JitsiMeetGlobalConfig.init().197 Lonely participants will be "terminated" after 20000 milliseconds
Jicofo 2018-03-09 14:32:16.848 SEVERE: [11] org.jitsi.jicofo.BridgeSelector.createBridgeSelectionStrategy().206 Failed to instantiate org.jitsi.jicofo.BridgeSelector$SingleBridgeSelectionStrategy. Falling back to SingleBridgeSelectionStrategy.
java.lang.IllegalAccessException: Class org.jitsi.jicofo.BridgeSelector can not access a member of class org.jitsi.jicofo.BridgeSelector$SingleBridgeSelectionStrategy with modifiers "private"
at sun.reflect.Reflection.ensureMemberAccess(Reflection.java:102)
at java.lang.Class.newInstance(Class.java:436)
at org.jitsi.jicofo.BridgeSelector.createBridgeSelectionStrategy(BridgeSelector.java:202)
at org.jitsi.jicofo.BridgeSelector.<init>(BridgeSelector.java:168)
at org.jitsi.jicofo.JitsiMeetServices.<init>(JitsiMeetServices.java:190)
at org.jitsi.jicofo.FocusManager.start(FocusManager.java:220)
at org.jitsi.jicofo.FocusBundleActivator.start(FocusBundleActivator.java:113)
at org.jitsi.impl.osgi.framework.BundleImpl.start(BundleImpl.java:293)
at org.jitsi.impl.osgi.framework.launch.FrameworkImpl.startLevelChanged(FrameworkImpl.java:460)
at org.jitsi.impl.osgi.framework.startlevel.FrameworkStartLevelImpl$Command.run(FrameworkStartLevelImpl.java:126)
at org.jitsi.impl.osgi.framework.AsyncExecutor.runInThread(AsyncExecutor.java:111)
at org.jitsi.impl.osgi.framework.AsyncExecutor.access$000(AsyncExecutor.java:17)
at org.jitsi.impl.osgi.framework.AsyncExecutor$1.run(AsyncExecutor.java:220)
Jicofo 2018-03-09 14:32:16.849 INFO: [11] org.jitsi.jicofo.BridgeSelector.<init>().169 Using org.jitsi.jicofo.BridgeSelector$SingleBridgeSelectionStrategy
Jicofo 2018-03-09 14:32:16.849 INFO: [11] org.jitsi.jicofo.BridgeSelector.init().669 Bridge failure reset threshold: 300000
Jicofo 2018-03-09 14:32:16.858 INFO: [11] org.jitsi.jicofo.auth.AuthBundleActivator.start().210 Starting authentication servic
e... URL: XMPP:ishaf.uw.is
Jicofo 2018-03-09 14:32:16.861 INFO: [11] org.jitsi.jicofo.auth.AbstractAuthAuthority.<init>().122 Authentication lifetime: 86400000
Jicofo 2018-03-09 14:32:16.861 INFO: [11] org.jitsi.jicofo.auth.AuthBundleActivator.start().237 Auth authority: org.jitsi.jicofo.auth.XMPPDomainAuthAuthority@50a05c7a
Jicofo 2018-03-09 14:32:16.946 INFO: [11] org.eclipse.jetty.server.Server.doStart() jetty-8.1.16.v20140903
Jicofo 2018-03-09 14:32:16.979 INFO: [11] org.eclipse.jetty.server.AbstractConnector.doStart() Started SelectChannelConnector@0.0.0.0:8888
Jicofo 2018-03-09 14:32:16.981 INFO: [1] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jicofo.auth.URL=XMPP:ishaf.uw.is
Jicofo 2018-03-09 14:32:16.990 INFO: [1] org.jitsi.xmpp.component.ComponentBase.loadConfig().200 Component org.jitsi.jicofo. config:
Jicofo 2018-03-09 14:32:16.990 INFO: [1] org.jitsi.xmpp.component.ComponentBase.loadConfig().201 ping interval: 10000 ms
Jicofo 2018-03-09 14:32:16.990 INFO: [1] org.jitsi.xmpp.component.ComponentBase.loadConfig().202 ping timeout: 5000 ms
Jicofo 2018-03-09 14:32:16.990 INFO: [1] org.jitsi.xmpp.component.ComponentBase.loadConfig().203 ping threshold: 3
Jicofo 2018-03-09 14:32:17.278 INFO: [17] org.jitsi.jicofo.ComponentsDiscovery.discoverServices().264 New component discovered: jitsi-videobridge.ishaf.uw.is, Version[JVB(0.1.995,Linux)@1280853270
Jicofo 2018-03-09 14:32:17.278 INFO: [17] org.jitsi.jicofo.BridgeSelector.addJvbAddress().248 Added videobridge: jitsi-videobridge.ishaf.uw.is v: Version[JVB(0.1.995,Linux)@1280853270
Jicofo 2018-03-09 14:32:17.278 WARNING: [17] org.jitsi.jicofo.BridgeSelector.addJvbAddress().260 No pub-sub node mapped for jitsi-videobridge.ishaf.uw.is
Jicofo 2018-03-09 14:32:17.281 INFO: [39] org.jitsi.jicofo.JvbDoctor.log() Scheduled health-check task for: jitsi-videobridge.ishaf.uw.is
Jicofo 2018-03-09 14:32:17.282 INFO: [17] org.jitsi.jicofo.ComponentsDiscovery.discoverServices().264 New component discovered: conference.ishaf.uw.is, null
Jicofo 2018-03-09 14:32:17.282 INFO: [17] org.jitsi.jicofo.JitsiMeetServices.newNodeDiscovered().235 MUC component discovered: conference.ishaf.uw.is
Jicofo 2018-03-09 14:32:17.286 INFO: [17] org.jitsi.jicofo.ComponentsDiscovery.discoverServices().264 New component discovered: auth.ishaf.uw.is, Version[Prosody(0.9.10,Linux)@-321706579
Jicofo 2018-03-09 14:32:17.286 INFO: [17] org.jitsi.jicofo.JitsiMeetServices.newNodeDiscovered().243 Detected XMPP server version: Version[Prosody(0.9.10,Linux)@-321706579
Jicofo 2018-03-09 14:32:17.301 INFO: [17] org.jitsi.jicofo.ComponentsDiscovery.discoverServices().264 New component discovered: focus.ishaf.uw.is, null
Jicofo 2018-03-09 14:32:17.301 INFO: [17] org.jitsi.jicofo.ComponentsDiscovery.scheduleRediscovery().186 Services re-discovery interval: 30000
Jicofo 2018-03-09 14:32:17.302 INFO: [17] org.jitsi.jicofo.FocusManager.log() XMPP provider reg state: RegistrationState=Registered
Jicofo 2018-03-09 14:32:17.303 INFO: [17] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.log() XMPP provider Jabber:focus@auth.ishaf.uw.is/focus2072917596376289@localhost connected (JID: focus@auth.ishaf.uw.is/focus2072917596376289)

Regards, Olafur

···

On 9.3.2018 13:59, Damian Minkov wrote:

Hi,

The error you have pasted is from jigasi, which is responsible for dialin/dialout.
You need to orovide browser js console log and jicofo logs, (restart jicofo, make a test, and provide the logs from the restart).

Regards
damencho

On Mar 9, 2018 07:33, "Ólafur Jens Sigurðsson" <ojs@sraf.is > <mailto:ojs@sraf.is>> wrote:

    Hello all

    I am new to Jitsi and have set up a server to host jitsi meetings.
    I set it up using packages from Linux Mint 18.1. Upon install it
    worked fine but when I tried to make it secure so that not anyone
    can create meetings on my server then I can no longer create
    meetings. Upon creating a room I get the following message "Error,
    Oops! Something went wrong and we couldn't connect to the
    conference: connection.otherError". Looking at logs I see in
    /var/log/jitsi/jigasi.log the following error: SEVERE: [40]
    org.jitsi.meet.ComponentMain.call().278 host-unknown,
    host:localhost, port:5347 org.xmpp.component.ComponentException:
    host-unknown

    Now I am very new with Jitsi and don't know how all these
    components work together and was wondering where I should start to
    look for what is wrong with my configuration.

    To make the server secure I followed the instructions on
    https://github.com/jitsi/jicofo#secure-domain
    <https://github.com/jitsi/jicofo#secure-domain>.

    Best regards, Olafur

    _______________________________________________
    users mailing list
    users@jitsi.org <mailto:users@jitsi.org>
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users
    <http://lists.jitsi.org/mailman/listinfo/users>

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hi, yes that was there by default, I added the anonymousdomain keyword after the domain keyword and before the muc keyword. Does the order here matter?

Best regards, Olafur

···

On 9.3.2018 14:35, Yang wrote:

When you added the anonymousdomain in the config file of meet under the folder /etc/jitsi/meet/, did you put a comma at the end of the line above it: "muc: 'conference.domain' *, *" ?

On Fri, Mar 9, 2018 at 9:01 AM Damian Minkov <damencho@damencho.com > <mailto:damencho@damencho.com>> wrote:

    Hi,

    The error you have pasted is from jigasi, which is responsible for
    dialin/dialout.
    You need to orovide browser js console log and jicofo logs,
    (restart jicofo, make a test, and provide the logs from the restart).

    Regards
    damencho

    On Mar 9, 2018 07:33, "Ólafur Jens Sigurðsson" <ojs@sraf.is > <mailto:ojs@sraf.is>> wrote:

        Hello all

        I am new to Jitsi and have set up a server to host jitsi
        meetings. I set it up using packages from Linux Mint 18.1.
        Upon install it worked fine but when I tried to make it secure
        so that not anyone can create meetings on my server then I can
        no longer create meetings. Upon creating a room I get the
        following message "Error, Oops! Something went wrong and we
        couldn't connect to the conference: connection.otherError".
        Looking at logs I see in /var/log/jitsi/jigasi.log the
        following error: SEVERE: [40]
        org.jitsi.meet.ComponentMain.call().278 host-unknown,
        host:localhost, port:5347
        org.xmpp.component.ComponentException: host-unknown

        Now I am very new with Jitsi and don't know how all these
        components work together and was wondering where I should
        start to look for what is wrong with my configuration.

        To make the server secure I followed the instructions on
        https://github.com/jitsi/jicofo#secure-domain.

        Best regards, Olafur

        _______________________________________________
        users mailing list
        users@jitsi.org <mailto:users@jitsi.org>
        Unsubscribe instructions and other list options:
        http://lists.jitsi.org/mailman/listinfo/users

    _______________________________________________
    users mailing list
    users@jitsi.org <mailto:users@jitsi.org>
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

Hi,

The order doesn't matter but on the default config file for meet, there
isn't a comma at the end of the "muc: ...." line. That was the problem for
me when I was trying to enable secure domain. But it seems that yours is
different, it looks like the connection to Prosody is not working. Can you
pastebin your prosody log too?

Cheers!

···

On Fri, Mar 9, 2018 at 9:53 AM Ólafur Jens Sigurðsson <ojs@sraf.is> wrote:

Hi, yes that was there by default, I added the anonymousdomain keyword
after the domain keyword and before the muc keyword. Does the order here
matter?

Best regards, Olafur

On 9.3.2018 14:35, Yang wrote:

When you added the anonymousdomain in the config file of meet under the
folder /etc/jitsi/meet/, did you put a comma at the end of the line above
it: "muc: 'conference.domain' *, *" ?

On Fri, Mar 9, 2018 at 9:01 AM Damian Minkov <damencho@damencho.com> > wrote:

Hi,

The error you have pasted is from jigasi, which is responsible for
dialin/dialout.
You need to orovide browser js console log and jicofo logs, (restart
jicofo, make a test, and provide the logs from the restart).

Regards
damencho

On Mar 9, 2018 07:33, "Ólafur Jens Sigurðsson" <ojs@sraf.is> wrote:

Hello all

I am new to Jitsi and have set up a server to host jitsi meetings. I set
it up using packages from Linux Mint 18.1. Upon install it worked fine but
when I tried to make it secure so that not anyone can create meetings on my
server then I can no longer create meetings. Upon creating a room I get the
following message "Error, Oops! Something went wrong and we couldn't
connect to the conference: connection.otherError". Looking at logs I see in
/var/log/jitsi/jigasi.log the following error: SEVERE: [40]
org.jitsi.meet.ComponentMain.call().278 host-unknown, host:localhost,
port:5347 org.xmpp.component.ComponentException: host-unknown

Now I am very new with Jitsi and don't know how all these components work
together and was wondering where I should start to look for what is wrong
with my configuration.

To make the server secure I followed the instructions on
https://github.com/jitsi/jicofo#secure-domain.

Best regards, Olafur

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing listusers@jitsi.org
Unsubscribe instructions and other list options:http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

Hi sorry for taking so long, didn't have time to look at this until today.

The /var/log/prosody/prosody.log contains lots of these messages but no others:

Mar 12 16:14:08 jcp25a2b00 info Incoming Jabber component connection
Mar 12 16:14:08 mod_component info Disconnecting component, <stream:error> is: <stream:error><host-unknown xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text xmlns='urn:ietf:params:xml:ns:xmpp-streams'>callcontrol.ishaf.uw.is does not match any configured external components</text></stream:error>
Mar 12 16:14:08 jcp25a2b00 info component disconnected: nil (false)

Regards, Olafur

···

On 9.3.2018 15:54, Yang wrote:

Hi,

The order doesn't matter but on the default config file for meet, there isn't a comma at the end of the "muc: ...." line. That was the problem for me when I was trying to enable secure domain. But it seems that yours is different, it looks like the connection to Prosody is not working. Can you pastebin your prosody log too?

Cheers!

On Fri, Mar 9, 2018 at 9:53 AM Ólafur Jens Sigurðsson <ojs@sraf.is > <mailto:ojs@sraf.is>> wrote:

    Hi, yes that was there by default, I added the anonymousdomain
    keyword after the domain keyword and before the muc keyword. Does
    the order here matter?

    Best regards, Olafur

    On 9.3.2018 14:35, Yang wrote:

    When you added the anonymousdomain in the config file of meet
    under the folder /etc/jitsi/meet/, did you put a comma at the end
    of the line above it: "muc: 'conference.domain' *, *" ?

    On Fri, Mar 9, 2018 at 9:01 AM Damian Minkov >> <damencho@damencho.com <mailto:damencho@damencho.com>> wrote:

        Hi,

        The error you have pasted is from jigasi, which is
        responsible for dialin/dialout.
        You need to orovide browser js console log and jicofo logs,
        (restart jicofo, make a test, and provide the logs from the
        restart).

        Regards
        damencho

        On Mar 9, 2018 07:33, "Ólafur Jens Sigurðsson" <ojs@sraf.is >> <mailto:ojs@sraf.is>> wrote:

            Hello all

            I am new to Jitsi and have set up a server to host jitsi
            meetings. I set it up using packages from Linux Mint
            18.1. Upon install it worked fine but when I tried to
            make it secure so that not anyone can create meetings on
            my server then I can no longer create meetings. Upon
            creating a room I get the following message "Error, Oops!
            Something went wrong and we couldn't connect to the
            conference: connection.otherError". Looking at logs I see
            in /var/log/jitsi/jigasi.log the following error: SEVERE:
            [40] org.jitsi.meet.ComponentMain.call().278
            host-unknown, host:localhost, port:5347
            org.xmpp.component.ComponentException: host-unknown

            Now I am very new with Jitsi and don't know how all these
            components work together and was wondering where I should
            start to look for what is wrong with my configuration.

            To make the server secure I followed the instructions on
            https://github.com/jitsi/jicofo#secure-domain.

            Best regards, Olafur

            _______________________________________________
            users mailing list
            users@jitsi.org <mailto:users@jitsi.org>
            Unsubscribe instructions and other list options:
            http://lists.jitsi.org/mailman/listinfo/users

        _______________________________________________
        users mailing list
        users@jitsi.org <mailto:users@jitsi.org>
        Unsubscribe instructions and other list options:
        http://lists.jitsi.org/mailman/listinfo/users

    _______________________________________________
    users mailing list
    users@jitsi.org <mailto:users@jitsi.org>
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users

    _______________________________________________
    users mailing list
    users@jitsi.org <mailto:users@jitsi.org>
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Something (probably jigasi) is trying to connect as a component to "callcontrol.ishaf.uw.is", but prosody's configuration does not have a component for this host name.

Boris

···

On 12/03/2018 11:17, Ólafur Jens Sigurðsson wrote:

Hi sorry for taking so long, didn't have time to look at this until today.

The /var/log/prosody/prosody.log contains lots of these messages but no others:

Mar 12 16:14:08 jcp25a2b00 info Incoming Jabber component connection
Mar 12 16:14:08 mod_component info Disconnecting component, <stream:error> is: <stream:error><host-unknown xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text xmlns='urn:ietf:params:xml:ns:xmpp-streams'>callcontrol.ishaf.uw.is does not match any configured external components</text></stream:error>


#9

I grepped the /etc/jitsi/ directory for callcontr and the only hit I got was from /etc/jitsi/meet/ishaf.uw.is-config.js and that was commented out with two // so I have no idea why that hostname is being called.

Regards, Olafur

···

On 12.3.2018 16:43, Boris Grozev wrote:

On 12/03/2018 11:17, Ólafur Jens Sigurðsson wrote:

Hi sorry for taking so long, didn't have time to look at this until today.

The /var/log/prosody/prosody.log contains lots of these messages but no others:

Mar 12 16:14:08 jcp25a2b00 info Incoming Jabber component connection
Mar 12 16:14:08 mod_component info Disconnecting component, <stream:error> is: <stream:error><host-unknown xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text xmlns='urn:ietf:params:xml:ns:xmpp-streams'>callcontrol.ishaf.uw.is does not match any configured external components</text></stream:error>

Something (probably jigasi) is trying to connect as a component to "callcontrol.ishaf.uw.is", but prosody's configuration does not have a component for this host name.

Boris


#10

callcontrol is hard-coded in the init.d script in jigasi.

Boris

···

On 12/03/2018 12:01, Ólafur Jens Sigurðsson wrote:

I grepped the /etc/jitsi/ directory for callcontr and the only hit I got
was from /etc/jitsi/meet/ishaf.uw.is-config.js and that was commented
out with two // so I have no idea why that hostname is being called.


#11

Hi,

1. Were you using Jigasi before when you had no problem?
2. Can you post the "host: " and "bosh: " section of your
/etc/jitsi/meet/ishaf.uw.is-config.js?
3. What did you get when you type in "domain/http-bind" in your browser?

Cheer!

···

On Mon, Mar 12, 2018 at 1:03 PM Ólafur Jens Sigurðsson <ojs@sraf.is> wrote:

I grepped the /etc/jitsi/ directory for callcontr and the only hit I got
was from /etc/jitsi/meet/ishaf.uw.is-config.js and that was commented
out with two // so I have no idea why that hostname is being called.

Regards, Olafur

On 12.3.2018 16:43, Boris Grozev wrote:
> On 12/03/2018 11:17, Ólafur Jens Sigurðsson wrote:
>> Hi sorry for taking so long, didn't have time to look at this until
>> today.
>>
>> The /var/log/prosody/prosody.log contains lots of these messages but
>> no others:
>>
>> Mar 12 16:14:08 jcp25a2b00 info Incoming Jabber component
>> connection
>> Mar 12 16:14:08 mod_component info Disconnecting component,
>> <stream:error> is: <stream:error><host-unknown
>> xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text
>> xmlns='urn:ietf:params:xml:ns:xmpp-streams'>callcontrol.ishaf.uw.is
>> does not match any configured external components</text></stream:error>
>
> Something (probably jigasi) is trying to connect as a component to
> "callcontrol.ishaf.uw.is", but prosody's configuration does not have a
> component for this host name.
>
> Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#12

Hi, here is the host: section

 hosts: \{
     // XMPP domain\.
     domain: &#39;ishaf\.uw\.is&#39;,
     anonymousdomain: &#39;guest\.ishaf\.uw\.is&#39;,

     // XMPP MUC domain\. FIXME: use XEP\-0030 to discover it\.
     muc: &#39;conference\.ishaf\.uw\.is&#39;,

     // When using authentication, domain for guest users\.
     //anonymousdomain: &#39;guest\.example\.com&#39;,

     // Domain for authenticated users\. Defaults to &lt;domain&gt;\.
     //authdomain: &#39;ishaf\.uw\.is&#39;,

     // Jirecon recording component domain\.
     //jirecon: &#39;jirecon\.ishaf\.uw\.is&#39;,

     // Call control component \(Jigasi\)\.
     //call\_control: &#39;callcontrol\.ishaf\.uw\.is&#39;,

     // Focus component domain\. Defaults to focus\.&lt;domain&gt;\.
     //focus: &#39;focus\.ishaf\.uw\.is&#39;,
 \},

Here is the bosh: section

 bosh: &#39;//ishaf\.uw\.is/http\-bind&#39;,

When I go to https://ishaf.uw.is/http-bind I get a message saying that it works and telling me to point my BOSH client to this URL to connect to Prosody

Where do I configure that?

Regards, Olafur

···

On 12.3.2018 17:50, Yang wrote:

Hi,

1. Were you using Jigasi before when you had no problem?
2. Can you post the "host: " and "bosh: " section of your /etc/jitsi/meet/ishaf.uw.is-config.js?
3. What did you get when you type in "domain/http-bind" in your browser?

Cheer!

On Mon, Mar 12, 2018 at 1:03 PM Ólafur Jens Sigurðsson <ojs@sraf.is > <mailto:ojs@sraf.is>> wrote:

    I grepped the /etc/jitsi/ directory for callcontr and the only hit
    I got
    was from /etc/jitsi/meet/ishaf.uw.is-config.js and that was commented
    out with two // so I have no idea why that hostname is being called.

    Regards, Olafur

    On 12.3.2018 16:43, Boris Grozev wrote:
    > On 12/03/2018 11:17, Ólafur Jens Sigurðsson wrote:
    >> Hi sorry for taking so long, didn't have time to look at this until
    >> today.
    >>
    >> The /var/log/prosody/prosody.log contains lots of these
    messages but
    >> no others:
    >>
    >> Mar 12 16:14:08 jcp25a2b00 info Incoming Jabber component
    >> connection
    >> Mar 12 16:14:08 mod_component info Disconnecting component,
    >> <stream:error> is: <stream:error><host-unknown
    >> xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text
    >>
    xmlns='urn:ietf:params:xml:ns:xmpp-streams'>callcontrol.ishaf.uw.is
    <http://callcontrol.ishaf.uw.is>
    >> does not match any configured external
    components</text></stream:error>
    >
    > Something (probably jigasi) is trying to connect as a component to
    > "callcontrol.ishaf.uw.is <http://callcontrol.ishaf.uw.is>", but
    prosody's configuration does not have a
    > component for this host name.
    >
    > Boris

    _______________________________________________
    users mailing list
    users@jitsi.org <mailto:users@jitsi.org>
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#13

Hi, this is starting to work when I enabled the bosh module in prosody and added the following line to it:

bosh_ports = { "http-bind" }

Thank you for all the help :slight_smile:

Regards, Olafur

···

On 13.3.2018 10:13, Ólafur Jens Sigurðsson wrote:

Hi, here is the host: section

hosts: \{
    // XMPP domain\.
    domain: &#39;ishaf\.uw\.is&#39;,
    anonymousdomain: &#39;guest\.ishaf\.uw\.is&#39;,

    // XMPP MUC domain\. FIXME: use XEP\-0030 to discover it\.
    muc: &#39;conference\.ishaf\.uw\.is&#39;,

    // When using authentication, domain for guest users\.
    //anonymousdomain: &#39;guest\.example\.com&#39;,

    // Domain for authenticated users\. Defaults to &lt;domain&gt;\.
    //authdomain: &#39;ishaf\.uw\.is&#39;,

    // Jirecon recording component domain\.
    //jirecon: &#39;jirecon\.ishaf\.uw\.is&#39;,

    // Call control component \(Jigasi\)\.
    //call\_control: &#39;callcontrol\.ishaf\.uw\.is&#39;,

    // Focus component domain\. Defaults to focus\.&lt;domain&gt;\.
    //focus: &#39;focus\.ishaf\.uw\.is&#39;,
\},

Here is the bosh: section

bosh: &#39;//ishaf\.uw\.is/http\-bind&#39;,

When I go to https://ishaf.uw.is/http-bind I get a message saying that it works and telling me to point my BOSH client to this URL to connect to Prosody

Where do I configure that?

Regards, Olafur

On 12.3.2018 17:50, Yang wrote:

Hi,

1. Were you using Jigasi before when you had no problem?
2. Can you post the "host: " and "bosh: " section of your /etc/jitsi/meet/ishaf.uw.is-config.js?
3. What did you get when you type in "domain/http-bind" in your browser?

Cheer!

On Mon, Mar 12, 2018 at 1:03 PM Ólafur Jens Sigurðsson <ojs@sraf.is >> <mailto:ojs@sraf.is>> wrote:

    I grepped the /etc/jitsi/ directory for callcontr and the only
    hit I got
    was from /etc/jitsi/meet/ishaf.uw.is-config.js and that was commented
    out with two // so I have no idea why that hostname is being called.

    Regards, Olafur

    On 12.3.2018 16:43, Boris Grozev wrote:
    > On 12/03/2018 11:17, Ólafur Jens Sigurðsson wrote:
    >> Hi sorry for taking so long, didn't have time to look at this
    until
    >> today.
    >>
    >> The /var/log/prosody/prosody.log contains lots of these
    messages but
    >> no others:
    >>
    >> Mar 12 16:14:08 jcp25a2b00 info Incoming Jabber component
    >> connection
    >> Mar 12 16:14:08 mod_component info Disconnecting component,
    >> <stream:error> is: <stream:error><host-unknown
    >> xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text
    >>
    xmlns='urn:ietf:params:xml:ns:xmpp-streams'>callcontrol.ishaf.uw.is
    <http://callcontrol.ishaf.uw.is>
    >> does not match any configured external
    components</text></stream:error>
    >
    > Something (probably jigasi) is trying to connect as a component to
    > "callcontrol.ishaf.uw.is <http://callcontrol.ishaf.uw.is>", but
    prosody's configuration does not have a
    > component for this host name.
    >
    > Boris

    _______________________________________________
    users mailing list
    users@jitsi.org <mailto:users@jitsi.org>
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users