[jitsi-users] screen sharing dosn't work on virtual machine environment


#1

hi, guy

Recently, I found jitsi's scree sharing didn't work on virtual machine.
I google it and try to find the resolution but i can't find the anwser.

the only tip is that
http://lists.jitsi.org/pipermail/users/2014-June/007333.html
==================================mail detail BEGIN==================================
Hi

I am having trouble testing jitsi's screen share over VM(VMware/Hyper-V)
guest OS
environments and like to know if this is an issue or limitation. My testing
environment and results
are as follows.

···

----------------------------------------
[Environment]

- Server side: openfire + jitsi video-bridge plugin (both latest release)
- Client side : Windows7Pro SP1 + jitsi (latest release)
- Network: same IP address segment (no firewalls)

Using Same Client OSs + jitsi client, I've tested screen sharing on
following pattern
(DesktopPC means normal PC(no virtual machine))

1) Desktop PC1 <-> Desktop PC2
2) Desktop PC1 <-> VM guest2(Vmware/Hyper-V)
3) VM guest1 <-> VM guest2

[Results]

1) screen sharing OK on both sides.
2) VM guest2 -> Desktop PC1 screen sharing is OK
       Desktop PC1 -> VM guest2 sceen sharing is NG ( black screen)
3) screen sharing NG on both sides (black screen).

#tested over couple VMware/Hyper-V version, but results are the same.

-------------------------------------------

On VM guest environment, it seems

- encoding it's own screen and sending capability works OK
- receiving and decoding capabilty have issues (or limitation)

I suspect some DirectX(DirectShow/Direct3D) limitation on VMs...

Any clues, suggestion, workaround is appreciated

Best Regards,
Toru HIROSE
==================================mail END==================================

the same issue post 2 years agao, but there is no any reply.

I believe i have encountered the same problem, and further more
I tried any other popular virual environment including KVM/XEN(hvm and pv) with ubuntu guest or WIN7 guest,
it has the same problem.

So, Is there something wrong in jitsi?

Any clues, suggestion, workaround is appreciated

--
Best regards.
Li Zhijian


#2

Add Toru HIROSE

Hi Toru HIROSE

Have you found the solution of this issue ?

Best regards.
Li Zhijian

···

On 02/18/2016 01:42 PM, Li Zhijian wrote:

hi, guy

Recently, I found jitsi's scree sharing didn't work on virtual machine.
I google it and try to find the resolution but i can't find the anwser.

the only tip is that
http://lists.jitsi.org/pipermail/users/2014-June/007333.html
==================================mail detail BEGIN==================================
Hi

I am having trouble testing jitsi's screen share over VM(VMware/Hyper-V)
guest OS
environments and like to know if this is an issue or limitation. My testing
environment and results
are as follows.

----------------------------------------
[Environment]

- Server side: openfire + jitsi video-bridge plugin (both latest release)
- Client side : Windows7Pro SP1 + jitsi (latest release)
- Network: same IP address segment (no firewalls)

Using Same Client OSs + jitsi client, I've tested screen sharing on
following pattern
(DesktopPC means normal PC(no virtual machine))

1) Desktop PC1 <-> Desktop PC2
2) Desktop PC1 <-> VM guest2(Vmware/Hyper-V)
3) VM guest1 <-> VM guest2

[Results]

1) screen sharing OK on both sides.
2) VM guest2 -> Desktop PC1 screen sharing is OK
       Desktop PC1 -> VM guest2 sceen sharing is NG ( black screen)
3) screen sharing NG on both sides (black screen).

#tested over couple VMware/Hyper-V version, but results are the same.

-------------------------------------------

On VM guest environment, it seems

- encoding it's own screen and sending capability works OK
- receiving and decoding capabilty have issues (or limitation)

I suspect some DirectX(DirectShow/Direct3D) limitation on VMs...

Any clues, suggestion, workaround is appreciated

Best Regards,
Toru HIROSE
==================================mail END==================================

the same issue post 2 years agao, but there is no any reply.

I believe i have encountered the same problem, and further more
I tried any other popular virual environment including KVM/XEN(hvm and pv) with ubuntu guest or WIN7 guest,
it has the same problem.

So, Is there something wrong in jitsi?

Any clues, suggestion, workaround is appreciated


#3

PING...

Is this is a known issue/BUG ?

or if I miss something, pls tell me.

Thanks

Li Zhijian

···

On 02/18/2016 02:13 PM, Li Zhijian wrote:

Add Toru HIROSE

Hi Toru HIROSE

Have you found the solution of this issue ?

Best regards.
Li Zhijian

On 02/18/2016 01:42 PM, Li Zhijian wrote:

hi, guy

Recently, I found jitsi's scree sharing didn't work on virtual machine.
I google it and try to find the resolution but i can't find the anwser.

the only tip is that
http://lists.jitsi.org/pipermail/users/2014-June/007333.html
==================================mail detail BEGIN==================================
Hi

I am having trouble testing jitsi's screen share over VM(VMware/Hyper-V)
guest OS
environments and like to know if this is an issue or limitation. My testing
environment and results
are as follows.

----------------------------------------
[Environment]

- Server side: openfire + jitsi video-bridge plugin (both latest release)
- Client side : Windows7Pro SP1 + jitsi (latest release)
- Network: same IP address segment (no firewalls)

Using Same Client OSs + jitsi client, I've tested screen sharing on
following pattern
(DesktopPC means normal PC(no virtual machine))

1) Desktop PC1 <-> Desktop PC2
2) Desktop PC1 <-> VM guest2(Vmware/Hyper-V)
3) VM guest1 <-> VM guest2

[Results]

1) screen sharing OK on both sides.
2) VM guest2 -> Desktop PC1 screen sharing is OK
       Desktop PC1 -> VM guest2 sceen sharing is NG ( black screen)
3) screen sharing NG on both sides (black screen).

#tested over couple VMware/Hyper-V version, but results are the same.

-------------------------------------------

On VM guest environment, it seems

- encoding it's own screen and sending capability works OK
- receiving and decoding capabilty have issues (or limitation)

I suspect some DirectX(DirectShow/Direct3D) limitation on VMs...

Any clues, suggestion, workaround is appreciated

Best Regards,
Toru HIROSE
==================================mail END==================================

the same issue post 2 years agao, but there is no any reply.

I believe i have encountered the same problem, and further more
I tried any other popular virual environment including KVM/XEN(hvm and pv) with ubuntu guest or WIN7 guest,
it has the same problem.

So, Is there something wrong in jitsi?

Any clues, suggestion, workaround is appreciated

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Hi, guys

a good news about this issue:

jitsi's screen sharing works in kvm with passthrough graphic card.

so, it seems that the default virtualized graphic card of kvm/xen/vmware/hyper-v
is not support some features which is needed by jitsi's screen sharing.
if someone knows the features, pls tell me.

thanks

···

On 02/22/2016 02:14 PM, Li Zhijian wrote:

PING...

Is this is a known issue/BUG ?

or if I miss something, pls tell me.

Thanks

Li Zhijian

On 02/18/2016 02:13 PM, Li Zhijian wrote:

Add Toru HIROSE

Hi Toru HIROSE

Have you found the solution of this issue ?

Best regards.
Li Zhijian

On 02/18/2016 01:42 PM, Li Zhijian wrote:

hi, guy

Recently, I found jitsi's scree sharing didn't work on virtual machine.
I google it and try to find the resolution but i can't find the anwser.

the only tip is that
http://lists.jitsi.org/pipermail/users/2014-June/007333.html
==================================mail detail BEGIN==================================
Hi

I am having trouble testing jitsi's screen share over VM(VMware/Hyper-V)
guest OS
environments and like to know if this is an issue or limitation. My testing
environment and results
are as follows.

----------------------------------------
[Environment]

- Server side: openfire + jitsi video-bridge plugin (both latest release)
- Client side : Windows7Pro SP1 + jitsi (latest release)
- Network: same IP address segment (no firewalls)

Using Same Client OSs + jitsi client, I've tested screen sharing on
following pattern
(DesktopPC means normal PC(no virtual machine))

1) Desktop PC1 <-> Desktop PC2
2) Desktop PC1 <-> VM guest2(Vmware/Hyper-V)
3) VM guest1 <-> VM guest2

[Results]

1) screen sharing OK on both sides.
2) VM guest2 -> Desktop PC1 screen sharing is OK
       Desktop PC1 -> VM guest2 sceen sharing is NG ( black screen)
3) screen sharing NG on both sides (black screen).

#tested over couple VMware/Hyper-V version, but results are the same.

-------------------------------------------

On VM guest environment, it seems

- encoding it's own screen and sending capability works OK
- receiving and decoding capabilty have issues (or limitation)

I suspect some DirectX(DirectShow/Direct3D) limitation on VMs...

Any clues, suggestion, workaround is appreciated

Best Regards,
Toru HIROSE
==================================mail END==================================

the same issue post 2 years agao, but there is no any reply.

I believe i have encountered the same problem, and further more
I tried any other popular virual environment including KVM/XEN(hvm and pv) with ubuntu guest or WIN7 guest,
it has the same problem.

So, Is there something wrong in jitsi?

Any clues, suggestion, workaround is appreciated

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users