[jitsi-users] Screen sharing debugging


#1

Hello,

I have a Jitsi Meet instance running well, but on which screen sharing doesn't. The button doesn't ask for plugin installation on Chrome (49.0.2623.110 m), and doesn't even appear on Firefox (45.0.1).

I looked at the online (meet.jit.si) configuration and tried several things, but the parameters seems to have changed between my version and meet.jit.si one.

I am running the 09/03/2016 delivery :
- jicofo_1.0-217-1_amd64.deb
- jitsi-meet_1.0.860-1_all.deb
- jitsi-meet-prosody_1.0.860-1_all.deb
- jitsi-videobridge_677-1_amd64.deb

Any suggestion ?

David


#2

Check the javascript console for errors or messages when you press the button, and post your config.js.

Regards,
Boris

···

On 06/04/16 09:27, David Mézière wrote:

Hello,

I have a Jitsi Meet instance running well, but on which screen sharing
doesn't. The button doesn't ask for plugin installation on Chrome
(49.0.2623.110 m), and doesn't even appear on Firefox (45.0.1).

I looked at the online (meet.jit.si) configuration and tried several
things, but the parameters seems to have changed between my version and
meet.jit.si one.

I am running the 09/03/2016 delivery :
- jicofo_1.0-217-1_amd64.deb
- jitsi-meet_1.0.860-1_all.deb
- jitsi-meet-prosody_1.0.860-1_all.deb
- jitsi-videobridge_677-1_amd64.deb

Any suggestion ?


#3

Boris,

I didn't see at first this line in the console at click :

[/modules/RTC/ScreenObtainer.js] <Object.onFailure>: Failed to install the extension Installs can only be initiated by one of the Chrome Web Store item's verified sites.

And here is the correspondig portion of my config.js, restaured to defaults :

     desktopSharingChromeMethod: 'ext',
     desktopSharingChromeExtId: 'diibjkoicjeejcmhdnailmkgecihlobk',
     desktopSharingChromeSources: ['screen', 'window'],
     desktopSharingChromeMinExtVersion: '0.1',
     desktopSharingFirefoxExtId: null,
     desktopSharingFirefoxDisabled: true,
     desktopSharingFirefoxMaxVersionExtRequired: -1,
     desktopSharingFirefoxExtensionURL: null,

David

···

Le 06/04/2016 16:43, Boris Grozev a écrit :

On 06/04/16 09:27, David Mézière wrote:

Hello,

I have a Jitsi Meet instance running well, but on which screen sharing
doesn't. The button doesn't ask for plugin installation on Chrome
(49.0.2623.110 m), and doesn't even appear on Firefox (45.0.1).

I looked at the online (meet.jit.si) configuration and tried several
things, but the parameters seems to have changed between my version and
meet.jit.si one.

I am running the 09/03/2016 delivery :
- jicofo_1.0-217-1_amd64.deb
- jitsi-meet_1.0.860-1_all.deb
- jitsi-meet-prosody_1.0.860-1_all.deb
- jitsi-videobridge_677-1_amd64.deb

Any suggestion ?

Check the javascript console for errors or messages when you press the button, and post your config.js.

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

That's the extension for meet.jit.si. You need to create your own (with your own domain):
https://github.com/jitsi/jidesha/tree/master/chrome

Boris

···

On 06/04/16 10:28, David Mézière wrote:

Boris,

I didn't see at first this line in the console at click :

[/modules/RTC/ScreenObtainer.js] <Object.onFailure>: Failed to install
the extension Installs can only be initiated by one of the Chrome Web
Store item's verified sites.

And here is the correspondig portion of my config.js, restaured to
defaults :

      desktopSharingChromeMethod: 'ext',
      desktopSharingChromeExtId: 'diibjkoicjeejcmhdnailmkgecihlobk',


#5

Hi,

Desktop sharing extension with id diibjkoicjeejcmhdnailmkgecihlobk is
enabled for domain meet.jit.si. You need to create a jidesha extension
for your domain it is described in the project how to do it and you
need to upload it to chrome web store and use the newly generated id
for your extension and put it in your config.
You also need to create FF extension for your domain and configure it,
again jidesha project.

Regards
damencho

···

On Wed, Apr 6, 2016 at 10:28 AM, David Mézière <d.meziere@immanens.com> wrote:

Boris,

I didn't see at first this line in the console at click :

[/modules/RTC/ScreenObtainer.js] <Object.onFailure>: Failed to install the
extension Installs can only be initiated by one of the Chrome Web Store
item's verified sites.

And here is the correspondig portion of my config.js, restaured to defaults
:

    desktopSharingChromeMethod: 'ext',
    desktopSharingChromeExtId: 'diibjkoicjeejcmhdnailmkgecihlobk',
    desktopSharingChromeSources: ['screen', 'window'],
    desktopSharingChromeMinExtVersion: '0.1',
    desktopSharingFirefoxExtId: null,
    desktopSharingFirefoxDisabled: true,
    desktopSharingFirefoxMaxVersionExtRequired: -1,
    desktopSharingFirefoxExtensionURL: null,

David

Le 06/04/2016 16:43, Boris Grozev a écrit :

On 06/04/16 09:27, David Mézière wrote:

Hello,

I have a Jitsi Meet instance running well, but on which screen sharing
doesn't. The button doesn't ask for plugin installation on Chrome
(49.0.2623.110 m), and doesn't even appear on Firefox (45.0.1).

I looked at the online (meet.jit.si) configuration and tried several
things, but the parameters seems to have changed between my version and
meet.jit.si one.

I am running the 09/03/2016 delivery :
- jicofo_1.0-217-1_amd64.deb
- jitsi-meet_1.0.860-1_all.deb
- jitsi-meet-prosody_1.0.860-1_all.deb
- jitsi-videobridge_677-1_amd64.deb

Any suggestion ?

Check the javascript console for errors or messages when you press the
button, and post your config.js.

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

Oh, thanks !

···

Le 06/04/2016 17:43, Boris Grozev a écrit :

On 06/04/16 10:28, David Mézière wrote:

Boris,

I didn't see at first this line in the console at click :

[/modules/RTC/ScreenObtainer.js] <Object.onFailure>: Failed to install
the extension Installs can only be initiated by one of the Chrome Web
Store item's verified sites.

And here is the correspondig portion of my config.js, restaured to
defaults :

      desktopSharingChromeMethod: 'ext',
      desktopSharingChromeExtId: 'diibjkoicjeejcmhdnailmkgecihlobk',

That's the extension for meet.jit.si. You need to create your own (with your own domain):
https://github.com/jitsi/jidesha/tree/master/chrome

Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

Thank you !

···

Le 06/04/2016 17:45, Damian Minkov a écrit :

Hi,

Desktop sharing extension with id diibjkoicjeejcmhdnailmkgecihlobk is
enabled for domain meet.jit.si. You need to create a jidesha extension
for your domain it is described in the project how to do it and you
need to upload it to chrome web store and use the newly generated id
for your extension and put it in your config.
You also need to create FF extension for your domain and configure it,
again jidesha project.

Regards
damencho

On Wed, Apr 6, 2016 at 10:28 AM, David Mézière <d.meziere@immanens.com> wrote:

Boris,

I didn't see at first this line in the console at click :

[/modules/RTC/ScreenObtainer.js] <Object.onFailure>: Failed to install the
extension Installs can only be initiated by one of the Chrome Web Store
item's verified sites.

And here is the correspondig portion of my config.js, restaured to defaults
:

     desktopSharingChromeMethod: 'ext',
     desktopSharingChromeExtId: 'diibjkoicjeejcmhdnailmkgecihlobk',
     desktopSharingChromeSources: ['screen', 'window'],
     desktopSharingChromeMinExtVersion: '0.1',
     desktopSharingFirefoxExtId: null,
     desktopSharingFirefoxDisabled: true,
     desktopSharingFirefoxMaxVersionExtRequired: -1,
     desktopSharingFirefoxExtensionURL: null,

David

Le 06/04/2016 16:43, Boris Grozev a écrit :

On 06/04/16 09:27, David Mézière wrote:

Hello,

I have a Jitsi Meet instance running well, but on which screen sharing
doesn't. The button doesn't ask for plugin installation on Chrome
(49.0.2623.110 m), and doesn't even appear on Firefox (45.0.1).

I looked at the online (meet.jit.si) configuration and tried several
things, but the parameters seems to have changed between my version and
meet.jit.si one.

I am running the 09/03/2016 delivery :
- jicofo_1.0-217-1_amd64.deb
- jitsi-meet_1.0.860-1_all.deb
- jitsi-meet-prosody_1.0.860-1_all.deb
- jitsi-videobridge_677-1_amd64.deb

Any suggestion ?

Check the javascript console for errors or messages when you press the
button, and post your config.js.

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users