[jitsi-users] Saving password does not work


#1

Hi all,

I have jitsi for desktop on a laptop Win7, 64 bit, current version.
I have several different linphone accounts (and therefore also several different user groups, in which I store my contacts).

Everything is working quite fine, BUT:
Although I entered the linphone password in the settings and ticked the box "save password", jitsi "forgets" this password! Whenever I start jitsi again, it is telling me that it needs the password to connect to the chosen account.
I have no clue, what to do to avoid that I have to reenter the password every time again and again.

A similar "bug" can be seen with the saved groups. If I change the account (why on earth do I have to close jitsi and start it again for this?), every now and then the groups together with the saved contacts get lost.
This behaviour is far from being professional.

Gerald


#2

since you are using linphone I guess you are talking about SIP account(s) but not XMPP?
which SIP provider you are using? I am using sip2sip on Jitsi Desktop (now latest nb 2.11.5601 on Mac) and the problems you described did so far not occur.
br, MS

ยทยทยท

On November 23, 2017 2:12:26 PM GMT+01:00, traumwundervoll@gmx.de wrote:

Hi all,

I have jitsi for desktop on a laptop Win7, 64 bit, current version.
I have several different linphone accounts (and therefore also several
different user groups, in which I store my contacts).

Everything is working quite fine, BUT:
Although I entered the linphone password in the settings and ticked the
box "save password", jitsi "forgets" this password! Whenever I start
jitsi again, it is telling me that it needs the password to connect to
the chosen account.
I have no clue, what to do to avoid that I have to reenter the password
every time again and again.

A similar "bug" can be seen with the saved groups. If I change the
account (why on earth do I have to close jitsi and start it again for
this?), every now and then the groups together with the saved contacts
get lost.
This behaviour is far from being professional.

Gerald

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Sent from my Android phone with K-9 Mail. Please excuse my brevity.


#3

I have jitsi for desktop on a laptop Win7, 64 bit, current version.
I have several different linphone accounts (and therefore also several
different user groups, in which I store my contacts).

Everything is working quite fine, BUT:
Although I entered the linphone password in the settings and ticked the box
"save password", jitsi "forgets" this password!

Whenever I start jitsi again,
it is telling me that it needs the password to connect to the chosen account.
I have no clue, what to do to avoid that I have to reenter the password every
time again and again.

There have been reports of this before, but I wasn't able to pin it down. AFAIK it can happen if the server incorrectly answers to a register with 403 (Forbidden) instead of 401 (Unauthorized).

Logs (https://jitsi.org/logs) may help.

A similar "bug" can be seen with the saved groups. If I change the account
(why on earth do I have to close jitsi and start it again for this?),

Uhm what? Not sure I follow. There are very few reason Jitsi requires a restart, reconfiguring or choosing accounts is definitely not one of them.

every
now and then the groups together with the saved contacts get lost.

There's a bug somewhere. I haven't found it yet since it's not reproducible.

This behaviour is far from being professional.

Haha, please look in the next mirror.

I maintain Jitsi Desktop in my spare time. Sentences like these are not something making me want to continue.

Gerald

Ingo