[jitsi-users] Rocket.chat & jitsi


#1

Hello guys,
I have Rocket.Chat installed and meet.jit.si locally on an Ubuntu machine.
I can start the video conference but screen sharing doesn't work:
"permission denied. Failed to install desktop sharing extension". The
extension is installed in chrome and added in the config (the id). When i'm
using the meet.jit.si online server everything works great. Please help me
eith this issue.

Regards,
Petro


#2

A extension is required for each domain you wish to whitelist, the one in the Google store only works for meet.jit.si. You can create one for your own domain by forking ours: https://github.com/jitsi/jidesha

Cheers,

···

On Aug 16, 2017, at 14:50, Petro Morosanu <petromorosanu1977@gmail.com> wrote:

Hello guys,
I have Rocket.Chat installed and meet.jit.si locally on an Ubuntu machine. I can start the video conference but screen sharing doesn't work: "permission denied. Failed to install desktop sharing extension". The extension is installed in chrome and added in the config (the id). When i'm using the meet.jit.si online server everything works great. Please help me eith this issue.

--
Saúl


#3

Hello Saul and thank you for your email,

I already did what you said with Desktop Capture, Jitsi Meetings, My Easy
Meeting, Rocket.Chat Screen Share extensions in Chrome and it didn't work.
Still the same error. Any other idea?

Thank you and regards,
Petronel Morosanu

···

On Thu, Aug 17, 2017 at 10:43 AM, Saúl Ibarra Corretgé < scorretge@atlassian.com> wrote:

> On Aug 16, 2017, at 14:50, Petro Morosanu <petromorosanu1977@gmail.com> > wrote:
>
> Hello guys,
> I have Rocket.Chat installed and meet.jit.si locally on an Ubuntu
machine. I can start the video conference but screen sharing doesn't work:
"permission denied. Failed to install desktop sharing extension". The
extension is installed in chrome and added in the config (the id). When i'm
using the meet.jit.si online server everything works great. Please help
me eith this issue.
>

A extension is required for each domain you wish to whitelist, the one in
the Google store only works for meet.jit.si. You can create one for your
own domain by forking ours: https://github.com/jitsi/jidesha

Cheers,

--
Saúl

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Hi Petronel

Does screen sharing work in Chrome?

Sean.

···

On Thu, Aug 17, 2017 at 10:43 AM, Saúl Ibarra Corretgé
scorretge@atlassian.com wrote:

On Aug 16, 2017, at 14:50, Petro Morosanu petromorosanu1977@gmail.com wrote:

Hello guys,

I have Rocket.Chat installed and
meet.jit.si
locally on an Ubuntu machine. I can start the video conference but screen sharing doesn’t work: “permission denied. Failed to install desktop sharing extension”. The extension is installed in chrome and added in the config (the id). When i’m using the meet.jit.si online server everything works great. Please help me eith this issue.

A extension is required for each domain you wish to whitelist, the one in the Google store only works for meet.jit.si. You can create one for your own domain by forking ours: https://github.com/jitsi/jidesha

Cheers,

Saúl


users mailing list

users@jitsi.org

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/users


#5

Hello Sean, no it doesn't. I installed the extension in Chrome (4 types of
e tensions) paste the id in config of jitsi.

Hi Petronel

Does screen sharing work in Chrome?

Sean.
Hello Saul and thank you for your email,

I already did what you said with Desktop Capture, Jitsi Meetings, My Easy
Meeting, Rocket.Chat Screen Share extensions in Chrome and it didn't work.
Still the same error. Any other idea?

Thank you and regards,
Petronel Morosanu

···

On 17 Aug 2017 13:48, "Hurley, Sean" <shurley@mcmaster.ca> wrote:
On Aug 17, 2017 6:56 AM, Petro Morosanu <petromorosanu1977@gmail.com> wrote:

On Thu, Aug 17, 2017 at 10:43 AM, Saúl Ibarra Corretgé < scorretge@atlassian.com> wrote:

> On Aug 16, 2017, at 14:50, Petro Morosanu <petromorosanu1977@gmail.com> > wrote:
>
> Hello guys,
> I have Rocket.Chat installed and meet.jit.si locally on an Ubuntu
machine. I can start the video conference but screen sharing doesn't work:
"permission denied. Failed to install desktop sharing extension". The
extension is installed in chrome and added in the config (the id). When i'm
using the meet.jit.si online server everything works great. Please help
me eith this issue.
>

A extension is required for each domain you wish to whitelist, the one in
the Google store only works for meet.jit.si. You can create one for your
own domain by forking ours: https://github.com/jitsi/jidesha

Cheers,

--
Saúl

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

It won’t work if you install random extensions from other people. You need one for **your own** domain. Please read the README: https://github.com/jitsi/jidesha/blob/master/chrome/README.md

Cheers,

···

On Aug 17, 2017, at 12:55, Petro Morosanu <petromorosanu1977@gmail.com> wrote:

Hello Saul and thank you for your email,

I already did what you said with Desktop Capture, Jitsi Meetings, My Easy Meeting, Rocket.Chat Screen Share extensions in Chrome and it didn't work. Still the same error. Any other idea?

--
Saúl


#7

Yes I saw this README, but I think I don't understand something:
"Each Jitsi Meet installation needs a customised extension. There is only
one small JSON file to adapt. You have to create the extension and
distribute it, either through Google's Chrome Web Store or by telling your
users how to install the CRX file.
<https://github.com/jitsi/jidesha/blob/master/chrome/README.md#create-the-extension>Create
the extension

Edit the manifest.json file. You must adapt the externally_connectable URL:

"matches": [
    "*://your.server.com/*"
]

So, from where I get this manifest.json file, because until now I did
it this way: I installed the extension in Chrome, went to the location
where the files of the extension are located, change the manifest.json
file, make the CRX file, install in extensions and change the config
in jitsi meet. Is this the right procedure?

Thank you

···

On Thu, Aug 17, 2017 at 2:31 PM, Saúl Ibarra Corretgé < scorretge@atlassian.com> wrote:

> On Aug 17, 2017, at 12:55, Petro Morosanu <petromorosanu1977@gmail.com> > wrote:
>
> Hello Saul and thank you for your email,
>
> I already did what you said with Desktop Capture, Jitsi Meetings, My
Easy Meeting, Rocket.Chat Screen Share extensions in Chrome and it didn't
work. Still the same error. Any other idea?
>

It won’t work if you install random extensions from other people. You need
one for **your own** domain. Please read the README:
https://github.com/jitsi/jidesha/blob/master/chrome/README.md

Cheers,

--
Saúl

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Hi

I tried also and it does not work for me for my site

the chrome extension i tried is available here:

https://github.com/jitsi/jidesha

you have do download the entire tree source

there is also the calendar extension that is a more complete one, but i tried to compile it into a crx extension with my site and it does not work for me too.

Instead the original extension jitsi meetings works fine with the https://meet.jit.si/ site.

so I guess it is an error in configuration of my server.

when I add the generated ID to the server :

// The ID of the jidesha extension for Chrome.
     desktopSharingChromeExtId: *omikhipjhdfmdnemgfifenclnmaphebc*,
     // Whether desktop sharing should be disabled on Chrome.
     desktopSharingChromeDisabled: false,
     // The media sources to use when using screen sharing with the Chrome
     // extension.
     desktopSharingChromeSources: ['screen', 'window', 'tab'],
     // Required version of Chrome extension
     desktopSharingChromeMinExtVersion: '0.1',

and I restart the jicofo service, I got a blank screen

Paolo

···

On 08/17/2017 06:14 PM, Petro Morosanu wrote:

Yes I saw this README, but I think I don't understand something:
"Each Jitsi Meet installation needs a customised extension. There is only one small JSON file to adapt. You have to create the extension and distribute it, either through Google's Chrome Web Store or by telling your users how to install the CRX file.

      Create the extension

Edit the |manifest.json| file. You must adapt the |externally_connectable| URL:

>"matches": [ "*://your.server.com/* <http://your.server.com/*>" ]|
>So, from where I get this manifest.json file, because until now I did it this way: I installed the extension in Chrome, went to the location where the files of the extension are located, change the manifest.json file, make the CRX file, install in extensions and change the config in jitsi meet. Is this the right procedure?|
>Thank you|

On Thu, Aug 17, 2017 at 2:31 PM, Saúl Ibarra Corretgé <scorretge@atlassian.com <mailto:scorretge@atlassian.com>> wrote:

    > On Aug 17, 2017, at 12:55, Petro Morosanu <petromorosanu1977@gmail.com <mailto:petromorosanu1977@gmail.com>> wrote:
    >
    > Hello Saul and thank you for your email,
    >
    > I already did what you said with Desktop Capture, Jitsi Meetings, My Easy Meeting, Rocket.Chat Screen Share extensions in Chrome and it didn't work. Still the same error. Any other idea?
    >

    It won’t work if you install random extensions from other people. You need one for **your own** domain. Please read the README: https://github.com/jitsi/jidesha/blob/master/chrome/README.md

    Cheers,

    --
    Saúl


#9

Hi
I opened an issue and the developer replied that the error for me was the missing single quotes around the ID

desktopSharingChromeExtId: *'omikhipjhdfmdnemgfifenclnmaphebc*',

This solves my problem.
Paolo

···

On 08/18/2017 11:56 AM, Paolo Marcheschi wrote:

Hi

I tried also and it does not work for me for my site

the chrome extension i tried is available here:

https://github.com/jitsi/jidesha

you have do download the entire tree source

there is also the calendar extension that is a more complete one, but i tried to compile it into a crx extension with my site and it does not work for me too.

Instead the original extension jitsi meetings works fine with the https://meet.jit.si/ site.

so I guess it is an error in configuration of my server.

when I add the generated ID to the server :

// The ID of the jidesha extension for Chrome.
    desktopSharingChromeExtId: *omikhipjhdfmdnemgfifenclnmaphebc*,
    // Whether desktop sharing should be disabled on Chrome.
    desktopSharingChromeDisabled: false,
    // The media sources to use when using screen sharing with the Chrome
    // extension.
    desktopSharingChromeSources: ['screen', 'window', 'tab'],
    // Required version of Chrome extension
    desktopSharingChromeMinExtVersion: '0.1',

and I restart the jicofo service, I got a blank screen

Paolo

On 08/17/2017 06:14 PM, Petro Morosanu wrote:

Yes I saw this README, but I think I don't understand something:
"Each Jitsi Meet installation needs a customised extension. There is only one small JSON file to adapt. You have to create the extension and distribute it, either through Google's Chrome Web Store or by telling your users how to install the CRX file.

      Create the extension

Edit the |manifest.json| file. You must adapt the |externally_connectable| URL:

>"matches": [ "*://your.server.com/* <http://your.server.com/*>" ]|
>So, from where I get this manifest.json file, because until now I did it this way: I installed the extension in Chrome, went to the location where the files of the extension are located, change the manifest.json file, make the CRX file, install in extensions and change the config in jitsi meet. Is this the right procedure?|
>Thank you|

On Thu, Aug 17, 2017 at 2:31 PM, Saúl Ibarra Corretgé <scorretge@atlassian.com <mailto:scorretge@atlassian.com>> wrote:

    > On Aug 17, 2017, at 12:55, Petro Morosanu <petromorosanu1977@gmail.com <mailto:petromorosanu1977@gmail.com>> wrote:
    >
    > Hello Saul and thank you for your email,
    >
    > I already did what you said with Desktop Capture, Jitsi Meetings, My Easy Meeting, Rocket.Chat Screen Share extensions in Chrome and it didn't work. Still the same error. Any other idea?
    >

    It won’t work if you install random extensions from other people. You need one for **your own** domain. Please read the README: https://github.com/jitsi/jidesha/blob/master/chrome/README.md

    Cheers,

    --
    Saúl


#10

Hi
I opened an issue and the developer replied that the error for me was the missing single quotes around the ID

desktopSharingChromeExtId: 'omikhipjhdfmdnemgfifenclnmaphebc',

This solves my problem.

Yeah, that developer is a cool guy :wink:

···

On Aug 18, 2017, at 13:47, Paolo Marcheschi <paolo.marcheschi@ftgm.it> wrote:

Paolo
On 08/18/2017 11:56 AM, Paolo Marcheschi wrote:

Hi
I tried also and it does not work for me for my site

the chrome extension i tried is available here:

https://github.com/jitsi/jidesha[github.com]

you have do download the entire tree source
there is also the calendar extension that is a more complete one, but i tried to compile it into a crx extension with my site and it does not work for me too.

Instead the original extension jitsi meetings works fine with the https://meet.jit.si/[meet.jit.si] site.

so I guess it is an error in configuration of my server.

when I add the generated ID to the server :

// The ID of the jidesha extension for Chrome.
    desktopSharingChromeExtId: omikhipjhdfmdnemgfifenclnmaphebc,
    // Whether desktop sharing should be disabled on Chrome.
    desktopSharingChromeDisabled: false,
    // The media sources to use when using screen sharing with the Chrome
    // extension.
    desktopSharingChromeSources: ['screen', 'window', 'tab'],
    // Required version of Chrome extension
    desktopSharingChromeMinExtVersion: '0.1',

and I restart the jicofo service, I got a blank screen
Paolo

On 08/17/2017 06:14 PM, Petro Morosanu wrote:

Yes I saw this README, but I think I don't understand something:
"Each Jitsi Meet installation needs a customised extension. There is only one small JSON file to adapt. You have to create the extension and distribute it, either through Google's Chrome Web Store or by telling your users how to install the CRX file.
Create the extension

Edit the manifest.json file. You must adapt the externally_connectable URL:

"matches": [
    "*://
your.server.com/*[your.server.com]
"
]

So, from where I get this manifest.json file, because until now I did it this way: I installed the extension in Chrome, went to the location where the files of the extension are located, change the manifest.json file, make the CRX file, install in extensions and change the config in jitsi meet. Is this the right procedure?
Thank you

On Thu, Aug 17, 2017 at 2:31 PM, Saúl Ibarra Corretgé <scorretge@atlassian.com> wrote:

> On Aug 17, 2017, at 12:55, Petro Morosanu <petromorosanu1977@gmail.com> wrote:
>
> Hello Saul and thank you for your email,
>
> I already did what you said with Desktop Capture, Jitsi Meetings, My Easy Meeting, Rocket.Chat Screen Share extensions in Chrome and it didn't work. Still the same error. Any other idea?
>

It won’t work if you install random extensions from other people. You need one for **your own** domain. Please read the README: https://github.com/jitsi/jidesha/blob/master/chrome/README.md[github.com]

Cheers,

--
Saúl

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.jitsi.org_mailman_listinfo_users&d=DwIGaQ&c=wBUwXtM9sKhff6UeHOQgvw&r=-T6Cew-S4Ei-6rhDWu1AY-o1ETORq5uAicdns9fSwgI&m=xWwTY2CQrlvIpYqlwt0jueVsffBiKEiFIqQmE98Fm8o&s=cIEX_auuE9BeC5wqpFILR0swqor0Fo7juW8KUYfNM_M&e=

--
Saúl


#11

Yes indeed , :-D.

Paolo

···

On 08/18/2017 04:50 PM, Saúl Ibarra Corretgé wrote:

On Aug 18, 2017, at 13:47, Paolo Marcheschi <paolo.marcheschi@ftgm.it> wrote:

Hi
I opened an issue and the developer replied that the error for me was the missing single quotes around the ID

desktopSharingChromeExtId: 'omikhipjhdfmdnemgfifenclnmaphebc',

This solves my problem.

Yeah, that developer is a cool guy :wink: