[jitsi-users] registration misbehavior?


#1

Hi guys,

I'm using Jitsi as client on a SIP network. I noticed that at times I can't
receive calls and figured out that my registration times out.
The reason being that the server answers to the registration with a lower
interval - 5mins - than what Jitsi asks for - 10mins - and Jitsi seems to
ignore that, only re-registering after 9 mins. Example of an exchange is
below.

I've observed this behavior on two versions I've tried: "Jitsi2.9.5486Mac
OS X" and "Jitsi2.4.4997Linux".

Not sure if this had been raised before, seems obvious, but on a
superficial search I could find no issue about it in the tracker. Not a big
deal, but I thought I'd let you know.

BTW, is there a way to change the default registration interval?

Cheers,
Bogdan.

REGISTER sip:example.com SIP/2.0.
Call-ID: b9864ac1bf69e893735b04fe0ff3b12b@0:0:0:0:0:0:0:0.
CSeq: 44 REGISTER.
Max-Forwards: 70.
User-Agent: Jitsi2.9.5486Mac OS X.
Expires: 600.
Contact: "6505550319" <sip:6505550319@CLT_IP
:1024;transport=udp;registering_acc=example_com>;expires=600.
Via: SIP/2.0/UDP
CLT_IP:1024;branch=z9hG4bK-373032-0228ff7fd6a2fbdbc0ab201c333a2ab7.
Authorization: Digest username="6505550319@example.com",realm="example.com
",nonce="464e16476945c1a1",uri="sip:example.com
",response="9126e57819195727c9a8ac43fe805c35",algorithm=MD5,opaque="79e9484c5ca1d5f8",qop=auth,cnonce="xyz",nc=00000001.
Content-Length: 0.
.

SIP/2.0 200 OK.
Service-Route: <sip:SRV_IP:5054;transport=TCP;lr;orig>.
Via: SIP/2.0/UDP
CLT_IP:1024;received=CLT_IP;branch=z9hG4bK-373032-0228ff7fd6a2fbdbc0ab201c333a2ab7.
Call-ID: b9864ac1bf69e893735b04fe0ff3b12b@0:0:0:0:0:0:0:0.

;tag=z9hG4bKPj.YwI-4mlZaNTRgn7NgbgoUyf3MEDowJt.

CSeq: 44 REGISTER.
Supported: outbound.
Contact: <sip:6505550319@CLT_IP
:1024;transport=udp;registering_acc=example_com>;expires=300.
Require: outbound.
Path: <sip:J5KvY2fayz@SRV_IP:5058;transport=TCP;lr;ob>.
P-Associated-URI: <sip:6505550319@example.com>.
Content-Length: 0.

ยทยทยท

From: "6505550319" <sip:6505550319@example.com>;tag=e6cd9441.
To: "6505550319" <sip:6505550319@example.com>.
From: "6505550319" <sip:6505550319@example.com>;tag=e6cd9441.
To: "6505550319" <sip:6505550319@example.com


#2

I'm using Jitsi as client on a SIP network. I noticed that at times I
can't receive calls and figured out that my registration times out. The
reason being that the server answers to the registration with a lower
interval - 5mins - than what Jitsi asks for - 10mins - and Jitsi seems
to ignore that, only re-registering after 9 mins. Example of an exchange
is below.

I've observed this behavior on two versions I've tried: "Jitsi2.9.5486Mac OS
X" and "Jitsi2.4.4997Linux".

Not sure if this had been raised before, seems obvious, but on a superficial
search I could find no issue about it in the tracker. Not a big deal, but I
thought I'd let you know.

AFAIK this has never come up before.

BTW, is there a way to change the default registration interval?

Tools->Options->Accounts->your sip account->Connection->KeepAlive
Change the method to Register and choose an appropriate interval.

Cheers,
Bogdan.

Ingo