[jitsi-users] Recent jitsi-meet / recent firefox ?


#1

Hi,

We've deployed jitsi-meet 1.0.634-1 on a debian jessie VM and
it works great with chrome 44 on debian jessie desktop and a few
smartphones.

I know jitsi-meet/firefox is a work in progress:
https://hacks.mozilla.org/2015/06/firefox-multistream-and-renegotiation-for-jitsi-videobridge/

I tried firefox 42.0a dev edition 64 bits linux on a debian jessie
desktop and I couldn't get to work, only one user shown. Packaged
firefox 40 has only the text chat working.

Should we wait more or is it some advanced version we can test
of both jitsi-meet and firefox?

Thanks for your help,

Sincerely,

Laurent


#2

Hi,

We've deployed jitsi-meet 1.0.634-1 on a debian jessie VM and
it works great with chrome 44 on debian jessie desktop and a few
smartphones.

I know jitsi-meet/firefox is a work in progress:
https://hacks.mozilla.org/2015/06/firefox-multistream-and-renegotiation-for-jitsi-videobridge/

I tried firefox 42.0a dev edition 64 bits linux on a debian jessie
desktop and I couldn't get to work, only one user shown. Packaged
firefox 40 has only the text chat working.

Should we wait more or is it some advanced version we can test
of both jitsi-meet and firefox?

Thanks for your help,

Sincerely,

Laurent

Hi again,

I tried jitsi-meet 1.0.650-1 and firefox nightly 43.0a1 and it
doesn't work either (chat message don't appear, etc...)

On the jitsi-dev list people seem to say
that jitsi works with firefox >= 40

http://lists.jitsi.org/pipermail/dev/2015-August/024972.html
<<
Hi Stefan, don’t worry about not having the `enableFirefoxSupport: true`
option in your config.js file, you don’t need that (but it doesn’t hurt
either); that option has been deprecated and FF should just work if
you’re using FF >= 40.

I hope this helps!

Best,
George

I wonder what I'm doing wrong, any suggestion?

Should I ask on the jitsi-dev list instead?

Sincerely,

Laurent

···

On Wed, 2015-09-02 at 20:59 +0200, Laurent GUERBY wrote:


#3

have you try your browser on https://beta.meet.jit.si?

(for me it works with two users but I haven't try with more clients)

···

Le 07/09/2015 19:16, Laurent GUERBY a écrit :

On Wed, 2015-09-02 at 20:59 +0200, Laurouent GUERBY wrote:

Hi,

We've deployed jitsi-meet 1.0.634-1 on a debian jessie VM and
it works great with chrome 44 on debian jessie desktop and a few
smartphones.

I know jitsi-meet/firefox is a work in progress:
https://hacks.mozilla.org/2015/06/firefox-multistream-and-renegotiation-for-jitsi-videobridge/

I tried firefox 42.0a dev edition 64 bits linux on a debian jessie
desktop and I couldn't get to work, only one user shown. Packaged
firefox 40 has only the text chat working.

Should we wait more or is it some advanced version we can test
of both jitsi-meet and firefox?

Thanks for your help,

Sincerely,

Laurent

Hi again,

I tried jitsi-meet 1.0.650-1 and firefox nightly 43.0a1 and it
doesn't work either (chat message don't appear, etc...)

On the jitsi-dev list people seem to say
that jitsi works with firefox >= 40

http://lists.jitsi.org/pipermail/dev/2015-August/024972.html
<<
Hi Stefan, don’t worry about not having the `enableFirefoxSupport: true`
option in your config.js file, you don’t need that (but it doesn’t hurt
either); that option has been deprecated and FF should just work if
you’re using FF >= 40.

I hope this helps!

Best,
George
I wonder what I'm doing wrong, any suggestion?

Should I ask on the jitsi-dev list instead?

Sincerely,

Laurent

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--

Vincent Mabillot
Maître de Conférences InfoCom
Université Lyon2
Responsable Licence Pro CoLibre
"Communiquer l'esprit libre"
http://colibre.org


#4

Hello Laurent,

Like Vincent suggested, could please try https://beta.meet.jit.si/ and see if that works. For your own deployments, please make sure you’re using the latest JVB, because there have been some changes recently that affect FF compatibility.

Hope this helps.

Best,
George Politis

···

On Sep 7, 2015, at 12:16 PM, Laurent GUERBY <laurent@guerby.net> wrote:

On Wed, 2015-09-02 at 20:59 +0200, Laurent GUERBY wrote:

Hi,

We've deployed jitsi-meet 1.0.634-1 on a debian jessie VM and
it works great with chrome 44 on debian jessie desktop and a few
smartphones.

I know jitsi-meet/firefox is a work in progress:
https://hacks.mozilla.org/2015/06/firefox-multistream-and-renegotiation-for-jitsi-videobridge/

I tried firefox 42.0a dev edition 64 bits linux on a debian jessie
desktop and I couldn't get to work, only one user shown. Packaged
firefox 40 has only the text chat working.

Should we wait more or is it some advanced version we can test
of both jitsi-meet and firefox?

Thanks for your help,

Sincerely,

Laurent

Hi again,

I tried jitsi-meet 1.0.650-1 and firefox nightly 43.0a1 and it
doesn't work either (chat message don't appear, etc...)

On the jitsi-dev list people seem to say
that jitsi works with firefox >= 40

http://lists.jitsi.org/pipermail/dev/2015-August/024972.html
<<
Hi Stefan, don’t worry about not having the `enableFirefoxSupport: true`
option in your config.js file, you don’t need that (but it doesn’t hurt
either); that option has been deprecated and FF should just work if
you’re using FF >= 40.

I hope this helps!

Best,
George

I wonder what I'm doing wrong, any suggestion?

Should I ask on the jitsi-dev list instead?

Sincerely,

Laurent

_______________________________________________
users mailing list
users@jitsi.org <mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hello Laurent,

Like Vincent suggested, could please try https://beta.meet.jit.si/ and
see if that works. For your own deployments, please make sure you’re
using the latest JVB, because there have been some changes recently
that affect FF compatibility.

Hope this helps.

Best,
George Politis

Hi George,

https://beta.meet.jit.si/ doesn't work for me with firefox nightly 64
bits 43.0a1 on debian 8.1 64 bits linux desktop. When
I create a conference, open chat and type something in "enter text" it
doesn't appear in the chat column. There is no popup to enter your
nickname when you click on your speaker box, and it doesn't
show other participants.

All works fine with Chrome 44.0.2403.157 (Official Build) (64-bit)

On the firefox web console I have the following log:

<<
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] api.callstats.io
The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol. testlg
This appears to be Firefox, ver: 43 app.bundle.js:1510:9
Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help http://xhr.spec.whatwg.org/ jquery-2.1.1.min.js:4:14348
Get media constraints Object { audio: true, video: false } app.bundle.js:1886:5
Strophe status changed to CONNECTING null app.bundle.js:19411:1
Detected lack of firefox screen sharing extension. app.bundle.js:12251:9
Strophe status changed to CONNECTED null app.bundle.js:19411:1
My Jabber ID: d6483832-d85a-4c88-8df1-8652bc1f47a6@beta.meet.jit.si/0744ed32-25e2-4063-8d6e-9935d73f5a3a app.bundle.js:19418:17
XMPP pings will be sent every 20000 ms app.bundle.js:19171:13
onUserMediaSuccess app.bundle.js:1893:17
Get media constraints Object { audio: false, video: Object } app.bundle.js:1886:5
Failed to get access to local media. Error MediaStreamError { name: "NotFoundError", message: "The object can not be found here.", constraintName: "", stack: "" } Object { audio: false, video: Object } app.bundle.js:1899:1
failed to obtain video stream - stop MediaStreamError { name: "NotFoundError", message: "The object can not be found here.", constraintName: "", stack: "" } app.bundle.js:1981:1

failed to obtain audio/video stream - trying audio only MediaStreamError { name: "NotFoundError", message: "The object can not be found here.", constraintName: "", stack: "" } app.bundle.js:2030:5

Get media constraints Object { audio: true, video: false } app.bundle.js:1886:5
onUserMediaSuccess app.bundle.js:1893:17
got LocalMediaStream { id: "{0396b7eb-1f03-47e9-8412-0e242a62c5…", currentTime: 268.4710657596372 } 1 0 app.bundle.js:2023:1
TypeError: Value being assigned to HTMLMediaElement.mozSrcObject does not implement interface MediaStream. app.bundle.js:1751:17
Requested local resource before we're in the MUC app.bundle.js:9459:9

Strophe: request id 7.1 error 0 happened app.bundle.js:19298:17

Strophe: request errored, status: 0, number of errors: 1 app.bundle.js:19294:17
Requested local resource before we're in the MUC app.bundle.js:9459:9
[38]</LocalVideo.prototype.getResourceJid() app.bundle.js:9459
[40]</SmallVideo.prototype.bindHoverHandler/<() app.bundle.js:10003
n.event.special[a].handle() jquery-2.1.1.min.js:3
n.event.dispatch() jquery-2.1.1.min.js:3
n.event.add/r.handle() jquery-2.1.1.min.js:3

Strophe: request id 26.1 error 0 happened app.bundle.js:19298:17

Strophe: request errored, status: 0, number of errors: 1 app.bundle.js:19294:17
Requested local resource before we're in the MUC app.bundle.js:9459:9

(I expanded "Requested local resource before we're in the MUC app.bundle.js" to get the backtrace)

To answer your last question here are the version on our server:

root@jitsi:~# dpkg -l|grep -i jitsi
ii jicofo 1.0-132-1 amd64 JItsi Meet COnference FOcus
ii jitsi-meet 1.0.650-1 all WebRTC JavaScript video conferences
ii jitsi-meet-prosody 1.0.650-1 all Prosody configuration for Jitsi Meet
ii jitsi-videobridge 509-1 amd64 WebRTC compatible Selective Forwarding Unit (SFU)

Thanks for your help,

Laurent

···

On Tue, 2015-09-08 at 11:08 -0500, George Politis wrote:

> On Sep 7, 2015, at 12:16 PM, Laurent GUERBY <laurent@guerby.net> > > wrote:
>
> On Wed, 2015-09-02 at 20:59 +0200, Laurent GUERBY wrote:
> > Hi,
> >
> > We've deployed jitsi-meet 1.0.634-1 on a debian jessie VM and
> > it works great with chrome 44 on debian jessie desktop and a few
> > smartphones.
> >
> > I know jitsi-meet/firefox is a work in progress:
> > https://hacks.mozilla.org/2015/06/firefox-multistream-and-renegotiation-for-jitsi-videobridge/
> >
> > I tried firefox 42.0a dev edition 64 bits linux on a debian jessie
> > desktop and I couldn't get to work, only one user shown. Packaged
> > firefox 40 has only the text chat working.
> >
> > Should we wait more or is it some advanced version we can test
> > of both jitsi-meet and firefox?
> >
> > Thanks for your help,
> >
> > Sincerely,
> >
> > Laurent
>
> Hi again,
>
> I tried jitsi-meet 1.0.650-1 and firefox nightly 43.0a1 and it
> doesn't work either (chat message don't appear, etc...)
>
> On the jitsi-dev list people seem to say
> that jitsi works with firefox >= 40
>
> http://lists.jitsi.org/pipermail/dev/2015-August/024972.html
> <<
> Hi Stefan, don’t worry about not having the `enableFirefoxSupport:
> true`
> option in your config.js file, you don’t need that (but it doesn’t
> hurt
> either); that option has been deprecated and FF should just work if
> you’re using FF >= 40.
>
> I hope this helps!
>
> Best,
> George
> > >
>
> I wonder what I'm doing wrong, any suggestion?
>
> Should I ask on the jitsi-dev list instead?
>
> Sincerely,
>
> Laurent
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

Hello Laurent,

It is possible that something changed in the latest FF nightly which breaks compatibility with Jitsi. I’m wondering if this could be it : https://groups.google.com/forum/#!topic/mozilla.dev.media/vNCjLFgc97c

Could you please fire up a conference and then go to “about:webrtc <about:webrtc>” and copy/paste here both the local SDP and the remote SDP?

Thank you.

Best,
George

···

On Sep 8, 2015, at 11:52 AM, Laurent GUERBY <laurent@guerby.net> wrote:

On Tue, 2015-09-08 at 11:08 -0500, George Politis wrote:

Hello Laurent,

Like Vincent suggested, could please try https://beta.meet.jit.si/ and
see if that works. For your own deployments, please make sure you’re
using the latest JVB, because there have been some changes recently
that affect FF compatibility.

Hope this helps.

Best,
George Politis

Hi George,

https://beta.meet.jit.si/ doesn't work for me with firefox nightly 64
bits 43.0a1 on debian 8.1 64 bits linux desktop. When
I create a conference, open chat and type something in "enter text" it
doesn't appear in the chat column. There is no popup to enter your
nickname when you click on your speaker box, and it doesn't
show other participants.

All works fine with Chrome 44.0.2403.157 (Official Build) (64-bit)

On the firefox web console I have the following log:

<<
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] api.callstats.io
The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol. testlg
This appears to be Firefox, ver: 43 app.bundle.js:1510:9
Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help http://xhr.spec.whatwg.org/ jquery-2.1.1.min.js:4:14348
Get media constraints Object { audio: true, video: false } app.bundle.js:1886:5
Strophe status changed to CONNECTING null app.bundle.js:19411:1
Detected lack of firefox screen sharing extension. app.bundle.js:12251:9
Strophe status changed to CONNECTED null app.bundle.js:19411:1
My Jabber ID: d6483832-d85a-4c88-8df1-8652bc1f47a6@beta.meet.jit.si <mailto:d6483832-d85a-4c88-8df1-8652bc1f47a6@beta.meet.jit.si>/0744ed32-25e2-4063-8d6e-9935d73f5a3a app.bundle.js:19418:17
XMPP pings will be sent every 20000 ms app.bundle.js:19171:13
onUserMediaSuccess app.bundle.js:1893:17
Get media constraints Object { audio: false, video: Object } app.bundle.js:1886:5
Failed to get access to local media. Error MediaStreamError { name: "NotFoundError", message: "The object can not be found here.", constraintName: "", stack: "" } Object { audio: false, video: Object } app.bundle.js:1899:1
failed to obtain video stream - stop MediaStreamError { name: "NotFoundError", message: "The object can not be found here.", constraintName: "", stack: "" } app.bundle.js:1981:1

failed to obtain audio/video stream - trying audio only MediaStreamError { name: "NotFoundError", message: "The object can not be found here.", constraintName: "", stack: "" } app.bundle.js:2030:5

Get media constraints Object { audio: true, video: false } app.bundle.js:1886:5
onUserMediaSuccess app.bundle.js:1893:17
got LocalMediaStream { id: "{0396b7eb-1f03-47e9-8412-0e242a62c5…", currentTime: 268.4710657596372 } 1 0 app.bundle.js:2023:1
TypeError: Value being assigned to HTMLMediaElement.mozSrcObject does not implement interface MediaStream. app.bundle.js:1751:17
Requested local resource before we're in the MUC app.bundle.js:9459:9

Strophe: request id 7.1 error 0 happened app.bundle.js:19298:17

Strophe: request errored, status: 0, number of errors: 1 app.bundle.js:19294:17
Requested local resource before we're in the MUC app.bundle.js:9459:9
[38]</LocalVideo.prototype.getResourceJid() app.bundle.js:9459
[40]</SmallVideo.prototype.bindHoverHandler/<() app.bundle.js:10003
n.event.special[a].handle() jquery-2.1.1.min.js:3
n.event.dispatch() jquery-2.1.1.min.js:3
n.event.add/r.handle() jquery-2.1.1.min.js:3

Strophe: request id 26.1 error 0 happened app.bundle.js:19298:17

Strophe: request errored, status: 0, number of errors: 1 app.bundle.js:19294:17
Requested local resource before we're in the MUC app.bundle.js:9459:9

(I expanded "Requested local resource before we're in the MUC app.bundle.js" to get the backtrace)

To answer your last question here are the version on our server:

root@jitsi:~# dpkg -l|grep -i jitsi
ii jicofo 1.0-132-1 amd64 JItsi Meet COnference FOcus
ii jitsi-meet 1.0.650-1 all WebRTC JavaScript video conferences
ii jitsi-meet-prosody 1.0.650-1 all Prosody configuration for Jitsi Meet
ii jitsi-videobridge 509-1 amd64 WebRTC compatible Selective Forwarding Unit (SFU)

Thanks for your help,

Laurent

On Sep 7, 2015, at 12:16 PM, Laurent GUERBY <laurent@guerby.net> >>> wrote:

On Wed, 2015-09-02 at 20:59 +0200, Laurent GUERBY wrote:

Hi,

We've deployed jitsi-meet 1.0.634-1 on a debian jessie VM and
it works great with chrome 44 on debian jessie desktop and a few
smartphones.

I know jitsi-meet/firefox is a work in progress:
https://hacks.mozilla.org/2015/06/firefox-multistream-and-renegotiation-for-jitsi-videobridge/

I tried firefox 42.0a dev edition 64 bits linux on a debian jessie
desktop and I couldn't get to work, only one user shown. Packaged
firefox 40 has only the text chat working.

Should we wait more or is it some advanced version we can test
of both jitsi-meet and firefox?

Thanks for your help,

Sincerely,

Laurent

Hi again,

I tried jitsi-meet 1.0.650-1 and firefox nightly 43.0a1 and it
doesn't work either (chat message don't appear, etc...)

On the jitsi-dev list people seem to say
that jitsi works with firefox >= 40

http://lists.jitsi.org/pipermail/dev/2015-August/024972.html
<<
Hi Stefan, don’t worry about not having the `enableFirefoxSupport:
true`
option in your config.js file, you don’t need that (but it doesn’t
hurt
either); that option has been deprecated and FF should just work if
you’re using FF >= 40.

I hope this helps!

Best,
George

I wonder what I'm doing wrong, any suggestion?

Should I ask on the jitsi-dev list instead?

Sincerely,

Laurent

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org <mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org <mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

Hello Laurent,

It is possible that something changed in the latest FF nightly which
breaks compatibility with Jitsi. I’m wondering if this could be
it : https://groups.google.com/forum/#!
topic/mozilla.dev.media/vNCjLFgc97c

Could you please fire up a conference and then go to “about:webrtc”
and copy/paste here both the local SDP and the remote SDP?

Thank you.

Best,
G4eorge

Hello George,

When I open a "about:webrtc" tab after connecting to
beta.meet.jit.si/test4 conference and typed a few things in chat
I get no new item in the page and if I activate debug mode I get an
empty webRTC.log file:

Debug Mode: debug mode active, trace log at: /tmp/WebRTC.log
Debug Mode: trace log can be found at: /tmp/WebRTC.log

If on the same firefox I click on the "firefox hello" button (start a
conversation) and do about:webrtc and activate debug and AEC I quickly
get plenty of lines in the log and various aec* files appear:

guerby@pc2:/tmp$ ls -l
(...)
-rw-r--r-- 1 guerby guerby 0 Sep 9 09:14 aec_skew0.dat
-rw-r--r-- 1 guerby guerby 42668 Sep 9 09:14 aec_out_linear0-0.wav
-rw-r--r-- 1 guerby guerby 42668 Sep 9 09:14 aec_out0-0.wav
-rw-r--r-- 1 guerby guerby 42668 Sep 9 09:14 aec_near0-0.wav
-rw-r--r-- 1 guerby guerby 42668 Sep 9 09:14 aec_far0-0.wav
-rw-r--r-- 1 guerby guerby 532 Sep 9 09:14 aec_delay0.dat
-rw-r--r-- 1 guerby guerby 266 Sep 9 09:14 aec_buf0.dat
-rw-r--r-- 1 guerby guerby 0 Sep 9 09:14 aec_skew1.dat
-rw-r--r-- 1 guerby guerby 0 Sep 9 09:14 aec_delay1.dat
-rw-r--r-- 1 guerby guerby 0 Sep 9 09:14 aec_buf1.dat
-rw-r--r-- 1 guerby guerby 69632 Sep 9 09:14 aec_out_linear0-1.wav
-rw-r--r-- 1 guerby guerby 69632 Sep 9 09:14 aec_out0-1.wav
-rw-r--r-- 1 guerby guerby 69632 Sep 9 09:14 aec_near0-1.wav
-rw-r--r-- 1 guerby guerby 344064 Sep 9 09:14 WebRTC.log
-rw-r--r-- 1 guerby guerby 69632 Sep 9 09:14 aec_far0-1.wav
guerby@pc2:/tmp$ head WebRTC.log
Local Date: Wed Sep 9 09:14:52 2015
DEBUGINFO ; ( 9:14:52:494 | 13) AUDIO DEVICE: 1 99; 29968; AudioMixerManagerLinuxPulse::MicrophoneVolume() => vol=-1283171024, volume
STREAM ; ( 9:14:52:494 | 0) VOICE: 1 99; 29968; VoEBaseImpl::RecordedDataIsAvailable(nSamples=441, nBytesPerSample=4, nChannels=2, samplesPerSec=44100, totalDelayMS=3, clockDrift=0, micLevel=32897)
STREAM ; ( 9:14:52:494 | 0) AUDIO DEVICE: 1 99; 29968; MaxMicrophoneVolume
STREAM ; ( 9:14:52:494 | 0) AUDIO DEVICE: 1 99; 29968; output: maxVolume=65536
STREAM ; ( 9:14:52:494 | 0) VOICE: 1 99; 29968; TransmitMixer::PrepareDemux(nSamples=441, nChannels=2,samplesPerSec=44100, totalDelayMS=3, clockDrift=0,currentMicLevel=128)
STREAM ; ( 9:14:52:494 | 0) AUDIO CODING: 1 0; 29968; SendCodec()
STREAM ; ( 9:14:52:494 | 0) VOICE: 1 99; 29968; TransmitMixer::DemuxAndMix()
STREAM ; ( 9:14:52:494 | 0) VOICE: 1 0; 29968; Channel::Demultiplex()
STREAM ; ( 9:14:52:494 | 0) VOICE: 1 0; 29968; Channel::PrepareEncodeAndSend()

Let me know if you need additional information, or
if you have a known working version of firefox
I could download and test.

Thanks for your time,

Laurent

···

On Tue, 2015-09-08 at 18:12 -0500, George Politis wrote:

> On Sep 8, 2015, at 11:52 AM, Laurent GUERBY <laurent@guerby.net> > > wrote:
>
> On Tue, 2015-09-08 at 11:08 -0500, George Politis wrote:
> > Hello Laurent,
> >
> >
> > Like Vincent suggested, could please try https://beta.meet.jit.si/
> > and
> > see if that works. For your own deployments, please make sure
> > you’re
> > using the latest JVB, because there have been some changes
> > recently
> > that affect FF compatibility.
> >
> >
> > Hope this helps.
> >
> >
> > Best,
> > George Politis
>
> Hi George,
>
> https://beta.meet.jit.si/ doesn't work for me with firefox nightly
> 64
> bits 43.0a1 on debian 8.1 64 bits linux desktop. When
> I create a conference, open chat and type something in "enter text"
> it
> doesn't appear in the chat column. There is no popup to enter your
> nickname when you click on your speaker box, and it doesn't
> show other participants.
>
> All works fine with Chrome 44.0.2403.157 (Official Build) (64-bit)
>
> On the firefox web console I have the following log:
>
> <<
> This site makes use of a SHA-1 Certificate; it's recommended you use
> certificates with signature algorithms that use hash functions
> stronger than SHA-1.[Learn More] api.callstats.io
> The character encoding of the HTML document was not declared. The
> document will render with garbled text in some browser
> configurations if the document contains characters from outside the
> US-ASCII range. The character encoding of the page must be declared
> in the document or in the transfer protocol. testlg
> This appears to be Firefox, ver: 43 app.bundle.js:1510:9
> Synchronous XMLHttpRequest on the main thread is deprecated because
> of its detrimental effects to the end user's experience. For more
> help http://xhr.spec.whatwg.org/ jquery-2.1.1.min.js:4:14348
> Get media constraints Object { audio: true, video: false }
> app.bundle.js:1886:5
> Strophe status changed to CONNECTING null app.bundle.js:19411:1
> Detected lack of firefox screen sharing extension.
> app.bundle.js:12251:9
> Strophe status changed to CONNECTED null app.bundle.js:19411:1
> My Jabber
> ID: d6483832-d85a-4c88-8df1-8652bc1f47a6@beta.meet.jit.si/0744ed32-25e2-4063-8d6e-9935d73f5a3a app.bundle.js:19418:17
> XMPP pings will be sent every 20000 ms app.bundle.js:19171:13
> onUserMediaSuccess app.bundle.js:1893:17
> Get media constraints Object { audio: false, video: Object }
> app.bundle.js:1886:5
> Failed to get access to local media. Error MediaStreamError { name:
> "NotFoundError", message: "The object can not be found here.",
> constraintName: "", stack: "" } Object { audio: false, video:
> Object } app.bundle.js:1899:1
> failed to obtain video stream - stop MediaStreamError { name:
> "NotFoundError", message: "The object can not be found here.",
> constraintName: "", stack: "" } app.bundle.js:1981:1
>
> failed to obtain audio/video stream - trying audio only
> MediaStreamError { name: "NotFoundError", message: "The object can
> not be found here.", constraintName: "", stack: "" }
> app.bundle.js:2030:5
>
> Get media constraints Object { audio: true, video: false }
> app.bundle.js:1886:5
> onUserMediaSuccess app.bundle.js:1893:17
> got LocalMediaStream { id: "{0396b7eb-1f03-47e9-8412-0e242a62c5…",
> currentTime: 268.4710657596372 } 1 0 app.bundle.js:2023:1
> TypeError: Value being assigned to HTMLMediaElement.mozSrcObject
> does not implement interface MediaStream. app.bundle.js:1751:17
> Requested local resource before we're in the MUC
> app.bundle.js:9459:9
>
> Strophe: request id 7.1 error 0 happened app.bundle.js:19298:17
>
> Strophe: request errored, status: 0, number of errors: 1
> app.bundle.js:19294:17
> Requested local resource before we're in the MUC
> app.bundle.js:9459:9
> [38]</LocalVideo.prototype.getResourceJid() app.bundle.js:9459
> [40]</SmallVideo.prototype.bindHoverHandler/<() app.bundle.js:10003
> n.event.special[a].handle() jquery-2.1.1.min.js:3
> n.event.dispatch() jquery-2.1.1.min.js:3
> n.event.add/r.handle() jquery-2.1.1.min.js:3
>
> Strophe: request id 26.1 error 0 happened app.bundle.js:19298:17
>
> Strophe: request errored, status: 0, number of errors: 1
> app.bundle.js:19294:17
> Requested local resource before we're in the MUC
> app.bundle.js:9459:9
> > >
>
> (I expanded "Requested local resource before we're in the MUC
> app.bundle.js" to get the backtrace)
>
> To answer your last question here are the version on our server:
>
> root@jitsi:~# dpkg -l|grep -i jitsi
> ii jicofo 1.0-132-1 amd64
> JItsi Meet COnference FOcus
> ii jitsi-meet 1.0.650-1 all
> WebRTC JavaScript video conferences
> ii jitsi-meet-prosody 1.0.650-1 all
> Prosody configuration for Jitsi Meet
> ii jitsi-videobridge 509-1 amd64
> WebRTC compatible Selective Forwarding Unit (SFU)
>
> Thanks for your help,
>
> Laurent
>
> > > On Sep 7, 2015, at 12:16 PM, Laurent GUERBY <laurent@guerby.net> > > > > wrote:
> > >
> > > On Wed, 2015-09-02 at 20:59 +0200, Laurent GUERBY wrote:
> > > > Hi,
> > > >
> > > > We've deployed jitsi-meet 1.0.634-1 on a debian jessie VM and
> > > > it works great with chrome 44 on debian jessie desktop and a
> > > > few
> > > > smartphones.
> > > >
> > > > I know jitsi-meet/firefox is a work in progress:
> > > > https://hacks.mozilla.org/2015/06/firefox-multistream-and-renegotiation-for-jitsi-videobridge/
> > > >
> > > > I tried firefox 42.0a dev edition 64 bits linux on a debian
> > > > jessie
> > > > desktop and I couldn't get to work, only one user shown.
> > > > Packaged
> > > > firefox 40 has only the text chat working.
> > > >
> > > > Should we wait more or is it some advanced version we can test
> > > > of both jitsi-meet and firefox?
> > > >
> > > > Thanks for your help,
> > > >
> > > > Sincerely,
> > > >
> > > > Laurent
> > >
> > > Hi again,
> > >
> > > I tried jitsi-meet 1.0.650-1 and firefox nightly 43.0a1 and it
> > > doesn't work either (chat message don't appear, etc...)
> > >
> > > On the jitsi-dev list people seem to say
> > > that jitsi works with firefox >= 40
> > >
> > > http://lists.jitsi.org/pipermail/dev/2015-August/024972.html
> > > <<
> > > Hi Stefan, don’t worry about not having the
> > > `enableFirefoxSupport:
> > > true`
> > > option in your config.js file, you don’t need that (but it
> > > doesn’t
> > > hurt
> > > either); that option has been deprecated and FF should just work
> > > if
> > > you’re using FF >= 40.
> > >
> > > I hope this helps!
> > >
> > > Best,
> > > George
> > > > >
> > >
> > > I wonder what I'm doing wrong, any suggestion?
> > >
> > > Should I ask on the jitsi-dev list instead?
> > >
> > > Sincerely,
> > >
> > > Laurent
> > >
> > >
> > >
> > > _______________________________________________
> > > users mailing list
> > > users@jitsi.org
> > > Unsubscribe instructions and other list options:
> > > http://lists.jitsi.org/mailman/listinfo/users
> >
> >
> > _______________________________________________
> > users mailing list
> > users@jitsi.org
> > Unsubscribe instructions and other list options:
> > http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Hello Laurent,

When I open a "about:webrtc" tab after connecting to
beta.meet.jit.si/test4 conference and typed a few things in chat
I get no new item in the page and if I activate debug mode I get an
empty webRTC.log file:

Just checking: You have to have at least 2 participants in the
conference for something to appear in "about:webrtc". You should see
something that looks like the attached image. The important information
that I'm interested in is found when you click the "show details" hyperlink.

Debug Mode: debug mode active, trace log at: /tmp/WebRTC.log
Debug Mode: trace log can be found at: /tmp/WebRTC.log

If on the same firefox I click on the "firefox hello" button (start a
conversation) and do about:webrtc and activate debug and AEC I quickly
get plenty of lines in the log and various aec* files appear:

guerby@pc2:/tmp$ ls -l
(...)
-rw-r--r-- 1 guerby guerby 0 Sep 9 09:14 aec_skew0.dat
-rw-r--r-- 1 guerby guerby 42668 Sep 9 09:14 aec_out_linear0-0.wav
-rw-r--r-- 1 guerby guerby 42668 Sep 9 09:14 aec_out0-0.wav
-rw-r--r-- 1 guerby guerby 42668 Sep 9 09:14 aec_near0-0.wav
-rw-r--r-- 1 guerby guerby 42668 Sep 9 09:14 aec_far0-0.wav
-rw-r--r-- 1 guerby guerby 532 Sep 9 09:14 aec_delay0.dat
-rw-r--r-- 1 guerby guerby 266 Sep 9 09:14 aec_buf0.dat
-rw-r--r-- 1 guerby guerby 0 Sep 9 09:14 aec_skew1.dat
-rw-r--r-- 1 guerby guerby 0 Sep 9 09:14 aec_delay1.dat
-rw-r--r-- 1 guerby guerby 0 Sep 9 09:14 aec_buf1.dat
-rw-r--r-- 1 guerby guerby 69632 Sep 9 09:14 aec_out_linear0-1.wav
-rw-r--r-- 1 guerby guerby 69632 Sep 9 09:14 aec_out0-1.wav
-rw-r--r-- 1 guerby guerby 69632 Sep 9 09:14 aec_near0-1.wav
-rw-r--r-- 1 guerby guerby 344064 Sep 9 09:14 WebRTC.log
-rw-r--r-- 1 guerby guerby 69632 Sep 9 09:14 aec_far0-1.wav
guerby@pc2:/tmp$ head WebRTC.log
Local Date: Wed Sep 9 09:14:52 2015
DEBUGINFO ; ( 9:14:52:494 | 13) AUDIO DEVICE: 1 99; 29968; AudioMixerManagerLinuxPulse::MicrophoneVolume() => vol=-1283171024, volume
STREAM ; ( 9:14:52:494 | 0) VOICE: 1 99; 29968; VoEBaseImpl::RecordedDataIsAvailable(nSamples=441, nBytesPerSample=4, nChannels=2, samplesPerSec=44100, totalDelayMS=3, clockDrift=0, micLevel=32897)
STREAM ; ( 9:14:52:494 | 0) AUDIO DEVICE: 1 99; 29968; MaxMicrophoneVolume
STREAM ; ( 9:14:52:494 | 0) AUDIO DEVICE: 1 99; 29968; output: maxVolume=65536
STREAM ; ( 9:14:52:494 | 0) VOICE: 1 99; 29968; TransmitMixer::PrepareDemux(nSamples=441, nChannels=2,samplesPerSec=44100, totalDelayMS=3, clockDrift=0,currentMicLevel=128)
STREAM ; ( 9:14:52:494 | 0) AUDIO CODING: 1 0; 29968; SendCodec()
STREAM ; ( 9:14:52:494 | 0) VOICE: 1 99; 29968; TransmitMixer::DemuxAndMix()
STREAM ; ( 9:14:52:494 | 0) VOICE: 1 0; 29968; Channel::Demultiplex()
STREAM ; ( 9:14:52:494 | 0) VOICE: 1 0; 29968; Channel::PrepareEncodeAndSend()

Let me know if you need additional information, or
if you have a known working version of firefox
I could download and test.

I just run a test with Firefox 40.0.3 in Ubuntu and it works fine here.
Firefox 40 is stable currently.

Thanks for your time,

Thank you for your interest!

Best regards,
George


#9

Hi,

We finally found the issue: with firefox 40 when
the popup "Share Microphone" appears you must
*not* click on "Share Microphone" (as most users including me will
do...), you must instead unroll the popup and then select "Always Share
Microphone" from the drop down menu. Same thing for camera.

Either Firefox UI is less than friendly there, or there's
an issue in jitsi detecting/using one time sharing (not "always").

If you don't do that even the text chat doesn't work.
And about:webrtc stays empty. I find this behaviour
surprising, why text chat depends on audio/video?

Once you've done that sometimes it works directly
sometimes you have to restart firefox and reconnect
for everything to work.

We found that it works more often on conferences where you have set
a password, even if in some cases between 2 and
three windows will ask for a password instead of just one, just fill the
first one and click on all ok.

Hello Laurent,

> When I open a "about:webrtc" tab after connecting to
> beta.meet.jit.si/test4 conference and typed a few things in chat
> I get no new item in the page and if I activate debug mode I get an
> empty webRTC.log file:

Just checking: You have to have at least 2 participants in the
conference for something to appear in "about:webrtc". You should see
something that looks like the attached image. The important information
that I'm interested in is found when you click the "show details" hyperlink.

On conferences with one participant when you type something
in the text chat it appears in the log column. In the
case you didn't select "always share" even the text chat doesn't
work.

I just run a test with Firefox 40.0.3 in Ubuntu and it works fine here.
Firefox 40 is stable currently.

I tested fresh install Ubuntu 14.04 with the packaged 40.0.3 and debian
8.2 with firefox 40.0.3 installed in /opt/firefox from the firefox
.tar.bz2.

> Thanks for your time,
>

Thank you for your interest!

Thanks for jitsi :).

The two real issues remaining are :
- why text chat is not working when microphone is not "always share",
- the multiple password windows asking for password instead of just one

But both are not blockers for users.

Sincerely,

Laurent

PS: we tested all the above on our own debian jitsi server.

···

On Wed, 2015-09-09 at 23:45 -0500, George Politis wrote:


#10

Hi Laurent,

Thank you for reporting back and sharing your experience. I’m able to reproduce at least some of the issues you’re having. If, for example, I share my mic but not share my camera, then I get a JS error and FF doesn’t join the XMPP MUC which provides the chat functionality. There must be a bug somewhere in our media acquisition code, sorry about that.

I’ve updated https://github.com/jitsi/jitsi-meet/issues/347 with a link to this thread because I believe it is related to the issues you’re having. You can subscribe to that issue so that you get notified with updates and when it’s fixed.

Best,
George

···

On Sep 10, 2015, at 11:46 AM, Laurent GUERBY <laurent@guerby.net> wrote:

Hi,

We finally found the issue: with firefox 40 when
the popup "Share Microphone" appears you must
*not* click on "Share Microphone" (as most users including me will
do...), you must instead unroll the popup and then select "Always Share
Microphone" from the drop down menu. Same thing for camera.

Either Firefox UI is less than friendly there, or there's
an issue in jitsi detecting/using one time sharing (not "always").

If you don't do that even the text chat doesn't work.
And about:webrtc stays empty. I find this behaviour
surprising, why text chat depends on audio/video?

Once you've done that sometimes it works directly
sometimes you have to restart firefox and reconnect
for everything to work.

We found that it works more often on conferences where you have set
a password, even if in some cases between 2 and
three windows will ask for a password instead of just one, just fill the
first one and click on all ok.

On Wed, 2015-09-09 at 23:45 -0500, George Politis wrote:

Hello Laurent,

When I open a "about:webrtc" tab after connecting to
beta.meet.jit.si/test4 conference and typed a few things in chat
I get no new item in the page and if I activate debug mode I get an
empty webRTC.log file:

Just checking: You have to have at least 2 participants in the
conference for something to appear in "about:webrtc". You should see
something that looks like the attached image. The important information
that I'm interested in is found when you click the "show details" hyperlink.

On conferences with one participant when you type something
in the text chat it appears in the log column. In the
case you didn't select "always share" even the text chat doesn't
work.

I just run a test with Firefox 40.0.3 in Ubuntu and it works fine here.
Firefox 40 is stable currently.

I tested fresh install Ubuntu 14.04 with the packaged 40.0.3 and debian
8.2 with firefox 40.0.3 installed in /opt/firefox from the firefox
.tar.bz2.

Thanks for your time,

Thank you for your interest!

Thanks for jitsi :).

The two real issues remaining are :
- why text chat is not working when microphone is not "always share",
- the multiple password windows asking for password instead of just one

But both are not blockers for users.

Sincerely,

Laurent

PS: we tested all the above on our own debian jitsi server.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users