[jitsi-users] Re: voip and a strict NAT/Firewall


#1

Hi,

I want to do voip with jitsi. The other person has jitsi too. But I'm
sitting behind a pretty strict NAT/Firewall.

Port 80, 443 and IMAP are allowed and only TCP. But port 53 is allowed
for UDP. I don't know if port 53 is allowed for TCP too, but I doubt
that.

So is it somehow possible to configure jitsi to only user port 53 for
its UDP traffic and e.g. port 443 for TCP traffic?

Thanks in advance,
--rik

···

-----Original Message-----
From: Rieker Flaik [mailto:rieker_flaik@arcor.de]
Sent: Thursday, November 03, 2011 1:37 PM
To: users@jitsi.java.net
Subject: [jitsi-users] voip and a strict NAT/Firewall

-----Original Message-----

How about doing OpenVPN over port 443?
Through that tunnel you can use any port for Jitsi

hw

______________________________________________________________________
Dit bericht kan informatie bevatten die niet voor u is bestemd. Indien u niet de geadresseerde bent of dit bericht abusievelijk aan u is toegezonden, wordt u verzocht dat aan de afzender te melden en het bericht te verwijderen. De Staat aanvaardt geen aansprakelijkheid voor schade, van welke aard ook, die verband houdt met risico's verbonden aan het elektronisch verzenden van berichten.

This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. The State accepts no liability for damage of any kind resulting from the risks inherent in the electronic transmission of messages.


#2

yes, this is my last option. But tunneling udp through tcp to a dial-up
dyndns "mini-openvpn-server" adds latency.

Do you know of any test call echo-server for xmpp/jingle?

thanks,
--rik

···

On Thu, 2011-11-03 at 13:53 +0100, J.Witvliet@mindef.nl wrote:

-----Original Message-----
From: Rieker Flaik [mailto:rieker_flaik@arcor.de]
Sent: Thursday, November 03, 2011 1:37 PM
To: users@jitsi.java.net
Subject: [jitsi-users] voip and a strict NAT/Firewall

Hi,

I want to do voip with jitsi. The other person has jitsi too. But I'm
sitting behind a pretty strict NAT/Firewall.

Port 80, 443 and IMAP are allowed and only TCP. But port 53 is allowed
for UDP. I don't know if port 53 is allowed for TCP too, but I doubt
that.

So is it somehow possible to configure jitsi to only user port 53 for
its UDP traffic and e.g. port 443 for TCP traffic?

Thanks in advance,
--rik

-----Original Message-----

How about doing OpenVPN over port 443?
Through that tunnel you can use any port for Jitsi


#3

O well,
Just pressed the send button too quickly...

If (!) udp-port 53 is really wide open, you might think about using that port.
Be shure that neither side is a bind-server ;-)))
It would rather complicate openvpn configuration with share=port stuff

But then you can tunnel using UDP instead of TCP.

···

-----Original Message-----
From: Rieker Flaik [mailto:rieker_flaik@arcor.de]
Sent: Thursday, November 03, 2011 2:15 PM
To: users@jitsi.java.net
Subject: [jitsi-users] Re: voip and a strict NAT/Firewall

On Thu, 2011-11-03 at 13:53 +0100, J.Witvliet@mindef.nl wrote:

-----Original Message-----
From: Rieker Flaik [mailto:rieker_flaik@arcor.de]
Sent: Thursday, November 03, 2011 1:37 PM
To: users@jitsi.java.net
Subject: [jitsi-users] voip and a strict NAT/Firewall

Hi,

I want to do voip with jitsi. The other person has jitsi too. But I'm
sitting behind a pretty strict NAT/Firewall.

Port 80, 443 and IMAP are allowed and only TCP. But port 53 is allowed
for UDP. I don't know if port 53 is allowed for TCP too, but I doubt
that.

So is it somehow possible to configure jitsi to only user port 53 for
its UDP traffic and e.g. port 443 for TCP traffic?

Thanks in advance,
--rik

-----Original Message-----

How about doing OpenVPN over port 443?
Through that tunnel you can use any port for Jitsi

yes, this is my last option. But tunneling udp through tcp to a dial-up
dyndns "mini-openvpn-server" adds latency.

Do you know of any test call echo-server for xmpp/jingle?

thanks,
--rik

______________________________________________________________________
Dit bericht kan informatie bevatten die niet voor u is bestemd. Indien u niet de geadresseerde bent of dit bericht abusievelijk aan u is toegezonden, wordt u verzocht dat aan de afzender te melden en het bericht te verwijderen. De Staat aanvaardt geen aansprakelijkheid voor schade, van welke aard ook, die verband houdt met risico's verbonden aan het elektronisch verzenden van berichten.

This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. The State accepts no liability for damage of any kind resulting from the risks inherent in the electronic transmission of messages.


#4

Hello Rieker,

You can try calling "gabble.echo@test.collabora.co.uk" to test XMPP/Jingle.

Regards, Adam.

···

Am 03.11.2011, 14:15 Uhr, schrieb Rieker Flaik <rieker_flaik@arcor.de>:

On Thu, 2011-11-03 at 13:53 +0100, J.Witvliet@mindef.nl wrote:

-----Original Message-----
From: Rieker Flaik [mailto:rieker_flaik@arcor.de]
Sent: Thursday, November 03, 2011 1:37 PM
To: users@jitsi.java.net
Subject: [jitsi-users] voip and a strict NAT/Firewall

Hi,

I want to do voip with jitsi. The other person has jitsi too. But I'm
sitting behind a pretty strict NAT/Firewall.

Port 80, 443 and IMAP are allowed and only TCP. But port 53 is allowed
for UDP. I don't know if port 53 is allowed for TCP too, but I doubt
that.

So is it somehow possible to configure jitsi to only user port 53 for
its UDP traffic and e.g. port 443 for TCP traffic?

Thanks in advance,
--rik

-----Original Message-----

How about doing OpenVPN over port 443?
Through that tunnel you can use any port for Jitsi

yes, this is my last option. But tunneling udp through tcp to a dial-up
dyndns "mini-openvpn-server" adds latency.

Do you know of any test call echo-server for xmpp/jingle?

thanks,
--rik


#5

okay, so you think I _have_ to use openvpn?

I'm still hoping for an as easy as skype setup for jitsi.

···

On Thu, 2011-11-03 at 16:45 +0100, J.Witvliet@mindef.nl wrote:

O well,
Just pressed the send button too quickly...

If (!) udp-port 53 is really wide open, you might think about using that port.
Be shure that neither side is a bind-server ;-)))
It would rather complicate openvpn configuration with share=port stuff

But then you can tunnel using UDP instead of TCP.


#6

O well,
Just pressed the send button too quickly...

If (!) udp-port 53 is really wide open, you might think about using that port.
Be shure that neither side is a bind-server ;-)))
It would rather complicate openvpn configuration with share=port stuff

But then you can tunnel using UDP instead of TCP.

okay, so you think I _have_ to use openvpn?

I'm still hoping for an as easy as skype setup for jitsi.

···

-----Original Message-----
From: Rieker Flaik [mailto:rieker_flaik@arcor.de]
Sent: Thursday, November 03, 2011 7:12 PM
To: users@jitsi.java.net
Subject: [jitsi-users] Re: voip and a strict NAT/Firewall

On Thu, 2011-11-03 at 16:45 +0100, J.Witvliet@mindef.nl wrote:
-----Original Message-----
As you said yourself:

Is it somehow possible to configure jitsi to only user port 53 for its UDP traffic and e.g. port 443 for TCP traffic?

I've seen some clients where you can configure easily call-set-up/audio/video ports.
And others that have it hard-coded internally.
To be honest, I can not say where signaling/data port configuration is located in Jitsi.
But using a tunnel will circumvent the problem generated by the firewall.

hw

______________________________________________________________________
Dit bericht kan informatie bevatten die niet voor u is bestemd. Indien u niet de geadresseerde bent of dit bericht abusievelijk aan u is toegezonden, wordt u verzocht dat aan de afzender te melden en het bericht te verwijderen. De Staat aanvaardt geen aansprakelijkheid voor schade, van welke aard ook, die verband houdt met risico's verbonden aan het elektronisch verzenden van berichten.

This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. The State accepts no liability for damage of any kind resulting from the risks inherent in the electronic transmission of messages.


#7

Really? Have you tried it? I also found this with google - but its down:
Even a:
ping test.collabora.co.uk
ping: unknown host test.collabora.co.uk

...

···

On Thu, 2011-11-03 at 15:29 +0100, Adam Reichold wrote:

Am 03.11.2011, 14:15 Uhr, schrieb Rieker Flaik <rieker_flaik@arcor.de>:

> On Thu, 2011-11-03 at 13:53 +0100, J.Witvliet@mindef.nl wrote:
>> -----Original Message-----
>> From: Rieker Flaik [mailto:rieker_flaik@arcor.de]
>> Sent: Thursday, November 03, 2011 1:37 PM
>> To: users@jitsi.java.net
>> Subject: [jitsi-users] voip and a strict NAT/Firewall
>>
>> Hi,
>>
>> I want to do voip with jitsi. The other person has jitsi too. But I'm
>> sitting behind a pretty strict NAT/Firewall.
>>
>> Port 80, 443 and IMAP are allowed and only TCP. But port 53 is allowed
>> for UDP. I don't know if port 53 is allowed for TCP too, but I doubt
>> that.
>>
>> So is it somehow possible to configure jitsi to only user port 53 for
>> its UDP traffic and e.g. port 443 for TCP traffic?
>>
>> Thanks in advance,
>> --rik
>>
>> -----Original Message-----
>>
>> How about doing OpenVPN over port 443?
>> Through that tunnel you can use any port for Jitsi
>
> yes, this is my last option. But tunneling udp through tcp to a dial-up
> dyndns "mini-openvpn-server" adds latency.
>
> Do you know of any test call echo-server for xmpp/jingle?
>
> thanks,
> --rik
>

Hello Rieker,

You can try calling "gabble.echo@test.collabora.co.uk" to test XMPP/Jingle.

Regards, Adam.


#8

I did use it, but not recently. And yes, it seems to be unreachable at the moment.

···

Am 03.11.2011, 16:06 Uhr, schrieb Rieker Flaik <rieker_flaik@arcor.de>:

On Thu, 2011-11-03 at 15:29 +0100, Adam Reichold wrote:

Am 03.11.2011, 14:15 Uhr, schrieb Rieker Flaik <rieker_flaik@arcor.de>:

> On Thu, 2011-11-03 at 13:53 +0100, J.Witvliet@mindef.nl wrote:
>> -----Original Message-----
>> From: Rieker Flaik [mailto:rieker_flaik@arcor.de]
>> Sent: Thursday, November 03, 2011 1:37 PM
>> To: users@jitsi.java.net
>> Subject: [jitsi-users] voip and a strict NAT/Firewall
>>
>> Hi,
>>
>> I want to do voip with jitsi. The other person has jitsi too. But I'm
>> sitting behind a pretty strict NAT/Firewall.
>>
>> Port 80, 443 and IMAP are allowed and only TCP. But port 53 is allowed
>> for UDP. I don't know if port 53 is allowed for TCP too, but I doubt
>> that.
>>
>> So is it somehow possible to configure jitsi to only user port 53 for
>> its UDP traffic and e.g. port 443 for TCP traffic?
>>
>> Thanks in advance,
>> --rik
>>
>> -----Original Message-----
>>
>> How about doing OpenVPN over port 443?
>> Through that tunnel you can use any port for Jitsi
>
> yes, this is my last option. But tunneling udp through tcp to a dial-up
> dyndns "mini-openvpn-server" adds latency.
>
> Do you know of any test call echo-server for xmpp/jingle?
>
> thanks,
> --rik
>

Hello Rieker,

You can try calling "gabble.echo@test.collabora.co.uk" to test XMPP/Jingle.

Regards, Adam.

Really? Have you tried it? I also found this with google - but its down:
Even a:
ping test.collabora.co.uk
ping: unknown host test.collabora.co.uk

...