[jitsi-users] Re: Video calls


#1

I presume you did enabled "video" in /etc/asterisk/sip.conf, with the appropriate video-codecs ??

A nice way to test, is to use the echo function of asterisk. Only if that works for both sip-users individually, it makes sense to try a video-call to each other.

···

Van: Matteo Calorio [mailto:matteo.calorio@linux.ors-tech.it]
Verzonden: Wednesday, May 08, 2013 09:27 AM W. Europe Standard Time
Aan: users@jitsi.java.net <users@jitsi.java.net>
Onderwerp: [jitsi-users] Video calls

Hello,

I'm trying to do a video-call with people with a Tandberg/Cisco Telepresence (http://www.cisco.com/en/US/products/ps7060/index.html) and Jitsi 2.0 on a Linux Debian Wheezy (I'll try today with Jitsi 2.2 on a Debian Jessie) using SIP protocol.

I enabled every video codec on Jitsi, but the best I get is they can see my video only if I disable and re-enable video, clicking on Jitsi's button, but I can not see them in any case. Audio is perfect.

We connect directly to an Asterisk 1.6.2 on a Debian Squeeze in my LAN.

Any ideas?

By the way, I don't know how to configure Asterisk to let me call directly account@otherdomains instead only phone numbers and internal@mypbx. Any hints? :slight_smile:

Thanks a lot,

Matteo

______________________________________________________________________
Dit bericht kan informatie bevatten die niet voor u is bestemd. Indien u niet de geadresseerde bent of dit bericht abusievelijk aan u is toegezonden, wordt u verzocht dat aan de afzender te melden en het bericht te verwijderen. De Staat aanvaardt geen aansprakelijkheid voor schade, van welke aard ook, die verband houdt met risico's verbonden aan het electronisch verzenden van berichten.

This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. The State accepts no liability for damage of any kind resulting from the risks inherent in the electronic transmission of messages.


#2

I have "videosupport=yes" in [general] section and allow=h263 and allow=h264
in a template one (sip.conf). Do I need something else?

I put "600" internal number for echo tests, but I can't see any video. The
only difference I see is that with echo tests I see 0% video packet lost and
with other people I see 100% packet lost in download and 0% in upload (infact
they can see me clearly). Voice ok with echo tests.

Another thing: I can do internal video calls without problems.

Thanks a lot,
  Matteo

---- Original Messagge ----

···

From: J.Witvliet@mindef.nl
Sent: mercoledì 8 maggio 2013, 09:41
To: users@jitsi.java.net
Cc:
Subj: [jitsi-users] Re: Video calls

I presume you did enabled "video" in /etc/asterisk/sip.conf, with the
appropriate video-codecs ??

A nice way to test, is to use the echo function of asterisk. Only if that
works for both sip-users individually, it makes sense to try a video-call to
each other.

Van: Matteo Calorio [mailto:matteo.calorio@linux.ors-tech.it]
Verzonden: Wednesday, May 08, 2013 09:27 AM W. Europe Standard Time
Aan: users@jitsi.java.net <users@jitsi.java.net>
Onderwerp: [jitsi-users] Video calls

Hello,

I'm trying to do a video-call with people with a Tandberg/Cisco Telepresence
(http://www.cisco.com/en/US/products/ps7060/index.html) and Jitsi 2.0 on a
Linux Debian Wheezy (I'll try today with Jitsi 2.2 on a Debian Jessie) using
SIP protocol.

I enabled every video codec on Jitsi, but the best I get is they can see my
video only if I disable and re-enable video, clicking on Jitsi's button, but I
can not see them in any case. Audio is perfect.

We connect directly to an Asterisk 1.6.2 on a Debian Squeeze in my LAN.

Any ideas?

By the way, I don't know how to configure Asterisk to let me call directly
account@otherdomains instead only phone numbers and internal@mypbx. Any hints?
:slight_smile:

Thanks a lot,

Matteo

______________________________________________________________________
Dit bericht kan informatie bevatten die niet voor u is bestemd. Indien u niet
de geadresseerde bent of dit bericht abusievelijk aan u is toegezonden, wordt
u verzocht dat aan de afzender te melden en het bericht te verwijderen. De
Staat aanvaardt geen aansprakelijkheid voor schade, van welke aard ook, die
verband houdt met risico's verbonden aan het electronisch verzenden van
berichten.

This message may contain information that is not intended for you. If you are
not the addressee or if this message was sent to you by mistake, you are
requested to inform the sender and delete the message. The State accepts no
liability for damage of any kind resulting from the risks inherent in the
electronic transmission of messages.


#3

Hey Matteo,

You may also want to check if traffic is flowing in either direction.

Also I definitely suggest you disable H.263 and VP8 (especially H.263)
as this might be confusing asterisk.

Cheers,
Emil

···

On 08.05.13, 10:41, J.Witvliet@mindef.nl wrote:

I presume you did enabled "video" in /etc/asterisk/sip.conf, with the
appropriate video-codecs ??

A nice way to test, is to use the echo function of asterisk. Only if
that works for both sip-users individually, it makes sense to try a
video-call to each other.

*Van*: Matteo Calorio [mailto:matteo.calorio@linux.ors-tech.it]
*Verzonden*: Wednesday, May 08, 2013 09:27 AM W. Europe Standard Time
*Aan*: users@jitsi.java.net <users@jitsi.java.net>
*Onderwerp*: [jitsi-users] Video calls

Hello,

I'm trying to do a video-call with people with a Tandberg/Cisco
Telepresence (http://www.cisco.com/en/US/products/ps7060/index.html) and
Jitsi 2.0 on a Linux Debian Wheezy (I'll try today with Jitsi 2.2 on a
Debian Jessie) using SIP protocol.

I enabled every video codec on Jitsi, but the best I get is they can see
my video only if I disable and re-enable video, clicking on Jitsi's
button, but I can not see them in any case. Audio is perfect.

We connect directly to an Asterisk 1.6.2 on a Debian Squeeze in my LAN.

Any ideas?

By the way, I don't know how to configure Asterisk to let me call
directly account@otherdomains instead only phone numbers and
internal@mypbx. Any hints? :slight_smile:

Thanks a lot,

Matteo

------------------------------------------------------------------------
Dit bericht kan informatie bevatten die niet voor u is bestemd. Indien u
niet de geadresseerde bent of dit bericht abusievelijk aan u is
toegezonden, wordt u verzocht dat aan de afzender te melden en het
bericht te verwijderen. De Staat aanvaardt geen aansprakelijkheid voor
schade, van welke aard ook, die verband houdt met risico's verbonden aan
het electronisch verzenden van berichten.

This message may contain information that is not intended for you. If
you are not the addressee or if this message was sent to you by mistake,
you are requested to inform the sender and delete the message. The State
accepts no liability for damage of any kind resulting from the risks
inherent in the electronic transmission of messages.

--
https://jitsi.org


#4

With echo tests I see 0 Kbps in download and 274 in upload. Even disabling
H.263 and VP8 situation does not change.

Thanks,
  Matteo

---- Original Messagge ----

···

From: Emil Ivov <emcho@jitsi.org>
Sent: mercoledì 8 maggio 2013, 12:09
To: users@jitsi.java.net
Cc: J.Witvliet@mindef.nl
Subj: [jitsi-users] Re: Video calls

Hey Matteo,

You may also want to check if traffic is flowing in either direction.

Also I definitely suggest you disable H.263 and VP8 (especially H.263)
as this might be confusing asterisk.

Cheers,
Emil

On 08.05.13, 10:41, J.Witvliet@mindef.nl wrote:

I presume you did enabled "video" in /etc/asterisk/sip.conf, with the
appropriate video-codecs ??

A nice way to test, is to use the echo function of asterisk. Only if
that works for both sip-users individually, it makes sense to try a
video-call to each other.

*Van*: Matteo Calorio [mailto:matteo.calorio@linux.ors-tech.it]
*Verzonden*: Wednesday, May 08, 2013 09:27 AM W. Europe Standard Time
*Aan*: users@jitsi.java.net <users@jitsi.java.net>
*Onderwerp*: [jitsi-users] Video calls

Hello,

I'm trying to do a video-call with people with a Tandberg/Cisco
Telepresence (http://www.cisco.com/en/US/products/ps7060/index.html) and
Jitsi 2.0 on a Linux Debian Wheezy (I'll try today with Jitsi 2.2 on a
Debian Jessie) using SIP protocol.

I enabled every video codec on Jitsi, but the best I get is they can see
my video only if I disable and re-enable video, clicking on Jitsi's
button, but I can not see them in any case. Audio is perfect.

We connect directly to an Asterisk 1.6.2 on a Debian Squeeze in my LAN.

Any ideas?

By the way, I don't know how to configure Asterisk to let me call
directly account@otherdomains instead only phone numbers and
internal@mypbx. Any hints? :slight_smile:

Thanks a lot,

Matteo

------------------------------------------------------------------------
Dit bericht kan informatie bevatten die niet voor u is bestemd. Indien u
niet de geadresseerde bent of dit bericht abusievelijk aan u is
toegezonden, wordt u verzocht dat aan de afzender te melden en het
bericht te verwijderen. De Staat aanvaardt geen aansprakelijkheid voor
schade, van welke aard ook, die verband houdt met risico's verbonden aan
het electronisch verzenden van berichten.

This message may contain information that is not intended for you. If
you are not the addressee or if this message was sent to you by mistake,
you are requested to inform the sender and delete the message. The State
accepts no liability for damage of any kind resulting from the risks
inherent in the electronic transmission of messages.


#5

With echo tests I see 0 Kbps in download and 274 in upload. Even
disabling H.263 and VP8 situation does not change.

How about the actual traffic? I mean, can you try running a
Wireshark/tcpdump trace?

If you can confirm that Asterisk isn't sending anything then you'd have
to investigate on the Asterisk side.

Emil

···

On 08.05.13, 13:26, Matteo Calorio wrote:

Thanks,

Matteo

---- Original Messagge ----

From: Emil Ivov <emcho@jitsi.org>

Sent: mercoledì 8 maggio 2013, 12:09

To: users@jitsi.java.net

Cc: J.Witvliet@mindef.nl

Subj: [jitsi-users] Re: Video calls

Hey Matteo,

You may also want to check if traffic is flowing in either direction.

Also I definitely suggest you disable H.263 and VP8 (especially H.263)

as this might be confusing asterisk.

Cheers,

Emil

On 08.05.13, 10:41, J.Witvliet@mindef.nl wrote:

I presume you did enabled "video" in /etc/asterisk/sip.conf, with the

appropriate video-codecs ??

A nice way to test, is to use the echo function of asterisk. Only if

that works for both sip-users individually, it makes sense to try a

video-call to each other.

*Van*: Matteo Calorio [mailto:matteo.calorio@linux.ors-tech.it]

*Verzonden*: Wednesday, May 08, 2013 09:27 AM W. Europe Standard Time

*Aan*: users@jitsi.java.net <users@jitsi.java.net>

*Onderwerp*: [jitsi-users] Video calls

Hello,

I'm trying to do a video-call with people with a Tandberg/Cisco

Telepresence (http://www.cisco.com/en/US/products/ps7060/index.html) and

Jitsi 2.0 on a Linux Debian Wheezy (I'll try today with Jitsi 2.2 on a

Debian Jessie) using SIP protocol.

I enabled every video codec on Jitsi, but the best I get is they can see

my video only if I disable and re-enable video, clicking on Jitsi's

button, but I can not see them in any case. Audio is perfect.

We connect directly to an Asterisk 1.6.2 on a Debian Squeeze in my LAN.

Any ideas?

By the way, I don't know how to configure Asterisk to let me call

directly account@otherdomains instead only phone numbers and

internal@mypbx. Any hints? :slight_smile:

Thanks a lot,

Matteo

------------------------------------------------------------------------

Dit bericht kan informatie bevatten die niet voor u is bestemd. Indien u

niet de geadresseerde bent of dit bericht abusievelijk aan u is

toegezonden, wordt u verzocht dat aan de afzender te melden en het

bericht te verwijderen. De Staat aanvaardt geen aansprakelijkheid voor

schade, van welke aard ook, die verband houdt met risico's verbonden aan

het electronisch verzenden van berichten.

This message may contain information that is not intended for you. If

you are not the addressee or if this message was sent to you by mistake,

you are requested to inform the sender and delete the message. The State

accepts no liability for damage of any kind resulting from the risks

inherent in the electronic transmission of messages.

--
https://jitsi.org


#6

I'll try, but that is only for the echo service, with real users calling me I
receive all packets on my pc, but Jitsi discards 100% of them (Call
informations button).

Matteo

---- Original Messagge ----

···

From: Emil Ivov <emcho@jitsi.org>
Sent: mercoledì 8 maggio 2013, 12:47
To: users@jitsi.java.net
Cc: Matteo Calorio <matteo.calorio@linux.ors-tech.it>
Subj: [jitsi-users] Re: Video calls

On 08.05.13, 13:26, Matteo Calorio wrote:

With echo tests I see 0 Kbps in download and 274 in upload. Even
disabling H.263 and VP8 situation does not change.

How about the actual traffic? I mean, can you try running a
Wireshark/tcpdump trace?

If you can confirm that Asterisk isn't sending anything then you'd have
to investigate on the Asterisk side.

Emil

Thanks,

Matteo

---- Original Messagge ----

From: Emil Ivov <emcho@jitsi.org>

Sent: mercoledì 8 maggio 2013, 12:09

To: users@jitsi.java.net

Cc: J.Witvliet@mindef.nl

Subj: [jitsi-users] Re: Video calls

Hey Matteo,

You may also want to check if traffic is flowing in either direction.

Also I definitely suggest you disable H.263 and VP8 (especially H.263)

as this might be confusing asterisk.

Cheers,

Emil

On 08.05.13, 10:41, J.Witvliet@mindef.nl wrote:

I presume you did enabled "video" in /etc/asterisk/sip.conf, with the

appropriate video-codecs ??

A nice way to test, is to use the echo function of asterisk. Only if

that works for both sip-users individually, it makes sense to try a

video-call to each other.

*Van*: Matteo Calorio [mailto:matteo.calorio@linux.ors-tech.it]

*Verzonden*: Wednesday, May 08, 2013 09:27 AM W. Europe Standard Time

*Aan*: users@jitsi.java.net <users@jitsi.java.net>

*Onderwerp*: [jitsi-users] Video calls

Hello,

I'm trying to do a video-call with people with a Tandberg/Cisco

Telepresence (http://www.cisco.com/en/US/products/ps7060/index.html) and

Jitsi 2.0 on a Linux Debian Wheezy (I'll try today with Jitsi 2.2 on a

Debian Jessie) using SIP protocol.

I enabled every video codec on Jitsi, but the best I get is they can see

my video only if I disable and re-enable video, clicking on Jitsi's

button, but I can not see them in any case. Audio is perfect.

We connect directly to an Asterisk 1.6.2 on a Debian Squeeze in my LAN.

Any ideas?

By the way, I don't know how to configure Asterisk to let me call

directly account@otherdomains instead only phone numbers and

internal@mypbx. Any hints? :slight_smile:

Thanks a lot,

Matteo

------------------------------------------------------------------------

Dit bericht kan informatie bevatten die niet voor u is bestemd. Indien u

niet de geadresseerde bent of dit bericht abusievelijk aan u is

toegezonden, wordt u verzocht dat aan de afzender te melden en het

bericht te verwijderen. De Staat aanvaardt geen aansprakelijkheid voor

schade, van welke aard ook, die verband houdt met risico's verbonden aan

het electronisch verzenden van berichten.

This message may contain information that is not intended for you. If

you are not the addressee or if this message was sent to you by mistake,

you are requested to inform the sender and delete the message. The State

accepts no liability for damage of any kind resulting from the risks

inherent in the electronic transmission of messages.


#7

... also, if I call another internal number I can see video perfectly...

---- Original Messagge ----

···

From: Matteo Calorio <matteo.calorio@linux.ors-tech.it>
Sent: mercoledì 8 maggio 2013, 14:49
To: users@jitsi.java.net
Cc:
Subj: [jitsi-users] Re: Video calls

I'll try, but that is only for the echo service, with real users calling me I
receive all packets on my pc, but Jitsi discards 100% of them (Call
informations button).

Matteo

---- Original Messagge ----
From: Emil Ivov <emcho@jitsi.org>
Sent: mercoledì 8 maggio 2013, 12:47
To: users@jitsi.java.net
Cc: Matteo Calorio <matteo.calorio@linux.ors-tech.it>
Subj: [jitsi-users] Re: Video calls

On 08.05.13, 13:26, Matteo Calorio wrote:

With echo tests I see 0 Kbps in download and 274 in upload. Even
disabling H.263 and VP8 situation does not change.

How about the actual traffic? I mean, can you try running a
Wireshark/tcpdump trace?

If you can confirm that Asterisk isn't sending anything then you'd have
to investigate on the Asterisk side.

Emil

Thanks,

Matteo

---- Original Messagge ----

From: Emil Ivov <emcho@jitsi.org>

Sent: mercoledì 8 maggio 2013, 12:09

To: users@jitsi.java.net

Cc: J.Witvliet@mindef.nl

Subj: [jitsi-users] Re: Video calls

Hey Matteo,

You may also want to check if traffic is flowing in either direction.

Also I definitely suggest you disable H.263 and VP8 (especially H.263)

as this might be confusing asterisk.

Cheers,

Emil

On 08.05.13, 10:41, J.Witvliet@mindef.nl wrote:

I presume you did enabled "video" in /etc/asterisk/sip.conf, with the

appropriate video-codecs ??

A nice way to test, is to use the echo function of asterisk. Only if

that works for both sip-users individually, it makes sense to try a

video-call to each other.

*Van*: Matteo Calorio [mailto:matteo.calorio@linux.ors-tech.it]

*Verzonden*: Wednesday, May 08, 2013 09:27 AM W. Europe Standard Time

*Aan*: users@jitsi.java.net <users@jitsi.java.net>

*Onderwerp*: [jitsi-users] Video calls

Hello,

I'm trying to do a video-call with people with a Tandberg/Cisco

Telepresence (http://www.cisco.com/en/US/products/ps7060/index.html) and

Jitsi 2.0 on a Linux Debian Wheezy (I'll try today with Jitsi 2.2 on a

Debian Jessie) using SIP protocol.

I enabled every video codec on Jitsi, but the best I get is they can see

my video only if I disable and re-enable video, clicking on Jitsi's

button, but I can not see them in any case. Audio is perfect.

We connect directly to an Asterisk 1.6.2 on a Debian Squeeze in my LAN.

Any ideas?

By the way, I don't know how to configure Asterisk to let me call

directly account@otherdomains instead only phone numbers and

internal@mypbx. Any hints? :slight_smile:

Thanks a lot,

Matteo

------------------------------------------------------------------------

Dit bericht kan informatie bevatten die niet voor u is bestemd. Indien u

niet de geadresseerde bent of dit bericht abusievelijk aan u is

toegezonden, wordt u verzocht dat aan de afzender te melden en het

bericht te verwijderen. De Staat aanvaardt geen aansprakelijkheid voor

schade, van welke aard ook, die verband houdt met risico's verbonden aan

het electronisch verzenden van berichten.

This message may contain information that is not intended for you. If

you are not the addressee or if this message was sent to you by mistake,

you are requested to inform the sender and delete the message. The State

accepts no liability for damage of any kind resulting from the risks

inherent in the electronic transmission of messages.


#8

I did some other tests: I asked my friends to call me from outside at the echo
test number and for them is all ok, they see themselves echoed in audio/video,
so my Asterisk should be ok?

There are differences if they call me or I call them: in the first case audio
is much better (PCMU is set), in the last worse (GSM is set).

At this link there are the info windows of both cases.

In the first case they can see me if I disable and re-enable video, in the
last they can't see me at all. In both cases I can't se them.

Thanks for your time,
  Matteo


#9

The link: http://linux.ors-tech.it/Jitsi-2.2-130508-1/

---- Original Messagge ----

···

From: Matteo Calorio <matteo.calorio@linux.ors-tech.it>
Sent: mercoledì 8 maggio 2013, 16:00
To: users@jitsi.java.net
Cc:
Subj: [jitsi-users] Re: Video calls

I did some other tests: I asked my friends to call me from outside at the echo
test number and for them is all ok, they see themselves echoed in audio/video,
so my Asterisk should be ok?

There are differences if they call me or I call them: in the first case audio
is much better (PCMU is set), in the last worse (GSM is set).

At this link there are the info windows of both cases.

In the first case they can see me if I disable and re-enable video, in the
last they can't see me at all. In both cases I can't se them.

Thanks for your time,
  Matteo


#10

Could be a codec issue? I tried the same with Ekiga and the result is the
opposite: I can see them, but they can't see me... :-?

Matteo

---- Original Messagge ----

···

From: Matteo Calorio <matteo.calorio@linux.ors-tech.it>
Sent: mercoledì 8 maggio 2013, 16:04
To: users@jitsi.java.net
Cc:
Subj: Re: [jitsi-users] Re: Video calls

The link: http://linux.ors-tech.it/Jitsi-2.2-130508-1/

---- Original Messagge ----
From: Matteo Calorio <matteo.calorio@linux.ors-tech.it>
Sent: mercoledì 8 maggio 2013, 16:00
To: users@jitsi.java.net
Cc:
Subj: [jitsi-users] Re: Video calls

I did some other tests: I asked my friends to call me from outside at the echo
test number and for them is all ok, they see themselves echoed in audio/video,
so my Asterisk should be ok?

There are differences if they call me or I call them: in the first case audio
is much better (PCMU is set), in the last worse (GSM is set).

At this link there are the info windows of both cases.

In the first case they can see me if I disable and re-enable video, in the
last they can't see me at all. In both cases I can't se them.

Thanks for your time,
  Matteo