[jitsi-users] Puhleease fix the pulseaudio bug


#1

Hello jitsi devs,

I just installed jitsi 2.5.5194 on debian 7 Wheezy and very nearly jumped out of my skin because it turned up the volume to 100%.

1. This bug was identified two years ago: https://java.net/jira/browse/JITSI-1050
2. The way to fix the bug is also mentioned in the bug report
3. The last comment on the bug report is from Feb. 2014 (2 years since the bug was reported), requesting for the bug to be fixed

And STILL the bug is not fixed! What gives??

I have rather big speakers and having jitsi max out the volume every time a call begins/ends is extremely annoying. It made me mad enough to sign up to this mailing list and write this email :stuck_out_tongue:

Otherwise, jitsi seems to be great :wink:

Regards,
Sagar


#2

I've used Jitsi with PulseAudio on at least 4 releases of Ubuntu and
I've never seen this issue. Consequently, I'm moderately suspicious
that the "fix" proposed in https://java.net/jira/browse/JITSI-1050
will be appropriate. Besides, I seem to remember there was something
about flat and maxed volumes. Anyway, I'll try to look into it sooner
rather than later.


#3

Commit 140f8b5eb86c1212a01f666efc846584e0416493 in jitsi/libjitsi and
commit ced46ddfb312caa6df6b563f0cad0da08411bc82 in jitsi/jitsi try to
remove the issue. These should be made available in Jitsi 2.5.5210.
Please try it out once it's baked and report back.


#4

Thank you. I am willing to help in any way I can, which would mostly be testing of possible solutions.

Please let me know whenever you need assistance.

Regards,
Sagar

···

On 04/25/2014 10:23 AM, Lyubomir Marinov wrote:

I've used Jitsi with PulseAudio on at least 4 releases of Ubuntu and
I've never seen this issue. Consequently, I'm moderately suspicious
that the "fix" proposed in https://java.net/jira/browse/JITSI-1050
will be appropriate. Besides, I seem to remember there was something
about flat and maxed volumes. Anyway, I'll try to look into it sooner
rather than later.


#5

By the way, I just came across

http://lists.jitsi.org/pipermail/dev/2012-June/004334.html

and can confirm that the workaround suggested there works. But it would still be nice to not have to do it :slight_smile:

Regards,
Sagar

···

On 04/25/2014 10:25 AM, Sagar Behere wrote:

On 04/25/2014 10:23 AM, Lyubomir Marinov wrote:

I've used Jitsi with PulseAudio on at least 4 releases of Ubuntu and
I've never seen this issue. Consequently, I'm moderately suspicious
that the "fix" proposed in https://java.net/jira/browse/JITSI-1050
will be appropriate. Besides, I seem to remember there was something
about flat and maxed volumes. Anyway, I'll try to look into it sooner
rather than later.

Thank you. I am willing to help in any way I can, which would mostly be
testing of possible solutions.

Please let me know whenever you need assistance.


#6

Lyubomir Marinov <lyubomir.marinov@jitsi.org> writes:

I've used Jitsi with PulseAudio on at least 4 releases of Ubuntu and
I've never seen this issue. Consequently, I'm moderately suspicious
that the "fix" proposed in https://java.net/jira/browse/JITSI-1050
will be appropriate. Besides, I seem to remember there was something
about flat and maxed volumes. Anyway, I'll try to look into it sooner
rather than later.

Is PulseAudio configured identically out-of-the-box on both Debian and
Ubuntu, though? i'm not sure it is ....

In any case, i'm on Debian Wheezy 32-bit, running Jitsi 2.5.5201,
and i don't experience this issue. i don't recall experiencing it with
any other nightly either, and i've been on nightlies for at least a
couple of months now.

Sagar, i notice you're on 2.5.5194; do you still get the problem on
later 2.5 builds?

Alexis.


#7

I just tried with 2.5.5210.

The problem no longer occurs. Thank you very much :slight_smile:

Regards,
Sagar

···

On 04/26/2014 10:40 PM, Lyubomir Marinov wrote:

Commit 140f8b5eb86c1212a01f666efc846584e0416493 in jitsi/libjitsi and
commit ced46ddfb312caa6df6b563f0cad0da08411bc82 in jitsi/jitsi try to
remove the issue. These should be made available in Jitsi 2.5.5210.
Please try it out once it's baked and report back.


#8

Thanks Lyubomir,
I also suffered from this issue, looking forward to test the fix, but
the feedback so far makes me confident that it will work.

···

On Sat, 26 Apr 2014 23:40:18 +0300 Lyubomir Marinov <lyubomir.marinov@jitsi.org> wrote:

Commit 140f8b5eb86c1212a01f666efc846584e0416493 in jitsi/libjitsi and
commit ced46ddfb312caa6df6b563f0cad0da08411bc82 in jitsi/jitsi try to
remove the issue. These should be made available in Jitsi 2.5.5210.
Please try it out once it's baked and report back.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#9

it’s also working now on debian jessie.

jitsi 2.5.5211-1 amd64
pulseaudio 4.0-6+b1 amd64

thx a lot!
günter

···

Am Samstag, 26. April 2014, 23:40:18 schrieb Lyubomir Marinov:

Commit 140f8b5eb86c1212a01f666efc846584e0416493 in jitsi/libjitsi and
commit ced46ddfb312caa6df6b563f0cad0da08411bc82 in jitsi/jitsi try to
remove the issue. These should be made available in Jitsi 2.5.5210.
Please try it out once it's baked and report back.


#10

I just downloaded the latest nightly, 2.5.5205 and tried it out. There is still a big jump in volume (although it does not go all the way to 100%). See here a 45 second screencast of the problem [HD video, you may need to view full-screen to make out the details]

http://prometheus.sagar.se:8000/f/16c209fabb/

As you can see, the volume was 24% before making the call. As soon as the call is initiated, the volume jumps to 74%.

Regards,
Sagar

···

On 04/25/2014 10:50 AM, Alexis wrote:

Lyubomir Marinov <lyubomir.marinov@jitsi.org> writes:

I've used Jitsi with PulseAudio on at least 4 releases of Ubuntu and
I've never seen this issue. Consequently, I'm moderately suspicious
that the "fix" proposed in https://java.net/jira/browse/JITSI-1050
will be appropriate. Besides, I seem to remember there was something
about flat and maxed volumes. Anyway, I'll try to look into it sooner
rather than later.

Is PulseAudio configured identically out-of-the-box on both Debian and
Ubuntu, though? i'm not sure it is ....

In any case, i'm on Debian Wheezy 32-bit, running Jitsi 2.5.5201,
and i don't experience this issue. i don't recall experiencing it with
any other nightly either, and i've been on nightlies for at least a
couple of months now.

Sagar, i notice you're on 2.5.5194; do you still get the problem on
later 2.5 builds?


#11

We haven't modified the PulseAudio integration in Jitsi for quite some
time so I don't expect functional differences with respect to it
between 2.5.5194 and subsequent 2.5 builds.

···

2014-04-25 11:50 GMT+03:00 Alexis <flexibeast@gmail.com>:

Sagar, i notice you're on 2.5.5194; do you still get the problem on
later 2.5 builds?


#12

FWIW, we don't play with PulseAudio volumes at all. We just open the device! There might be ways for us to work around that issue but it still sounds to me as though this is primarly a PulseAudio problem that they may also want to resolve in PulseAudio itself.

Emil

···

On 25.04.14, 11:18, Sagar Behere wrote:

On 04/25/2014 10:50 AM, Alexis wrote:

Lyubomir Marinov <lyubomir.marinov@jitsi.org> writes:

I've used Jitsi with PulseAudio on at least 4 releases of Ubuntu and
I've never seen this issue. Consequently, I'm moderately suspicious
that the "fix" proposed in https://java.net/jira/browse/JITSI-1050
will be appropriate. Besides, I seem to remember there was something
about flat and maxed volumes. Anyway, I'll try to look into it sooner
rather than later.

Is PulseAudio configured identically out-of-the-box on both Debian and
Ubuntu, though? i'm not sure it is ....

In any case, i'm on Debian Wheezy 32-bit, running Jitsi 2.5.5201,
and i don't experience this issue. i don't recall experiencing it with
any other nightly either, and i've been on nightlies for at least a
couple of months now.

Sagar, i notice you're on 2.5.5194; do you still get the problem on
later 2.5 builds?

I just downloaded the latest nightly, 2.5.5205 and tried it out. There
is still a big jump in volume (although it does not go all the way to
100%). See here a 45 second screencast of the problem [HD video, you may
need to view full-screen to make out the details]

http://prometheus.sagar.se:8000/f/16c209fabb/

As you can see, the volume was 24% before making the call. As soon as
the call is initiated, the volume jumps to 74%.

--
https://jitsi.org


#13

Due to the annoyance factor of this bug, maybe this should become the
current stable release? :slight_smile:
Or maybe backported to 2.4?

Or wasn't this present in 2.4 at all?
Just a thought...

FC

···

On Sun, Apr 27, 2014 at 5:44 AM, Sagar Behere <sagar.behere@gmail.com> wrote:

I just tried with 2.5.5210.

The problem no longer occurs. Thank you very much :slight_smile:

--
During times of Universal Deceit, telling the truth becomes a revolutionary act
- George Orwell


#14

Yup a release is long overdue we should try and roll one soon.

···

On 27.04.14, 12:26, Fernando Cassia wrote:

On Sun, Apr 27, 2014 at 5:44 AM, Sagar Behere <sagar.behere@gmail.com> wrote:

I just tried with 2.5.5210.

The problem no longer occurs. Thank you very much :slight_smile:

Due to the annoyance factor of this bug, maybe this should become the
current stable release? :slight_smile:
Or maybe backported to 2.4?

Or wasn't this present in 2.4 at all?
Just a thought...

FC

--
https://jitsi.org


#15

I had a similar issue and this worked for me:
http://lists.jitsi.org/pipermail/dev/2012-June/004334.html

Hope it helps!

···

El 26/04/14 15:53, Emil Ivov escribió:

On 25.04.14, 11:18, Sagar Behere wrote:

On 04/25/2014 10:50 AM, Alexis wrote:

Lyubomir Marinov <lyubomir.marinov@jitsi.org> writes:

I've used Jitsi with PulseAudio on at least 4 releases of Ubuntu and
I've never seen this issue. Consequently, I'm moderately suspicious
that the "fix" proposed in https://java.net/jira/browse/JITSI-1050
will be appropriate. Besides, I seem to remember there was something
about flat and maxed volumes. Anyway, I'll try to look into it sooner
rather than later.

Is PulseAudio configured identically out-of-the-box on both Debian and
Ubuntu, though? i'm not sure it is ....

In any case, i'm on Debian Wheezy 32-bit, running Jitsi 2.5.5201,
and i don't experience this issue. i don't recall experiencing it with
any other nightly either, and i've been on nightlies for at least a
couple of months now.

Sagar, i notice you're on 2.5.5194; do you still get the problem on
later 2.5 builds?

I just downloaded the latest nightly, 2.5.5205 and tried it out. There
is still a big jump in volume (although it does not go all the way to
100%). See here a 45 second screencast of the problem [HD video, you may
need to view full-screen to make out the details]

http://prometheus.sagar.se:8000/f/16c209fabb/

As you can see, the volume was 24% before making the call. As soon as
the call is initiated, the volume jumps to 74%.

FWIW, we don't play with PulseAudio volumes at all. We just open the device! There might be ways for us to work around that issue but it still sounds to me as though this is primarly a PulseAudio problem that they may also want to resolve in PulseAudio itself.

Emil


#16

Jacobo Bouzas Quiroga <jacobo.bouzas.quiroga@udc.es> writes:

I had a similar issue and this worked for me:
http://lists.jitsi.org/pipermail/dev/2012-June/004334.html

As a data point, i just checked my own PulseAudio config:

* i have no ~/.pulse/daemon.conf file;
* The system-wide /etc/pulse/daemon.conf file has not been changed from
  its default value of "flat-volumes = yes";

and yet i'm not experiencing the volume problem described. Which suggests
to me that the flat-volumes setting might be only part of the issue.

Alexis.