[jitsi-users] Problems with Jitsi on OSX-10.9.5


#1

I have Jitsi 2.6.5390 installed on OSX-10.9.5. When I attempt to
connect to a public SIP registrar at iptel.org I see this error:

Connection failed for the following account:
User name: userid, Server: sip.provider.tld
Please check your settings or contact your
network administrator for more information.

In the Jitsi logs I see this:

19:41:55.357 WARNING: [339]
service.resources.AbstractResourcesService.getSettingsInt().596
Missing resource for key:
net.java.sip.communicator.SIP_PREFERRED_CLEAR_PORT

19:41:55.358 INFO: [339] impl.protocol.sip.SipLogger.logInfo().185
Info from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been started

19:41:55.363 SEVERE: [339] impl.protocol.sip.SipLogger.logError().122
Error from the JAIN-SIP stack: Invalid argument address = ::0 port =
5060 transport = TLS

19:41:55.382 SEVERE: [339]
impl.protocol.sip.ProtocolProviderServiceSipImpl.register().349 No
address found for ProtocolProviderServiceSipImpl(byrnejb@iptel.org
(SIP))

19:41:55.387 INFO: [339] impl.protocol.sip.SipLogger.logInfo().185
Info from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped

19:41:56.932 INFO: [339] impl.protocol.sip.SipLogger.logInfo().185
Info from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped

However, I cannot determine what is wrong with this installation or my
network settings. Does anyone know what I have to do to get this to
work on a Mac? I have the test account working with Jitsi on a
CentOS-6.6 Linux host. But the Mac will not connect to the same
account even when connected to the same lan segment.

···

--
*** E-Mail is NOT a SECURE channel ***
James B. Byrne mailto:ByrneJB@Harte-Lyne.ca
Harte & Lyne Limited http://www.harte-lyne.ca
9 Brockley Drive vox: +1 905 561 1241
Hamilton, Ontario fax: +1 905 561 0757
Canada L8E 3C3


#2

Error from the JAIN-SIP stack: Invalid argument address = ::0 port =
5060 transport = TLS

Iptel doesn't support TLS AFAIK
http://www.iptel.org/service

···

On 2015-02-11 05:14, James B. Byrne wrote:

I have Jitsi 2.6.5390 installed on OSX-10.9.5. When I attempt to
connect to a public SIP registrar at iptel.org I see this error:

Connection failed for the following account:
User name: userid, Server: sip.provider.tld
Please check your settings or contact your
network administrator for more information.

In the Jitsi logs I see this:

19:41:55.357 WARNING: [339]
service.resources.AbstractResourcesService.getSettingsInt().596
Missing resource for key:
net.java.sip.communicator.SIP_PREFERRED_CLEAR_PORT

19:41:55.358 INFO: [339] impl.protocol.sip.SipLogger.logInfo().185
Info from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been started

19:41:55.363 SEVERE: [339] impl.protocol.sip.SipLogger.logError().122
Error from the JAIN-SIP stack: Invalid argument address = ::0 port =
5060 transport = TLS

19:41:55.382 SEVERE: [339]
impl.protocol.sip.ProtocolProviderServiceSipImpl.register().349 No
address found for ProtocolProviderServiceSipImpl(byrnejb@iptel.org
(SIP))

19:41:55.387 INFO: [339] impl.protocol.sip.SipLogger.logInfo().185
Info from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped

19:41:56.932 INFO: [339] impl.protocol.sip.SipLogger.logInfo().185
Info from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped

However, I cannot determine what is wrong with this installation or my
network settings. Does anyone know what I have to do to get this to
work on a Mac? I have the test account working with Jitsi on a
CentOS-6.6 Linux host. But the Mac will not connect to the same
account even when connected to the same lan segment.